MSCAD 2005 Upgrade Information \

What’s new in MSCAD 2005?

As a company that wants the best for our customers, we decided that it was time to closely
look at the cad engine and confirm that it meets our customer’s expectations, as well as our
own. Some of the questions we asked ourselves were:

Is the CAD engine providing our customers with all the functionality they need?

Is the CAD engine stable?

Is the CAD engine easy to customize?

Does the CAD engine provide MicroSurvey with a platform that is competitive with
other products on the market?

e How compatible is it with AutoCAD?

So we started looking at alternatives just to make sure we were not missing out on something
that could breathe new life into our products. We looked at a CAD engine called IntelliCAD
and we soon realized we may have found something that could take MSCAD to a new level.

Who and What is IntelliCAD?

The IntelliCAD Technology Consortium is an independent organization committed to promoting
a cooperatively developed CAD engine. In July we signed up with IntelliCAD as an API
member which gave us access to IntelliCAD installs and technical information about the
product. We decided that we would build a test version running in IntelliCAD and began
development of an alpha version of MSCAD 2005. It took us all of July and August to build the
alpha version and we began our in-house trials in September.

To help us learn more about IntelliCAD, Darcy Detlor attended the World IntelliCAD
Conference in September. Attending the meeting was very beneficial and he came back to
Canada with a new outlook on MSCAD'’s future.

e He learned that IntelliCAD has a strong development team, almost twice as large as
FelixCAD.

e They run extensive regression tests on their cad engine. Over 46,000 drawings are
used during their testing sessions.

e They also use hundreds of script files that test the integrity and stability of the CAD
engine.

e They have an online web site that allows their Commercial members to access their
bug database to see what bugs have been reported, and what bugs they are currently
working on.

e They are currently working on a new version that has incredible speed enhancements.

e They hate bugs as much as we do, and try to fix them as quickly as possible.

IntelliCAD has been around for many years and they have a very loyal following. In mid
November we joined the IntelliCAD Technology Consortium as a Commercial Member which
gives us full access to the source code. This is something that we have never had before and
it will give us even more flexibility and control over the product.

To learn more about the consortium visit the web site at www.intellicad.org.




What will the new CAD Engine do?

Just a few of the IntelliCAD Engine Improvements:

Offsets now works on 3D linework.

Object selection can now be done based upon their properties (color, linetype, etc.).

New Align command.

Ray and Construction lines.

Dynamic wheel zoom that zooms into the location you are pointing with your cursor.

Trim and extend to 3D objects. No more need to flatten or use SCALEZ.

Dashed linetype on curved polyline support.

Multiple Layout tabs (Paper Space Sheets).

Enhanced distance entry. For example if you use the line command, when prompted

for the end point, simply type the distance and a line will be drawn using this length.

e Line Weights while viewing or plotting, allows you to specify line thickness based on
layers instead of line color.

e IntelliCAD Explorer which can be accessed from the CAD Tools menu. Provides a
common area where you can access all your settings for layers, linetypes, text styles,
blocks, dimension styles, views and coordinate systems.

e Right-click support that allows you to right click on objects. This brings up a context
menu containing commands that you can use to edit the object.

e Improved raster support. Support for BMP, CALS Type 1 (.cg4, gp4, .cal, .g4), EOSAT
Ver B, JFIF, PCX, PNG, Sun Raster and SPOT.

e Geo-Referenced raster support. The new raster engine can read embedded position

information, or the user can specify a separate position file. Position files that we

support are RAT, TFW and RES.

Customizable toolbars, from inside the program, as you work.

No more annoying Drawing_0.

Increased speed.

MSCAD 2005 now creates native DWG files.

Improved DIM options

Improved Print/Plot options

More hatch patterns

And much more ...

So will it be a big adjustment learning MSCAD 2005?

Overall you should not find it difficult to get up to speed with MSCAD 2005. The main
interface, menus and toolbars are essentially the same as the ones you have been using in
MSCAD 2004. There are no major new survey related functions added (just a few
enhancements); all our development time has been spent integrating our existing code with
IntelliCAD.

What's up with the three versions of MSCAD 2005?

MSCAD 2005 is available in three versions: Premium, Standard and Basic. All three versions
will have a similar look and feel which will make it easier for companies who have multiple
versions of MSCAD. MSCAD 2005 Standard has everything the Premium version has minus
the Design and Modeling functions. MSCAD 2005 Basic has everything the Standard version
has minus the powerful CAD drawing commands. The upgrade from all previous versions of
MSCAD will be to MSCAD 2005 Premium. The upgrade from MS 98 or MSX 2001/2002 will be
to MSCAD 2005 Basic.




Will MSCAD 2005 overwrite my existing copy of MSCAD or MSX?

MSCAD 2005 will install by default to C:\Program Files\MicroSurvey\MSCAD2005. We
recommend that you leave it there. This will allow your MSCAD 3.1, 2001, 2002, or 2004 to
continue to run in its original folder so you can transition cleanly and easily.

Should I un-install my current version of MSCAD 3.1, 2001, 2002,
or 2004 prior to installing MSCAD 2005?

We suggest keeping your current version installed until after you install MSCAD 2005 and have
tested it to make sure it installed ok. You will need to use your previous version of MSCAD to
convert your FLX files to DWG so that they can be opened in MSCAD 2005. When you're
satisfied that everything is running ok, you can un-install your older version.

What will happen to all my old jobs? Can I still use them?

MSCAD 2005 uses the IntelliCAD engine which works with DWG files rather than FLX files, so
you will need to convert them from FLX to DWG within your previous version of MSCAD. This
can be done very easily using the Batch Processing abilities in MSCAD 2004 to convert your
FLX files to DWG:

1) Open up MSCAD 2001/2002/2004

2) Press Cancel on the Project Manager window without opening any drawings.

3) Pause MSCAD by going to File > Batch Processing > 1. Pause MSCAD

4) Start up the Batch Processing command by going to File > Batch Processing > 2.
Batch Process Files.

5) You will be asked whether or not to save the current drawing. If the only file that is
open is Drawing_0.flx, then you can choose “Don’t save the current drawing (discard
changes). Then press Continue.

6) Ensure that “Include Subdirectories” is checked, so that any files in nested
subdirectories will be included in the conversion process.

7) At “Types:” ensure that FLX is checked, and that DXF and DWG are unchecked.

8) Press the “Select Directory to add Files from” button and select your data directory
(for example, c:\jobs2004), and press OK. Repeat this step for any other data
directories on your computer.

9) In the “Convert to” section, select DWG

10) Press Start to begin processing your files. You will see your drawings open one at a
time as they are saved to a DWG file. This may take quite some time if you have a lot
of FLX drawings.

11) After batch processing is complete, go to File > Batch Processing > 3. Restart MSCAD
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What about the drawing file? Is it different for 2005?

Yes, MSCAD 2005 uses a new CAD engine called MSCI_\D Compat|bl_e
IntelliCAD. IntelliCAD is completely compatible with Version: DWG version:
AutoCAD, and it uses industry standard DWG drawing files. MSCAD 3.1

Older versions of MSCAD can read DWG files, but you will MSCAD 2001 R14 DWG
need to convert them to an older DWG format depending MSCAD 2002 2002 DWG

on your version of MSCAD. From the File Menu you can MSCAD 2004 2004 DWG

use the SAVEAS command and save your project back to MSCAD 2005 | 2006 DWG

previous DWG versions. Refer to the table to see what DWG version can be handled by your
version of MSCAD.

What about the database file? Is it different for 2005?

No, MSCAD 2005 uses the same database file as did MSCAD 2002 and 2004. However, if you
need to open a MSCAD 2005 drawing in a previous version always use the SAVEAS command
in the File Menu, and save it to an older DWG format, as discussed above.

If you need to open your drawing in MSCAD 3.1 or 2001, you will need to create the older-
style .PST database file. To do this, run the command MsPoints > Other Program Ties >
MicroSurvey Database MSD to PST.

What about all the other files? Are they different for 2005?

All other files types created by MSCAD 2005 such as surface files, alignment files, batch files
etc, are completely interchangeable between MSCAD 2002, 2004 and 2005.

How do | install the new version?

To install, you must be logged in with an Administrator account. Please contact your network
administrator if you do not have Administrator access. Insert the CD that you received when
you purchased the upgrade into your CDROM drive. The install wizard should automatically
start for you. If it doesn't simply browse to your CDROM drive and execute the setup.exe file.
Follow the on-screen instructions to step through the installation. Once the install is complete
you will need to register your version of MSCAD 2005.

Do | really need an Administrator account?

You need an Administrator account only to install MSCAD 2005 and then to run it for the very
first time on your computer. After that, you can use your normal account; it will not matter
whether it is an Administrator or Limited account.

| inserted the new CD in my drive and nothing seems to happen.
Is the CD damaged or did | do something wrong?

If your CD does not automatically start the install wizard you can try the following. 1) Insert
the CD into your drive and close the CD door while holding the <shift> key down on the
keyboard. 2) Go to the Windows Explorer program and change to the CD drive that contains
your new CD. 3) Double click on the setup.exe file to start the install procedure.




If this doesn't work you may have a damaged CD, contact your sales representative for
another CD.

I've got it installed. How do | register it?

Once installed, the first time you start the program you will see our startup dialog. Press the
Register Now! button. You will then see a Local or Network License dialog where you can
choose to register it either as a Stand Alone Installation or as a Network Floating License. If
you do not know which license type to choose, select Stand Alone Installation by clicking on
the My Computer button. Follow the steps and you will be registered in no time.
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Press the “Create Registration Form to FAX or Email” button at Step 1, fill out the form
it gives you and send it in to us. We will contact you with the appropriate Registration
Keys, which you can enter in at Step 2.

How do | register it with my network license?

The floating network license file must be located in a mapped network drive accessible by your
computer. If it is not already mapped, open a Windows Explorer or My Computer window and
go to Tools > Map Network Drive. Please contact your network administrator for specific
information on what drive and folder need to be mapped.

Once MSCAD 2005 is installed, the first time you start the program you will see our startup
dialog. Press the Register Now! button, then press the My Network Places button. Browse
to the mapped directory containing your floating license file (microsurvey.lic) and press Open.
You will see a message indicating that you are now registered via a network license, and
reminding you to not disconnect from the network before exiting MSCAD 2005. The program
will remember where to look for the network file, and the next time you start the program all
you will need to do is press the Register Now and My Network Places buttons. You will not
be prompted again for the network location unless that directory changes or is no longer
available.




Do you still have hardware locks available?

No. Hardware locks were discontinued with the release of MSCAD2004 but with MSCAD2005
we now have many new options that will assist you. You can even check out a licence to a
laptop for a period of time.

Can | continue to use my older version of MSCAD while MSCAD
2005 is installed?

Yes you could, but there is no need to do so, once you have batch converted your FLX files to
DWG. MSCAD 2005 has everything in it that the older version did as well as hundreds of
improvements and new features. You may run the older version for a period of 30 days while
you are becoming more comfortable with the new version. At this time you must uninstall the
old version. You are not permitted to run the two versions on two computers. This is not a
new license - it is an upgrade and replaces the old version.

| have taken many hours to setup my AutoMap library to work as
desired. What is going to happen to all that work?

All you need to do is copy the CSV file that you created in MSCAD 3.1, 2001, 2002 or 2004
into MSCAD 2005. Then as you have done before, load it and use it anytime you require. If
you had saved your CSV file under the name MSCAD.CSV then we recommend that you give it
a new name in MSCAD 2005.

You will need to update the paths for the symbols that may be associated with your Automap
library if you used MSCAD specific symbols. For example, if you created your library with
MSCAD 2004 you may see something like: C:\MSCAD2004\MSCAD\blocks\ICI_AP.FLX for a
symbol path. When you remove MSCAD 2004 from your computer the path will no longer exist
and you will need to update your AutoMap library to look in C:\Program Files\MicroSurvey\
MSCAD2005\MSCAD\blocks\......

MSCAD 2005 will automatically scan through your AutoMap library to convert the symbol
paths to use DWG files rather than FLX files.

New capabilities were also added to AutoMAP and when you read in an older library file, it will
automatically have these new fields added to it. You would then need to modify these fields in
the AutoMAP Library Editor, to take advantage of them.

| have setup many aliases in MSCAD 3.1, 2001, 2002, and 2004
and | really would prefer not to have to do them all again in
MSCAD2004. Is there a quick way to convert these over so |
don't lose them?

The original alias's are saved in a file called SAMPLE.KEY or MicroSurvey.key located in your
MSCAD----\CFG folder. All you need to do is open this file in WordPad, find the section
marked [ALIAS COMMANDS], highlight the alias's you wish to save, with your mouse, and
then Copy it to the clipboard. Then open the MSCAD2005.PGP file found in the Program
Files\MicroSurvey\MSCAD2005\SUPPORT folder. Pick on the last line under the list and Paste
your old list into the new file. Because the new IntelliCAD engine requires this list to be in a
different format, click on Edit > Replace, in the “Find what:” field enter = and in the “Replace




with:” field enter ,* then press Replace All. Then check for any duplication of keys and correct
appropriately. Close the file and save your changes.

Now open MSCAD 2005, and go to Cad Tools >
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I have setup several Hotkeys in MSCAD3.1/2001/2002/2004 and |
really would prefer not to have to do them all again in
MSCAD2005. Is there a quick way to convert these over so |
don't lose them?

Customize
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Because MSCAD 2005 is using the new
IntelliCAD engine, hotkeys created in previous
versions can not be used, so you will need to
manually re-enter them in MSCAD 2005. Open
MSCAD 2005, and go to Cad Tools > Customize,

and click on the Keyboard tab. To add a new
hotkey, press the New button, then press the
key you want to add, then highlight the desired
command from the “Available commands” list
and press the "Add Command” button. If you
want to change the command for an existing
key, highlight it in the “Defined keys” list, erase
its entry from the "Command” field, then
highlight the desired command from the
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Command” button.

If you want to view or print your original hotkeys as a reference, they are saved in a file called
SAMPLE.KEY or MicroSurvey.key located in your MSCAD----\CFG folder. All you need to do is
open this file in WordPad or Notepad, and find the section marked [FCAD FctKeys] or
[ACCELERATOR KEYS]. Some key combinations setup in MSCAD3.1, 2001, 2002, or 2004

may not be available in MSCAD 2005.



| have customized a Palette in MSCAD3.1, 2001, 2002, 2004 and
created a new one of my own. What do | do to save them so |
can use them in MSCAD2005?

Because MSCAD 2005 is using the new IntelliCAD engine, palettes/toolbars created in previous
versions can not be used. It is very easy to create new toolbars in 2005, on the fly, as you
work.

| have several copies of MSCAD 3.1/2001/2002 and a few copies
of MS98 / MSX. Can | work in MSCAD2004 and then have
another person continue in MSCAD 3.1/2001/2002 or MS98 /
MSX?

Yes we can save the file back to the older version from MSCAD 2004 by going under the File
menu -> SaveAs and save back to an older DWG format. We do suggest that you upgrade all
your copies to the latest version especially if you have MS98, MSX 2001, MSCAD 3.1 or
MSCAD 2001. These versions have our older style database (PST) that can make it difficult to
keep track of your database files as each project will have a PST and MSD database.

I was lucky enough to have a prerelease or Beta copy of MSCAD
2005. What do | do now with the new CD?

We appreciate your assistance as a Beta tester and we thank you all for your assistance in
getting MSCAD 2005 completed. We do recommend that you uninstall your beta copy of
MSCAD 2005. Any changes you have made to customize MSCAD 2005 should be backed up.
We recommend that you copy the changes out to a safe location prior to installing the new CD
and then if desired, copy the files back in over the new ones, after looking at what we have
done.

| see that MSCAD 2005 defaults to a working folder of JOBS2005
for my new jobs. Can I still place my jobs in my old folders?

Yes. The default is Jobs2005 but you can save your projects to any directory you want. The
MicroSurvey Project Manager now shows the recent jobs you have worked on and allows you
to open them directly without having to go to that folder manually.

How do | remove my old MSCAD Version?

Please use the Control Panel > Add / Remove Programs option and remove the program. This
will remove any extra files that we installed into the Windows System directory. After the
program is removed, there will be a few configuration files left in the MSCAD31, 2001, 2002 or
2004 directory. After you have examined the remaining files in this directory and
subdirectories to verify that you haven't placed any valuable files in here, you can delete this
directory and subdirectories.




Do | have to reset all of my Labelling Defaults so the Bearings,
Distances, Point Numbers, Elevations, and Descriptions all have
the size and style of lettering | desire, and had in my previous
version?

We do ship the program with our defaults preset to make it easier for new customers to get
started immediately. However, it is very simple to reset them back to your desired default
settings that you setup in your previous version. All you need to do is take an old job that had
the desired labelling defaults and open it in MSCAD 2005. Then go to the MsTools Menu ->
MicroSurvey System Defaults -> Save as Default Configuration. This will set it so all new jobs
use your previous settings.

| want to plot my first MSCAD 2005 drawing. Can | get my
MSCAD 3.1/2001/2002/2004 plot configuration for line width and
colors into MSCAD 2005?

Because MSCAD 2005 uses the new IntelliCAD engine, printing is handled differently than in
previous versions, and so your previous plot configuration files are not compatible. Please
refer to our online Tech Note “Printing / Plotting in MSCAD 2005” to review all of the changes
and enhancements.

| see that the menus have changed for MSCAD 2005.

If you are upgrading from MSCAD 3.1, 2001, or 2002 then yes, the menus have changed. We
have spent a great deal of time re-organizing the menus in MSCAD 2004 so they're more
intuitive to use. In the short term, you will be a little lost but take some time and examine
how they've been organized.

If you are upgrading from MSCAD 2004, then only the IntelliCAD menus have changed,
including File, Edit, View, Draw, Modify, Settings, and Cad Tools. All of the MicroSurvey
menus have retained their MSCAD 2004 organization (or very minor changes).

Where is the Options Bar?

The option bar was a FelixCAD feature. MSCAD 2005 no longer has one but you will see that
it has an option menu that appears which is just as useful...

What is this Floating Menu? Can | get rid of it?

First thing you will notice when you use MSCAD 2005 is a floating menu that will appear as
you use different commands at the command line. It does operate similar to the FelixCAD
option bar, but it might annoy some users. If you want to turn it off, type Config at the
command line, and turn off “Display prompt boxes” in the display tab.




How do | load Toolbars?

You can load toolbars by going to the menu that the palette resides in. You will note that each
menu item has a toolbar or toolbars listed towards the bottom of the menu. For example to
open the Area Toolbar you would go to the MsCOGO Menu and choose the Area Toolbar
command.

How do | play the training movies?

For MSCAD 2005, the help movies have been built into the help system. Not only is there a
topic listing the available movies you will find that individual topics will have a link to
corresponding movies.

I've heard the online help file was improved for MSCAD 2005?

Topics in the help file now contain links to training movies and tell you where the command
can be found in the menus. The topics will also list what command name and icon to use. We
have also updated the help for the new CAD engine and the survey commands have also been
updated.

What happened to the Symbol Palettes from the old Design
Menu?

For MSCAD 2004 and 2005 we built a new Symbol Librarian. You will find all the symbols from
the Symbol Palettes in this function which you can open by typing INSYM at the command
line, or pick MsAnnotate > Add Symbols > Symbol Librarian.

A range of new symbols have also been included in 2005 that can also be found in the Symbol
Librarian. Any custom symbols from older versions of MSCAD would have to be saved as DWG
files to be used in MSCAD2005.

What about the house libraries | have setup in MSCAD2004?

You can simply copy the files from MSCAD2004 to MSCAD2005 and they will work
automatically. Copy the following files DB_POLY.ASC from the C:\MSCAD2004\MSCAD folder
into the C:\Program Files\MSCAD2005\MSCAD folder. And copy all of the files from the
C:\MSCAD2004\MSCAD\HOUSELIB folder into the C:\Program Files\MSCAD2005\MSCAD
folder.

What about the Description Translation Library from
MSCAD2004?

You can simply copy the files from MSCAD2004 to MSCAD2005 and they will work
automatically. Copy the following files IC_CCPD.MP, IC_CCPD.ST and IC_CCPD.NX from the
C:\MSCAD2004\MSCAD folder into the C:\Program Files\MSCAD2005\MSCAD folder.




When using FieldGenius with MSCAD2005, where do my jobs go
now?
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