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Introduction

Using IntelliCAD is part of an integrated documentation set that includes this manual 
and a comprehensive collection of help resources to give you the information you 
need to create drawings in IntelliCAD®.

This manual is organized into chapters that parallel how you work in IntelliCAD, 
according to the tasks you might perform. The tasks are divided and organized into 
the following work-focused chapters:

Introduction: Chapter 1  An overview of the key features of IntelliCAD plus basic con-
cepts of computer-aided design (CAD) as they apply to IntelliCAD.

Getting started: Chapter 2  Installing IntelliCAD, starting and exiting IntelliCAD, 
working with toolbars, and selecting commands. 

Working with drawings: Chapter 3  Opening and saving an existing drawing and start-
ing a new drawing. Using drawing settings to establish paper size, scale factors, and 
text height. Working with colors in your drawings. Using drawing aids such as entity 
snaps and orthogonal mode to draw accurately.

Creating entities: Chapters 4–5  Working with simple entities such as lines, circles, and 
arcs and with complex entities such as polygons, spline curves, planes, wipeouts, 
boundary hatches, and more.

Viewing your drawing: Chapter 6  Moving around in the drawing, changing its magnifi-
cation, creating multiple views, and saving arrangements of windows of the drawing.

Topics in this chapter

About IntelliCAD and other CAD software ............................................................ 3

Comparing IntelliCAD and CAD to manual drafting ....................................... 5

Using advanced CAD features............................................................................ 13

Getting more information .................................................................................... 13

What’s new in IntelliCAD 6.0 – 6.5...................................................................... 14
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Working with coordinates: Chapter 7  Working with Cartesian coordinate systems, 
specifying two-dimensional and three-dimensional coordinates, and defining your 
own user coordinate systems.

Working with the IntelliCAD Explorer: Chapter 8  Using the IntelliCAD Explorer to man-
age your drawings: controlling layers, linetypes, text styles, coordinate systems, 
views, and blocks and copying information between drawings.

Getting drawing information: Chapter 9  Working with the additional information in 
IntelliCAD drawings, calculating areas and distances, and displaying other drawing 
information.

Modifying entities: Chapter 10  Selecting, copying, rearranging, resizing, and editing 
entities.

Annotating and dimensioning your drawing: Chapters 11–12  Using text to annotate 
drawings; using dimensions to annotate the measurement of entities.

Working with blocks, attributes, and external references: Chapter 13  Using blocks and 
external references to combine entities and data for reuse; creating attribute informa-
tion to extract for use in other programs. 

Formatting and printing drawings: Chapter 14  Combining drawings into finished lay-
outs, customizing print options, and printing copies.

Drawing in three dimensions: Chapter 15  Creating and editing three-dimensional enti-
ties. And visualizing them using hidden line removal, shading, and photo-realistic 
rendering.

Working with other programs: Chapter 16  Sharing drawings and data with other users, 
documents, and programs.

Customizing IntelliCAD: Chapter 17  Customizing the appearance and operation of the 
program to suit your needs.

Understanding AutoCAD compatibility: Appendix  Describes similarities and differences 
between IntelliCAD and AutoCAD.
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About IntelliCAD and other CAD software

IntelliCAD is designed for anyone who wants a fast and efficient CAD program with 
all the power and versatility of standard programs such as AutoCAD® by Autodesk®, 
Inc., or MicroStation® by Bentley Systems, Inc., at an affordable price. Using today’s 
advanced technology, IntelliCAD integrates the Microsoft® Windows® interface with 
a powerful CAD engine. 

IntelliCAD provides unparalleled compatibility with AutoCAD, using most of the 
same file formats including those for drawings (.dwg files), commands, linetypes, 
hatch patterns, and text styles. You can also use AutoCAD menu files and run 
Autodesk® AutoLISP® programs. If you have written your own ADS (Autodesk® 

AutoCAD Development System®) programs, simply recompile them to link with the 
IntelliCAD libraries. Many third-party ADS programs already support IntelliCAD. If 
you have a program that is not already supported, ask your software vendor to pro-
vide an IntelliCAD-compatible version of the program.

IntelliCAD is more compatible with the AutoCAD program than any other CAD 
product, delivers additional tools with advanced CAD features, and has a seamless 
Microsoft® Windows integration. This powerful program provides a superb combina-
tion of features for CAD users like architects, engineers, and designers.

IntelliCAD incorporates standard features found in other CAD programs, along with 
features and capabilities you won’t find anywhere else. Its multiple-document inter-
face (MDI) lets you open and work with several drawings at the same time. You can 
easily copy drawing entities between drawings. In addition, the powerful IntelliCAD 
Explorer lets you manage information and settings and quickly copy layers, linetypes, 
and other information between drawings.

Using AutoCAD legacy drawings
IntelliCAD fully supports AutoCAD legacy drawings. IntelliCAD reads and writes 
DWG files in their native format without any loss of data, from AutoCAD 2007 back 
to Version 11, including AutoCAD LT®. Because IntelliCAD uses DWG as its native 
file format, no translation is required. 

IntelliCAD provides you with the appropriate tools for your experience level—
whether you are a beginner, intermediate, or advanced CAD user. If you are just start-
ing out with CAD, you may want to use the beginner level, which provides toolbars 
containing the basic tools such as lines, arcs, and circles. As you become more expe-
rienced, you can move to the intermediate level and then to the advanced level, which 
gives you access to more than 300 commands through toolbars, menus, and keyboard 
entries. You can change the experience level in the Options dialog box on the Tools 
menu.

IntelliCAD supports three-dimensional wireframes and surfaces. Three-dimensional 
drawings can be displayed in wireframe, hidden-line view, and surface shading. 
Some versions of IntelliCAD also support creating and editing 3D solids; all versions 
display 3D solids, along with limited editing features. 



4 C H A P T E R  1
Some versions of IntelliCAD support displaying and working with raster images in 
your drawings. However, IntelliCAD does not display images located inside of 
blocks and externally referenced drawings (xrefs). When a drawing containing proxy 
entities is loaded into IntelliCAD, a message displays indicating that some entities 
will not display, however, the entities reappear when you open the drawing later in 
AutoCAD. 

It’s easy to customize IntelliCAD. You can modify menus and toolbars, create 
custom menus, dialog boxes, command aliases, and scripts, and add custom programs 
written in any of several programming languages, including LISP (the program’s 
Autodesk® AutoLISP-compatible language) and SDS™ (Solutions Development 
System™, the program’s Autodesk® ADS-compatible language). There is also 
Microsoft® Visual Basic for Applications (VBA).

You can run existing Autodesk® AutoLISP applications in IntelliCAD with little or 
no modification. IntelliCAD uses the Appload command so you can easily load LISP 
programs. IntelliCAD reads files that contain dialog control language (DCL) state-
ments as well, which makes IntelliCAD compatible with dialog boxes created for 
AutoCAD.

Using AutoCAD commands with IntelliCAD
Because IntelliCAD supports hundreds of AutoCAD commands, you use the com-
mands you already know. For example, to draw a circle, use the Circle command. To 
copy a circle, use the Copy command. 

When you press Enter or the spacebar, you activate the command—just like in 
AutoCAD. IntelliCAD accepts the special characters used by AutoCAD, such as 
point filters (for example, .xy), relative coordinates (the @ symbol), and the apostro-
phe (the ‘ prefix) for transparent commands. IntelliCAD function keys are also simi-
lar to those used in AutoCAD. 

Because you do not need to learn a new set of commands, you are immediately pro-
ductive with IntelliCAD. 
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Comparing IntelliCAD and CAD to manual drafting

IntelliCAD greatly reduces the time and effort it takes to create and revise drawings. 
Not only can you produce accurate drawings faster, you can also reuse the informa-
tion in your drawings. These are the primary reasons for making the transition to 
CAD from traditional, manual drafting on paper.

As with any tool, however, to use it effectively, you need to be familiar with some of 
the special features, functions, and concepts of CAD. If you are familiar with manual 
drafting, you’ll find some conceptual similarities in CAD as well as some differences.

Drawing to scale
In traditional, manual drafting, you usually determine the scale of the drawing before 
you even start to draw, because you are working with a sheet of paper of a fixed size. 
You may have to reduce or enlarge the entity you are drawing to fit within the con-
fines of the paper.

When you create a drawing in IntelliCAD, you draw everything full-size. You deter-
mine the type of units in which your drawing is measured. If you are drawing a build-
ing, 1 drawing unit might equal 1 inch. If you are drawing a map, 1 drawing unit 
might equal 1 mile. Your drawing environment and the CAD drawing file itself are 
not limited to the size of a particular sheet of paper. 

As you draw, you can use commands such as Pan and Zoom to work on different por-
tions of the drawing and to magnify the display of the drawing to view small details. 
These commands have no effect on the actual size of the entities in your drawing; 
they affect only the way the drawing is displayed on your screen. Only when you 
print or plot your drawing do you need to set the scale so that the printed drawing fits 
within a specific paper size.

1 drawing unit equals 1 inch. 1 drawing unit equals 1 foot.
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Using tools
In manual drafting, you use tools such as pencils, rulers, T-squares, templates, eras-
ers, and so on. When you create a drawing in IntelliCAD, you use a mouse instead of 
a pencil, and you use the mouse to select other tools—commands you select from a 
menu or a toolbar.

You use some tools to create basic entities, such as lines, circles, and arcs, and other 
tools to modify existing entities (for example, to copy or move them or to change 
properties such as color and linetype).

Organizing information
In traditional drafting, you often separate elements such as walls, dimensions, struc-
tural steel members, and electrical plans onto separate, translucent overlays. When 
you want to print the working drawings, you can create several different drawings by 
combining different overlays.

When you create a drawing in IntelliCAD, you use layers to organize elements in a 
similar manner. However, the layers feature in CAD offers numerous advantages 
over physical transparencies. The number of overlays you can combine to print a 
manually drafted drawing is limited by the printing process. There is no such limita-
tion in CAD. With IntelliCAD, you can define an unlimited number of layers, any of 
which can be visible or invisible at any time. You can name each layer and assign 
each its own color, linetype, lineweight, and print style. You can also lock individual 
layers to ensure that information on those layers isn’t altered accidentally. 

Use layers to organize drawing information.
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Drawing accurately
When you create a manual drawing, ensuring accuracy typically requires a lot of 
manual calculations and rechecking. By contrast, IntelliCAD offers a number of 
drawing aids that ensure accuracy from the start. For example, you create and modify 
entities based on an underlying Cartesian coordinate system. Every location in the 
drawing has its own x,y,z-coordinates. You can also display a grid as a visual refer-
ence to your coordinate system.     

Settings such as snap and entity snap allow you to draw accurately without specifying 
coordinates. The snap setting forces the selected points to adhere to the grid incre-
ment or to any other increment you set. Entity snaps let you snap to precise geometric 
points on existing entities—for example, the endpoint of a line or the center of a cir-
cle. Another setting, orthogonal, constrains lines so that they are drawn parallel to the 
vertical and horizontal axes. 

Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate 
system. Point 5,2,0 is 5 units to the right (along the x-axis), 2 units up (along the y-axis), and 0 units (along 
the z-axis) from the origin (the 0,0,0 point).
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Drawing efficiently
In paper-based, manual drafting, you often have to redraw the same entity several 
times at different scales or from different vantage points. You may also need to 
redraw the border and title block on each new sheet.

One of the most powerful features of IntelliCAD is that when you create a drawing, 
you can reuse individual entities, borders, and title blocks as often as you want. You 
need draw an entity only once; the final printed drawing can show the entity at sev-
eral different scales and viewpoints.

You usually begin drawing in model space on the Model tab, creating the drawing (a 
floor plan, a map, or a three-dimensional part) without regard to the final layout on 
paper. When you are ready to print your drawing, you have the option to switch to 
paper space on a Layout tab, where you lay out the drawing as you want it to appear 
on a sheet of paper. For example, you can insert a drawing file that contains the stan-
dard border and title block that you created. You can define and arrange multiple 
views of the drawing at appropriate scales and with specific portions visible or invisi-
ble—again, without having to redraw the border and title block for each view. 

Paper-based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail 
to meet adjacent lines.

Snap and entity snap force the cursor to adhere to a specified increment or attach to key geometric points on 
existing entities. You can also constrain lines to vertical and horizontal axes.
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You create the basic drawing in model space on the Model tab.

When you’re ready to print or plot your drawing, you can switch to paper space on a Layout tab, where you provide a 
layout of the drawing as you want it to appear on a sheet of paper.
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Reusing CAD drawings and entities
When you create a paper drawing manually, you can draw repetitive symbols by trac-
ing a plastic template. After you draw a symbol in IntelliCAD, you can reuse that 
symbol without having to redraw it. You simply save the symbol as a block. You can 
then insert copies of that block anywhere in your drawing. You can also save the 
symbol as a separate drawing for use in other drawings.  

In addition, you can reuse entire drawings and insert individual drawings into other 
drawings. You can also use an external reference, which acts as a pointer to another 
drawing rather than a copy of the entire drawing. Using an external reference has an 
added advantage: when you update the externally referenced drawing, each drawing 
that references it can be automatically updated.

You can draw a symbol one time, save it as a block, and then insert multiple copies of that symbol anywhere 
in your drawing.
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Making changes
To make changes to a paper drawing, you erase and then redraw. With IntelliCAD, 
you use commands to modify entities in the drawing. You can move, rotate, stretch, 
or change the scale of entities. When you want to remove an entity, you can delete it 
with a single click of the mouse. If you make a mistake while creating or modifying 
your drawing, you can easily reverse your actions.    

Working with other data and programs
Traditional paper drawings serve only as a means of communicating information 
between the person who created the drawing and the person viewing the drawing. The 
drawings contain no more information than what is visually imparted by the creator 
and seen by the viewer.

IntelliCAD offers rich possibilities for analyzing drawings and attaching additional 
data to them. For instance, although it may be impractical to count entities in a com-
plex paper drawing, this task is simple in CAD. IntelliCAD can calculate the number 
of entities in a drawing and compute area and distance.

CAD drawings can also contain information in addition to visible entities. You can 
attach invisible database information to visible drawing entities and extract the infor-
mation for analysis in a database or spreadsheet. (Working with information in a data-
base requires a program from a third-party vendor, or you can create your own means 
of exporting the data in LISP or SDS. Or, you can also use VBA.) 

You can easily change an entity using commands such as move, rotate, stretch, and scale instead of 
redrawing the entity.
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IntelliCAD provides in-place editing of Microsoft® objects, such as those created in 
Microsoft® Word and Microsoft® Excel software programs. In-place editing makes it 
easy to share data with other users and programs. For example, you can include Intel-
liCAD drawings in files created using Microsoft® Word, and you can insert files cre-
ated using Microsoft® Word into your IntelliCAD drawings.

You can extract information stored in the drawing as 
visible or invisible attributes…

…and use that data for analysis in a database or 
spreadsheet.
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Using advanced CAD features

In addition to being compatible with AutoCAD, IntelliCAD goes several steps further 
by providing you with innovative features to increase your productivity.

Using the IntelliCAD Explorer
The IntelliCAD Explorer has an interface similar to the Windows Explorer, allowing 
you to view and manage the elements of multiple, open drawings, such as layers, 
blocks, linetypes, views, user coordinate systems, and text styles. 

Editing multiple documents simultaneously
With IntelliCAD, you can open and edit multiple drawings simultaneously. You can 
also copy and paste elements between open drawings. 

Editing multiple entities
IntelliCAD allows you to change most of the properties of all selected entities using a 
single, tabbed dialog box. 

Using the Customize dialog box
IntelliCAD has a single, tabbed dialog box for changing toolbars, menus, keyboard 
shortcuts, and command aliases. You can also use the drag-and-drop method to cus-
tomize toolbars, including flyouts. The simple, point-and-click action lets you easily 
create new menu items and keyboard shortcuts—no programming or manual text 
editing required.

Performing unlimited undo and redo
IntelliCAD increases your power with unlimited undo and redo of editing actions.

Getting more information

In addition to the IntelliCAD documentation, much of the assistance you need as you 
use IntelliCAD is specific to the commands you work with on the screen. To obtain 
immediate information as you work, use these additional sources of information:

ToolTips To find out what a specific tool on a toolbar does, pause the cursor over it for 
a moment. A ToolTip appears on the screen.

Status bar To find out more detailed information about a tool when you pause the cur-
sor over it, look on the status bar at the bottom of the screen.
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Online help IntelliCAD online help is available on the screen when you press F1, 
choose a command from the Help menu, or click the question mark in a dialog box. 
The online help also presents information that does not appear in this manual, includ-
ing a programming reference that describes how to program in LISP, SDS, and 
DIESEL. The programming reference also describes programming in VBA.

What’s new in IntelliCAD 6.0 – 6.5

What’s new in IntelliCAD 6.5

Performance enhancements

Performance has been enhanced considerably when using real-time zoom, real-time 
pan, and saving drawings.

Toolbar and menu icons

The IntelliCAD user interface has been enhanced with new 24-bit icons for all color 
toolbar icons and menus.

Use polar tracking

Polar tracking is a new tool used to help you draw with precision. When polar track-
ing is turned on, guides display on the screen automatically at specified polar angle 
increments. For more details, see “Using polar tracking” on page 73. 

Check the spelling of text

You can check the spelling of single-line text, multiline text, paragraph text, 
attributes, attribute definitions, and dimension text. Additional features include load-
ing dictionaries from different sources, including various languages, and adding your 
own words to a custom dictionary.

For more details, see “Checking the spelling of text” on page 289. 

Copy multiple entities

Now it’s easier to copy multiple entities. IntelliCAD defaults to prompting for addi-
tional copies of selected entities during the Copy command. For details, see “Copying 
entities within a drawing” on page 242. 

Work with additional image formats

The number of image formats available for drawings has been expanded. You can 
include images in the following formats: ECW, JPG 2000, ERS, ALG, HDR, DAT, 
DOQ, FST, NTF, ASC, IMG, DEM, DDF, DT0 and DT1, and HDF (including MET, 
L1R, and L1G).

For details about working with images, see “Using images in a drawing” on page 449. 
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Layer toolbar

You can now use the Layer toolbar to specify layout-specific layer settings. The 
Layer toolbar also displays more text, making it easier to use large layer lists. For 
details about working with layers, see “Organizing information on layers” on page 
177. 

Customize the status bar and menus using DIESEL

You can use DIESEL from the command line, in MNU menu files, and in LISP to 
customize the status bar and menus. For more details, see the Developer’s Reference 
online help.

Use new and enhanced system variables

New system variables include: AUTOSNAP, COPYMODE, DCTCUST, 
DCTMAIN, DCTMAINPATH, DIMTFAC, POLARADDANG, POLARANG, 
POLARDIST, POLARMODE, SNAPTYPE, and TRACKPATH.

What’s new in IntelliCAD 6.4

Work with the newest DWG 2007 format

IntelliCAD supports the updated DWG 2007 format by opening, printing, and saving 
new entity types, such as annotations.

There are also many new system variables that are supported for DWG file compati-
bility only.

What’s new in IntelliCAD 6.3

Work with DWG 2007 files

IntelliCAD supports opening, modifying, printing, and saving drawings in DWG 
2007 format. The DWG 2007 format is now the default format in which IntelliCAD 
drawings are saved.

Create and edit color books

Now you can create and edit color books, which help you organize collections of col-
ors, right from IntelliCAD. For more details, see “Using color books” on page 61. 

Work with images

IntelliCAD Professional version includes enhanced imaging features to help you 
work with images in your drawings. Working with images is similar as in previous 
IntelliCAD versions, with easy-to-use features located on the Image menu in 
IntelliCAD. For more details, see “Using images in a drawing” on page 449. 

Use new layout viewport features

There are several new features for layout viewports: 

• Snap to model space entities from paper space.
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• Lock layout viewports to lock the model space view or location while panning or 
zooming in paper space. 

• Assign a unique UCS to a layout viewport.

For details, see “Working with layout viewports” on page 368. 

Manage character sets for drawings

IntelliCAD allows you to manage which character set is assigned to a drawing. This 
unique feature can be very helpful when sharing or distributing drawings in geo-
graphic regions where several languages are used that require different character sets 
to display text properly. For details, see “Specifying character sets for drawings” on 
page 295. 

Reverse the zoom direction of the mouse wheel

Instead of zooming in and out by moving the mouse wheel forward and backward, 
you can reverse the settings to zoom in when spinning the mouse wheel backward 
and zoom out when spinning the wheel forward. This can be especially helpful if you 
use the mouse with your left hand. For details, see “Changing the options on the Dis-
play tab” on page 480. 

Use new and enhanced system variables

New system variables include: 3DDWFPREC, DIMARCSYM, DWGCODEPAGE, 
IMAGEHLT, RASTERVERNUM, RTDISPLAY, UCSVP, and ZOOMWHEEL.

Enhanced system variables include: DELOBJ, FACETRATIO, HALOGAP, HIDE-
PRECISION, OBSCUREDCOLOR, OBSCUREDLTYPE, OLEQUALITY, and 
TEXTEVAL.

There are also many new system variables that are supported for DWG file compati-
bility only.

What’s new in IntelliCAD 6.2

Assign true colors and color book colors

You’ve always been able to add color to your drawings using index colors, but now 
you use two new color features:

• True colors — Defined using 24-bit color, there are more than 16 million true col-
ors from which you can choose.

• Color books — Defined with a list of colors, color books help you organize col-
lections of colors. For example, you can store a unique color scheme for a client in  
a color book and then use colors only from that color book for the client’s draw-
ings.

For more details, see “Working with colors” on page 58. 
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Work with raster images using ADeko Raster

IntelliCAD Professional version includes new raster imaging software to help you 
work with images in your drawings. Working with raster images is similar to previ-
ous IntelliCAD versions, with easy-to-use features located on the Image menu in 
IntelliCAD. For more details, see “Using images in a drawing” on page 449. 

Export to PDF and 3D DWF format

You can export drawings to two new formats: 

• PDF — Portable Document Format files allow you to distribute your drawing to 
others for viewing with Adobe® Acrobat® Reader®, which is free software that 
users can download, and for viewing, reviewing, and editing with Adobe® Acro-
bat. For more details, see “Exporting to a PDF file” on page 468. 

• 3D DWF — 3D Design Web Format files can be viewed in a Web browser if 
Autodesk® DWF Viewer is also installed on the computer. DWF Viewer is a free 
tool from Autodesk® that always supported viewing 2D DWF files, but now sup-
ports viewing DWF files in three dimensions. For more details, see “Exporting to 
a DWF file” on page 470. 

Use entity snaps

When using the extension option with Intersection Snap and Apparent Intersection 
Snap, IntelliCAD draws dashed extension lines to help guide you as you use the 
extension snap option. For more details, see “Using entity snaps” on page 74. 

If you are working in the command bar, you can modify the active command by typ-
ing m2p or mtp to enable a one-time snap to the midpoint of two points that you spec-
ify. For details, see “Modifying a command” on page 34. 

Edit text in the command line

The command bar and Prompt History window include enhanced text editing, includ-
ing cutting, copying, and pasting text; copying the last command line or the entire 
command history; and repeating a previously executed command. For details, see 
“Starting commands using the command bar” on page 33. Also see “Using the 
Prompt History window” on page 34. 

Create wipeout entities

Wipeouts are unique entities that can help you hide areas of your drawing. They dis-
play with the current background color, so the details behind the wipeout do not dis-
play or print. However, if your version of IntelliCAD does not include raster image 
capability (that is, does not include an Image menu), wipeout entities display, but the 
details behind the wipeouts also display. For details, see “Drawing wipeouts” on page 
121. 
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Create audio notes from existing *.wav files

In addition to recording audio notes in IntelliCAD and attaching them to entities, you 
can now create audio notes from existing *.wav files. Audio notes created from an 
existing *.wav file are saved in the drawing file and the separate *.wav file remains 
unchanged. For details, see “Working with audio notes” on page 514. 

View thumbnails of drawings

When you open or save a drawing, drawing files can be displayed in a number of 
ways, including by filename with or without the additional details. Now you can also 
view thumbnail images of drawing files. For details, see “Opening a drawing” on 
page 41. 

You can also view thumbnail images when you browse drawing files on your com-
puter using programs that came with your operating system, such as Windows File 
Explorer or My Computer.

Use new and enhanced system variables

New system variables include: AUDIOICONCOLOR, NOMUTT, OSNAPCOORD, 
OSNAPHATCH, OSNAPZ, and RTSKIPCOUNT.

Enhanced system variables include: CECOLOR and SNAPCOLOR.

What’s new in IntelliCAD 6.1

Create rendered images

IntelliCAD uses new and enhanced rendering features to create higher-quality and 
more photo-realistic images of models.

Both IntelliCAD Standard and IntelliCAD Professional include the new rendering 
solution, while some versions provide additional rendering capabilities with a com-
plete set of materials, backgrounds, lighting options, and render settings.

For details, see “Hiding, shading, and rendering” on page 441. 

Format text

New formatting features are available when you enter text using Insert > Multiline 
Text. You can specify text color, first line indents, paragraph indents, right indents, 
and tabs.

For details, see “Creating paragraph text” on page 279. 

Attach and record audio

IntelliCAD provides the unique ability to record audio notes, which are sound clips 
attached to entities and available for playback at any time. For example, audio notes 
in a factory floor plan can describe maintenance activities for specific areas of the 
factory — employees can play the audio notes to hear instructions.

For details, see “Working with audio notes” on page 514. 
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Work with 3D solids

In addition to slicing and sectioning solids, you can now slice regions and bodies 
(typically sheets). 

For details, see “Sectioning and slicing solids” on page 431. 

Use entity snaps

You can now snap to hatch patterns when using entity snaps:

• Snap to the middle points and end points of hatch pattern lines.

• Snap to the nearest point and perpendicular point on a hatch pattern line.

• Snap to any intersection point or apparent intersection point where the pattern line 
intersects with other entities that are supported by entity snaps.

For details, see “Using entity snaps” on page 74. 

Use new system variables

New system variables include: AUDIOICON, AUDIOICONCOLOR, and 
AUDIOICONSCALE.

What’s new in IntelliCAD 6.0

Utilize performance enhancements

Many IntelliCAD features include increased performance. The following table 
describes the main enhancements and estimated performance increases.

Feature Performance increase

True Type Fonts
Pan
Zoom

4X (400%)
7X (700%)

Polylines
Pedit 50X (5000%)

Linetypes
Zoom extents
Pan
Regen

7X (700%)
10X (1000%)
7X (700%)

Hatch Patterns
Regen 50X (5000%)

LISP Performance
General

10X (1000%)

Blocks
Symbol table search
Regen

7X (700%)
7X (700%)

Viewports
Regen
Model space
Block display
Paper space

4X (400%)
4X (400%)
4X (400%)
3X (300%)
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Assign print style tables

The following printing features have greatly enhanced flexibility and control over the 
printing process:

• Previously you could use the PenMap/Width mapping to associate colors with 
specific pen widths on your printer. New print style tables allow you to still spec-
ify color-based settings, but also allow you to specify pen widths, linetypes, and 
lineweight regardless of color. 

• Print style tables (.ctb and .stb files) are stored in files; you can share the files 
across multiple drawing files or with other users.

Print style tables affect numerous existing features, including: New Drawing and 
New Drawing Wizard; Properties and Entity Properties toolbar; Change; IntelliCAD 
Explorer (Layers); Drawing Settings > Entity Creation tab; Status bar; Options > 
Paths/Files tab; Options > Printing tab; and Print > Advanced tab.

There are also several new commands for print style tables: Print Style (printstyle), 
Print Styles Manager (stylesmanager), Convert Drawing Print Style Tables 
(convertpstyles), and Convert CTB Print Style Table (convertctb).

For details, see “Using print styles” on page 379. 

Manage external references

Attaching and working with external references is now easier with the new 
Xref Manager. You can view a detailed list of the referenced drawing, or you can 
view a hierarchical display that shows how drawings are nested and related to one 
another. Quickly attach, detach, reload, bind, open, and change the path for all exter-
nal references in the current drawing.

The Xref Manager allows you to use the same external reference features as in previ-
ous versions of IntelliCAD, but in a more efficient manner.

For details, see “Working with external references” on page 348. 

Work with 3D solids

IntelliCAD Standard version now supports viewing and limited editing of 3D solids, 
including moving, rotating, and scaling. IntelliCAD Professional version still allows 
you to create and more completely edit 3D solids.

For details, see Chapter 15, “Drawing in three dimensions.” 
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Use entity snaps

The existing Intersection Snap has a new Extended option, which snaps to the logical 
location where two entities would intersect if they were of infinite length. 

The new Apparent Intersection Snap tool snaps to the intersection of two entities that 
are not in the same plane but seem to intersect in the current view. You can also use 
its Extended option, which snaps to the logical location where two entities would 
intersect if they were of infinite length. 

For details, see “Using entity snaps” on page 74. 

Customize more options

The following features are new to the Tools > Options dialog box:

• General tab Set the default Save As format. Specify how drawings are opened.

• Paths/Files tab Specify search paths for print style tables.

• Display tab Use Up/Down arrows in the command history. Show or hide the 
Model and Layout tabs. Show or hide scroll bars.

• Profiles tab Create and manage drawing environment profiles.

• Printing tab Specify headers and footers for all drawings. Assign default print 
style table settings for new drawings.

For details, see “Setting and changing options” on page 476. 

Save and restore drawing environment profiles

Customize the settings that control your drawing environment, and then save and 
restore those settings in a profile. For example, if you prefer working with custom 
menus and toolbars, you can save these settings as your own profile.

Profiles can be helpful if you have multiple users with different preferences, or if you 
are a single user who works on various projects that require unique settings. You can 
even export your profile and bring it with you when you work on a different com-
puter. 

For details, see “Changing the options on the Profiles tab” on page 484. 

Navigate model space and paper space

Use the enhanced Model/Paper Space control in the status bar to switch more effi-
ciently between model space and paper space on either the Model tab or a Layout tab. 
For details, see “Viewing drawings in paper space and model space” on page 364.  

You can also change the display of the Model and Layout tabs in the following ways:

• Show or hide the Model and Layout tabs. For details, see “Displaying the Model 
and Layout tabs” on page 365. 

• Reorder the position of the Layout tabs. For details, see “Managing layouts in a 
drawing” on page 367. 



22 C H A P T E R  1
Work in the command bar

In the command bar, you can do the following:

• Select text, and then right-click to copy, cut, and paste.

• Press Ctrl + K and Ctrl + L to move forward and backward in the command his-
tory. 

• Use the Up and Down arrows to scroll the command history, if enabled by choos-
ing Tools > Options.

For details, see “Repeating a command” on page 33. Also see “Using the Prompt His-
tory window” on page 34. 

Choose single IntelliCAD sessions

Use the new Single Session command (type singleton) to choose whether IntelliCAD 
can be started one time or multiple times simultaneously.

Use new system variables

New system variables include: APBOX, CPLOTSTYLE, CTRLMOUSE, 
DEFLPSTYLE, DEFPLSTYLE, DEFPLSTYLETBL, FONTALT, PSTYLEMODE, 
PSTYLEPOLICY, MBUTTONPAN, SAVEROUNDTRIP, and SHOWTABS.
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Getting started

This section helps you get started using IntelliCAD software by explaining how to 
install it and providing basic information about how to use it.

NOTE This guide assumes that you have used other Windows-based programs and are 
familiar with Windows terminology and techniques.
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System requirements

You need the following software and hardware to install and run IntelliCAD: 

• Microsoft® Windows Vista®, Windows XP Professional, Windows XP 
Professional x64 Edition, Windows XP Home Edition, Windows 2000, or 
Windows® 98

• 300 megahertz (MHz) or faster processor recommended; 233 MHz minimum 
required (single or dual processor)

• 1 gigabyte (GB) of RAM minimum for Windows Vista

512 megabytes (MB) of RAM minimum for Windows XP and Windows 2000

• 1.5 GB of free hard disk space recommended; 160 MB is required for a full instal-
lation, including sample files, electronic documentation, and online Help

• Super VGA (800 x 600) or higher resolution, video adapter, and monitor

• Keyboard and mouse, or other pointing device

• CD-ROM or DVD drive for installation, if installing from a CD or DVD

Installing IntelliCAD

A setup program guides you through the IntelliCAD installation process. The pro-
gram transfers files to a folder that it creates on your hard disk. The program also cre-
ates a menu item on the Start menu.

Installation starts automatically after you insert the IntelliCAD compact disc into 
your CD-ROM drive. If installation does not start, you can install IntelliCAD by 
using the following procedure.

To install IntelliCAD from a compact disc

1 Insert the IntelliCAD compact disc into your CD-ROM drive.

2 Do one of the following:

• Wait for the autorun feature to start.

• Choose Start > Run and in the Open field, type d:\setup, where d is the letter 
assigned to your CD-ROM drive. Click OK.

3 Follow the instructions on your screen.

NOTE If you did not receive an IntelliCAD compact disc, for example, if you down-
loaded the program from the Internet, follow the instructions that came with the pro-
gram.
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Starting IntelliCAD

To start IntelliCAD, choose Start > Programs > ITC > IntelliCAD (may vary, depend-
ing on your operating system).

When you start IntelliCAD, the program opens a new, blank drawing based on a 
default template, icad.dwt. Using a template as the basis for a new drawing has sev-
eral advantages: 

• You can use predetermined units of measure, grid settings, text heights, and other 
settings appropriate for the type of drawing you’re creating.

• You can predefine special layers.

• You can predefine the type of print style table.

• You can include predefined title blocks and borders.

Each time you start IntelliCAD, a Tip of the Day appears on your screen. To display 
the Tip of the Day dialog box at any time, choose Help > Tip of the Day. To prevent 
the Tip of the Day dialog box from being displayed, click the check box for Show 
Tips On StartUp to clear it.

Working in IntelliCAD

You can work with the IntelliCAD window and its elements in a variety of ways. For 
example, you can display and rearrange the toolbars, display the command bar, and 
enable the status bar. The toolbars and command bar can also be floated anywhere on 
the screen or docked to the edges of the main IntelliCAD window. 
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A You can customize the menu bar at the top of the 
window.

B You can customize the toolbars, changing the 
appearance and arrangement of tools and 
adding your own commands and macros.

C Your drawings are displayed in the drawing 
window.

D Click a tab to switch between the drawing of your 
model and a printed layout.

E You can type commands in the command bar. To 
reposition the command bar, drag it to another 
location on your screen.

F The status bar displays information such as the 
name or purpose of a tool, the current cursor 
coordinates, layer name, and mode settings.

G The user coordinate system (UCS) icon indicates 
the orientation of the drawing in three-
dimensional space. 

H You can move and dock the toolbars to any 
location on your screen. 

A

B

C

D

F

H

E

G
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Displaying commands on a shortcut menu
Shortcut menus provide quick access to specific commands. A shortcut menu dis-
plays when you right-click an entity, toolbar, status bar, the Model tab name, or a 
Layout tab name. The selections presented in the shortcut menu depend on what you 
clicked.      

When you right-click a toolbar, the program displays a shortcut menu that lets you 
toggle the command bar, status bar, and various toolbars on and off. If you select one 
or more entities and then right-click, the program displays a shortcut menu from 
which you can choose a command to modify the selected entities. To display a short-
cut menu from which you can choose an entity snap, press and hold down the Shift 
key, and then right-click anywhere within the drawing window.

Displaying and hiding toolbars
When you start IntelliCAD the first time, multiple toolbars are displayed. IntelliCAD 
provides more than a dozen toolbars, which you can customize by adding and delet-
ing tools. You can also move and resize toolbars, and you can create new toolbars. 
You can use a shortcut menu to display or hide toolbars. 

You can also choose whether toolbars are displayed large or small and in color. You 
can choose to display or hide ToolTips, which provide descriptions of tools that dis-
play when you pause the cursor over them. Go to View > Toolbars to make these 
selections.

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close 
box, can be located anywhere on the screen, and can be resized. A docked toolbar 
does not display a title or Close box, cannot be resized, and is attached along one of 
the edges of the drawing window.

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 
away from the perimeter.

• To position a toolbar in a docking area without docking it, press Ctrl while you 
drag it.

• To move a toolbar, drag it to a new location.

• To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, 
and then drag.
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To choose which toolbars to display

1 Do one of the following:

• Choose View > Toolbars.

• Right-click anywhere on a docked toolbar to display the toolbar shortcut menu, 
and then choose Toolbars. You can also select the toolbars you want displayed 
directly on the shortcut menu.

2 In the Select Toolbars dialog box, choose the toolbars you want displayed, and 
then click OK.

Using the command bar
The command bar is a dockable window in which you type IntelliCAD commands 
and view prompts and other program messages. To display the command bar, choose 
View > Command Bar. The command bar displays the three most recent lines of 
prompts. You can move the command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to 
change the number of lines of text it displays. You can dock the command bar at the 
top or bottom of the drawing. 

Select the check boxes for the toolbars you want to display.
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Using the status bar
If you elect not to use the command bar, the status bar displays information about the 
selected command or tool. It also displays the current cursor coordinates, the name of 
the current layer, mode settings, and other information about current settings.

In addition to displaying information, the status bar is a quick way to access many 
features. You can click status bar items to make changes, and right-click items to dis-
play short-cut menus that allow you more choices.          

To change the items that display on the status bar

1 Right-click an empty area of the status bar.

2 Select an item to add or remove it.

To change the setting of an item on the status bar

1 Do one of the following:

• Double-click the status bar item.

• Right-click the status bar item you want to change, and then select the desired 
setting.

A Information about the current command.

B Cursor coordinates (x,y,z).

C Layer name. Double-click to change layers.

D Drawing color. Double-click to change colors.

E Linetype. By default, the linetype is BYLAYER. 
Double-click to change linetypes.

F Lineweight. By default, the lineweight is 
BYLAYER. Double-click to change lineweights.

G Text style. Double-click to change text styles.

H Dimension style. Double-click to change 
dimension styles.

I Print style. Double-click to change print styles. 
(Available only for drawings that use named print 
style tables.)

J Snap setting. Double-click to toggle on or off.

K Grid setting. Double-click to toggle on or off.

L Orthogonal setting. Double-click to toggle on or 
off.

M Polar tracking setting. Double-click to toggle on 
or off.

N Entity snap setting. Double-click to select entity 
snaps. 

O Lineweight display. Double-click to toggle on or 
off.

P Model space or paper space. Double-click to 
toggle between model space and paper space. 

Q Digitizer mode. Double-click to toggle on or off.

A B

C D E F G H I

J K L M N O P Q



30 C H A P T E R  2
To display or hide the status bar

1 Do one of the following:

• Choose View > Status Bar.

• Type statbar and then press Enter.

Using prompt boxes
IntelliCAD commands often provide several options. These options appear in the sta-
tus bar or command bar and also in a prompt box (called a context menu in 
AutoCAD) initially displayed in the upper right corner of the screen. You can move 
the prompt box by dragging it; future prompt boxes will appear where you last placed 
it. The options appear as menu selections. Choose the appropriate option by selecting 
it in the prompt box. To close a prompt box, click the Close box.   

The prompt box is displayed by default. To turn off the display of prompt boxes, 
choose Tools > Options, click the Display tab, and then click the Display Prompt 
Boxes check box to clear it.     

Command options appear in a prompt box.



G E T T I N G  S T A R T E D 31
The IntelliCAD user interface.        
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 Selecting commands

Select commands using any of these methods:

• Choose a command from a menu.

• Click a tool in a toolbar.

• Type the command in the command bar.

Some commands remain active until you end them, so you can repeat an action with-
out having to select a command repeatedly. You can end a command by clicking 
Done in the prompt box or by pressing Esc.

Using commands
You can use most commands while another command is active. For example, while 
drawing a line, you may want to use the Pan command to move the drawing across 
the screen to select the endpoint of the line. You can also change the settings of draw-
ing aids such as snap or grid while other commands are active.

Starting commands using toolbars
To start a command from a toolbar, click a tool and respond to the prompts. 

NOTE  The available toolbars depend on the experience level that is set. To change 
the current experience level, choose Tools > Options, and then click the General tab.

Some tools, such as Line or Arc, contain flyouts, which are options either for using 
the basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, 
click the tool and hold down the mouse button. To select a tool from a flyout, point to 
the tool you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar.

Starting commands using menus
To start a command from a menu, choose it from the list of menu options available.

The available menu options depend on the experience level that is set. To change the 
current experience level, choose Tools > Options, and then click the General tab.
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Starting commands using the command bar
Type a command, and then press Enter. If the command bar is displayed, the com-
mand you typed appears there. If the command bar is not displayed, the command 
you typed appears in the status bar.

TIP Quickly start commands using the command bar by copying, cutting, and pasting 
text. In the command bar or Prompt History window, right-click to select various cut, 
copy, and paste commands.

Repeating a command
You can repeat a command you used previously without having to reselect it. 

To repeat the command you just used

1 Do one of the following:

• Press the spacebar.

• Press Enter.

• Click the right mouse button in the drawing.

To repeat commands you used previously

1 Do one of the following:

• In the command bar or Prompt History window, press Ctrl and double-click the 
previous command text.

• In the command bar or Prompt History window, right-click, choose Recent 
Commands, and then choose the desired command.

• Press Ctrl + K, repeat until you get back to the desired command, and then press 
Enter. Press Ctrl + L to move forward to the desired command, and then press 
Enter.

• Use the Up and Down arrows to display previously used commands, if Use Up/
Down Arrows for Command History Navigation is selected in Tools > Options.

TIP  If you are using the command bar to type commands, you can type multiple 
before starting some commands (Circle, Arc, and Rectangle, for example) to repeat a 
command indefinitely. When you are done with a command, press Esc.

Nesting a command
If you are working in the command bar, you can use another command from within a 
command, called nesting. To use a command inside an active command, type an 
apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can 
nest commands indefinitely in IntelliCAD. Many menu and toolbar macros work this 
way by default; for example, select color, reference grid, zoom, and snap. When you 
have finished with the nested command, the original command resumes. 
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Modifying a command
If you are working in the command bar, there are special ways that you can modify a 
command as you work. You can modify the active command using any of the follow-
ing options:

• Entity snaps — Type an entity snap command, such as nearest or midpoint, to 
enable a one-time entity snap for a single selection. You can also use a one-time 
entity snap to override a running entity snap.

• Extension snaps — Type int after selecting a command, such as Line or Circle, to 
enable a one-time snap to the logical location where two entities would intersect if 
they were of infinite length. Type app to enable a similar one-time snap if the 
extensions would not intersect in three-dimensional space but would intersect in 
the current view. 

• Midpoint snaps — Type m2p or mtp to enable a one-time snap to the midpoint of 
two points that you specify. 

Using the Prompt History window
The Prompt History window displays a history of the commands and prompts issued 
since you started the current session of IntelliCAD. By default, the program tracks up 
to 256 command lines. There is no limit to the number of command lines you can 
track, but program performance may be degraded if you choose to track an exces-
sively high number of lines.

To display or close the Prompt History window 

• Press F2. 

To view entries in the Prompt History window 

1 Do one of the following:

• Use the scroll bars.

• Press Ctrl + K to browse backward; press Ctrl + L to browse forward.

• Use the Up and Down arrows to display previously used commands, if Use Up/
Down Arrows for Command History Navigation is selected in Tools > Options.

To copy or paste text in the Prompt History window 

1 If copying text, do one of the following: 

• Highlight text using your mouse.

• Press Ctrl + Shift + arrow keys to highlight text.

2 Right-click and choose whether to copy or paste.

TIP  You can also copy the entire command history by choosing Copy History or 
copy the last command line by choosing Copy Last Line. 
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To change the number of command lines to track

1 Do one of the following:

• Choose Tools > Options, and then click the Display tab.

• Type options and then press Enter. Click the Display tab.

2 In the Command Lines To Track field, type the number of command lines you 
want to display, and then click OK.

Using mouse shortcuts
You can use your mouse, often combined with the keyboard, to start commands and 
perform other actions.  

Using scripts
The IntelliCAD Script Recorder captures and saves many of your actions so you can 
play them back. After you enable the Script Recorder, all commands and options that 
you type in the command bar are recorded until you type a command to stop 
recording. When you run the script, the program carries out the recorded commands 
in succession.

Mouse shortcuts

Shortcut Action

Ctrl + Shift + Hold and drag left mouse button Real-Time Zoom command

Ctrl + Shift + Hold and drag right mouse button Real-Time Pan command

Ctrl + Hold and drag left mouse button Real-Time Sphere command

Ctrl + Hold and drag right mouse button Real-Time Z command

Shift + Left-click mouse Deselect entities

Shift + Right-click mouse Entity snap shortcut menu

Hold and drag left mouse button Move selected entities

Ctrl + Hold and drag left mouse button Copy and move selected entities

Right-click mouse Display shortcut menu for the selected entity

Rotate mouse wheel Zoom In and Zoom Out commands

Hold mouse wheel, and then move mouse Pan command



36 C H A P T E R  2
Correcting mistakes

IntelliCAD tracks the commands you use and the changes you make. If you change 
your mind or make a mistake, you can undo, or reverse, the last action or several pre-
vious actions. You can also redo any actions that you reversed.  

You can undo multiple actions by typing undo and specifying the number of actions 
to undo. 

Customizing IntelliCAD

You can tailor many aspects of IntelliCAD to better suit your needs. For example, 
you can easily create and modify toolbars by simply dragging and dropping icons. If 
you want to restore any area of the user interface back to its default state, click Reset. 
IntelliCAD stores your customized settings in the Windows registry; you can also 
store them in a separate file, called a profile.

IntelliCAD supports the most important AutoCAD customization files, including 
linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, and 
aliases. In addition, IntelliCAD unifies four AutoCAD customization functions with a 
single customize command: command aliases, keyboard shortcuts, menus, and 
toolbars.

You can also add custom programs written in any of several programming languages, 
including the following:

• LISP (the program’s Autodesk® AutoLISP-compatible language)

• SDS (the program’s Autodesk® ADS-compatible language)

• DIESEL

• Microsoft® Visual Basic for Applications (VBA)

A Click the Undo tool to reverse the last action.

B Click the Redo tool to reverse the previous 
undos.

A B
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Getting online Help

IntelliCAD includes online Help, which contains task-oriented topics, a command 
reference, a system variables reference, and a programming language reference.

You can display online Help in any of these ways:

• On the Standard toolbar, click Help ( ).

• Press F1.

• Choose a command from the Help menu.

• Click the question mark in a dialog box.

• Type help in the command bar.

Saving your drawing

You can save your drawing at any time.

To save a drawing, use one of the following methods:

• On the Standard toolbar, click Save ( ).

• Choose File > Save.

• Type save and then press Enter.

TIP When you save a drawing the first time, the program displays the Save Drawing 
As dialog box so that you can choose a directory and type a name for the drawing. To 
save the drawing later using another name, choose File > Save As and type the new 
name.

Exiting IntelliCAD

When you have finished working in IntelliCAD, choose File > Exit. 
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Working with drawings

CAD drawings help you organize information for greater efficiency. With Intelli-
CAD, you can draw entities representing different types of information on various 
layers and use those layers to control color, linetype, and visibility. IntelliCAD also 
includes drawing aids that help you draw accurately.

This section explains setting up drawings and using built-in drawing aids, including 
how to:

• Create new drawings, open existing drawings, and save changes to drawings.

• Use aids such as the grid, snap, and orthogonal settings to draw accurately.

Topics in this chapter

Creating a new drawing ...................................................................................... 40

Opening a drawing.............................................................................................. 41

Setting up a drawing ........................................................................................... 44

Working with colors............................................................................................. 58

Using the grid, snap alignment, and cursor restriction ....................................... 66

Using orthogonal locking .................................................................................... 72

Using entity snaps .............................................................................................. 74

Saving your drawing ........................................................................................... 85
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Creating a new drawing    

When you start IntelliCAD, the program automatically creates a new drawing based 
on a template drawing, icad.dwt. This template includes predefined settings such as 
drawing units, text size, print style table type, and drawing area. You can either use 
these settings or change them according to your needs. There is nothing unique about 
a template drawing. You can use any drawing as a template for future drawings.              

You can save many steps by basing a new drawing on an existing template (.dwt file). 
By doing this, a new drawing will contain all the settings and entities you need. When 
you open a new drawing from your custom template, you can modify existing settings 
and delete any entities that you don’t need. When you save a drawing that was created 
using a template, you do not change the template.

To create a new drawing based on a template    

1 Do one of the following:

• Choose File > New.

• Type newwiz and then press Enter.

2 Click Use A Template Drawing, and then click Next.

3 To display the Open Template dialog box, click Browse.

4 Select the template (.dwt) file that you want, and then click Open.

You can also choose any drawing (.dwg) file to use as a template.

5 Click Finish.
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Opening a drawing    

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design 
Web Format™ (.dwf) files, and drawing template (.dwt) files.

You can also open and check drawings that you suspect are damaged. 

Opening an existing drawing
You can open any of these drawing files:

• Standard drawing files with a .dwg extension. 

In addition to your own drawing files, you can open and use one of the sample 
drawings that are included with IntelliCAD.      

• Drawing Exchange Format files with a .dxf file extension.

• Design Web Format files with a .dwf file extension.

• Drawing templates with a .dwt file extension.

To open an existing drawing 

1 Use one of the following methods:

• Choose File > Open.

• On the Standard toolbar, click the Open tool ( ).

• Type open and then press Enter.

2 In Files of Type, choose the type of file you want to open.

3 Choose the folder containing the desired file.

4 Do one of the following:

• Choose the drawing you want to open, and then click Open.

• Double-click the drawing you want to open.

If the drawing requires a password, enter the password, click OK to verify the 
password, and then click Open again.

TIP You can also open drawings while browsing files on your computer using pro-
grams that came with your operating system, such as Windows File Explorer or My 
Computer. Simply double click the file to open it in IntelliCAD. Easily find the draw-
ing you want by viewing thumbnail images of the drawing files as you browse them.
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TIP To quickly open a drawing file that you recently used, choose File > <file name>. 
The program tracks the last four drawings.          

Opening damaged files
Files can become damaged for many reasons. For example, if you are working on a 
drawing during a power outage, a system crash, or a hardware failure, your drawing 
file may become damaged. IntelliCAD allows you to open and check damaged files 
to attempt file recovery.

Recovering a file attempts to open one of the following file types:

• Standard drawing files with a .dwg extension. 

• Drawing Exchange Format files with a .dxf file extension.

• Design Web Format files with a .dwf file extension.

• Drawing templates with a .dwt file extension.

A Displays a description of the file size, creation 
date, and other information about the drawing.

B Opens the drawing as read-only to prevent 
making changes to the file.    

C Turns the drawing preview on or off.

D Unavailable when opening drawings; available 
only when saving drawings.

E If a thumbnail image exists in the selected 
drawing, displays an image of the drawing 
before you open it.     

F Defines how drawings display in the list, 
including file details and thumbnail images.

A

B
C

E

D

F
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You can also audit any open file to check it for errors. You specify whether you want 
IntelliCAD to fix any errors that are found automatically. IntelliCAD fixes as many 
errors as possible and any errors that cannot be fixed are reported as “Ignored” in the 
Prompt History window.

To open a damaged file

1 Use one of the following methods:

• Choose File > Recover.

• Type recover and then press Enter.

2 In Files of Type, choose the type of file you want to recover.

3 Choose the directory containing the damaged file.

4 Choose the damaged file you want to recover.

5 Click Open.

If you want to check all drawings for errors automatically when you open them, 
choose Tools > Options > General tab and mark the check box for Open Drawings 
using Recover.

To check a drawing file for errors

1 With the drawing open that you want to check, do one of the following:

• Choose File > Audit.

• Type audit and then press Enter.

2 Choose whether you want IntelliCAD to fix any found errors automatically, and 
then press Enter.

NOTE If the AUDITCTL system variable is set to On and errors are found during a 
file recovery or audit, an ASCII file is created that describes the audit. The ASCII file 
is saved in the same folder as the audited drawing and has the same name as the 
drawing file, but with an .adt extension. 
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Setting up a drawing    

You can specify individual settings when you create a new drawing or when you 
modify settings in a drawing created from a template.

Setting the current layer
Layers are like the overlays that you use in manual drafting. You use layers to orga-
nize different types of drawing information. Every drawing has at least one layer, the 
default layer, named “0.” Your drawing can also contain an unlimited number of 
additional layers. When you create an entity, it is created on the current layer.     

To set the current layer

1 Do one of the following:         

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

• Type la and then press Enter.

2 Double-click the layer name that you want to make current.

3 Close the IntelliCAD Explorer window.  

TIP On the status bar, right-click on the current layer control, and from the list, select 
the layer you want to make current.

Double-click the layer name that you want to make current.
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Setting the current entity color
An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color. 

When you open a new drawing, entities are created in the color BYLAYER, which 
adopts the color of the current layer. Initially, layer 0 is both the only layer and the 
current layer. Its default color is white, so your entities appear as white.      

There are index colors, which contain two additional color properties that are often 
referred to as colors, true colors, and color book colors. The two additional color 
properties are BYLAYER and BYBLOCK. These color properties cause an entity to 
adopt the color either of the layer or of the block in which it is a member.

To set the current entity color

1 Do one of the following:      

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 Click Select Color.

4 In the Color dialog box, click one of the following tabs and select a color:

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 
You can also type the color number in the Index box.

• True Color — Click a basic color, click a color in the color palette, enter the Hue, 
Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) 
values. There are more than 16 million true colors from which you can choose.

• Color Books — Select a color book from the list, then click a color. You can 
select Show Only Color Book Colors Used in Drawing to limit the selection to 
only those color book colors that are used in the current drawing.

5 Click OK.

6 Click OK again.

TIP On the status bar, right-click on the current color, and select from the list the 
color you want to use for new entities. You can also click Select Color to choose addi-
tional colors.

For more details about using color in the many aspects of your drawing, see “Work-
ing with colors” on page 58 in this chapter.  
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Setting the current linetype
Linetypes help convey information. You use different linetypes to differentiate the 
purpose of one line from another. A linetype consists of a repeating pattern of dots, 
dashes, or blank spaces. Linetypes determine the appearance of entities both on the 
screen and when printed. By default, every drawing has at least three linetypes: CON-
TINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an unlim-
ited number of additional linetypes.           

When you create an entity, it is created using the current linetype. By default, the cur-
rent linetype is BYLAYER. IntelliCAD indicates that the entity linetype is deter-
mined by the current layer’s linetype by assigning the BYLAYER property as the 
default linetype setting. When you assign BYLAYER, changing a layer’s linetype 
changes the linetype of all the entities assigned that layer (if they were created using 
the linetype BYLAYER).     

You can also select a specific linetype as the current linetype, which overrides the 
layer’s linetype setting. Entities are then created using that linetype, and changing the 
layer linetype has no effect on them.

As a third option, you can use the linetype BYBLOCK property, in which case new 
entities are drawn using the CONTINUOUS linetype until you group them into a 
block. The entities then inherit the block’s linetype setting when you insert the block 
into a drawing.

To set the current linetype

1 Do one of the following:          

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Entity Linetype list, choose the linetype that you want to make current.

4 Click OK.

TIP  On the status bar, right-click the word BYLAYER for the current linetype, click 
Properties, and then choose the linetype that you want to make current.
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Setting the linetype scale    
You can specify the linetype scale. The smaller the scale, the more repetitions of the 
linetype pattern are generated per drawing unit. For example, a linetype pattern is 
defined as a sequence of dashed lines and open spaces, each 0.25 units long. The line-
type scale uses the drawing scale factor to determine the length. A scale factor of 0.5 
would reduce the length of each line and space to 0.125 units; a scale factor of 2 
would increase the length of each to 0.5 units.         

NOTE  Setting the linetype scale too large or too small may result in a line pattern 
looking like a solid line, depending on what the scale view is or at what scale the 
drawing is printed.

You can control a new entity’s individual linetype scale factor as well as the overall 
or global scale factor applied to all the entities in the drawing.

To set the current individual linetype scale

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Linetype Scale field, type or choose the linetype scale that you want to 
make current.

4 Click OK.

To change the global linetype scale

1 Do one of the following:     

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Global Linetype Scale field, type or choose the global linetype scale that 
you want to change.

4 Click OK.
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Setting the current lineweight
Lineweights help differentiate the purpose of one line from another. Lineweights 
determine how thick or thin entities appear both on the screen and when printed. 
Every drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and 
many additional lineweights in millimeters (or you can use inches).            

When you create an entity, it is created using the current lineweight. By default, the 
current lineweight for a new entity is BYLAYER. This means that the entity line-
weight is determined by the current layer. When you assign BYLAYER, changing a 
layer’s lineweight changes the lineweight of all the entities assigned that layer (if they 
were created using the lineweight BYLAYER).     

You can also select a specific lineweight (or DEFAULT) as the current lineweight, 
which overrides the layer’s lineweight setting. Entities are then created using that lin-
eweight (or the DEFAULT lineweight), and changing the layer lineweight has no 
effect on them.

As a third option, you can use the lineweight BYBLOCK property, in which case new 
entities are drawn using the DEFAULT lineweight until you group them into a block. 
The entities then inherit the block’s lineweight setting when you insert the block into 
a drawing.

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel 
when you create your drawing. When you print your drawing, it prints at the thinnest 
lineweight that is available for your printer.

You cannot assign lineweights to planes, points, TrueType fonts, or raster images (if 
supported in your version of IntelliCAD).

To set the current lineweight

1 Do one of the following:         

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Lineweight list, choose the lineweight that you want to make current.

4 Click OK.

TIP  On the status bar, right-click the word BYLAYER for the current lineweight, and 
then choose the current lineweight. You can also double-click the word LWT to toggle 
the display of lineweights on and off.

NOTE To see lineweights in your drawing, you may need to turn on lineweights. For 
details, see see “Controlling the display of lineweights” on page 154. 
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Setting the current print style
Print styles are used to change the appearance of an entity when it prints, without 
actually changing the entity in the drawing. 

If your drawing uses named print style tables, you can specify a print style for any 
entity. Named print style tables contain print styles that you set up. If your drawing 
uses color-dependent print style tables, the print style is BYCOLOR, which cannot be 
changed. These types of print style tables determine printing requirements by the 
color assigned to an entity or layer. For details about converting a drawing that uses 
color-dependent print style tables to use named print style tables, see “Changing a 
drawing’s print style table type” on page 387. 

When you create an entity in a drawing that uses named print style tables, the entity is 
created using the current print style. By default, the current print style is BYLAYER.  
When you assign BYLAYER, changing a layer’s print style changes the print style of 
all the entities assigned that layer if they were created using the print style 
BYLAYER.     

You can also select a specific print style as the current print style, which overrides the 
layer’s print style setting. Entities are then created using that print style, and changing 
the layer print style has no effect on them.

As a third option, you can use the print style BYBLOCK, in which case new entities 
use the Normal print style until you group them into a block. The entities then inherit 
the block’s print style setting when you insert the block into a drawing.

To set the current print style in a drawing that uses named print style tables

1 Do one of the following:          

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Print Style list, choose the print style that you want to make current. If nec-
essary, choose Other and then select a print style.

4 Click OK.

TIP  On the status bar, right-click the word BYLAYER for the current print style, click 
Other, and then choose the print style that you want to make current. Or, 
type printstyle to choose the current print style.
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Setting drawing units    
With IntelliCAD, you typically draw at full-size (1:1 scale), and then set a scale fac-
tor when you print or plot your drawing. Before you begin drawing, however, you 
need to determine the relationship between drawing units and real-world units.            

For example, you can decide whether one linear drawing unit represents an inch, a 
foot, a meter, or a mile. In addition, you can specify the way the program measures 
angles. For both linear and angular units, you can also set the degree of display preci-
sion, such as the number of decimal places or smallest denominator used when dis-
playing fractions. The precision settings affect only the display of distances, angles, 
and coordinates. IntelliCAD always stores distances, angles, and coordinates using 
floating-point accuracy.     

To set the linear drawing units    

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Drawing Units tab.

3 Under Change Settings For, choose Linear Units.

4 Under Unit Types, select a unit type.

5 Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it.

The field above this setting shows an example of the linear unit type at the current 
precision.

6 Click OK. 
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To set the angular drawing units                   

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Drawing Units tab.

3 Under Change Settings For, choose Angular Units.

4 Under Unit Types, select a unit type.

5 Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it.    

The field above this setting shows an example of the angular unit type at the cur-
rent precision.

A Select the type of linear units. B Choose the display precision for linear units.  

A

B
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6 Under Angle Direction, select the direction in which angles increase when you 
specify a positive angle value.    

7 Under Angle Base, specify the compass location for the zero angle.    

For example, by default, angle 0 is at the “three o’clock” or “east” position.

The adjacent icon shows the current location of the angle base.

8 Click OK. 

A Determines the type of units you are controlling.

B Select the type of angular units.

C Choose the display precision for angular units.

D Select the direction in which angles increase.

E Select the angle base, the direction of the zero 
angle.

C

D

B

A

E
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Understanding scale factors    
Instead of drawing to a particular scale, you draw everything in the program full-size. 
Although it’s a good idea to keep your scale factor in mind when setting up a draw-
ing, you don’t need to set the scale until you print it. For example, when you draw a 
mechanical part 40 inches in length with IntelliCAD, you actually draw it as 40 
inches, rather than applying a scale factor as you draw. When you print your drawing, 
you can assign the scale at which the drawing is to print.          

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 
print or plot in your drawing. For these, you can make adjustments when you first set 
up your drawing so that they print or plot at the correct size. For example, when you 
draw text, you need to determine the text size so that when you print it later at a par-
ticular scale, the text height is correct.     

After you determine the eventual scale of your finished drawing, you can calculate 
the scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 
represented by each drawing unit. For example, if you plan to print your drawing at 
1/8” = 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you 
want your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.        

The following table shows some standard architectural and engineering scale ratios 
and equivalent text heights required to create text that measures 1/8-inch high when 
you print the drawing at the specified scale.           

Standard scale ratios and equivalent text heights 

Scale Scale factor Text height

1/16” = 1’-0” 192 24”

1/8” = 1’-0” 96 12”

3/16” = 1’-0” 64 8”

1/4” = 1’-0” 48 6”

3/8” = 1’-0” 32 4”

1/2” = 1’-0” 24 3”

3/4” = 1’-0” 16 2”

1” = 1’-0” 12 1.5”

1 1/2” = 1’-0” 8 1”

3” = 1’-0” 4 0.5”

1” = 10’ 120 15”

1” = 20’ 240 30”

1” = 30’ 360 45”

1” = 40’ 480 60”

1” = 50’ 600 75”

1” = 60’ 720 90”

1” = 100’ 1200 150”
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You can use these scale factors to predetermine the size of your drawing to make sure 
that it fits on a specific size paper when you print it. You control the size of your 
drawing by the drawing limits. To calculate the drawing limits to match the size of 
your paper, multiply the dimensions of your paper size by your scale factor.        

For example, if the paper you use to print measures 36 inches x 24 inches and you 
print your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size 
of your drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 
96 (or 2,304 units) high.

Keep in mind that you can print the finished drawing at any scale, regardless of the 
scale factor you calculate. You can also print on paper of a different size and use the 
Layout tabs to create different views of your drawing and to position and scale those 
views differently. The scaling factor is not related to the size of the entities you draw; 
it simply provides a preliminary guide to help you establish the text height and draw-
ing limits when you begin your drawing. You can change the text height and drawing 
limits at any time.

Setting the text height            
The text height setting controls the height of text, measured in drawing units. Set this 
value initially so that text used for your most common annotations, when scaled to the 
size at which you will print a drawing, measures 1/8-inch high on the printed draw-
ing.              

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text 
to be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-
world drawing units) so that when you print it, it appears 1/8-inch high on the paper. 
You must create text 4 feet high that you want to print 1/2-inch high.



W O R K I N G  W I T H  D R A W I N G S 55
To set the text height

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 Under Change Settings For, choose Text.

4 In the Default Text Height field, select the text height or type the text height value 
that you want.

5 Click OK.   

NOTE  The default text height applies only if the current text style height is 0.0. Other-
wise, the text height for the current style takes precedence.

A Choose Text. B Specify the text height in drawing units.

A

B
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Setting the drawing limits    
You can specify the drawing limits that form an invisible boundary around your 
drawing. You can use the drawing limits to make sure that you do not create a draw-
ing larger than can fit on a specific sheet of paper when printed at a specific scale.       

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 
scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 
drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 
which allows a 1-inch margin around the edges of the printed image.

To set the drawing limits    
1 Do one of the following:         

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click either the Coordinate Input tab or the Display tab.

3 Under Change Settings For, choose Limits.

4 Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 
lower left drawing limit.

You can also click Select to specify the drawing limits by selecting points in the 
drawing.

5 To constrain your drawing to these drawing limits, click the Disallow Input 
Beyond Limits check box.

6 Click OK.  
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A Choose limits.

B Specify the x-coordinate and y-coordinate of the 
upper right drawing limit.

C Specify the x-coordinate and y-coordinate of the 
lower left drawing limit.

D When you click this check box, the program 
prevents you from drawing outside the drawing 
limits.

E Specify the drawing limits by selecting points in 
the drawing.

A

B

C

D

E
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Working with colors

An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color specified for the drawing.

Layers can also control the color of entities. When you open a new drawing, entities 
are created in the color BYLAYER, which adopts the color of the current layer. Ini-
tially, layer 0 is both the only layer and the current layer. Its default color is white, so 
your entities appear as white.      

For entities and layers in IntelliCAD, there are three different types of colors:

• Index colors

• True colors

• Color book colors

NOTE True colors and color books are unavailable in some cases, such as dimension 
entities and cursor display.

You can choose colors by selecting them from the Color dialog box. In the command 
bar or in some dialog boxes, you specify a color either by name or by number. 

Using index colors
There are 255 standard index colors and two additional color properties that are often 
referred to as colors (BYLAYER and BYBLOCK). You can use seven of the 255 
standard index colors by name: red, yellow, green, cyan, blue, magenta, and white. 
(Numbers eight and nine are not named.) Each index color has a unique number from 
1 to 255. The two additional color properties are BYLAYER and BYBLOCK. These 
color properties cause an entity to adopt the color either of the layer or of the block in 
which it is a member. BYLAYER is color number 256, and BYBLOCK is color num-
ber 0. In all commands for which you would use a color, you can indicate BYLAYER 
and BYBLOCK as well as by numbers 256 and 0, respectively.

To select an index color

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Index Color tab.

3 Do one of the following:

• Click BYBLOCK.

• Click BYLAYER.

• Click the color of your choice, or type the color number in the Current box.

4 Click OK.    
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Using true colors
There are more than 16 million true colors from which you can choose. True colors 
are defined using 24-bit color. 

Even with so many colors available, you can quickly choose a color from the display 
of basic colors or by clicking  the color palette. Alternatively, if you know the values 
used to define the desired color, you can enter the Hue, Saturation, and Luminance 
(HSL) values, or you can enter the Red, Green, Blue (RGB) values.

To select a true color

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text.

The Color dialog box opens.

2 Click the True Color tab.

A Click to select one of the standard colors.

B Click to select one of the gray shades.

C Click to select any one of the available index 
colors.

D Indicates the current color.

E Displays the color number, or enter the color 
number.

F Click to set the color to BYLAYER.

G Click to set the color to BYBLOCK.

A

B

D E

G

F

C
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3 Do one of the following:

• Click a basic true color.

• Click a true color in the color palette.

• Enter HSL values for the desired true color.

• Enter RGB values for the desired true color.

4 Click OK.    

A Click to select one of the basic true colors.

B Click to select one of the custom true colors, if 
any are defined.

C Click to add the selected color to the custom 
color area.

D Enter (or view)  the amount of red, green, and 
blue of the desired true color.

E Enter (or view) the amount of hue, saturation, 
and luminance of the desired true color.

F Slide or click to adjust the color luminance. 

G Click to select a true color in the color palette.

A

C

D
B

E

F

G
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Using color books
IntelliCAD uses color books to store collections of colors. For example, you can store 
a unique color scheme for a client in a color book and then use colors only from that 
color book for the client’s drawings.

To select a color book color

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Color Books tab.

3 Select a color book from the list.

4 If you want to narrow your color search, do one of the following:

• In the list of colors, select a color book page, if one is available. Pages are partic-
ularly helpful in large color books — they help group colors so you can find 
them quickly.

• Select Show Only Color Book Colors Used in Drawing. Only those color book 
colors that are used in the current drawing will display in the list.

5 Select the desired color.

6 Click OK.  
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Creating color books
You may have a color book given to you by a client, developed by a third-party, or 
you can create your own. Each color book has an .acb extension and is saved auto-
matically in Extensible Markup Language (XML) format. 

To create a color book

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Color Books tab.

3 Click Color Book Editor.

4 In the Color Book Editor dialog box, click the New tool ( ).

5 In Color Book Name, enter the name of the color book. This name will appear in 
the list of color books on the Color Books tab in the Color dialog box.

A Select a color book.

B Click to select a color book color.

C Select to list only those color book colors that 
are used in the current drawing.

D Click to create and modify color books.

E Displays the selected color and its RGB values.

A

B

E

C

D
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6 Do the following to define organizational pages in the color book:

• In the contents of the color book, click an existing page or color where you want 
to add a page. 

• Define a color in the palette.

• Enter the name of the page, and then click Add Page.

7 Do the following to define colors in the color book:

• In the contents of the color book, click an existing page or color where you want 
to add a color.

• Define a color in the palette.

• Enter the name of the color, and then click Add Color.

8 Do any of the following to change existing pages and colors in the color book:

• Modify pages and colors — Select a page or color in the color book, define its 
new color settings in the palette, enter any changes to its name, and then click 
Modify.

• Delete pages and colors — Select a page or color in the color book, and then 
click Delete.

• Rearrange pages and colors — Select a page or color in the color book, and then 
click the up arrow ( ) or down arrow ( ).

9 In the Color Book Editor dialog box, click the Save tool ( ).

10 Enter a filename for the color book, and then click Save.

By default, the file is saved in the default folder where IntelliCAD searches for 
color books.
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A Click New to create a color book; click Open to 
open a color book; click Save to save the color 
book; click Save As to save the color book with 
a new filename.

B Select a page or color to modify, delete, or 
reorder it, or to view its settings.

C Click to create a new page in the color book 
using the current color settings.

D Click to create a new color in the color book 
using the current color settings.

E Click to delete the selected page or color from 
the color book.

F Click to redefine the selected page or color to 
use the current color settings.

G Click to move the selected page or color up or 
down one position in the color book.

H Enter the name of the page or color as you want 
it to appear in the color book.

I Enter (or view)  the amount of red, green, and 
blue of the desired color.

J Enter (or view) the amount of hue, saturation, 
and luminance of the desired color.

K Slide or click to adjust the color luminance. 

L Click to select a color.

M Enter the name of the color book.

A

B
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Modifying color books
You can modify your own color books and the color books that came with Intelli-
CAD. If you modify a color book that came with IntelliCAD, it is recommended that 
you save it with a new filename first so the original color book is not overwritten. 

To modify a color book

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text.

The Color dialog box opens.

2 Click the Color Books tab.

3 Select the color book you want to modify.

4 Click Color Book Editor.

5 In Color Book Name, enter any changes to the color book name. This name 
appears in the list of color books on the Color Books tab in the Color dialog box.

6 Do any of the following to modify pages or colors in the color book:

• Add pages — In the contents of the color book, click an existing page or color 
where you want to add a page. Define a color in the palette, enter the name of 
the page, and then click Add.

• Add colors — In the contents of the color book, click an existing page or color 
where you want to add a color. Define a color in the palette, enter the name of 
the color, and then click Add.

• Modify pages and colors — Select a page or color in the color book, define its 
new color settings in the palette, enter any changes to its name, and then click 
Modify.

• Delete pages and colors — Select a page or color in the color book, and then 
click Delete.

• Rearrange pages and colors — Select a page or color in the color book, and then 
click the up arrow ( ) or down arrow ( ).

7 Do one of the following to save the color book:

• To save the color book with the same filename, click the Save tool ( ) in the 
Color Book Editor.

• To save the color book with a new filename or in a new location, click the 
Save As tool ( ) in the Color Book Editor.
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Loading color books

If you have a color book given to you by a client or developed by a third-party, sim-
ply save it on your computer in a folder where IntelliCAD can find it. By default, 
color books are stored in following folder: \Documents and Settings\YourName\My 
Documents\Color Books.

To load a color book

1 Save the color book in the folder where IntelliCAD searches for color books. 

To verify the folder location, choose Tools > Options, click the Paths/Files tab, 
and find the Color Book folder in the Paths list.

2 In a Color dialog box, click the Color Books tab. 

The previously loaded color book displays in the list of color books.

Using the grid, snap alignment, and cursor restriction

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 
Although many users find it convenient to match grid points to snap settings, they are 
independent of each other and should not be confused. Grid points are for visual ref-
erence only; they do not affect your drawing and they do not print. Snap points are, 
by themselves, not visible; however, when set, they constrain the creation of new 
entities.  

In addition, the cursor can be restricted to move orthogonally only or guides can dis-
play on the screen automatically at specified polar angle increments.    

Setting a reference grid
A reference grid displays as a pattern of regularly spaced dots. You can turn the dis-
play on and off, and you can specify how far apart the dots are spaced.       

The reference grid extends only to the limits of the drawing, helping you to visualize 
the boundary of your drawing and to align entities and visualize distances between 
entities. You can turn the grid on and off as needed. You can also change the spacing 
of the grid at any time. 
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To turn the grid on and set the grid spacing

1 Do one of the following:         

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, choose Snap And Grid.

4 Under Reference Grid, click the Show Grid check box.

5 Under Reference Grid Spacing, in the X field, choose the horizontal grid spacing.

6 Under Reference Grid Spacing, in the Y field, choose the vertical grid spacing.    

7 Click OK.

TIP To toggle the grid display on and off at any time, double-click the GRID setting 
on the status bar, click the Reference Grid tool ( ) on the Settings toolbar, or press 
F7.       
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A Click the check box to enable orthogonal mode.    

B Click the check box to display the reference 
grid.

C Specify the x and y grid spacing.

D Click the check box to enable snap mode.

E Specify the x and y snap spacing.

F Click the check box to use an isometric snap 
and grid.     

G Click the current isometric plane.

H Specify the grid rotation angle.    

I Indicates the current grid rotation angle.

J Specify the x- and y-coordinates of the snap 
origin.

K Click to match the grid spacing to the snap 
spacing.

E
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Setting snap spacing 
Another way to ensure drawing accuracy is to turn on and set snap spacing. When 
snap is turned on, the program restricts the selection points to predetermined snap 
intervals. Although it is often helpful to match the snap spacing to some interval of 
the grid spacing or another related setting, the settings do not have to match.           

To turn snap settings on and set snap spacing

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, choose Snap And Grid.

4 Under Snap Settings, click the Snap check box to turn Snap on.

5 Under Snap Settings Spacing, in the X field, choose the horizontal snap spacing.

6 Under Snap Settings Spacing, in the Y field, choose the vertical snap spacing.

7 Click OK.

TIP To toggle snap settings on and off at any time, double-click the SNAP setting on 
the status bar, click the Snap tool ( ) on the Settings toolbar, or press F9.       

In addition to setting the snap spacing, you can change the snap and grid orientation. 
You can also rotate the alignment of the grid or set it to create isometric drawings.

Changing the snap and grid angle and base point
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate 
in the World Coordinate System (WCS). You can relocate the snap and grid origin, 
however, to help you draw entities in relation to a different location. You can also 
rotate the grid to a different angle to realign the crosshairs to the new grid angle. If the 
grid is on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.                 
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To change the snap angle and base point

1 Do one of the following:        

• Click Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, select Snap And Grid.

4 Under Snap Settings, click the Snap check box to turn Snap on.

5 Under Reference Grid, click the Show Grid check box to turn Show Grid on. 

6 Under Snap And Grid Settings, in the X Origin field, type the x-coordinate of the 
new snap origin.

7 Under Snap And Grid Settings, in the Y Origin field, type the y-coordinate of the 
new snap origin.

8 Under Snap And Grid Settings, in the Rotation field, type the grid rotation angle. 

9 Click OK.   

Default grid and snap alignment. Rotated grid and snap alignment.
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Using isometric snap and grid
You can use the Isometric Snap And Grid option to create two-dimensional isometric 
drawings. With the isometric option, you are simply drawing a simulated three-
dimensional view on a two-dimensional plane, much the same as you might draw on 
a piece of paper. Do not confuse isometric drawings with three-dimensional draw-
ings. You create three-dimensional drawings in three-dimensional space.                       

The isometric option always uses three preset planes, which are denoted as left, right, 
and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 
three isometric axes are 30 degrees, 90 degrees, and 150 degrees.

When you check the Isometric Snap And Grid option and select an isometric plane, 
the snap intervals, grid, and crosshairs align with the current plane. The grid is always 
shown as isometric and uses y-coordinates to calculate the grid spacing. If you click 
the Draw Orthogonal check box, the program restricts the drawing of entities to the 
current isometric plane.

TIP  To toggle between isometric planes, press F5.

To turn the Isometric Snap And Grid option on

1 Do one of the following:        

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, select Snap And Grid.

4 Click the Isometric Snap And Grid check box.

5 Under Isometric Crosshairs, click the option for the isometric plane you want 
(Top, Left, or Right).

6 Click OK.

  

Isometric planes left (A), right (B), top (C).     

A B

C
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Using orthogonal locking   
You can restrict cursor movement to the current horizontal and vertical axes so that 
you can draw at right angles, or orthogonally. For example, with the default 0-degree 
orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthog-
onal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 
270 degrees. As you draw lines, the rubber-banding line follows either the horizontal 
or vertical axis, depending on which axis is farthest from the cursor. When you 
enable the isometric snap and grid, cursor movement is restricted to orthogonal 
equivalents within the current isometric plane.            

NOTE  IntelliCAD ignores orthogonal drawing when you type coordinates in the com-
mand bar or when you use entity snaps. Additionally, orthogonal locking and polar 
tracking cannot be used at the same time — turning one option on turns the other 
option off.

To enable orthogonal locking

1 Do one of the following:       

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Click the Draw Orthogonal check box.

4 Click OK.

TIP To toggle orthogonal drawing on and off at any time, double-click the ORTHO 
setting on the status bar, click the Draw Orthogonal tool ( ) on the Settings tool-
bar, or press F8.    
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Using polar tracking
When polar tracking is turned on, guides display on the screen automatically at the 
polar angle increment that you specify. For example, if you draw a line with polar 
tracking turned on at 45 degrees, the rubber-banding line displays at 45 degree angle 
increments.

Polar tracking and orthogonal locking cannot be used at the same time — turning one 
option on turns the other option off.         

To enable polar tracking and specify the polar angle increment

1 Do one of the following:       

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, select Polar Tracking.

4 Click the Polar Tracking check box.

5 Do one of the following to specify the polar angle increments:

• In Increment, select an angle.

• Mark the Additional Angles check box and click New to define a custom angle 
increment.

6 Click OK.

TIP To toggle polar tracking on and off at any time, double-click the POLAR setting 
on the status bar.    
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Using entity snaps   

Entity snaps enable you to quickly select exact geometric points on existing entities 
without having to know the exact coordinates of those points. With entity snaps, you 
can select the endpoint of a line or arc, the center point of a circle, the intersection of 
any two entities, or any other geometrically significant position. You can also use 
entity snaps to draw entities that are tangent or perpendicular to an existing entity.              

You can use entity snaps any time the program prompts you to specify a point—for 
example, if you are drawing a line or other entity. You can work with entity snaps in 
one of two ways:

• Enable a running entity snap that remains in effect until you turn it off by choosing 
an entity snap when no other command is active.    

• Enable a one-time entity snap for a single selection by choosing an entity snap 
when another command is active. You can also use a one-time entity snap to over-
ride a running entity snap.    

TIP  If you type the name of the entity snap, you need to type only the first three letters.    

When using entity snaps, the program recognizes only visible entities or visible por-
tions of entities. You cannot snap to entities on layers that have been turned off or to 
the blank portions of dashed lines.

When you specify one or more entity snaps, an entity snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 
entity snap. When you select an entity, the program snaps to the snap point closest to 
the center of the target box.            

TIP  Type m2p or mtp to enable a one-time snap to the midpoint of two points that you 
specify, such as two points selected using entity snaps.   

To change the size of the entity snap target box      

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, choose Entity Selection.

4 Under Entity Snap Aperture, change the value in the Aperture field.

5 Click OK. 
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Setting entity snaps                              
You can set entity snaps using any of the following methods:        

• Choose Settings > Entity Snap, and choose the entity snap you want to set.

• On the Entity Snaps toolbar, click one of the entity snap tools.

• In the command bar, type an entity snap command.

• In the status bar, double-click ESNAP.     

• Press and hold down the Shift key while right-clicking anywhere within the draw-
ing window to display the entity snap shortcut menu, and then choose the entity 
snap you want to set.    

You can also set entity snaps using the Drawing Settings dialog box. To do this, 
choose Settings > Entity Snap > Entity Snap Settings. The Drawing Settings dialog 
box is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, 
click the check box for each of the entity snaps that you want to set.

TIP When you select an entity snap, a check mark appears next to the entity snap in 
the menu, the associated tool if the Entity Snaps toolbar is active, and the corre-
sponding box is checked in the Coordinate tab of the Drawing Settings dialog box. 

A Choose Entity Selection. B Type or select the entity snap aperture size.

A

B
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Nearest Snap tool
Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap 
to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline seg-
ment, ray, spline, infinite line, or hatch pattern that is visually closest to the cursor.

To set the Nearest Snap    

Do one of the following:

• Choose Settings > Entity Snap > Nearest Snap.

• On the Entity Snaps toolbar, click the Set Nearest Snap tool ( ).

• Type nearest and then press Enter.

Endpoint Snap tool
Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to 
the closest endpoint of an arc, line, polyline segment, ray, hatch pattern, plane, or 
three-dimensional face. If an entity has thickness, the Endpoint Snap also snaps to the 
endpoints of the edges of the entity.       

To set the Endpoint Snap

Do one of the following:

• Choose Settings > Entity Snap > Endpoint Snap.

• On the Entity Snaps toolbar, click the Set Endpoint Snap tool ( ).

• Type endpoint and then press Enter.
 

 

Midpoint Snap tool
Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to 
the midpoint of an arc, ellipse, line, polyline segment, plane, infinite line, spline, or 
hatch pattern. In the case of infinite lines, the midpoint snaps to the first defined 
point. If an entity has thickness, the midpoint entity snap also snaps to the midpoint of 
the edges of the entity.        

To set the Midpoint Snap

Do one of the following:

• Choose Settings > Entity Snap > Midpoint Snap.

• On the Entity Snaps toolbar, click the Set Midpoint Snap tool ( ).

• Type midpoint and then press Enter. 

To snap to the endpoint, select anywhere on the entity near its endpoint (A).

A
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Center Snap tool
Use the Center Snap tool to snap to the center point of another entity. You can snap to 
the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, 
you must select a visible portion of the entity.    

To set the Center Snap

Do one of the following:    

• Choose Settings > Entity Snap > Center Snap.

• On the Entity Snaps toolbar, click the Set Center Snap tool ( ).

• Type center and then press Enter.
  

Perpendicular Snap tool
Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. 
You can snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, hatch 
pattern, or edge of a plane to form a perpendicular alignment with that entity or with 
an imaginary extension of that entity.    

To set the Perpendicular Snap    

Do one of the following:

• Choose Settings > Entity Snap > Perpendicular Snap.

• On the Entity Snaps toolbar, click the Set Perpendicular Snap tool ( ).

• Type perpendicular and then press Enter. 

To snap to the midpoint, select anywhere on the entity near its midpoint (A).

To snap to the center, select anywhere on the visible portion of the entity (A).

A

A
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Tangent Snap tool
Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap 
to the point on an arc, ellipse, spline, or circle that, when connected to the previous 
point, forms a line tangent to that entity.

To set the Tangent Snap       

Do one of the following:

• Choose Settings > Entity Snap > Tangent Snap.

• On the Entity Snaps toolbar, click the Set Tangent Snap tool ( ).

• Type tangent and then press Enter.

  

To form a perpendicular angle (A) to an entity (B), select anywhere on 
the entity.

To snap to a tangent, select the entity near the tangent point (A).

A

B

A
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Quadrant Snap tool
Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can 
snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc.    

To set the Quadrant Snap    

Do one of the following:

• Choose Settings > Entity Snap > Quadrant Snap.

• On the Entity Snaps toolbar, click the Set Quadrant Snap tool ( ).

• Type quadrant and then press Enter.

  

Insertion Point Snap tool
Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, 
or text entity.              

To set the Insertion Point Snap

Do one of the following:

• Choose Settings > Entity Snap > Insertion Point Snap.

• On the Entity Snaps toolbar, click the Set Insertion Point Snap tool ( ).

• Type insertion and then press Enter. 

  

To snap to a quadrant, select the entity near the quadrant point (A).

To snap to an insertion point, select anywhere on the entity (A).

A

A

A
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Point Snap tool
Use the Point Snap tool to snap to a point entity.        

To set the Point Snap

Do one of the following:

• Choose Settings > Entity Snap > Point Snap.

• On the Entity Snaps toolbar, click the Set Point Snap tool ( ).

• Type node and then press Enter. 

  

Intersection Snap tool
The Intersection Snap tool snaps to the actual intersection in three-dimensional space 
of any combination of entities. You can snap to the combination of an arc, circle, line, 
infinite line, polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon mesh, 
or polyface mesh. You can also snap to an intersection point within a single entity, 
including a polyline or spline.           

The Extended Intersection Snap option snaps to the logical location where two enti-
ties (lines, arcs, or elliptical segments) would intersect if they were of infinite length. 
IntelliCAD automatically uses the extension option only when you type int in the 
command bar (not the full intersection command name) after selecting a command, 
such as Line or Circle. Dashed extension lines are drawn to help show the extended 
intersection.

NOTE There are two types of intersection snaps. You can set the Intersection Snap or 
Apparent Intersection Snap, but you cannot use both at the same time. 

To set the Intersection Snap

Do one of the following:    

• Choose Settings > Entity Snap > Intersection Snap.

• On the Entity Snaps toolbar, click the Set Intersection Snap tool ( ).

• Type intersection and then press Enter.

To snap to a point entity, select the entity (A).

A
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To snap to an extended intersection point

1 Choose a command, for example, line.

2 Type int and then press Enter.

3 Select an extended intersection point. 

The Extended Intersection Snap turns off automatically after you select a point.

Apparent Intersection Snap tool    
The Apparent Intersection Snap tool snaps to the intersection of two entities that do 
not intersect in three-dimensional space but seem to intersect in the current view. You 
can snap to any two entities in the combination of an arc, circle, line, infinite line, 
polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon mesh, or polyface 
mesh. You can also snap to an intersection point within a single entity, including a 
polyline or spline.          

The Extended Apparent Intersection Snap option snaps to the logical location where 
two entities (lines, arcs, or elliptical segments) would intersect if they were of infinite 
length. IntelliCAD automatically uses the extension option only when you type app 
in the command bar (not the full apparent command name) after selecting a com-
mand, such as Line or Circle. Dashed extension lines are drawn to help show the 
extended apparent intersection.

NOTE There are two types of intersection snaps. You can set the Apparent Intersection 
Snap or Intersection Snap, but you cannot use both at the same time. 

To set the Apparent Intersection Snap       

Do one of the following:

• Choose Settings > Entity Snap > Apparent Intersection Snap.

• On the Entity Snaps toolbar, click the Apparent Intersection Snap tool ( ).

• Type apparent and then press Enter.

To snap to an intersection, select the intersection (A).

A

A



82 C H A P T E R  3
  

To snap to an extended apparent intersection point

1 Choose a command, for example, line.

2 Type app and then press Enter.

3 Select an extended apparent intersection point.

The Extended Apparent Intersection Snap turns off automatically after you select a 
point.

Quick Snap command
Normally, an entity snap searches all the entities crossing the target and selects the 
one closest to the center of the target. Use the Quick Snap command to modify the 
current entity snap so that the program stops searching for the snap point as soon as it 
finds one entity with at least one point of the current entity type.    

To set the Quick Snap    

• Type quick and then press Enter.

Clear Entity Snaps tool
Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how 
they were set: by menu, tool, command, or in the Drawing Settings dialog box.

To set Clear Entity Snaps

Do one of the following:

• Choose Settings > Entity Snap > Clear Entity Snaps.

• On the Entity Snaps toolbar, click the Clear Entity Snaps tool ( ).

• Type none and then press Enter.

To snap to an intersection, select the apparent intersection (A).

A
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Using fly-over snapping 
Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 
When fly-over snapping is turned on, IntelliCAD displays a colored marker at match-
ing entity snap points as you move the crosshairs around the drawing. 

Each entity snap has its own marker. 

When fly-over snapping is enabled and multiple entity snaps are on, you can press 
Tab to cycle through the available entity snap points of the entities covered by the tar-
get box. For example, when the Endpoint and Midpoint Snaps are on and the aperture 
box is located on a line, press Tab to cycle between the line's closest endpoint and 
midpoint.

Fly-over snap markers    

Marker Entity snap

Endpoint Snap

Nearest Snap

Midpoint Snap

Center Snap

Perpendicular Snap

Tangent Snap

Quadrant Snap

Insertion Snap

Point Snap

Intersection Snap

Apparent Intersection Snap
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To set the fly-over snapping options 

1 Do one of the following:

• Choose Settings > Drawing Settings.

• Choose Settings > Entity Snap > Entity Snap Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Click Fly-Over. The Options dialog box opens to the Snapping tab. 

4 Mark Enable Fly-Over Snapping to turn on fly-over snapping. 

5 Set the fly-over options, including the color, size, and thickness of the snap 
marker. 

6 Click OK. 

7 Click OK again. 

NOTE  For details about the various fly-over snapping options, see “Changing the 
options on the Snapping tab” on page 490. 
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Saving your drawing    

When you save a drawing, your work is saved in a drawing (.dwg) file. 

After you have saved your drawing for the first time, you can save it with a new 
name. In addition to drawing (.dwg) files, you can also save a drawing in a Drawing 
Exchange Format (.dxf) file or a drawing template (.dwt) file. 

If you created your drawing using a template, saving the drawing does not alter the 
original template.

If you need an added level of security for your drawing files, you can save the draw-
ing with a password so only you and those who know the password can open the 
drawing.

Saving a drawing
To save a drawing, choose any of the following methods:

• Choose File > Save.

• On the Standard toolbar, click Save ( ).

• Type save and then press Enter.

• Type qsave and then press Enter.

TIP When you save a drawing the first time, the program displays the Save Drawing 
As dialog box so that you can choose a directory and type a name for the drawing. 
You can use any name when you first save the drawing. 
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Saving a drawing with a new name or file format
You can save a drawing with a new name and in any of the following file formats:

• Standard drawing files with a .dwg extension. You can choose a .dwg file format 
that is compatible with various versions of AutoCAD.

• Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf 
file format that is compatible with various versions of AutoCAD.

• Drawing templates with a .dwt file extension. Drawing templates allow you to eas-
ily create new drawings that reuse your drawing settings and entities.

To save a drawing with a new name or file format 

1 Do one of the following: 

• Choose File > Save As.

• Type saveas and then press Enter.

2 In the Save Drawing As dialog box, under Save As Type, choose the file format.

3 Specify the name of the file you want to create.

4 Click Save.

A Displays a description of the file size, creation 
date, and other information about the drawing.

B Unavailable when saving drawings; available 
only when opening drawings.

C Turns the drawing preview on or off.

D Saves the drawing with a password.

E Displays an image of the drawing before you 
save it.     

A

B
C

E

D
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TIP You can also export drawing files to various file formats. For more details, see 
“Exporting drawings” on page 467. 

Saving a drawing with a password
Sometimes drawings may contain confidential information and you want to control 
who has access to that information. If you need an added level of security, you can 
save a drawing with a password so only you and those who know the password can 
open the drawing.

To save a drawing with a password, you must save it in the DWG 2004, or later, 
drawing (.dwg) file format.

NOTE If you forget a drawing’s password, the drawing cannot be opened or recov-
ered. You may want to store all passwords in a safe place.

To save a drawing with a password

1 Do one of the following: 

• Choose File > Save As.

• Type saveas and then press Enter.

2 In the Save Drawing As dialog box, under Save As Type, choose a DWG format 
that is 2004 or later.

3 Click Password Protect.

4 Choose a folder where you want to save the drawing.

5 In File Name, specify the name of the file you want to create.

6 Click Save.

7 In the Password dialog box, enter a password.

8 If desired, record and store the password in a safe place. If you forget the draw-
ing’s password, the drawing cannot be opened or recovered.

9 Click OK.
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Creating simple entities  

With IntelliCAD, simple entities include lines (both finite and infinite), circles, arcs, 
ellipses, elliptical arcs, points, and rays. In addition, IntelliCAD includes a freehand 
sketch tool. Entities drawn freehand are also considered to be simple entities.

This section explains several methods for creating simple entities, including how to:

• Use menu commands on the Insert menu.

• Use the tools on the Draw 2D toolbar.

• Type commands in the command bar.

In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given here. Refer to the online Help to learn how to create entities 
using other methods.

When you use a tool or a drawing command, the program prompts you to enter coor-
dinate points, such as endpoints or insertion points. You can enter the points or dis-
tances either using a mouse or by typing coordinate values in the command bar. As 
you draw, IntelliCAD also displays a context-sensitive prompt box with appropriate 
additional options for the type of entity you are drawing.

After you create entities, you can modify them using the entity modification tools.

Topics in this chapter

Drawing lines ...................................................................................................... 90

Drawing circles ................................................................................................... 91

Drawing arcs....................................................................................................... 93

Drawing ellipses.................................................................................................. 96

Drawing elliptical arcs ......................................................................................... 97

Creating point entities ......................................................................................... 98

Drawing rays ..................................................................................................... 100

Drawing infinite lines......................................................................................... 101

Creating freehand sketches.............................................................................. 103
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Drawing lines

A line consists of two points: a start point and an endpoint. You can connect a series 
of lines, but each line segment is considered a separate line entity.  

To draw a line

1 Do one of the following:

• Choose Insert > Line.

• On the Draw 2D toolbar, click the Line tool ( ).

• Type line and then press Enter.

2 Specify the start point.

3 Specify the endpoint.

4 In the prompt box, choose Done to complete the command.

The prompt box provides several options as you draw. For example, when you draw 
the first line segment, you can specify its length or orientation angle. After you draw 
at least one line segment, you can click Undo to remove the previous line segment. 
You can click Done to end the line command. After you draw two or more line seg-
ments, you can click Close to complete the line command by drawing a line segment 
that connects to the start point of the first line segment you drew.

If the last entity you drew was an arc, you can also draw a line tangent to and starting 
from the endpoint of the arc.

To draw a line as a continuation from the end of an arc 

1 Do one of the following:

• Choose Insert > Line.

• On the Draw 2D toolbar, click the Line tool ( ).

• Type line and then press Enter.

2 In the prompt box, choose Follow.

3 Specify the length of the line.

Start point (A) and endpoint (B).

A

B



C R E A T I N G  S I M P L E  E N T I T I E S 91
Drawing circles

The default method for drawing a circle is to specify a center point and radius. You 
can draw circles using any of the following methods:         

• Center-Radius ( )

• Center-Diameter ( ) 

• Two points ( ) 

• Three points ( )

• Radius-Tangent-Tangent ( ) 

• Convert Arc to Circle ( )

To draw a circle by specifying its center and radius 

1 Do one of the following: 

• Choose Insert > Circle.

• On the Draw 2D toolbar, click the Circle Center-Radius tool ( ).

• Type circle and then press Enter.

2 Specify the center point.

3 Specify the radius of the circle.

Endpoint of previous arc (A) and length of the line (B).

A

B

Center point (A) and radius (B).

A
B
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To draw a circle tangent to existing entities

1 Do one of the following: 

• Choose Insert > Circle.

• On the Draw 2D toolbar, click the Circle Radius-Tangent tool ( ). 
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Radius-Tangent-Tangent.

3 Specify the radius of the circle.

4 Select the first entity to which to draw the circle tangent.

5 Select the second entity to which to draw the circle tangent.

To convert an arc to a circle

1 Do one of the following: 

• Choose Insert > Circle.

• On the Draw 2D toolbar, click the Convert Arc to Circle tool. ( ). 
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Turn Arc Into Circle.

3 Select the arc you want to convert to a circle. 

Radius of circle (A) and tangent lines (B) and (C).

A

B

C

Select an arc (A) to convert to a circle.

A
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Drawing arcs

An arc is a portion of a circle. The default method for drawing an arc is to specify 
three points—the start point, a second point, and the endpoint. You can draw arcs 
using any of the following methods:                                                

• Three points on an arc ( ).

• Start point-center-endpoint ( ), or Start point-endpoint-center ( ), or Center-
start point-endpoint ( ).

• Start point-center-included angle ( ), or Start point-included angle-center 
( ), or Center-start point-included angle ( ).    

• Start point-center-chord length ( ), or Center-start point-chord length ( ).   

• Start point-endpoint-radius ( ), or Start point-radius-endpoint ( ). 

• Start point-endpoint-included angle ( ), or Start point-included angle-endpoint 
( ).

• Start point-endpoint-starting direction ( ), or Start point-starting direction-end-
point ( ).

• Start point-radius-angle ( ).

• As a tangent continuation of the previous arc or line ( ).

To draw an arc by specifying three points

1 Do one of the following:

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the 3-Point Arc tool ( ).

• Type arc and then press Enter.

2 Specify the start point.

3 Specify a second point.

4 Specify the endpoint.

Start point (A), second point (B), and endpoint (C).

A

B
C
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The prompt box provides additional options for drawing arcs. For example, after you 
specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, 
or Radius. You can select the options in a different order as well. For instance, you 
can draw an arc by specifying its start point, endpoint, and radius, or you can specify 
the start point, radius, and then endpoint.

To draw an arc by specifying its start point, center point, and endpoint

1 Do one of the following: 

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the Arc Start-Center-End tool ( ).

• Type arc and then press Enter.

2 Specify the start point.

3 In the prompt box, choose Center.

4 Specify the center point.

5 Specify the endpoint.

To draw an arc by specifying two points and an included angle     

1 Do one of the following:

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the Arc Start-End-Angle tool ( ).

• Type arc and then press Enter.

2 Specify the start point.

3 In the prompt box, choose Angle or type angle.

4 To draw an arc in a counterclockwise direction, enter a positive value for the 
included angle.

To draw an arc in a clockwise direction, enter a negative value for the included 
angle.

5 Specify the endpoint.

Start point (A), center point (B), and endpoint (C).

A

B

C
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If the last entity you drew was an arc or a line, you can also draw an arc tangent to and 
starting from the endpoint of the arc or line.

To draw an arc tangent to an arc or line 

1 Do one of the following:

• Choose Insert > Arc.

• On the Draw 2D toolbar, click the Tangent Arc tool ( ). Go to step 3.

• Type arc and then press Enter.

2 In the prompt box, choose Follow.

3 Specify the endpoint.

TIP To convert an arc to a circle, on the Draw 2D toolbar, click the Convert Arc To 
Circle flyout tool ( ).

Start point (A), endpoint (B), and included angle (C).

A

B

C

Endpoint (A).

A
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Drawing ellipses

The default method for drawing an ellipse is to specify the endpoints of one axis of 
the ellipse, and then specify a distance representing half the length of the second axis. 
The endpoints of the first axis determine the orientation of the ellipse. The longer axis 
of the ellipse is called the major axis, and the shorter one is the minor axis. The order 
in which you define the axes does not matter. The program determines the major and 
minor axes based on their relative lengths. You can draw ellipses using any of the fol-
lowing methods:  

• Axis-axis ( )

• Axis-rotation ( )

• Center-axis ( ) 

• Center-rotation ( )

To draw an ellipse by specifying the axis endpoints

1 Do one of the following: 

• Choose Insert > Ellipse.

• On the Draw 2D toolbar, click the Ellipse Axis-Axis tool ( ).

• Type ellipse and then press Enter.

2 Specify the first endpoint.

3 Specify the second endpoint. 

4 Specify the half-length of the other axis.

First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C).

A
C

B
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Drawing elliptical arcs

An elliptical arc is a portion of an ellipse. The default method for drawing an ellipti-
cal arc is to specify the endpoints of one axis of the ellipse, and then specify a dis-
tance representing half the length of the second axis. Then you specify the start and 
end angles for the arc, measured from the center of the ellipse in relation to its major 
axis. You can draw elliptical arcs using any of the following methods: 

• Axis-axis ( ) 

• Axis-rotation ( )

• Center-axis ( ) 

• Center-rotation ( )

To draw an elliptical arc by specifying the axis endpoints

1 Do one of the following:

• Choose Insert > Elliptical Arc.

• On the Draw 2D toolbar, click the Elliptical Arc Axis-Axis tool ( ).

• Type ellipse and then press Enter, and then type a (for Arc) and press Enter.

2 Specify the first endpoint.

3 Specify the second endpoint.

4 Specify the half-length of the other axis.

5 Specify the start angle of the arc.

6 Specify the end angle.

NOTE  IntelliCAD draws elliptical arcs in the direction you specify. Go to Settings > 
Drawing Settings > Drawing Units tab. Under Change Settings For, select Angular 
Units. The default setting is counterclockwise.

First axis endpoint (A), second axis endpoint (B), half-length of other axis (C), start angle of arc (D), and 
end angle (E).

A

D

C
E

B
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Creating point entities

You can draw a point entity formatted as either a single dot or as one of 19 other pos-
sible display styles.        

To draw a point

1 Do one of the following:

• Choose Insert > Draw Point.

• On the Draw 2D toolbar, click the Point tool ( ).

• Type point and then press Enter.

2 Specify the location of the point.

To draw several points

1 Do one of the following:

• Choose Insert > Draw Point.

• On the Draw 2D toolbar, click the Point tool ( ).

• Type point and then press Enter.

2 In the prompt box, choose Multiple Points.

3 Specify the location of each point.

4 In the prompt box, choose Done to complete the command.

Changing the size and appearance of point entities
Changing the size and appearance of point entities affects all point entities already in 
the drawing, as well as all points that you subsequently draw. Positive values repre-
sent the absolute size of the point entity measured in drawing units. Negative values 
represent a percentage relative to the drawing screen, so that points retain their visual 
size as you use the Zoom command to change the magnification of the drawing.

To change the size and appearance of point entities

1 Do one of the following: 

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 Under Change Settings For, click Points.

4 Under Point Display Type, select the style you want.

5 Under Point Size, select the point size, or choose one of the options.

6 Click OK.
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When you regenerate the drawing, all point entities change to reflect the new size and 
appearance settings.   

A To increase or decrease the point size, type or 
select a value. 

B To use one of the preset point size options, click 
the one that you want.

C Select the button for the Point Display Type that 
you want.

A

B

C
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Drawing rays

A ray is a line in three-dimensional space that starts at a point and extends to infinity. 
Because rays extend to infinity, they are not calculated as part of the drawing extents. 
The default method for drawing a ray is to select the start point of the ray and then 
specify its direction. You can draw a ray in any of the following ways:

• Horizontal draws the ray parallel to the x-axis of the current user coordinate sys-
tem (UCS). 

• Vertical draws the ray parallel to the y-axis of the current UCS.

• Angle draws the ray parallel to a specified angle.

• Bisect draws the ray perpendicular to an existing entity.

• Parallel draws the ray parallel to an existing entity.

To draw a ray

1 Do one of the following:

• Choose Insert > Ray.

• On the Draw 2D toolbar, click the Ray tool ( ).

• Type ray and then press Enter.

2 Specify the start point.

3 Specify the direction.

4 To complete the command, press Enter.

Start point (A) and direction (B).

A B
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Drawing infinite lines

Infinite lines are sometimes referred to as construction lines. An infinite line is a line 
through a given point, oriented at a specified angle in three-dimensional space and 
extending to infinity in both directions. Because infinite lines extend to infinity, they 
are not calculated as part of the drawing extents.  

The default method for drawing an infinite line is to select a point along the line and 
then specify the direction of the line. You can draw an infinite line in any of the fol-
lowing ways:

• Horizontal draws the infinite line parallel to the x-axis of the current UCS. 

• Vertical draws the infinite line parallel to the y-axis of the current UCS.

• Angle draws the infinite line parallel to a specified angle.

• Bisect draws the infinite line perpendicular to an existing entity.

• Parallel draws the infinite line parallel to an existing entity.

To draw an infinite line

1 Do one of the following:   

• Choose Insert > Infinite Line.

• On the Draw 2D toolbar, click the Infinite Line tool ( ).

• Type infline and then press Enter.

2 Specify a point along the line.

3 Specify the direction.

4 To complete the command, press Enter.

.

You can also draw infinite lines at a specific angle or at an angle relative to an exist-
ing entity.

Point along the infinite line (A) and the direction (B).

A
B
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To draw an infinite line at a specified angle relative to another entity

1 Do one of the following:

• Choose Insert > Infinite Line.

• On the Draw 2D toolbar, click the Infinite Line tool ( ).

• Type infline and then press Enter.

2 In the prompt box, choose Angle.

3 In the prompt box, choose Reference.

4 Select the reference entity.

5 Specify the angle of the infinite line in relation to the selected entity.

6 Specify the location of the infinite line.

7 To complete the command, press Enter.

Reference entity (A) and angle in relation to entity (B).

A B
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Creating freehand sketches

A freehand sketch consists of many straight line segments, created either as individ-
ual line entities or as a polyline. Before you begin creating a freehand sketch, you 
must set the length, or increment, of each segment. The smaller the segments, the 
more accurate your sketch, but segments that are too small can greatly increase the 
file size.   

After you specify the length of the sketch segments, the crosshairs change to a Pencil 
tool. Your freehand sketch is not added to the drawing until you “write” the sketch 
into your drawing. This means that you temporarily save the segment that you’ve 
drawn and the segment length, and you can continue sketching. 

To create a freehand sketch

1 Do one of the following: 

• Choose Insert > Freehand.

• On the Draw 2D toolbar, click the Draw Freehand tool ( ).

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.

3 Click the mouse button to place the Pencil tool ( ) on the drawing to begin 
sketching.

4 Move the pencil image to draw a temporary freehand sketch.

5 Click the mouse button to lift the pencil up to stop sketching.

6 In the prompt box, choose Write, Then Resume to write the temporary freehand 
sketch into the drawing.

7 Click the mouse button to put the pencil down again and resume sketching.

8 Click the mouse button again to lift the pencil up to stop sketching.

9 In the prompt box, choose Done to write the temporary freehand sketch into the 
drawing and end the command.

A freehand sketch consists of individual line entities or a polyline.
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Erasing freehand sketch lines
You can erase temporary freehand sketch lines that have not yet been written into the 
drawing by choosing the Delete On option in the prompt box. The pencil changes to 
an Eraser tool. You can erase portions of the line when you move the eraser over a 
temporary freehand line without clicking the mouse button.

To erase freehand sketch lines

1 Do one of the following:

• Choose Insert > Freehand.

• On the Draw 2D toolbar, click the Draw Freehand tool ( ).

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.

3 Select a point on the drawing to display the Pencil tool and begin sketching.

4 Click the mouse button to lift the pencil up to stop sketching.

5 In the prompt box, choose Delete On.

6 Move the Eraser tool ( ) to the beginning or end of the freehand sketch line that 
you drew, and then move it as far along the line as you want to erase.

7 Click the mouse button to put the Pencil tool down to resume sketching.

Setting the sketch method and accuracy
Using polylines for freehand sketches makes it easier to go back and edit sketches. 
You control whether to create freehand sketches using line segments or polylines in 
the Drawing Settings dialog box. You can also control the length of sketch segments 
in this dialog box. 
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To specify lines or polylines when sketching

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Choose the Entity Creation tab.

3 Under Change Settings For, click Freehand Sketches.

4 Under Freehand Sketching Methods, click either Freehand Command Creates 
Lines or Freehand Command Creates A Polyline.

5 Click OK.         

A Select the sketch method. B Specify the default length of sketch segments.

A

B
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5

Creating complex entities

With IntelliCAD, complex entities include polylines (including rectangles and poly-
gons), spline curves, donuts, and planes. In addition, IntelliCAD includes tools for 
adding hatching to your drawings.   

This section explains several methods for creating complex entities, including how 
to:

• Use menu commands on the Insert menu.

• Use the tools on the Draw 2D toolbar.

• Type commands in the command bar.

When you type a drawing command or select a tool, the program prompts you to 
enter coordinate points, such as endpoints or insertion points. As you draw, the pro-
gram displays a context-sensitive prompt box with appropriate additional options for 
the type of entity you are drawing.

After you create complex entities, you can modify them using the entity-modification 
tools. Several of these entity types require special editing commands. 

Topics in this chapter

Drawing rectangles ........................................................................................... 108

Drawing polygons ............................................................................................. 110

Drawing polylines.............................................................................................. 111

Drawing splines ................................................................................................ 114
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Drawing wipeouts ............................................................................................. 121

Creating boundary polylines ............................................................................. 123

Adding hatching................................................................................................ 127
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Drawing rectangles

With IntelliCAD, rectangles are closed polylines with four sides. You draw a rectan-
gle by specifying its opposite corners. The rectangle is normally aligned parallel to 
the current snap and grid alignment, but you can use the Rotated option to align the 
rectangle to any angle.   

To draw a rectangle

1 Do one of the following:

• Choose Insert > Rectangle.

• On the Draw 2D toolbar, click the Rectangle tool ( ).

• Type rectangle and then press Enter.

2 Specify one corner of the rectangle.

3 Specify the opposite corner of the rectangle.    

You can edit each side of a rectangle individually using the Edit Polyline tool ( ) 
on the Modify toolbar. You can convert the sides into individual line entities using 
the Explode tool ( ) on the Modify toolbar. You can control whether wide rectan-
gle lines are shown filled or as outlines using the Fill tool ( ) on the Settings tool-
bar.

You can also use the Rectangle tool to draw a square. Instead of specifying the oppo-
site corners, you specify the length of one side and the alignment of the square.

Opposite corners (A and B). Resulting rectangle.

A
B



C R E A T I N G  C O M P L E X  E N T I T I E S 109
To draw a square    

1 Do one of the following:

• Choose Insert > Rectangle.

• On the Draw 2D toolbar, click the Rectangle tool ( ).

• Type rectangle and then press Enter.

2 In the prompt box, choose Square.

3 Specify one corner of the square.

4 Specify the length of one side of the square by selecting its other end.

The point you specify determines both the size and alignment of the square.       

TIP To control the line width of the rectangle, choose the Width Of Line option in the 
prompt box. After you change the width of the line, the new width setting remains in 
effect for subsequent rectangles until you change it again.

Endpoints of one side of the square (A and B). Resulting square.

A

B
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Drawing polygons

Polygons are closed polylines composed of a minimum of three and a maximum of 
1,024 equal-length sides. The default method for drawing a polygon is to specify the 
center of the polygon and the distance from the center to each vertex. You can draw a 
polygon using any of the following methods:

• Center - by vertex ( ) on the Draw 2D toolbar

• Center - by side ( ) on the Draw 2D toolbar

• Edge ( ) on the Draw 2D toolbar

The vertex polygon drawing method creates an equal-sided polygon defined by its 
center point and the distance to its vertices. You specify the number of sides, the cen-
ter point, and the location of one vertex, which determines both the size and orienta-
tion of the polygon.

To draw a polygon by vertex    

1 Do one of the following:

• Choose Insert > Polygon.

• On the Draw 2D toolbar, click the Polygon, Center-Vertex tool ( ).

• Type polygon and then press Enter.

2 Type 5 to specify five sides for the polygon.

3 Specify the center of the polygon.

4 Specify the vertex of the polygon.            

The center (A) and vertex (B). Resulting polygon.

A

B
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Drawing polygons by side
The side polygon drawing method creates an equal-sided polygon defined by its cen-
ter point and the distance to the midpoint of a side. You specify the number of sides, 
the center point, and the location of the midpoint of one side, which determines both 
the size and orientation of the polygon.

To draw a polygon by side   

1 Do one of the following:

• Choose Insert > Polygon.

• On the Draw 2D toolbar, click the Polygon, Center-Side tool ( ).

• Type polygon and then press Enter.

2 Type 3 to specify three sides for the polygon.

3 Specify the center of the polygon.

4 In the prompt box, choose Specify By Side, and then press Enter.

5 Specify the midpoint of the side.

 

You can edit each side of a polygon individually using the Edit Polyline tool ( ) on 
the Modify toolbar. You can convert the sides into individual line entities using the 
Explode tool ( ) on the Modify toolbar. You can control whether wide polygon 
lines are shown filled or as outlines using the Fill tool ( ) on the Settings toolbar.              

Drawing polylines    

With IntelliCAD, a polyline is a connected sequence of arcs and lines that is treated 
as a single entity. You can draw a polyline with any linetype and using a width that 
either remains constant or tapers over the length of any segment. When editing a 
polyline, you can modify the entire polyline or change individual segments.     

After you specify the start point of a polyline, a prompt box provides several options 
as you draw, such as Distance, Halfwidth, and Width. You can specify different start-
ing and ending widths to create a tapered polyline segment.      

The center (A) and midpoint of one side (B). Resulting polygon.

A
B
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After you draw at least one polyline segment, you can use the Undo tool ( ) to 
remove the previous segment. After you draw two or more polyline segments, you 
can use the Close option to complete the command by drawing a segment that ends at 
the start point of the first polyline segment you drew. Choose Done to complete the 
command without closing the polyline.              

To draw a polyline with straight segments

1 Do one of the following:

• Choose Insert > Polyline.

• On the Draw 2D toolbar, click the Polyline tool ( ).

• Type polyline and then press Enter.

2 Specify the start point.

3 Specify the endpoint of each segment.

4 To complete the command, choose Close or Done.

With the Draw Arcs option, you can continually draw arc segments until you select 
the Draw Lines option to go back to drawing line segments. When you draw arc seg-
ments, the first point of the arc is the endpoint of the previous segment. By default, 
you draw arc segments by specifying the endpoint of each segment. Each successive 
arc segment is drawn tangent to the previous arc or line segment. If you choose Close 
while in the Draw Arcs option, the closing segment is created as an arc. 

Curved polyline with tapered width. Polyline with straight 
segments.

Closed polyline.

Polyline start point (A) and segment endpoints (B).

A

B

B

B

B
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You can also specify the arc using any of the following methods:

• Start point, included angle, center point

• Start point, included angle, radius

• Start point, center point, endpoint

• Start point, included angle, endpoint

• Start point, center point, included angle

• Start point, center point, chord length

• Start point, direction, endpoint

• Start point, radius, included angle

• Start point, second point, endpoint

To draw a line segment followed by an arc polyline segment

1 Do one of the following: 

• Choose Insert > Polyline.

• On the Draw 2D toolbar, click the Polyline tool ( ).

• Type polyline and then press Enter.

2 Specify the start point.

3 Specify the endpoint.

4 In the prompt box, choose Draw Arcs.

5 Specify the endpoint of the arc segment.

6 To complete the command, choose Done.

You can edit entire polylines and individual segments using the Edit Polyline tool 
( ) on the Modify toolbar. You can convert polylines into arc and line entities 
using the Explode tool ( ) on the Modify toolbar. You can control whether wide 
polylines are shown filled or as outlines using the Fill tool ( ) on the Settings 
toolbar.

Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).

A
B

C
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Drawing splines    

A spline is a smooth curve defined by a set of points. You can use splines to create 
sculptured shapes such as the cross section of a turbine blade or an airplane wing.           

To draw a spline     

1 Do one of the following:

• Choose Insert > Spline.

• On the Draw 2D toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.

3 Specify the second point of the spline.

4 Specify as many more points as you want.

5 When you have finished, press Enter.

You can add tangents to the spline, which are lines that give it shape.

To add tangents to a spline

1  Specify the starting tangent point.

2 Specify the ending tangent point.

Spline.                                                                      Spline with starting tangent point (A) and ending tangent 
point (B).

A B
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Specifying fit tolerance
By default, a spline passes through all of the control points. When you draw a spline, 
you can change this by specifying the fit tolerance. The fit tolerance value determines 
how closely the spline fits the set of points you specify. For example, a spline fit tol-
erance value of 0 causes the spline to pass through the control points. A value of 0.01 
creates a spline that passes through the start and endpoints and within 0.01 units of 
the intermediate control points.

To specify the fit tolerance

1 Do one of the following:

• Choose Insert > Spline.

• On the Draw 2D toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.

3 Specify the second point of the spline.

4 In the prompt box, choose Fit Tolerance.

5 To accept the default of 0.0000, press Enter.

To specify a different fit tolerance, type the number, and then press Enter.

6 Specify the additional points you need to draw a spline or a closed spline.
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Drawing a closed spline
You can draw a closed spline, which is a spline for which the start point and endpoint 
are the same. Because the spline is closed, you specify only one tangent.

To draw a closed spline

1 Do one of the following:

• Choose Insert > Spline.

• On the Draw 2D toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.

3 Specify the second point of the spline.

4 Specify as many more points as you want.

5 When you have finished, in the prompt box, choose Close.

6 To complete the command, specify the tangent point. 

The start point and endpoint (A) of a closed spline.

A
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Drawing donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can 
draw a donut using one of several methods. The default method is to specify the 
inside and outside diameters of the donut, and then specify its center. You can then 
create multiple copies of the same donut by specifying different center points until 
you press Enter to complete the command.  

To draw a donut

1 Do one of the following:

• Choose Insert > Donut.

• On the Draw 2D toolbar, click the Donut tool ( ).

• Type donut and then press Enter.

2 Specify the inside diameter of the donut.

3 Specify the outside diameter of the donut.

4 Specify the center of the donut.

5 Specify the center point to draw another donut, or choose Done to complete the 
command.

The prompt box provides additional options for drawing donuts. For example, you 
can specify the width of the donut and two points on the diameter of the donut, or you 
can specify the width and three points on the donut. You can also draw a donut tan-
gent to existing entities.   

TIP A donut can be a completely filled circle by specifying an inside diameter of zero.

Inside diameter (A) and outside diameter (B).

A

B



118 C H A P T E R  5
To draw a donut tangent to existing entities

1 Do one of the following: 

• Choose Insert > Donut.

• On the Draw 2D toolbar, click the Donut tool ( ).

• Type donut and then press Enter.

2 In the prompt box, choose Radius Tangent Tangent.

3 Specify the width of the donut.

4 Specify the diameter of the donut.

5 Select the first tangent entity to which to draw the donut.

6 Select the second tangent entity to which to draw the donut.

You can edit donuts using the Edit Polyline tool ( ) on the Modify toolbar. You 
can convert donuts into arc entities using the Explode tool ( ) on the Modify 
toolbar. You can control whether donuts are shown filled or as outlines using the Fill 
tool ( ) on the Settings toolbar.

TIP You can control the default outside and inside diameter of donuts by choosing 
Settings > Drawing Settings, and then clicking the Entity Creation tab and choosing 
the options you want.

Width (A) and diameter (B) of the donut and tangent entities (C).

A

B

C

C
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Creating planes    

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled 
with a solid color. The default method is to specify the corners of the plane. After you 
specify the first two corners, the plane is displayed as you specify the remaining cor-
ners. Specify corner points in a triangular manner. The program prompts you for the 
third point and then the fourth point. If you continue specifying points, the third- and 
fourth-point prompts toggle until you press Enter to complete the command.   

Creating planes in IntelliCAD is similar to the Solid command in AutoCAD.

To draw a quadrilateral plane

1 Do one of the following:

• Choose Insert > Plane.

• On the Draw 2D toolbar, click the Plane tool ( ).

• Type plane and then press Enter.

2 Specify the first point.

3 Specify the second point.

4 Specify the third point.

5 Specify the fourth point.

6 To complete the command, press Enter.

The prompt box provides additional options for drawing planes. For example, you 
can draw rectangular, square, or triangular planes.

After you select the first two points (A) and (B), the sequence in which you select the third (C) 
and fourth (D) points determines the shape of the resulting quadrilateral plane.

B

A

D

C

B

A D

C



120 C H A P T E R  5
To draw a rectangular plane

1 Do one of the following:

• Choose Insert > Plane.

• On the Draw 2D toolbar, click the Plane tool ( ).

• Type plane and then press Enter.

2 Choose Rectangle.

3 Specify the first point.

4 Specify the opposite corner.

5 Specify the rotation angle.

6 To complete the command, specify the opposite corner to draw another rectangle, 
or press Enter.

You can control whether planes are shown filled or as outlines using the Fill tool 
( ) on the Settings toolbar. You can convert planes into individual line entities cor-
responding to the outline of the plane using the Explode tool ( ) on the Modify 
toolbar.                             

Opposite corners (A and B) and rotation angle (C). Resulting plane.

A BC
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Drawing wipeouts

Wipeouts are unique entities that can help you hide areas of your drawing. They dis-
play with the current background color, so the details behind the wipeout do not dis-
play or print.

Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, 
and scale them, and they can be used in both model space and paper space.

If you want to print the wipeout entities located in a drawing, you must print to a ras-
ter-capable printer. Note that in some cases you may have unexpected results when 
printing drawings that contain wipeout entities, for example, if printing on colored 
paper.

NOTE If your version of IntelliCAD does not include raster image capability (that is, 
does not include an Image menu), wipeout entities display, but the details behind the 
wipeouts also display.

Drawing wipeouts using polygons and polylines
Wipeouts are created using existing polygons, closed zero-width polylines made up 
of only line segments, or new polylines that you draw while using the Wipeout com-
mand.

To draw a wipeout

1 Do one of the following:

• Choose Insert > Wipeout.

• On the Draw 2D toolbar, click the Wipeout tool ( ).

• Type wipeout and then press Enter.

2 Specify the start point.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, choose Done or press Enter.

Drawing without wipeout. Drawing with wipeout.
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To create a wipeout using an existing polygon or polyline

1 Do one of the following:

• Choose Insert > Wipeout.

• On the Draw 2D toolbar, click the Wipeout tool ( ).

• Type wipeout and then press Enter.

2 Choose Polyline.

3 Select the closed polyline to use for the wipeout.

4 Choose one of the following:

• Yes — Creates the wipeout and deletes the polyline used to create the wipeout. 

• No — Creates the wipeout and keeps the polyline used to create the wipeout. 

Turning wipeout frames on or off
Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off 
for any drawing. When wipeout frames are on, you can select and modify wipeouts. 
You may want to turn off wipeout frames when it’s time to print.

To turn wipeout frames on or off

1 Do one of the following:

• Choose Insert > Wipeout.

• On the Draw 2D toolbar, click the Wipeout tool ( ).

• Type wipeout and then press Enter.

2 Choose Frames.

3 Choose On or Off.

Wipeout frames turned on. Wipeout frames turned off.
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Creating boundary polylines

With the Boundary command, you can designate a specific area of a drawing for 
operations such as hatching and dimensioning. You create a boundary polyline by 
selecting an area inside a closed loop. The area you select can be bounded by a single 
closed entity or by multiple entities that intersect.

In cases where entities intersect, IntelliCAD interprets the boundary as the closed 
loop closest to the point specifying the area. In the following figure, for example, the 
area point selected in the rectangle results in a boundary consisting of the closed loop 
nearest the point selection, as opposed to the closed loop formed by the rectangle 
itself.         

To make boundaries more specific, you can create a boundary set. A boundary set 
specifies which entities are considered in determining the boundary path. This can 
make creating the boundary polyline faster if you are working with a complex draw-
ing.

In the following figure, the circle and triangle are the selected entities. If you select an 
area anywhere inside the circle or the triangle, the result is a polyline that bounds the 
shaded area.

Selected point (A). Resulting boundary (B).

A

B

Selected entities (A and B).                                                                    Point specified in the selected area (C), 
which results in a new boundary 
around the shaded area.

A

B
C



124 C H A P T E R  5
Using islands and island detection
Islands are closed loops that reside inside other closed loops. IntelliCAD provides 
island-detection options so that you can specify which islands, if any, should be con-
sidered in the area selection for a boundary. 

The following figure shows a rectangular polyline with two islands. The circle is 
referred to as the outer island, and the octagon is referred to as a nested island.  

You can choose from three island-detection methods.

• Nested Islands The outer entity and all its islands are considered for the polyline.

• Outer Only Only the outer entity and its outer island are considered for the 
polyline.

• Ignore Islands Only the outer entity is considered for the polyline. 

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island 
(D).

Nested islands (A), with outer island (B), and with ignore islands (C).

A

B

C

D

A B C
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To draw a boundary polyline

Advanced experience level

1 Do one of the following:

• Choose Insert > Boundary Polyline.

• On the Draw 2D toolbar, click the Boundary tool ( ).

• Type boundary and then press Enter.

2 Specify the entities that you want made available for the boundary polyline by 
doing one of the following:

• All entities Select All Visible Entities to have all entities in the drawing 
considered when creating the boundary polyline.

• Custom selection Define only specific areas to be considered when creating the 
boundary polyline, which can improve system performance if you are working 
with a complex drawing. Click Select Boundary Set. In the drawing, select the 
entities individually or by choosing a selection method from the prompt box, 
and then press Enter. The Current Selection Set option becomes selected 
automatically, which indicates that the entities you selected with the Select 
Boundary Set button will be considered when creating the boundary polyline.

NOTE You can alternate between All Visible Entities and Current Selection Set 
without having to select entities again using the Select Boundary Set button. The 
Current Selection Set option uses the last set of entities you selected with the 
Select Boundary Set button.

3 Choose an island-detection option.

4 Click Select Area.

5 In the drawing, click inside the area whose closed perimeter forms the boundary, 
not on the polyline itself. If desired, continue clicking inside additional closed 
perimeters.

6 To complete the selection, press Enter.

7 In the Boundary dialog box, click OK.
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A Opens the drawing area for selection of entities 
to be considered when creating the boundary 
polyline.

B Choose to consider all visible entities when 
creating the boundary polyline. 

C Choose to use the entities you selected for the 
boundary set. (Becomes available after you click 
the Select Boundary Set button.)

D Select an island-detection option.

E Opens the drawing area for selection of the 
enclosed areas used to create new boundary 
polylines.

A

B

D

E

C
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Adding hatching  

When you add hatching to a drawing, IntelliCAD fills entities or enclosed areas with 
a pattern. You can choose a predefined hatch pattern, or you can create your own 
hatch pattern.

First you specify the hatch pattern and other options, and then you choose which enti-
ties or enclosed areas that you want to hatch.           

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing. 

To open the Boundary Hatch dialog box

Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

Specifying a hatch pattern
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 
select a hatch pattern from a set of predefined patterns, or you can define a pattern of 
your own. The hatch pattern you used most recently is the default pattern the next 
time you add hatching.

The program supplies predefined standard hatch patterns, which are stored in the 
icad.pat and icadiso.pat hatch pattern library files. You can use other external hatch 
pattern libraries, such as an office standard library, customized patterns, and libraries 
available from vendors or standards organizations.

NOTE The icad.pat hatch pattern library files are ANSI (American National Standards 
Institute)-compliant patterns; the icadiso.pat hatch pattern library files are ISO 
(International Standards Organization)-compliant.
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To specify a predefined hatch pattern    

1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Pattern Properties tab.

3 In the Pattern Type list, click Predefined.

With Predefined, you can apply a scale factor to make the pattern larger or smaller 
than the default size. 

4 For Scale, enter the scale factor as a percentage of the default.

5 For Angle, enter the angle of the pattern in degrees (1-360). 

The default angle is clockwise; you can change the angle of any hatch pattern by 
entering a numerical value.

6 For ISO Pen Width, enter the pen width.

If you choose a predefined, ISO standard pattern, you can scale the pattern based 
on the ISO pen width. 

7 To copy the pattern properties from an existing hatch, choose Copy Hatch Proper-
ties and select the hatch.

8 To associate the hatch pattern to its boundary entities, under Hatch Attributes, 
select the Associative check box. An associative hatch updates automatically if 
you move any of its boundaries.

9 To continue, add a hatch by doing one of the following:

• Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching” on page 132 in this chapter. Begin with step 2.

• Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching” on page 133 in this chapter. Begin with step 2.
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To specify a user-defined hatch pattern  

1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Pattern Properties tab.

3 In the Pattern Type list, click User Defined.

4 For Spacing, enter the line spacing for the pattern.

5 To crosshatch the pattern, select the Cross-Hatched check box.

You can choose to crosshatch the pattern. Cross-hatching imposes a copy of the 
specified user-defined pattern at a 90-degree angle over the first pattern you 
defined.

6 To copy the pattern properties from an existing hatch, choose Copy Hatch Proper-
ties, and select a hatch pattern from a hatched entity in the drawing.

7 To associate the hatch pattern to its boundary entities, under Hatch Attributes, 
select the Associative check box. An associative hatch updates automatically if 
you move any of its boundaries.

8 To continue, add a hatch by doing one of the following:

• Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching” on page 132 in this chapter. Begin with step 2.

• Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching” on page 133 in this chapter. Begin with step 2.  
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A Determines how the hatch will be defined.

B Determines density of hatching for Predefined 
hatch patterns.

C Sets angle of hatch in relation to entity (User 
Defined only).

D Determines density of hatching for User Defined 
hatch patterns.

E Sets pen width for ISO-standard pattern.

F Imposes another copy of the specified pattern at 
a 90-degree angle over the first.

G Closes dialog to allow selection and copying of 
existing hatch pattern properties.

H Displays the tolerance that non-touching entities 
can be within and still be used to create the 
hatch pattern boundary.

I Select to update the hatch automatically if you 
move any of its boundaries.

A

B

C

D

E

F
G

I

H
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To use a predefined library pattern

1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Pattern tab.

3 For Hatch File, select the icad.pat or icadiso.pat hatch pattern library file.

4 To select a predefined pattern, do one of the following:

• In the Patterns list, click the pattern name.

• Click the graphical representation of the hatch pattern.

5 To continue, add a hatch by doing one of the following:

• Select the entities you want to add hatching. For details, see “Selecting entities 
for hatching” on page 132 in this chapter. Begin with step 2.

• Select an area or boundary you want to add hatching. For details, see “Selecting 
areas for hatching” on page 133 in this chapter. Begin with step 2.

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing.       

A Hatch pattern library files.

B Hatch patterns listed by name.

C Hatch patterns shown graphically.

B

A

C
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Selecting entities for hatching
You can add hatching to any entity that forms a closed boundary, for example, a cir-
cle or rectangle. You can assign hatching to a single entity or several entities at the 
same time. 

To select entities for hatching

1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Boundary tab.

3 Under Island Detection Options, choose one of the following:

• Nested Islands The outer entity and all its islands are considered for hatching.

• Outer Only Only the outer entity and its outer island are considered for hatching.

• Ignore Islands Only the outer entity is considered for hatching. 

4 To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.

5 Click Select Entities.

6 In the drawing, click the entities to be hatched individually or by choosing a selec-
tion method from the prompt box, and then press Enter when done.

7 In the Boundary Hatch dialog box, click OK. 

Nested islands (A), with outer island (B), and with ignore islands (C).

A B C
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Selecting areas for hatching
You can add hatching to an area enclosed by selected entities to form the hatch 
boundary. The hatch is formed in the enclosed area, not the entities themselves. 

After IntelliCAD draws the hatch, the entire hatch is treated as a single entity and it is 
is either associative or independent of the hatch boundary entities. 

A Choose to consider all visible entities when 
creating the boundary hatch.

B Mark the check box to keep any new entities that 
are created to draw the boundary hatch. Existing 
entities are always retained.

C (Display only) Indicates the boundary is created 
as a polyline. 

D Determines how hatching interacts with islands.
E Opens the drawing area for selection of entities 

to be hatched.

A

D
B

E

C
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To select an area for hatching

1 Do one of the following:

• Choose Insert > Hatch.

• On the Draw 2D toolbar, click the Boundary Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Boundary tab.

3 Under Island Detection Options, choose one of the following:

• Nested Islands The outer entity and all its islands are considered for hatching.

• Outer Only Only the outer entity and its outer island are considered for hatching.

• Ignore Islands Only the outer entity is considered for hatching.

4 To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.

5 Specify the entities that you want made available for boundary hatching by doing 
one of the following:

• All entities Select All Visible Entities to have all entities in the drawing 
considered when creating the boundary hatch.

• Custom selection Define only specific areas to be considered when creating the 
boundary hatch, which can improve system performance if you are working 
with a complex drawing. Click Select Boundary Set. In the drawing, select the 
entities individually or by choosing a selection method from the prompt box, 
and then press Enter. The Current Selection Set option becomes selected 
automatically, which indicates that the entities you selected with the Select 
Boundary Set button will be considered when creating the boundary hatch.

Nested islands (A), with outer island (B), and with ignore islands (C).

A B C
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NOTE You can alternate between All Visible Entities and Current Selection Set 
without having to select entities again using the Select Boundary Set button. The 
Current Selection Set option uses the last set of entities you selected with the 
Select Boundary Set button.

6 In the Boundary Hatch dialog box, click Select Area.

7 In the drawing, click inside the closed perimeter of a boundary, not on the bound-
ary itself. If desired, continue clicking inside additional closed perimeters.

8 To complete the selection, press Enter.

9 In the Boundary Hatch dialog box, click OK. 

A Opens the drawing area for selection of entities 
to be considered when creating the boundary 
hatch.

B Choose to consider all visible entities when 
creating the boundary hatch.

C Choose to use the entities you selected for the 
boundary set. (Becomes available after you click 
the Select Boundary Set button.)

D Mark the check box to keep any new entities that 
are created to draw the boundary hatch. Existing 
entities are always retained.

E (Display only) Indicates the boundary is created 
as a polyline. 

F Determines how hatching interacts with islands.
G Opens the drawing area for selection of enclosed 

areas to be hatched.

A

B

F

G

C

D

E
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Viewing your drawing

IntelliCAD provides many ways to display and view your drawing. You can also 
change various display settings to speed up the display or printing of a drawing. This 
section explains how to:

• Navigate within a drawing by scrolling, panning, and rotating the view.

• Change the magnification of a drawing by zooming in and out.

• Work with multiple windows or views of a drawing.

• Control the display of elements to optimize performance when working with large 
or complex drawings.

Topics in this chapter

Redrawing and regenerating a drawing ............................................................ 138

Moving around within a drawing ....................................................................... 138

Changing the magnification of your drawing..................................................... 142

Displaying multiple views.................................................................................. 146

Controlling visual elements............................................................................... 151
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Redrawing and regenerating a drawing     

As you work on a drawing, visual elements may remain after the completion of a 
command. You can remove these elements by refreshing, or redrawing, the display.            

To redraw (refresh) the current window display

Do one of the following:

• Choose View > Redraw.

• On the View toolbar, click the Redraw tool ( ).

• Type redraw and then press Enter.

Information about drawing entities is stored in a database as floating point values, 
ensuring a high level of precision. Sometimes a drawing must be recalculated, or 
regenerated, from the floating-point database to convert those values to the appropri-
ate screen coordinates. This occurs automatically. You can also manually initiate a 
regeneration. When the drawing is regenerated, it is also redrawn.       

To regenerate the current window, type regen in the command bar. If more than one 
window is displayed, type regenall to regenerate all the windows.    

Moving around within a drawing  

You can move the view of a drawing displayed in the current viewport by scrolling, 
panning, or rotating the view. Doing this changes the portion of the drawing you are 
viewing without changing the current magnification. Scrolling lets you move around 
in the drawing horizontally and vertically. Panning lets you move the drawing in any 
direction. Rotating lets you view your drawing from any angle.          

NOTE You can also move to a different view using the Model and Layout tabs. For 
more details, see “Viewing drawings in paper space and model space” on page 364. 

Using scroll bars
To assist you in navigating within a drawing, horizontal and vertical scroll bars are 
available in each drawing window. The size of the scroll box in relation to the scroll 
bar indicates the current level of drawing magnification. The position of the scroll 
box in relation to the scroll bar indicates the location of the center of the drawing in 
relation to the extents of the drawing (the smallest rectangle containing all the entities 
in the drawing).       
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To turn scroll bars on or off

Do one of the following:

• Choose View > Scroll Bars.

• Choose Tools > Options > Display tab, and select Show Scroll Bars. 

• Type scrollbar, press Enter, and then select On, Off, or Toggle.

Using the Pan command
You can move the drawing in any direction using the Pan tool ( ) on the View 
toolbar. Panning shifts or slides the view of the drawing horizontally, vertically, or 
diagonally. The magnification of the drawing remains the same, as does its orienta-
tion in space. The only change is the portion of the drawing displayed.        

To pan, you can use any of the following methods:

• For precise panning, specify two points defining the magnitude and direction of 
the pan. The first point, or base point, indicates the starting point of the pan. The 
second point indicates the amount of pan displacement relative to the first point.

• To pan in real time, press Ctrl + Shift and use the right mouse button, or use the 
Real-Time Pan tool ( ) on the View toolbar. 

• If you have a mouse with a wheel, press and hold the wheel, and then move the 
mouse.

• To pan in small increments, use the arrow keys (if the arrow keys were not 
selected for command history navigation in Tools > Options > Display tab).

To pan by specifying two points

1 Do one of the following:

• Choose View > Pan.

• On the View toolbar, click the Pan tool ( ).

• Type pan and then press Enter.

2 Specify the pan base point either by typing the coordinates or by specifying a point 
in the drawing window.

3 Specify the pan displacement point either by typing the coordinates or by specify-
ing a point in the drawing window. 
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To pan in real time    

1 Do one of the following:

• Choose View > Real-Time Motion > Real-Time Pan.

• On the View toolbar, click the Real-Time Pan tool ( ).

• Type rtpan and then press Enter.

2 Click and hold the left mouse button. 

3 Move the cursor in the direction you want to pan.

4 To stop panning, release the mouse button.

TIP Hold down the right mouse button while  simultaneously pressing and holding 
Ctrl + Shift to pan in real-time.

NOTE If you are working with a large drawing file, it may be helpful to set the 
RTSKIPCOUNT system variable to a higher number to reduce the number of entities 
that display. For example, if the value is set to 10, only the 10th entity will display 
when panning and rotating in real-time.

To pan using a mouse with a wheel    

• Press and hold the wheel, and then move the mouse in the direction you want to 
pan. (The MBUTTONPAN system variable controls this feature.)

To pan using the arrow keys

• Press the up, down, right, or left arrow keys.

NOTE You can pan using the arrow keys if Use Up/Down Arrows for Command His-
tory Navigation is not marked on the Display tab in Tools > Options.

Select the pan base point (A), and then select a 
second point (B) to specify the pan displacement.

Result.

A
B
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Rotating the view in real time
IntelliCAD allows you to rotate your view of a drawing in real time. This allows you 
to view your model from any angle while in model space. You cannot rotate the view 
while in paper space.

If desired, you can continue the view rotation after you release your mouse. Choose 
Tools > Options to enable continuous motion. For more information, see “Changing 
the options on the Display tab” on page 480.        

To rotate the view in real time   

1 Do one of the following:

• Choose View > Real-Time Motion > Real-Time Sphere.

• On the View toolbar, click the Real-Time Sphere tool ( ).

• Type rtrot and then press Enter.

• Press and hold Ctrl. 

2 Click and drag the left mouse button. The view rotates according to the movement 
of your mouse. 

3 To stop rotating, release the mouse button.

4 If the view continues to rotate, press Enter or right-click the drawing when fin-
ished.

TIP  You can use the Real-Time X, Real-Time Y, and Real-Time Z commands to lock 
the rotation in the corresponding axis. You can also press Ctrl and use the right 
mouse button to rotate the view about the z-axis.

NOTE If you are working with a large drawing file, it may be helpful to set the 
RTSKIPCOUNT system variable to a higher number to reduce the number of entities 
that display. For example, if the value is set to 10, only the 10th entity will display 
when panning and rotating in real-time.



142 C H A P T E R  6
Changing the magnification of your drawing  

You can change the magnification of your drawing at any time by zooming. The 
cursor changes to a magnifying glass ( ) when a zoom tool is active. Zoom out to 
reduce the magnification so you can see more of the drawing, or zoom in to increase 
the magnification so you can see a portion of the drawing in greater detail. Changing 
the magnification of the drawing affects only the way the drawing is displayed; it has 
no effect on the dimensions of the entities in your drawing.             

NOTE If you are working in a layout viewport and cannot zoom, the layout viewport 
may be locked. The scale and view do not change in model space while panning or 
zooming in a locked layout viewport.For more details, see “Modifying layout view-
ports” on page 371. 

Zooming in and out
One of the easiest ways to change the magnification of the drawing is to zoom in or 
out by a preset increment. On the View toolbar, the Zoom In tool ( )doubles the 
current magnification of the drawing. The Zoom Out tool ( ) reduces the magnifi-
cation of the drawing by half. The portion of the drawing located at the center of the 
current viewport remains centered on the screen as you zoom in and out.            

Zooming methods
To zoom, you can use any of the following methods:

• To define the portion of the drawing to zoom, create a window.

• To zoom in real time, press Ctrl + Shift and use the left mouse button, or use the 
Real-Time Zoom tool ( ) on the View toolbar. 

• If you have a mouse with a wheel, rotate the wheel to zoom in and out.

Zoom in. Zoom out.
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To zoom in to an area using a window

1 Do one of the following:

• Choose View > Zoom > Window.

• On the View toolbar, click the Zoom Window tool ( ).

• Type zoom and then press Enter.

2 Select one corner of the window around the area you want to magnify.

3 Specify the opposite corner of the window around the area you want to magnify.

To zoom in real time    

1 Do one of the following:

• Choose View > Real-Time Motion > Real-Time Zoom.

• On the View toolbar, click the Real-Time Zoom tool ( ).

• Type rtzoom and then press Enter.

• Simultaneously press and hold Ctrl + Shift.

2 Click and hold the left mouse button.

3 To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 
screen.

4 To stop zooming, release the mouse button.

To zoom using a mouse with a wheel    

• Rotate the wheel away from you to zoom in or toward you to zoom out.

Each rotation of the wheel away from you zooms out .8 times; each rotation 
toward you zooms in 1.25 times.

To specify a rectangular window around the 
area you want to magnify, select first one corner 
(A), and then select the opposite corner (B).

Result.

A

B
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Displaying the previous view of a drawing
After you zoom in or pan to view a portion of your drawing in greater detail, you may 
want to zoom back out to see the entire drawing. On the View menu, the 
Zoom Previous tool ( ) lets you restore the previous view. Selecting this tool 
repeatedly steps back through up to 25 successive zoomed or panned views.      

Zooming to a specific scale  
You can increase or decrease the magnification of your view by a precise scale factor 
measured relative to the overall size of the drawing or in relation to the current dis-
play. When you change the magnification factor, the portion of the drawing located at 
the center of the current viewport remains centered on the screen.    

To change the magnification of the view relative to the overall size of the drawing, 
type a number representing the magnification scale factor. For example, if you type a 
scale factor of 2, the drawing appears at twice its original size. If you type a magnifi-
cation factor of .5, the drawing appears at half its original size.

You can also change the magnification of the drawing relative to its current magnifi-
cation by adding an x after the magnification scale factor. For example, if you type a 
scale factor of 2x, the drawing changes to twice its current size. If you type a magnifi-
cation factor of .5x, the drawing changes to half its current size.

To zoom to a specific scale relative to the current display    

1 Do one of the following:

• Choose View > Zoom > Zoom In.

• On the View toolbar, click the Zoom In tool ( ).

• Type zoom and then press Enter.

2 Type the scale factor, followed by an x (such as 2x).

3 Press Enter.

Combining zooming and panning  
You can specify the point you want at the center of the view when you change the 
drawing magnification. You can specify the point you want at the lower left of the 
view when you change the magnification of the drawing with the Zoom Left tool 
( ) on the View toolbar. With the exception of the Zoom Window tool, the other 
zoom tools zoom in or out from the center of the current view.        

To change the center of the current view

1 Do one of the following:    

• Choose View > Zoom > Center.

• On the Zoom toolbar, click the Zoom Center tool ( ).

• Type zoom, press Enter, and then in the prompt box, choose Center.

2 Select the point you want located at the center of the new view.
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3 Specify the zoom scale factor or the height of the drawing in drawing units.     

Displaying the entire drawing
You can use the Zoom All tool ( ) on the View toolbar to display an entire draw-
ing. If you have drawn any entities outside the defined limits of the drawing, the 
extents of the drawing are displayed. If you drew all entities within the limits of the 
drawing, the drawing is displayed all the way to the drawing limits.                 

The Zoom Extents tool ( ) on the View toolbar displays the drawing to its extents, 
making the image fill the display to the greatest possible magnification. 
 

Current view showing the point to be centered in the new view (A), and the new view zoomed using a scale 
factor of 2x.

Zoom extents (displays all entities). Zoom all (displays to drawing limits).

A
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Displaying multiple views

When you begin a new drawing, it is displayed in a single window. You can view the 
drawing in a second window, or you can divide one window into multiple windows. 
You can also open and display multiple drawings.          

Working with multiple views of a single drawing
You can open and work with several views of the same drawing simultaneously. 
There are two methods for dividing the current drawing into multiple views:

• Open a new window of the open drawing.

• Divide the current window into multiple views.

After you divide a single window into multiple windows, you can control each win-
dow separately. For example, you can zoom or pan in one window without affecting 
the display in any of the other windows. You can control the grid, snap, and view ori-
entation separately for each window. You can restore named views in individual win-
dows, draw from one window to another, and name window configurations 
individually so you can reuse them later.       

As you draw, any changes you make in one window are immediately visible in the 
others. You can switch from one window to another at any time, even in the middle of 
a command, by clicking the window’s title bar.

Opening a new window of the same drawing
You can open additional windows to create more than one view of a drawing. To 
open a new window, choose Window > New Window. After you open a new win-
dow, you can change its display without affecting any of the other windows.    

When you open more than one window for a single drawing, each window is assigned 
a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your cur-
rent window is maximized, you can switch to another open window by selecting its 
name from the bottom of the Window menu.              

The names of other open drawings appear at the bottom of the Window menu. You 
can also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange 
all the open windows and drawings. To arrange all the windows and drawings into a 
stack of identically sized windows, choose Window > Cascade. Arranging windows 
and drawings in this way makes it easy to see the title bar for each window.       

To arrange all the windows and drawings horizontally so they are placed in order 
from top to bottom, choose Window > Tile Horizontally. Arranging windows and 
drawings in this way displays each open window. The windows are resized to fit 
within the available space.    

To arrange all the windows and drawings vertically so they are placed side by side, 
choose Window > Tile Vertically. Arranging windows and drawings in this way dis-
plays each open window. The windows are resized to fit within the available space.
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IntelliCAD uses the commands in the following table to control its windows.  

Dividing the current window into multiple views
You can divide a single drawing window into multiple tiled windows (called view-
ports) on the Model tab. You can control the number of windows created and the 
arrangement of the windows. You can also save and restore named window configu-
rations and display a list of the current and saved window configurations.

To create multiple views   

1 Do one of the following:    

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 
Viewports.

3 In the prompt box, choose the viewport orientation.  

IntelliCAD window-control commands

Command Result

vports Splits the current window into two, three, or four tiled windows.

wcascade Cascades (overlaps) all open windows.

wclose Closes the current window.

wcloseall Closes all windows; also closes all drawings.

whtile Tiles all windows horizontally.

wiarrange Arranges window icons.

wopen Opens another window of the current drawing.

wvtile Tiles all windows vertically.
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To join two views

1 Do one of the following:      

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Join.

3 Click anywhere inside the window you want to keep.

4 Click anywhere inside the adjacent window you want to join to the first window.

5 Press Enter.

You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows 
arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I).

A B C

D E F

G H I
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Saving window configurations
If you have divided the drawing window into multiple views, you can save the current 
window arrangement so that you can recall it to the screen later. The number and 
placement of the windows are saved exactly as they are currently displayed. The set-
tings for each window are also saved.  

To name and save a window configuration        

1 Do one of the following:

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Save.

3 Type a configuration name, and then press Enter.

The name can be up to 31 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.      

To restore a named window configuration    

1 Do one of the following:

• Choose View > Viewports.

• On the View toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Restore.

3 Type the name of the window configuration you want to restore.

Working with multiple drawings
With the multiple-document interface (MDI) feature, you can open more than one 
drawing inside of IntelliCAD. Because you can open and work on several drawings at 
one time, you can copy, cut, or paste an entity from one drawing to another.          

Each drawing appears in a drawing window, which has the following advantages:

• You can see two or more drawings side by side.

• You can easily copy entities from one drawing to another.

• Using the IntelliCAD Explorer, you can copy such elements as layers, linetypes, 
and text styles from one drawing to another.

• Like viewports on the Model tab, you can tile or overlap drawing windows; unlike 
viewports on the Model tab, drawing windows maximize or reduce to an icon. 
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Each drawing window that you open and work on retains in the Prompt History log 
all the commands that you perform, but the command line does not indicate when you 
have switched windows.

When you work with more than one drawing open in its own window, you can easily 
move, cut, copy, and paste in between drawings. If you move an entity from one win-
dow to another and then want to undo this action, you must undo it in both drawings 
for it to take effect. If you copy an entity from one window to another and then want 
to undo that action, you must undo it from the drawing into which you copied the 
entity. If you cut and paste an entity and then want to undo that action, you must undo 
it in both drawings.

One session of IntelliCAD with four drawings open.
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Controlling visual elements  

The number of entities in your drawing and the complexity of the drawing affect how 
quickly IntelliCAD can process commands and display your drawing. You can 
improve overall program performance by turning off the display of certain visual ele-
ments, such as solid fills and text, while you work on the drawing. When you are 
ready to print your drawing, turn on the display of these elements so your drawing 
prints the way you want.       

You can also improve performance by turning off entity-selection highlighting, turn-
ing off the display of marker blips created when you select locations in the drawing, 
and by turning off the display of lineweights.

Turning Fill on and off
You can reduce the time it takes to display or print a drawing by turning off the dis-
play of solid fill. When Fill is turned off, all filled entities, such as wide polylines and 
planes, display and print as outlines. When you turn Fill on or off, you must redraw 
the drawing before the change is displayed.        

To turn Fill on or off

1 Do one of the following:

• Choose Settings > Fill.

• On the Settings toolbar, click the Fill tool ( ).

• Type fill and then press Enter.

2 Choose View > Redraw.    

TIP  On the Settings menu, a check mark appears next to the Fill command when it is 
turned on and the Fill tool on the Settings toolbar is activated. 

Fill on. Fill off.
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Turning Quick Text on and off   
Text entities require a considerable amount of time to display and print. You can 
reduce the time it takes to display or print a drawing by enabling Quick Text. For 
example, if you’re doing a preliminary check print of a drawing, you may want to 
turn Quick Text on to speed up printing. When Quick Text is enabled, text entities are 
replaced by rectangular boxes that indicate the outline of the area occupied by the 
text. When you turn Quick Text on or off, you must regenerate the drawing before the 
change is displayed.          

To turn Quick Text on and off

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type qtext, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Enable Quick Text check box.

5 Click OK.

6 To regenerate your drawing, do one of the following:

• Choose View > Regen.

• On the View toolbar, click the Regen tool ( ).

• Type regen and then press Enter.

Quick Text off. Quick Text on.
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Turning highlighting on and off
You can improve overall program performance by turning highlighting off. When 
you select entities to modify, the program highlights them using a dashed linetype. 
This highlight disappears when you finish modifying the entities or when the entities 
are cleared. Sometimes highlighting entities can take a considerable amount of time. 

To turn highlighting on and off

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type highlight, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Highlight Item When Selected check box.

5 Click OK.

Turning Blips on and off
You can turn Blips off. They are the temporary markers that appear on the screen 
when you select an entity or location. Blips are visible only until you redraw the 
drawing. You cannot select Blips; they are used only for reference and never print.

To turn Blips on and off

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type blipmode, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Show Marker Blips check box.

5 Click OK.

Blips on. Blips off.
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Controlling the display of lineweights
You can reduce the time it takes to display a drawing by turning off the display of lin-
eweights. When you turn off lineweights, all entities display as outlines. 

You can also specify a lineweight scale. Specify a smaller scale to display thinner 
lines; specify a larger scale to display thicker lines. For example, a scale factor of 0.5 
would display a .80 millimeter lineweight as .40 millimeter; a scale factor of 2 would 
increase the same lineweight to display at 1.6 millimeters. This can help you differen-
tiate various lineweights that display in a drawing. Adjusting the lineweight display 
scale affects how the lineweights appear on your screen, not how they appear when 
printed.  

NOTE  Setting the lineweight scale too high may result in slower system performance.

You can also adjust the units for measuring lineweights, and the default lineweight.        

To control the display of lineweights

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

• Type lweight and then press Enter.

2 Click the Display tab.

3 Under Change Settings For, click Lineweights.

4 Select or clear Display Lineweights.

5 In Units for Listing, choose Millimeters or Inches.

6 In Default, select the lineweight assigned to layers and entities that use the Default 
lineweight.

7 In Adjust Display Scale, move the slider to the scale you want. By default, the 
slider begins at 1.00.

8 Click OK.

TIP  On the status bar, double-click the word LWT to turn the display of lineweights 
on or off.  

You can turn lineweights on or off when you print. For details, see “Choosing how 
lineweights print” on page 377. 
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Working with coordinates

For accuracy in a drawing, you can locate specific points by entering coordinates as 
you draw or modify entities. When you create two-dimensional entities, you enter 
two-dimensional coordinates; for three-dimensional entities, you specify three-
dimensional coordinates.

You can also specify coordinates in relation to other known locations or entities in a 
drawing. In particular, when you work in three-dimensional drawings, it is often eas-
ier to specify coordinates in relation to a two-dimensional working plane, called a 
user coordinate system (UCS).

This section explains how to work with coordinates, including how to:

• Use two-dimensional and three-dimensional coordinate systems.

• Specify absolute and relative coordinates.

• Specify polar, spherical, and cylindrical coordinates.

• Define and manipulate user coordinate systems.

Topics in this chapter

Using Cartesian coordinates ............................................................................ 156

Using two-dimensional coordinates .................................................................. 159

Using three-dimensional coordinates ............................................................... 163

Using xyz point filters........................................................................................ 166

Defining user coordinate systems..................................................................... 168
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Using Cartesian coordinates  

Many commands in IntelliCAD require that you specify points as you draw or modify 
entities. You can do so by selecting points with the mouse or by typing coordinate 
values in the command bar. The program locates points in a drawing using a Carte-
sian coordinate system.

Understanding how coordinate systems work  
The Cartesian coordinate system uses three perpendicular axes—x, y, and z—to spec-
ify points in three-dimensional space. Every location in a drawing can be represented 
as a point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-
dimensional entity, you specify horizontal coordinate positions along the x-axis and 
vertical coordinate positions along the y-axis. Thus, every point on a plane can be 
represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 
Positive coordinates are located above and to the right of the origin; negative coordi-
nates are located to the left and below the origin.        
     

When you work in two dimensions, you need enter only the x- and y-coordinates; the 
program assumes that the z-axis value is always the current elevation. When you 
work in three dimensions, however, you must also specify the z-axis value. When you 
look at a plan view of your drawing (a view from above, looking down), the z-axis 
extends straight up out of the screen at a 90-degree angle to the xy plane. Positive 
coordinates are located above the xy plane, and negative coordinates are below the 
plane.

The three perpendicular axes of the Cartesian coordinate system.
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All IntelliCAD drawings use a fixed coordinate system, called the World Coordinate 
System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the 
WCS. You can also define arbitrary coordinate systems located anywhere in three-
dimensional space. These are called user coordinate systems and can be located any-
where in the WCS and oriented in any direction.          

You can create as many user coordinate systems as you want, saving or redefining 
them to help you construct three-dimensional entities. By defining a UCS within the 
WCS, you can simplify the creation of most three-dimensional entities into combina-
tions of two-dimensional entities.    

To help you keep your bearings in the current coordinate system, the program dis-
plays a coordinate system icon. When you begin a new drawing, you are automati-
cally in the WCS, indicated by the letter W in the icon. When you display a drawing 
in plan view, you see the coordinate system icon from the top, with the z-axis directed 
straight toward you. When you display a three-dimensional drawing in a view other 
than plan view, the coordinate system icon changes to reflect your new viewpoint.        

TIP The visible portions of the axes are the positive directions.    

The IntelliCAD UCS icon looks different from the UCS icon in AutoCAD, because it 
presents more information. Three colors represent the three axes, making it easier for 
you to recognize the orientation in three-dimensional space:

• x-axis: red

• y-axis: green

• z-axis: blue 

If you prefer a single color for the cursor and UCS icon, you can make that change 
with the config or options command.

WCS icon. Plan UCS icon. 3D View WCS icon.
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Understanding how coordinates are displayed
The current position of the cursor is displayed as x,y,z-coordinates in the status bar 
and, by default, updates dynamically as you move the cursor. You can toggle the 
coordinate display to static mode by pressing F6, so that it updates only when you 
select a point in the drawing.        

You can also change the coordinate display to a different dynamic mode that shows 
the distance and angle (rather than x,y,z-coordinates) when the program displays a 
rubber-band line. To do this, choose Settings > Drawing Settings and select the Dis-
play tab. Under Coordinate Display, select the option for Coordinates In Polar Form 
For Distance And Angle Selection.          
      

You can control the coordinate display from the Drawing Settings dialog box.
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Finding the coordinates of a point
To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 
select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 
have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 
with the z-coordinate equal to the current elevation.  

To find the coordinate of a point in the drawing

1 Do one of the following: 

• Choose Tools > Inquiry > ID Coordinates.

• On the Inquiry toolbar, click the ID Coordinates tool ( ).

• Type idpoint and then press Enter.

2 Select the point for which you want to find the coordinates.

If the command bar is activated, the x,y,z-coordinates for the point you selected 
display in the command bar.

If the command bar is not activated, the Prompt History window displays, show-
ing the x,y,z-coordinates for the point you selected.

Using two-dimensional coordinates

When working in two dimensions, you specify points on the xy plane. You can spec-
ify any point as an absolute coordinate (or Cartesian coordinate), using the exact x-
coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate 
point at which the two axes intersect), or as a relative coordinate in relation to the pre-
vious point. You can also specify points using relative or absolute polar coordinates, 
which locate a point using a distance and an angle. 



160 C H A P T E R  7
Entering absolute Cartesian coordinates
To enter absolute Cartesian coordinates, type the coordinate location of the point in 
the command bar. For example, to use absolute Cartesian coordinates to draw a line 
from the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the 
Line command and respond to the prompts as follows:     

Start of line: 0,0

Angle • Length • <Endpoint>: 3,1   

When using absolute Cartesian coordinates, you need to know the exact point loca-
tions for anything you draw. For instance, to use absolute Cartesian coordinates to 
draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 
upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 
lower right corner at 12.5,5.

Drawing a line using the absolute Cartesian coordinate method.

1
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(3, 1)
(0, 0)
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Entering relative Cartesian coordinates
Another, simpler method is to use relative Cartesian coordinates: you specify a 
location in the drawing by determining its position relative to the last coordinate you 
specified. To use relative Cartesian coordinates, type the coordinate values in the 
command bar, preceded by the at symbol (@). The coordinate pair following the @ 
symbol represents the distance along the x-axis and the y-axis to the next point. For 
example, to draw an 8.5-unit square with its lower left corner at 4,5 using relative 
Cartesian coordinates, start the Line command, and then respond to the prompts as 
follows:

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5,0

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0

Angle • Length • Follow • Close • Undo • <Endpoint>: C

  

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right 
(along the x-axis) from the previous point of 4,5; the second relative coordinate 
(@0,8.5) locates the next point 8.5 units above (along the y-axis) the previous point, 
and so on. Entering C (for Close) draws the final line segment back to the first point 
specified when you started the Line command.                      

Drawing a square using the relative Cartesian coordinates method; enter C to close.
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Entering polar coordinates
Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 
simple task. Polar coordinates base the location of a point on a distance and angle 
from either the origin (absolute coordinate) or from the previous point (relative coor-
dinate).                                

To specify polar coordinates, type a distance and an angle, separated by the open 
angle bracket (<). For example, to use relative polar coordinates to specify a point 1 
unit away from the previous point and at an angle of 45 degrees, type @1<45.                

To draw the square from the example in the previous section, “Entering relative Car-
tesian coordinates,” this time tilted at a 45-degree angle, start the Line command, and 
then respond to the prompts as follows:     

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5<45

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315

Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

  

NOTE  This example, like all examples in this guide, assumes the program’s default 
settings: Angles increase counterclockwise and decrease clockwise. Thus, an angle of 
315 degrees is the same as -45 degrees.

Drawing a tilted square using the relative polar coordinates method; enter C to close.
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Using three-dimensional coordinates  

Specifying coordinates in three-dimensional space is similar to working in two 
dimensions, except that you also use the z-axis to locate coordinates. Three-dimen-
sional coordinates are represented in the format x,y,z (for example, 2,3,6).

Using the right-hand rule   
To visualize how IntelliCAD works with three-dimensional space, use a technique 
known as the right-hand rule. Hold up your right hand in a loose fist with your palm 
facing you. Extend your thumb in the direction of the positive x-axis and your index 
finger upward in the direction of the positive y-axis. Then extend your middle finger 
straight toward you in the direction of the z-axis. These three fingers are now pointing 
in the positive x, y, and z directions, respectively.       

You can also use the right-hand rule to determine the positive rotation direction. Point 
your thumb in the positive direction of the axis about which you want to rotate, and 
then curl the rest of your fingers toward your palm. These fingers are curling in the 
positive rotation direction.      

Entering x,y,z-coordinates  
When working in three dimensions, you can specify x,y,z-coordinates as absolute dis-
tances in relation to the origin (the 0,0,0 coordinate point at which the three axes 
intersect) or as relative coordinates based on the last point selected. For example, to 
specify a point 3 units along the positive x-axis, 4 units along the positive y-axis, and 
2 units along the positive z-axis, specify the coordinate 3,4,2.    

The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the 
positive rotation direction.

Y

Z

X
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Entering spherical coordinates
When working in three-dimensional space, you can use spherical coordinates to spec-
ify a three-dimensional point by entering its distance from either the origin (absolute 
distance) or the last point (relative distance), along with its angle in the xy plane and 
its angle up from the xy plane. In spherical format, you separate each angle with the 
open angle bracket (<).              

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an 
angle of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line 
command, and then respond to the prompts as follows:

Start of line: 0,0,0

Angle • Length • <Endpoint>: 10.2500<45<35 

  

When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you 
specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 
degrees), and the angle from the xy plane (E, in this case 35 degrees).
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Entering cylindrical coordinates  
When working in three-dimensional space, you can also use cylindrical coordinates 
to specify a three-dimensional point. You specify a point by entering its distance from 
either the origin (absolute distance) or the last point (relative distance), its angle in the 
xy plane, and its z-coordinate value.      

In cylindrical format, you separate the distance and angle with the open angle 
bracket (<) and separate the angle and z value with a comma. For example, to draw a 
line from the last point to a point 7.4750 units away, at an angle of 27 degrees from 
the x-axis in the xy plane and 3 units up in the z direction, start the Line command, 
and then respond to the prompts as follows: 

Start of line: (select point A)

Angle • Length • <Endpoint>: @7.4750<27,3 

 

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, 
you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 
degrees), and the distance in the z direction (E, in this case 3 units).
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Using xyz point filters  

Point filters provide a method of locating a point in a drawing relative to another 
point without specifying the entire coordinate. Using a point filter, you can enter par-
tial coordinates, and then the program prompts you for the remaining coordinate 
information. To use xyz point filters, respond to the prompt for a coordinate with a 
filter in the following form:         

.coordinate

where coordinate is one or more of the letters x, y, and z. The program then prompts 
you for the filtered coordinate(s). For example, if you type .xy, the program prompts 
you to select a point whose xy-coordinate you want, and then prompts you for the z-
coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters.

Using point filters in two dimensions
You can use point filters when you work in two dimensions to locate points in rela-
tion to existing entities. For example, to draw a circle centered in a rectangle, start the 
Circle command, and then respond to the prompts as follows:

2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y

Select Y of: mid

Snap to midpoint of: (select the left side of the rectangle)

Still need XZ of: mid

Snap to midpoint of: (select top of the rectangle)

Diameter • <Radius>: (specify radius of circle) 

  

You can use point filters to center the circle by separately selecting the midpoints of 
two sides of the rectangle (A and B) and then specifying its radius.

A

B
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Using point filters in three dimensions
You can use point filters when you work in three-dimensional space to locate points 
in two dimensions and then specify the z-coordinate as the elevation above the xy 
plane. For example, to begin drawing a line from a point with a z-coordinate 3 units 
above the center of a circle, insert the circle, and then start the Line command and 
respond to the prompts as follows:      

ENTER to use last point • Follow • <Start of line>: .xy

Select XY of: cen

Snap to centerpoint of: (select a point on the circle)

Still need Z of: 3 (locates the starting point 3 units above the center of 

the circle)

Length of line: (specify the length of the line) 

  

You can use point filters to draw a line by first selecting a point in the xy plane (A), 
specifying the z-coordinate (B), and then specifying the length of the line (C).

A

B

C
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Defining user coordinate systems  

When working in three-dimensional space, you can define a UCS with its own 0,0,0 
origin and orientation separate from the WCS. You can create as many user coordi-
nate systems as you want, and then save and recall them as you need them to simplify 
construction of three-dimensional entities.              

For example, you can create a separate UCS for each side of a building. Then, by 
switching to the UCS for the east side of the building, you can draw the windows on 
that side by specifying only their x- and y-coordinates. When you create one or more 
user coordinate systems, the coordinate entry is based on the current UCS. 
  

Defining a user coordinate system
To define a UCS, you can use any of the following methods:

• Specify a new origin and points on the positive x- and y-axes.

• Specify a new origin and point on the positive z-axis.

• Align the UCS with an existing entity.    

• Rotate the current UCS around any of its axes.    

• Align the UCS with its z-axis parallel to the current viewing direction.

• Align the UCS xy plane perpendicular to the current view.

When you define a new UCS, the UCS icon changes to indicate the origin and orien-
tation of the new UCS.

UCS aligned with the front wall of the house.
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To define a UCS by specifying a new origin and points on the positive x- and y-
axes    

1 Do one of the following: 

• Choose Settings > User Coordinate Systems.

• On the Settings toolbar, click the User Coordinate Systems tool ( ).

• Type setucs and then press Enter.

2 In the User Coordinate Systems dialog box, click Explore UCSs.

3 In the IntelliCAD Explorer, be sure that Coordinate Systems is selected, and click 
the New Item tool ( ).    

4 In the prompt box, choose 3 Point.

5 Select the new origin.

6 Select a point on the positive x-axis.

7 Select a point in the positive y direction.

8 In the IntelliCAD Explorer - Coordinate Systems dialog box, type the name for the 
new UCS, and then close the dialog box.  

Using a preset user coordinate system
IntelliCAD lets you select a preset UCS. The six planes defined by looking along the 
x,y,z-axes align the UCS with the top, left, front, bottom, right, or back, based on 
either the WCS or the current UCS in effect when you select the tool. You can also 
select the previous UCS, align the UCS to the current view, or select the WCS.

When you select a UCS, the cursor orientation and UCS icon change to reflect the 
new UCS. The display does not change, however, unless you select the Change View 
To Plan View Of The Selected UCS check box.     

After you align the UCS to a preset UCS, you can use the IntelliCAD Explorer to 
save the UCS. To do this, in the IntelliCAD Explorer window, choose Edit > New > 
UCS, and then select Current.

Define the new UCS by selecting the origin (A), a point on the positive x-axis 
(B), and a point in the positive y direction (C).

A

B

C
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To select a preset UCS 

1 Do one of the following: 

• Choose Settings > User Coordinate Systems.

• On the Settings toolbar, click the User Coordinate Systems tool ( ).

• Type setucs and then press Enter.

2 Under Set The Selected UCS Relative To, select either Current UCS to change to 
the new UCS by reorienting relative to the current UCS or World Coordinate Sys-
tem (WCS) to base the new UCS orientation on the WCS.

3 Under Select UCS, click the button corresponding to the UCS you want as the new 
current UCS.     

A Specify whether to define the new UCS relative 
to the current UCS or to the World Coordinate 
System (WCS).

B Select to change the display to the plan view of 
the new UCS.

C Click to select the previous UCS.

D Click one of these buttons to select the view you 
want of a preset UCS.

E Click to select the WCS.

F Click to align the UCS with the current view.

G Click to display the IntelliCAD Explorer.

A

B

C

D

E

F

G
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Working with the IntelliCAD Explorer

The IntelliCAD Explorer provides a powerful and convenient way to maintain and 
manage many of the features and settings of your drawings. You can use the Intelli-
CAD Explorer to work with layers, linetypes, text styles, coordinate systems, named 
views, blocks, and dimension styles within the current drawing or to copy this infor-
mation between drawings.

This section explains how to use the IntelliCAD Explorer to:

• Manage elements related to settings and entities in your drawings.

• Organize information on layers and manage layers.

• Create and use linetypes.

• Load text fonts and create text styles.

• Select and control coordinate systems.

• Save and restore named views.

• Save, insert, and manage blocks.

• Copy, cut, and paste dimension styles between DWG files.

Topics in this chapter

Using the IntelliCAD Explorer ........................................................................... 172

Organizing information on layers................................................................177

Working with linetypes ...................................................................................... 190

Working with text fonts and styles..................................................................... 198

Working with coordinate systems ..................................................................... 202

Using named views........................................................................................... 206

Working with blocks and external references..............................................209

Working with dimension styles.......................................................................... 216
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Using the IntelliCAD Explorer 

The IntelliCAD Explorer opens in its own, separate window, which you can move or 
resize. The IntelliCAD Explorer window has its own menu and tools. 

To display the IntelliCAD Explorer

Do one of the following:    

• Choose Tools > IntelliCAD Explorer.     

• On the Tools toolbar, click the IntelliCAD Explorer tool ( ).

• Type explayers and then press Enter.       

• Type la and then press Enter.

• On the status bar, right-click on the current layer, and from the list, select the layer 
you want to make current.

The IntelliCAD Explorer window has two panes, a left pane and a right pane. The 
elements are listed in the left pane, and the drawing settings are listed and described 
in the right pane.

TIP On the Settings menu, you can use the Explore Layers, Explore Blocks, Explore 
Views, Explore Coordinate Systems, Explore Linetypes, Explore Text Styles, and 
Explore Dimension Styles commands to display the layers, blocks, views, coordinate 
systems, linetypes, text styles, and dimension styles for the current drawing in the 
IntelliCAD Explorer window. Tools for these commands also appear on the Settings 
toolbar.    
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A Tools on the Standard toolbar provide controls common to all 
elements.

B The Elements pane shows an outline view containing the name of 
every drawing currently open and lists the elements you can control 
in each drawing.      

C  Click on a setting to change it.

D The named settings for the selected element.

E Other toolbars appear, depending on the selection in the Elements 
pane.

A
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Using the IntelliCAD Explorer, you can create, delete, or modify any of the settings 
for the currently selected element for a given drawing. You can also copy the contents 
of any element from one drawing to another. The tools and menu items on the Intelli-
CAD Explorer provide the following functions:         

Copying settings   
A particularly powerful feature of the IntelliCAD Explorer is its capability of copying 
many of the settings—layers, linetypes, text styles, coordinate systems, views, blocks, 
or dimension styles—from one drawing to another. If you have more than one draw-
ing open, the IntelliCAD Explorer makes it easy to reuse information. For example, 
when you copy layers from one drawing to another, the layer names as well as their 
linetypes, colors, and other settings are also copied, but not the entities on those lay-
ers.    

IntelliCAD Explorer tools    

Tool Function

( ) New Item Creates a new layer, linetype, style, coordinate system, view, block, or 
dimension style.

( ) Current Makes the selection current.

( ) Cut Cuts the selection to the Clipboard.

( ) Copy Copies the selection to the Clipboard.

( ) Paste Pastes the selection from the Clipboard into the appropriate list of a 
different drawing.

( ) Delete Deletes the selection from the list.

( ) Properties Displays the properties for the selection.

( ) World Sets the current coordinate system to the World Coordinate System 
(WCS).

( ) Purge Eliminates unreferenced elements from your drawing file.

( ) Regen Recalculates the display for the current window.

( ) On/Off Regen Turns on and off the display recalculation.
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To copy layers from one open drawing to another open drawing

1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Elements pane, select the drawing from which you want to copy layers.

3 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 
and then click Layers.

4 In the Layers Settings In Drawing list (right pane), select the layers you want to 
copy.

5 Choose Edit > Copy, or click the Copy tool ( ).

6 In the Elements pane, select the drawing to which you want to copy the layers.

7 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 
and then click Layers.

8 Choose Edit > Paste, or click the Paste tool ( ).

Deleting settings   
You can use the IntelliCAD Explorer to delete many of the items that appear in the 
Elements list. You can delete a layer, linetype, text style, coordinate system, view, 
block, or dimension style.     

Because you may have already created entities on a particular layer or using a partic-
ular linetype or text style, deleting one of these elements requires that you make cer-
tain choices from options the program presents. For example, if you attempt to delete 
a layer, the program prompts you to specify whether you want to move any entities 
from that layer to another layer. Every drawing has at least one layer, the default 
layer, named “0.” You cannot delete or rename this layer. Your drawing can also con-
tain an unlimited number of additional layers, each of which you assign a unique 
name.    

If you try to delete a linetype, the program prompts you to specify whether you want 
to convert all entities drawn using that linetype to a different linetype. If you attempt 
to delete a text style, the program prompts you to specify whether you want to convert 
all text entities created using that style to a different style.    
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To delete a layer and relocate its entities to another layer

1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 From the Layer Name list, select the layer that you want to delete.

If that layer is the current layer, layer 0 automatically becomes the current layer.

3 Choose Edit > Delete, or click the Delete tool ( ).

4 From the dialog box, click Change.

5 In the drop-down list, double-click the layer to which you want to relocate entities.      

A Click to delete the layer and all entities on
the layer.

B Click to delete the layer after first relocating all of 
its entities to a selected layer.

C Click to cancel the layer deletion.

A

B

C
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Purging elements    
From within the IntelliCAD Explorer, you can eliminate unused blocks, layers, line-
types, text styles, or dimension styles from your drawing file. Purging unused ele-
ments can significantly reduce the drawing file size.

To purge an element

1 Do one of the following:

• Choose Tools > IntelliCAD Explorer.

• On the Tools toolbar, click the IntelliCAD Explorer tool ( ).

• Type explayers and then press Enter.

2 Select the element from which you want to purge unreferenced elements.

3 From the Standard toolbar, select the Purge tool ( ).
The main drawing window appears. 

4 In the command bar, do one of the following:

• Enter the name of the element to purge, and then press Enter.

• Press Enter to purge all unused elements of the selected type without confirming 
the removal of each element.

Organizing information on layers 

Layers in IntelliCAD are like the transparent overlays you use in manual drafting. 
You use layers to organize different types of drawing information. In IntelliCAD, 
each entity in a drawing exists on a layer. When you draw an entity, it is created on 
the current layer.    

You can control the visibility of layers in individual viewports. When you turn a layer 
off, entities drawn on that layer are no longer visible, and they do not print. Although 
a layer may be invisible, you can still select it as the current layer, in which case new 
entities are also invisible until you turn the layer back on. Entities on invisible layers 
can also affect the display and printing of entities on other layers. For example, enti-
ties on invisible layers can hide other entities when you use the Hide command to 
remove hidden lines.    

You can also freeze and thaw layers. Entities drawn on frozen layers do not display, 
do not print, and do not regenerate. When you freeze a layer, its entities do not affect 
the display or printing of other entities. For example, entities on frozen layers do not 
hide other entities when you use the Hide command to remove hidden lines. In addi-
tion, you cannot draw on a frozen layer until you thaw it, and you cannot make a fro-
zen layer current.     
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You cannot freeze the current layer. If you attempt to freeze the current layer, a dia-
log box appears prompting you to specify a different layer. You also cannot freeze or 
thaw a viewport layer unless you are working in a Layout tab.

You can lock or unlock layers. The entities on a locked layer are still visible and will 
print, but you cannot edit them. Locking a layer prevents you from accidentally mod-
ifying entities.     

Each layer has its own color, linetype, and lineweight. For drawings that use named 
print styles, layers can also have their own print style. Entities you draw on a particu-
lar layer are displayed in the color, linetype, and lineweight associated with that layer 
unless you override these settings. You control all of the associated settings for layers 
using the Layers elements in the IntelliCAD Explorer. You can also access layer set-
tings for entities using the Entity Properties toolbar.   

To display layers in the IntelliCAD Explorer

Do one of the following:       

• Choose Settings > Explore Layers.

• Choose Tools > IntelliCAD Explorer.

• On the Tools toolbar, click the IntelliCAD Explorer tool ( ).

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.
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A Select Layers to display the Layers settings.     

B Lists named layers in the current drawing. A check mark
indicates the current layer.

C Displays the color assigned to each layer.

D Displays the linetype assigned to each layer.

E Indicates the visibility status of each layer.     

F Indicates the locked or unlocked status of each layer. 

G Indicates the frozen or thawed status of each layer for all viewports.

H Indicates the lineweight assigned to each layer.

I Indicates the print style assigned to each layer.

J Indicates the print status of each layer.

K Indicates the frozen or thawed status of the layer in the current 
viewport.

L Indicates the frozen or thawed status of the layer for new viewports 
on a Layout tab.

M Sorts the layers by that property when you click a column head.

A

B C D E F H I J KG
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When Layers are displayed, three tools on the Layer toolbar provide the following 
functions:

( ) Layer On/Off toggles the selected layers on and off.     

( ) Freeze/Thaw freezes or thaws the selected layers.    

( ) Lock/Unlock locks or unlocks the selected layers.

You can change any of these settings by clicking either the tool or its current condi-
tion. You can edit the color, linetype, lineweight, and other properties of a layer by 
clicking the corresponding name and selecting the values you want in the dialog box. 
You can also edit a layer’s properties by right-clicking it and choosing Properties.

Creating and naming layers 
You can create an unlimited number of layers in every drawing and use those layers 
for organizing information. When you create a new layer, it is initially assigned the 
color white (or black, depending on your system settings) and the linetype CONTIN-
UOUS. By default, a new layer is also visible. After you create and name a layer, you 
can change its color, linetype, visibility, and other properties.     

NOTE  Layer names created or renamed in IntelliCAD can have up to 31 characters 
and cannot include spaces. IntelliCAD will, however, display longer layer names and 
names containing spaces, such as layers created in AutoCAD 2000.

A Select to keep the dialog box on the screen 
when you switch back to the IntelliCAD Explorer.

B Displays the name of the layer whose properties 
are being changed.

C Displays the current layer color.

D Choose the linetype assigned to the selected 
layer.

E Choose the lineweight assigned to the selected 
layer.

F Choose the print style assigned to the selected 
layer (only for drawings that use named print 
style tables).

G Click to display the Color dialog box to select a 
new color.   

H Select or clear check boxes to control other 
properties of the selected layer.

A
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To create a new layer

1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 Choose Edit > New > Layer.

The program adds a new layer to the Layer Name list, with the default name 
NewLayer1.

3 Type a name for the new layer over the highlighted default name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

TIP You can also create a new layer by selecting the Layers element for a drawing 
and clicking the New Item tool ( ).

To change a layer name in the current drawing

1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to make current.

3 Do one of the following:

• Choose Edit > Rename, type a new name, and then press Enter.

• Highlight the layer name you want to change, type a new name, and then press 
Enter.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

4 To complete the command and return to your drawing, close the window.    

NOTE  You cannot rename the 0 layer.
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Setting the current layer
When you create new entities, they are drawn on the current layer. To draw new enti-
ties on a different layer, you must first make that layer the current layer.   

To make a layer current 

1 Do one of the following:

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• In the Layer Name list, select the name you want to make current, and then click 
the Current tool ( ).

• Double-click the layer name in the Layer Name list. 

• Right-click the layer name you want to change, and from the shortcut menu 
select Current. 

4 To complete the command and return to your drawing, close the window.

To set the current layer to that of an existing entity

1 Do one of the following:      

• Choose Settings > Set Layer By Entity.

• On the Settings toolbar, click the Set Layer By Entity tool ( ).

• Type setlayer and then press Enter.

2 Select the entity to set the current layer.    

Controlling layer visibility   
A layer can be visible or invisible. Entities on invisible layers are not displayed and 
do not print. By controlling layer visibility, you can turn off unnecessary information, 
such as construction lines or notes. By changing layer visibility, you can put the same 
drawing to multiple uses.    

For example, if you are drawing a floor plan, you can draw the layout of light fixtures 
on one layer and the location of plumbing lines on another. By selectively turning 
layers on and off, you can print the electrical engineering drawings and the plumbing 
drawings from the same drawing file. For even more convenience, you can control 
the visibility of layers within individual viewports, so that layers that display in one 
viewport are invisible in other viewports in the same drawing.

When you turn a layer off, entities drawn on that layer are no longer visible. When 
you turn the layer back on, the entities on that layer are redisplayed.
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To turn layers on or off

1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layer you want to turn on or off.

3 Do one of the following:

• Choose View > On/Off.

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and turn the layer on or off. 

• Click the setting in the On/Off column.

The On/Off column shows the new setting.

4 To complete the command and return to your drawing, close the window.

You can also freeze layers to improve the performance of operations such as zooming 
and panning or producing hidden lines or shaded images. When a layer is frozen, 
entities drawn on that layer are no longer visible.    

To control the visibility of external reference layers and save any changes made to 
them in the current drawing, turn on Xref Layer Visibility.

To turn on Xref Layer Visibility

1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter

2 Choose View > Xref Layer Visibility.

TIP  You can also turn on this variable by typing visretain.
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To freeze or thaw layers

1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layers you want to freeze or thaw.

3 Do one of the following:

• Choose View > Freeze/Thaw.

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and freeze or thaw the layer.

• Click the setting in the All Viewports column.

The All Viewports column shows the new setting.

4 To complete the command and return to your drawing, close the window.

Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but pre-
vents you from accidentally modifying its entities. When a layer is locked (but visible 
and thawed), its entities remain visible, but you cannot edit them. If you lock the cur-
rent layer, you can still add new entities to it. You can also change the linetype and 
color associated with a locked layer. Unlocking a layer restores full editing capabili-
ties.    

To lock or unlock layers

1 Do one of the following:

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the Layer Name list, select the layers you want to lock or unlock.

3 Do one of the following:

• Choose View > Lock/Unlock.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Properties and lock or unlock the layer.

• Click the setting in the Locked column.

The Locked column shows the new setting.

4 To complete the command and return to your drawing, close the window.
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Controlling layer printing   
Controlling layer printing is another way you can specify which entities print in your 
drawing. 

By controlling layer printing, you can turn off unnecessary information during print-
ing. For example, if you are drawing a floor plan, you can draw the layout of light fix-
tures on one layer and the location of plumbing lines on another. By selectively 
turning layers on and off when you print, you can print the electrical engineering 
drawings and the plumbing drawings from the same drawing file. By changing layer 
printing, you can put the same drawing to multiple uses.    

When you turn off printing for a layer, entities drawn on that layer are still visible, but 
they do not print. If you turn off a layer’s visibility, entities drawn on that layer do not 
display or print. Controlling layer printing can be especially helpful if you want layer 
visibility on, but do not want to print entities on that layer. 

Layer visibility must be turned on in order to print entities drawn on that layer.

To turn layer printing on or off

1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the setting in the Print column for the layer you want to 
change. Choose Yes to print entities assigned to the layer. Choose No to omit enti-
ties assigned to the layer during printing.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the print setting for a layer.

Setting the layer color   
Each layer in a drawing is assigned a color. IntelliCAD uses the BYLAYER color as 
the default color setting for entity creation so that new entities are drawn in the color 
of the layer on which they are inserted (set in the Drawing Settings dialog box).    

Using the IntelliCAD Explorer, you can set or change the color assigned to a layer. 
With the direct-editing feature, you can click on the color you want to change, and 
then select a new color from the dialog box that appears. Changing a layer’s color 
automatically changes the color of all entities on that layer with the BYLAYER color.
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To change the layer color

1 Do one of the following:     

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the color swatch for the layer you want to change.

TIP Right-click the name of the layer you want to change, and from the shortcut 
menu, select Properties and change the layer color.

3 In the Color dialog box, select a color on one of the following tabs:

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 
You can also type the color number in the Index box.

• True Color — Click a basic color, click a color in the color palette, enter the Hue, 
Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) 
values. There are more than 16 million true colors from which you can choose.

• Color Books — Select a color book from the list, then click a color. You can 
select Show Only Color Book Colors Used in Drawing to limit the selection to 
only those color book colors that are used in the current drawing. If necessary, 
create or edit color books by clicking Color Book Editor. For more details, see 
“Using color books” on page 61. 

4 Click OK. 

NOTE You can also assign a specific color to an entity, which overrides the layer’s 
color setting. When you create a new entity, use the Settings > Colors > Select Color 
command to change the current color. For an existing entity, select the entity, right-
click for the shortcut menu, and choose Properties. You can then change the entity’s 
color in the Entity Properties dialog box.        

For more details about using color in the many aspects of your drawing, see “Work-
ing with colors” on page 58. 
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Setting a layer’s linetype    
Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). 
Linetype determines the appearance of entities both on the screen and when printed.    

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that 
layer. IntelliCAD uses the BYLAYER linetype as the default linetype setting for 
Entity Creation (in the Drawing Settings dialog box).

Using the IntelliCAD Explorer, you can set or change the linetype assigned to a layer. 
With the direct-editing feature, you can click on the linetype you want to change, and 
then select a new linetype from the dialog box that appears. Changing the linetype 
assigned to a layer changes the linetype of all entities drawn on that layer with the 
BYLAYER linetype.

NOTE  Only those linetypes already set in the drawing can be assigned to layers. For 
more information about setting additional linetypes, see see “Working with 
linetypes” on page 190 in this chapter. 

To change the linetype assigned to one or more layers

1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the linetype for the layer you want to change.

3 In the Linetype dialog box, select a new linetype for the layer, or click Browse to 
select your linetype file.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the linetype assigned to a layer.

NOTE  You can also assign a specific linetype to an entity, which overrides the layer’s 
linetype setting. When you create a new entity, use the Settings > Explore Linetypes 
command to change the current linetype through the IntelliCAD Explorer. For an 
existing entity, select the entity, right-click for the shortcut menu, and choose Proper-
ties. You can then modify the entity’s linetype in the Entity Properties dialog box.    
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Setting a layer’s lineweight 
Each layer uses a default lineweight. Lineweights determine the thickness of entities 
both on the screen and when printed.              

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or 
.01 inches. If you want a different lineweight assigned to a layer, you can easily 
change it using IntelliCAD Explorer. For example, you may want different line-
weights on each layer of your drawing to show separate elements, such as walls, 
dimensions, structural steel, and electrical plans. Changing the lineweight assigned to 
a layer changes the lineweight of all entities drawn on that layer with the BYLAYER 
lineweight.

When you create new entities, it’s a good idea to assign the BYLAYER lineweight to 
any entities that you draw on that layer, unless you want to override the layer line-
weight. IntelliCAD uses the BYLAYER lineweight as the default lineweight setting 
when you create entities (in the Drawing Settings dialog box). 

TIP  To change the DEFAULT lineweight, choose Settings > Drawing Settings, click 
the Display tab, select Lineweights in Change Settings For, and then select a new 
default.

To change the lineweight assigned to one or more layers

1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the lineweight for the layer you want to change.

3 In the Lineweight list, click the arrow to scroll the lineweights, and then select a 
new lineweight for the layer.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the lineweight assigned to a layer.

NOTE  You can also assign a specific lineweight to an entity, which overrides the 
layer’s lineweight setting. When you create a new entity, use the Settings > Drawing 
Settings > Entity Creation tab to change the current lineweight. For an existing 
entity, select the entity, right-click for the shortcut menu, and choose Properties. You 
can then modify the entity’s lineweight in the Entity Properties dialog box.      
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Setting a layer’s print style 

If your drawing uses named print style tables, you can specify a print style for each 
layer. Named print style tables contain print styles that you set up to control what enti-
ties look like when they print, without actually changing the entities in the drawing.

If your drawing uses color-dependent print style tables, you cannot specify a print 
style for a layer. These types of print style tables automatically determine printing 
requirements by the color assigned to a layer or an entity. For details about converting 
a drawing that uses color-dependent print style table to use named print style tables, 
see “Changing a drawing’s print style table type” on page 387. 

In drawings that use named print style tables, the default print style is Normal for all 
new layers. If desired, you can assign a print style using IntelliCAD Explorer. Chang-
ing the print style assigned to a layer changes the print style of all entities drawn on 
that layer with the BYLAYER print style.

When you create new entities, it’s a good idea to assign the BYLAYER print style to 
any entities that you draw on that layer, unless you want to override the layer print 
style. IntelliCAD uses the BYLAYER print style as the default print style setting 
when you create entities (in the Drawing Settings dialog box).

To change the print style assigned to one or more layers (only in a drawing that 
uses named print style tables)

1 Do one of the following:    

• Choose Settings > Explore Layers.

• On the Settings toolbar, click the Explore Layers tool ( ).

• Type explayers and then press Enter.

2 In the right pane, click the print style for the layer you want to change.

3 If necessary, select a different print style table in the Active Print Style Table list.

4 In Print Styles, select a print style.

5 Click OK. 

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the print style assigned to a layer.

NOTE  For drawings that use named print style tables, you can also assign a specific 
print style to an entity, which overrides the layer’s print style setting. When you cre-
ate a new entity, use the Settings > Drawing Settings > Entity Creation tab to change 
the current print style. For an existing entity, select the entity, right-click for the 
shortcut menu, and choose Properties. You can then modify the entity’s print style in 
the Entity Properties dialog box.    
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Working with linetypes 

IntelliCAD provides simple and complex linetypes:

• A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces.

• A complex linetype contains embedded shape and text entities along with
dots, dashes, and spaces.

You can use different linetypes to represent specific kinds of information. For exam-
ple, if you are drawing a site plan, you can draw roads using a continuous linetype, a 
fence using a using a linetype of dashes with square posts, or a gas line using a com-
plex linetype showing the text “GAS”.

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, 
and BYBLOCK. You cannot rename or delete these linetypes. Your drawing may 
also contain an unlimited number of additional linetypes. You can load more line-
types into the program from a linetype library file or create and save linetypes you 
define. 

To display the IntelliCAD Explorer Linetypes element

Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

• Choose Tools > IntelliCAD Explorer, and then click the Linetypes element.
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Setting the current linetype
You normally draw an entity using the linetype assigned to the current layer, indi-
cated as BYLAYER. You can also assign linetypes on a per-entity basis, which over-
rides the layer’s linetype setting. A third option is to assign the BYBLOCK linetype, 
whereby you draw new entities using the default linetype until you group them into a 
block. The entities inherit the current linetype setting when you insert the block into 
the drawing.    

To make the linetype current

1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 In the Linetype Name list, select the linetype you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• Select it in the Linetype Name list and click the Current tool ( ).

• Double-click the linetype name.

4 To complete the command and return to your drawing, close the window.

A Select Linetypes to display the Linetypes settings.

B Lists names of linetypes loaded in the current drawing. A check 
mark indicates the current linetype.

C Describes linetypes loaded in the current drawing.

D Shows how linetypes will appear in the drawing.

E Sorts the linetypes by that property when you click a column head.

A

B C D

E
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Loading additional linetypes 
Before you can select a new linetype to use in a drawing, you must either create the 
linetype definition or load a predefined linetype from a linetype library file (*.lin). 
IntelliCAD includes a linetype library file, icad.lin, which contains more than 100 
predefined linetypes.    

To load a new linetype from a linetype library

1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With the cursor in the right pane of the window, right-click to display the 
shortcut menu, and then choose New > Linetype.

3 Click Choose From File.

4 Click Browse. 

5 Select the linetype library file, and then click Open.

6 Select the linetype you want to load.

7 Click OK, and then close the window.
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Creating and naming linetypes 
In addition to loading predefined linetypes from a linetype library file, you can create 
new linetypes. You can save new linetypes you create to a linetype library file for use 
in other drawings.   

NOTE  Linetype names created or renamed in IntelliCAD can have up to 31 charac-
ters and cannot include spaces. IntelliCAD will, however, display longer linetype 
names and names containing spaces, such as linetypes created in AutoCAD 2000.

To create a new simple linetype   

1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose New > Linetype.

3 In the Linetype Description field, type the linetype description.

You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For example, it is helpful to type text or symbols such 
as __..__.. that approximate the appearance of the linetype.

4 In the Linetype Definition field, type the linetype definition.

The definition consists of positive and negative numbers separated by commas. A 
positive number draws a solid line segment for the specified number of drawing 
units; a negative number creates a gap for the specified number of units; a zero 
creates a dot.   

5 Click OK.

The program adds the new linetype to the linetypes list with the default name, 
NewLinetype1.

6 To enter a name for the new linetype, type over the highlighted default text, and 
press Enter.

Do not use spaces between words in the new linetype name.

7 To complete the command and return to your drawing, close the window.
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To create a new complex linetype

A complex linetype can denote utilities, boundaries, contours, and so on. As with 
simple linetypes, complex lines are dynamically drawn as the user specifies vertices. 
Shapes and text entities embedded in lines are always displayed completely; they are 
never trimmed.

1 Do one of the following: 

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the shortcut 
menu, and choose New > Linetype.

3 In the Linetype Description field, type the linetype description.

You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For complex linetypes, it is helpful to type a text 
description of the linetype.

4 In the Linetype Definition field, type the linetype definition.

As for the simple linetypes, the syntax for a complex linetype is a comma delimi-
nated list of pattern descriptors. For more details, see “Syntax for a complex line-
type definition” on page 195 in this chapter. 

A Click to select a predefined linetype from a 
linetype library file.

B Type any description in this box that helps you 
remember the purpose or appearance of the 
linetype.

C Type the definition of the linetype, consisting of 
positive and negative numbers separated by 
commas.

A

B

C
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5 Click OK.

The program adds the new linetype to the linetypes list with the default name, 
NewLinetype1.

6 To enter a name for the new linetype, type over the highlighted default text, and 
press Enter.

Do not use spaces between words in the new linetype name.

7 To complete the command and return to your drawing, close the window.

Syntax for a complex linetype definition
Complex linetypes can include shape and text entities as pattern descriptors, as well 
as the dash and dot descriptors of simple linetypes.

The shape descriptor syntax

You can add a shape entity to a complex linetype using the following syntax:

[shape_name, shape_filename] or [shape_name, shape_filename, transform]

The definitions of the fields in the syntax are as follows.

shape_name The name of the shape to add to the linetype. The shape name must exist 
in the specified shape file (shape_filename).

shape_filename The name of a compiled shape definition file (extension *.shx). If no 
path is defined for the shape file name, the library path is searched for the file.

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in 
degrees while the other options are in linetype scaled drawing units.

rotation R=value or A=value.

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the shape with respect to the origin. All shapes 
have the same rotation regardless of their relative position to the line. The value can 
be appended with a d for degrees (default), r for radians, or g for grads. If rotation is 
omitted, 0 relative rotation is used.
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scale S=value.

Determines a factor by which the shape's internal scale is multiplied. If the shape's 
internal scale is 0, the scale value is used as the scale.

X offset X=value.

Determines a shift of the shape along the X axis of the linetype computed from the 
end of the linetype definition vertex. If X offset is omitted or is 0, the shape is elabo-
rated with no offset. Include this field if you want a continuous line with shapes. This 
value is not scaled by the scale factor defined by S.

Y offset Y=value.

Determines a shift of the shape along the Y axis of the linetype computed from the 
end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elabo-
rated with no offset. This value is not scaled by the scale factor defined by S.

The text descriptor syntax

You can add a text entity to a complex linetype using the following syntax:

["string", style_name] or ["string", style_name, transform]

The definitions of the fields in the syntax are as follows.

string The text to be used in the complex linetype. You cannot use the ` or the " char-
acters in the text string. To use these characters, enter a control code (%%) with the 
ASCII value for the character instead.

style_name The name of the text style to be elaborated. The specified text style must 
be included. If it is omitted, use the currently defined style.

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in 
degrees while the other options are in linetype scaled drawing units.
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rotation R=value or A=value.

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the text with respect to the origin. All text has 
the same rotation regardless of its relative position to the line. The value can be 
appended with a d for degrees (default), r for radians, or g for grads. If rotation is 
omitted, 0 relative rotation is used.

Rotation is centered between the baseline and the nominal cap heights box.

scale S=value.

Determines a factor by which the style's height is multiplied. If the style's height is 0, 
the scale value is used as the scale.

Because the final height of the text is defined by both the scale value and the height 
assigned to the text style, you will achieve more predictable results by setting the text 
style height to 0. It is recommended that you create separate text styles for text in 
complex linetypes to avoid conflicts with other text in your drawing.

X offset X=value.

Determines a shift of the text along the X axis of the linetype computed from the end 
of the linetype definition vertex. If X offset is omitted or is 0, the text is elaborated by 
using the lower left corner of the text as the offset. Include this field if you want a 
continuous line with text. This value is not scaled by the scale factor that is defined by 
S.

Y offset Y=value.

Determines a shift of the text along the Y axis of the linetype computed from the end 
of the linetype definition vertex. If Y offset is omitted or is 0, the text is elaborated by 
using the lower left corner of the text as the offset. This value is not scaled by the 
scale factor that is defined by S.

Editing linetypes

To change a linetype name   

1 Do one of the following:    

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Do one of the following:

• Select the linetype, and then choose Edit > Rename. 

• Click the linetype name you want to change, and then type the new name.

• Right-click the linetype name you want to change, and from the shortcut menu, 
select Rename.

3 To complete the command and return to your drawing, close the window.
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To change a linetype definition

1 Do one of the following:

• Choose Settings > Explore Linetypes.

• On the Settings toolbar, click the Explore Linetypes tool ( ).

• Type expltypes and then press Enter.

2 Right-click on the linetype name for which you want to change the definition.

3 From the shortcut menu, select Properties.

4 In the Linetype Definition field, define the linetype using positive and negative 
numbers and zeros. 

A positive number draws a solid line segment for the specified number of drawing 
units. A negative number creates a gap for the specified number of drawing units. 
A zero creates a dot.

5 To complete the command and return to your drawing, close the Linetypes dialog 
box and the IntelliCAD Explorer window.

NOTE  You cannot rename the CONTINUOUS, BYBLOCK, or BYLAYER linetypes.

Working with text fonts and styles 

When you add text to a drawing, it is created using the current text style. The text 
style determines the font, size, angle, orientation, and other text characteristics.   

Every drawing has at least one text style, named Standard, which initially uses the txt 
font. You cannot delete the Standard style, but you can rename it or modify it. For 
example, you can change the font or the oblique angle applied to the font. You also 
can use an unlimited number of additional text styles in your drawing.    

From the IntelliCAD Explorer, you can directly edit any setting associated with a text 
style by using the single-click editing method to change the setting.   

To display the IntelliCAD Explorer Text Styles element

Do one of the following:    

• Choose Settings > Explore Text Styles.

• Choose Tools > IntelliCAD Explorer, and then click the Text Styles element.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expstyles and then press Enter.
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Creating and naming text styles 
Fonts are character sets that consist of letters, numbers, punctuation marks, and sym-
bols. Each font is stored in its own font file. Text styles apply additional formatting to 
fonts. You can create multiple text styles based on the same font, changing the vari-
ous characteristics to alter the appearance of the font. To create a new text style, you 
assign formatting characteristics to a font.    

IntelliCAD uses *.shx font files and provides a selection of fonts. These fonts are 
located in the IntelliCAD/Fonts directory. You can also use any font designed to 
work with AutoCAD. Many fonts are available from third-party vendors.    

NOTE  Text style names created or renamed in IntelliCAD can have up to 31 charac-
ters and cannot include spaces. IntelliCAD will, however, display longer text style 
names and names containing spaces, such as text styles created in AutoCAD.

A Select Text Styles to display the text style settings.

B Lists names of text styles defined in the current drawing. A check 
mark indicates the current style.    

C Displays the height assigned to the text style.

D Displays the width factor assigned to the text style.    

E Displays the oblique angle assigned to the text style.    

F Displays the font on which the style is based.

G Displays the font style, such as bold or italic.

H Displays the language on which the text style is based.

I Displays whether Asian language big font files are used (for .shx file 
fonts only).

J Indicates whether text will appear backward.    

K Indicates whether text will appear upside down.

L Indicates whether text will appear vertically.

M Click any column head to sort the styles by that property.

A

B C D E F H I J LG

M

K
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To create a new text style

1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Choose Edit > New > Text Style.

3 Select the font on which you want to base the new style, and then click Open.

The program adds a new style to the text styles list with the default name, 
NewStyle1.

4 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

5 To complete the command, close the window.

TIP You can also create a new text style by selecting the Text Styles element and click-
ing the New Item tool ( ).

To change a text style name in the current drawing

1 Do one of the following: 

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Do one of the following:

• Select the text style, choose Edit > Rename, type a new name, and then press 
Enter.

• Click the text style name you want to change, type a new name, and then press 
Enter. 

• Right-click the text style name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

Modifying text styles
A new text style is initially assigned default values for height, width factor, oblique 
angle, and other characteristics. You can change these values for both new and exist-
ing text styles. You can also change the font assigned to the text style. If you change 
the font or orientation properties of a text style assigned to text previously inserted in 
the drawing, all text using that style is regenerated to reflect the changes. Oblique 
angle and height, if specified, are given by the style definition when text is created, 
but are not updated for existing text when the style is changed.    
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A fixed text height value of 0 allows you to specify the text height at the time you 
insert text into the drawing. Any other value sets height of the text to that value; the 
program does not prompt for the text height when you insert text into the drawing. 
The width factor determines the horizontal scaling of text. A value less than 1 com-
presses the text (for example, 0.75 compresses the text 25 percent); a value greater 
than 1 expands the text (for example, 1.50 expands the text 50 percent). The oblique 
angle determines the forward or backward slant of text as an angle offset from 90 
degrees. Negative values slant text to the left; positive values slant text to the right.

To modify a text style   

1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Select the text characteristic of a style that you want to modify.
The text characteristic either toggles its value or a dialog box appears, allowing 
you to make the modifications you want.

3 To complete the command, close the IntelliCAD Explorer window.    

A Select to keep the dialog box on the screen 
when you switch back to the IntelliCAD Explorer 
or another element.

B Displays the name of the text style whose 
properties are being changed.

C Type the fixed text height. 

D Type the width factor.

E Type the oblique angle.

F Select to create text that displays backward.

G Select to create text that displays upside down.    

H Select to create text that displays vertically.    

I Displays a text preview of the text font.

J Select the Asian language big font (for .shx file 
fonts only).

K Select the text style language.

L Select the font style.

M Select the font name.   

A

B

C

D

E

F
G
H

I

J
K
L
M
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Setting the current text style
When you insert text in a drawing, the text is created using the current text style. You 
can also select a different text style when you create text.    

To make the text style current

1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 In the Text Style Name list, click the style you want to make current.

3 Use one of the following methods to make the style the current style:

• Choose Edit > Current.

• Click the Current tool ( ).

• With the cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose Current.

4 To complete the command and return to your drawing, close the IntelliCAD 
Explorer window.

TIP You can also make a text style current by selecting it in the Text Style Name list 
and clicking the Current tool ( ) or by double-clicking the text style name in the 
Text Style Name list.    

Working with coordinate systems 

When you create entities in a drawing, they are located in relation to the drawing’s 
underlying Cartesian coordinate system. Every drawing has a fixed coordinate system 
called the World Coordinate System (WCS). You cannot delete or modify the WCS.   

Your drawing may contain additional coordinate systems, however, each with its own 
0,0,0 origin and orientation. You can create as many user coordinate systems as you 
want, and then save and recall them as you need them. You can edit the origin of a 
coordinate system from within the IntelliCAD Explorer by single-clicking the origin 
coordinates and then typing new coordinates.

For example, you can create a separate user coordinate system (UCS) for each side of 
a building. Then, by switching to the UCS for the east side of the building, you can 
draw the windows on that side by specifying only their x- and y-coordinates.

You can create and then switch between various user coordinate systems by selecting 
Coordinate Systems in the IntelliCAD Explorer.
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To display the Coordinate Systems element

Do one of the following:    

• Choose Settings > Explore Coordinate Systems.

• Choose Tools > IntelliCAD Explorer, and then click the Coordinate Systems 
element.

• Choose Settings > User Coordinate Systems, and then click Explore UCSs.

• On the Settings toolbar, click the Explore Coordinate Systems tool ( ).

• Type expucs and then press Enter.  

A Select Coordinate Systems to display the Coordinate 
Systems settings.

B Lists names of coordinate systems defined in the current 
drawing. A check mark indicates the current coordinate 
system.

C Displays the origin of the coordinate system in relation to 
the WCS.

D Displays the x-axis direction of the coordinate system in 
relation to the WCS.

E Displays the y-axis direction of the coordinate system in 
relation to the WCS.

F Click any column head to sort the coordinate systems by 
that property.

A

B C D E

F
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Defining and naming user coordinate systems 
A drawing can contain as many coordinate systems as you want and can be named 
appropriate names so you can remember how they are used in your drawing for 
recalling them later.

NOTE  Coordinate system names created or renamed in IntelliCAD can have up to 31 
characters and cannot include spaces. IntelliCAD will, however, display longer coor-
dinate system names and names containing spaces, such as coordinate systems cre-
ated in AutoCAD 2000.

To define new user coordinate systems in the IntelliCAD Explorer

1 Do one of the following:   

• Choose Settings > Explore Coordinate Systems.

• On the Settings toolbar, click the Explore Coordinate Systems tool ( ).

• Type expucs and then press Enter.

2 Do one of the following:   

• Choose Edit > New > UCS.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose New > UCS.

3 Select a method from the prompt box or command bar by which to define the UCS 
in the drawing window. 

For example, select 3 Point and then specify three points in the drawing window 
to define the x, y, and z axes for your coordinate system.

4 Type the name for the new user coordinate system by typing over the highlighted 
default text, and then press Enter.

5 To complete the command, close the window.
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To change a user coordinate system name in the current drawing

1 Do one of the following:

• Choose Settings > Explore Coordinate Systems.

• On the Settings toolbar, click the Explore Coordinate Systems tool ( ).

• Type expucs and then press Enter.

2 Do one of the following:

• Select the user coordinate system, and then choose Edit > Rename, type a new 
name, and then press Enter.

• Click the user coordinate system name you want to change, type a new name, 
and then press Enter.

• Right-click the user coordinate system name you want to change, and from the 
shortcut menu, select Rename, type a new name, and then press Enter.

3 Type the new user coordinate system name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

Setting the current user coordinate system
When you draw new entities, they are created in relation to the current coordinate 
system. You can set the current UCS from the IntelliCAD Explorer.    

To set the current UCS from the IntelliCAD Explorer

Do one of the following:

• Double-click the UCS name in the UCS Name list.

• Select the UCS in the UCS Name list, and then choose Edit > Current.

• Select the UCS in the UCS Name list, and then click the Current tool ( ).     
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Using named views 

As you work on a drawing, you may find that you frequently switch among different 
portions of it. For example, if you are drawing the floor plan of a house, you may 
zoom in to particular rooms of the house and then zoom out to display the entire 
house. Although you can repeat the Pan and Zoom commands to do this, it is much 
easier to save various views of the drawing as named views. You can then quickly 
switch among these views. You can save and later restore named views using either 
the View command or the Views element in the IntelliCAD Explorer.    

To display Views in the IntelliCAD Explorer

Do one of the following:    

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

• Choose Tools > IntelliCAD Explorer, and then click the Views element.    

A To display the Views settings, select Views.

B Lists names of views defined in the current drawing.
A check mark indicates the current view.    

C Displays the height of the view in drawing units.   

D Displays the width of the view in drawing units.

E Displays the direction of the view, expressed as a three-
dimensional coordinate in the WCS.

F Click any column head to sort the views by that property.

A

B C D E

F
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Saving and naming views 
You can save the view displayed in the current window as a named view. After you 
save a named view, you can restore that view in the current window at any time.    

NOTE  View names created or renamed in IntelliCAD can have up to 31 characters 
and cannot include spaces. IntelliCAD will, however, display longer view names and 
names containing spaces, such as views created in AutoCAD 2000.

To save the current view as a named view

1 Do one of the following:     

• Choose View > Save/Restore View.

• On the View toolbar, click the Save/Restore View tool ( ).

• Type view and then press Enter.

2 In the prompt box, choose Save.

3 Type a name for the view, and then press Enter.

4 To complete the command and return to your drawing, close the window.

To save a portion of the current view as a named view

1 Do one of the following:     

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

2 Do one of the following:

• Choose Edit > New > View.

• On the IntelliCAD Explorer toolbar, click the New Item tool ( ).

3 In the prompt box, choose Window.

4 Specify the first corner of the view window.

5 Specify the opposite corner of the view window.

6 Rename the new view, and then press Enter.

Do not use spaces between words in the new view name.

7 To complete the command and return to your drawing, close the window.

TIP You can also create a new view by selecting the Views element in the IntelliCAD 
Explorer and clicking the New Item tool ( ).
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To change a saved view name in the current drawing

1 Do one of the following:

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

2 Do one of the following:

• Select the view, choose Edit > Rename, type a new name, and then press Enter.

• Click the view name you want to change, type a new name, and then press Enter.

• Right-click the view name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 Type the new view name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

Restoring named views   
After you save one or more named views, you can restore any of those views in the 
current window using either the View command or the IntelliCAD Explorer.    

To restore a named view using the View command

1 Do one of the following:

• Choose View > Save/Restore View.

• On the View toolbar, click the Save/Restore View tool ( ).

• Type view and then press Enter.

2 In the prompt box, choose Restore.

3 Type the name of the view you want to restore, and then press Enter.

To restore a named view from the IntelliCAD Explorer

Do one of the following:

• Select the view name in the list of View settings, and then choose Edit > Current.

• Select the view name in the list of View settings, and then click the Current tool 
( ).

• Double-click the view name in the View list.

Changing named view properties   
Once you create a named view you can modify its properties, such as the target direc-
tion and twist angle. This gives you access to many of the view settings after a view 
has been defined.   
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To change the view options

1 Do one of the following:

• Choose Settings > Explore Views.

• On the Settings toolbar, click the Explore Views tool ( ).

• Type expviews and then press Enter.

2 Select the view whose properties you want to change.

3 Choose Edit > Properties.

You can also right-click the view you want to change, and from the shortcut menu, 
select Properties. 

4 Change the values of the settings on any of the tabs and close the dialog box.

5 To complete the command and return to your drawing, close the window.

Working with blocks and external references 

Blocks represent a special type of entity that, once saved, can be inserted and manip-
ulated in the drawing as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles as well as visible or invisible data called attributes. You can 
use attributes to track things such as part numbers and prices and to export attribute 
information to an external database. You can also track the number of parts by count-
ing the number of times a block has been inserted into the drawing. Blocks are stored 
as part of the drawing file.    

External references have similar uses to blocks. Using external references, you can 
attach entire drawings to your current drawing. Unlike a block, however, an external 
reference does not become part of the current drawing.    

You can save blocks in the IntelliCAD Explorer. You can also use the IntelliCAD 
Explorer to manage and insert copies of blocks. The IntelliCAD Explorer lists the 
names of all blocks contained in the current drawing, along with other information 
about each block or external reference.    

You can also rename a block, modify its insertion point, and change the path of an 
externally referenced drawing by single-clicking on the property and making your 
edits within the IntelliCAD Explorer.
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To display blocks in the IntelliCAD Explorer

Do one of the following:    

• Choose Settings > Explore Blocks.

• Choose Tools > IntelliCAD Explorer, and then click the Blocks element.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

The Blocks element in the IntelliCAD Explorer defaults with images on. The Images 
view shows you a small image of each block or external reference.     

When blocks are displayed, additional tools on the Block toolbar provide the func-
tions described in the following table: 
    

 The Images view shows an image of each block in the selected drawing. Click an image to select it.

Additional tools on the Block toolbar   

Tool Function

( ) Images Displays a small image of each block.

( ) Details Displays information about each block.

( ) Insert Inserts a block.
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To see more information about each block, click the Details tool ( ). In the Details 
view, you can edit the path and the insertion point by clicking the setting and typing 
your changes.      

( ) Insert External File Blocks Inserts a drawing available from disk as a block.

( ) Save Block Saves selected block as independent.dwg file.

( ) Attach Drawing Attaches drawing as an external reference.

Additional tools on the Block toolbar   

Tool Function

A To display the Blocks settings, select Blocks.

B Lists names of blocks and external references defined in the 
current drawing.    

C Displays the number of occurrences of the block in the 
current drawing.      

D Displays the insertion point of the block in the current 
drawing.

E Displays the name and path for externally referenced 
drawings.

F Click any column head to sort the blocks by that property.

A

B C D E

F
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Creating and naming blocks
You can combine any number of entities into a single block. After you create a block, 
you can insert copies of it into a drawing. Each block insertion is treated as a single 
entity; for example, you can rotate or scale each block when you insert it. The program 
adds the name of the new block you insert to the Block Name list in the IntelliCAD 
Explorer.    

NOTE  Block names created or renamed in IntelliCAD can have up to 31 characters 
and cannot include spaces. IntelliCAD will, however, display longer block names and 
names containing spaces, such as blocks created in AutoCAD 2000.

To create a block

1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 Do one of the following:

• Choose Edit > New > Block.

• On the IntelliCAD Explorer toolbar, click the New Item tool ( ).

3 Enter a name for the new block.    

4 Specify the insertion point for the block.

5 Select the entities to be combined into the block, and then press Enter.

The program adds a new block to the blocks list, with the name you entered for it.

6 To complete the command and return to your drawing, close the window.

To change a block name in the current drawing

1 Do one of the following:

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 Do one of the following:

• Select the block, choose Edit > Rename, type a new name, and then press Enter.

• Click the block name you want to change, type a new name, and then press 
Enter.

• Right-click the block name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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Inserting a block
You can insert into a drawing any block listed in the Block Name list in the Intelli-
CAD Explorer. This includes blocks contained within any open drawing. 

To insert a block

1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 If you want to insert a block from another open drawing, select the drawing in the 
Elements pane. (If the block is contained within the same drawing, you can skip 
this step.)

3 In either the Details or Images view, select the block to be inserted.

4 On the IntelliCAD Explorer toolbar, click the Insert tool ( ).

5 In the drawing, specify the insertion point.    

6 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.   

7 To complete the command and return to your drawing, close the window.

TIP  You can also insert a block by choosing Tools > IntelliCAD Explorer, and then 
double-clicking the name of the block you want to insert in the Block Name list.

TIP  You can also insert a block from the Insert menu. see Chapter 13, “Working with 
blocks, attributes, and external references.” 

Inserting a drawing as a block      
You can insert as a block another drawing into the current drawing. After you do this, 
the block name is added to the Block Name list in the IntelliCAD Explorer. Changes 
made later to the inserted drawing will not be reflected in this drawing.    
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To insert a drawing as a block

1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 On the IntelliCAD Explorer toolbar, click the Insert External File Blocks tool 
( ).    

3 In the Insert Block dialog box, select the drawing you want to insert, and then 
click Open.   

4 In the drawing, specify the insertion point.

5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.

6 To complete the command and return to your drawing, close the window.

Attaching a drawing as an external reference
You can attach another drawing to the current drawing as an external reference and 
insert a copy of the drawing into the current drawing. The name of the external refer-
ence drawing is added to the Block Name list. Changes made later to the referenced 
drawing will appear in this drawing when you reload the external reference.    

To attach an external reference

1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 On the IntelliCAD Explorer toolbar, click the Attach Drawing tool ( ).    

3 In the Select File To Attach dialog box, select the drawing you want to attach, and 
then click Open.

4 In the drawing, specify the insertion point.     

5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.    

6 To complete the command and return to your drawing, close the window.
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To edit the path of an external reference

1 Do one of the following:    

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 Click the path you want to change.

3 From the Insert Block dialog box, select the new drawing you want as the external 
reference.

4 Click Open.

5 To complete the command and return to your drawing, close the window.

Saving a block as a separate drawing

You can save a block as a separate drawing, and then you can open and modify that 
drawing as you would any other drawing.     

To save a block as a separate drawing file

1 Do one of the following:     

• Choose Settings > Explore Blocks.

• On the Settings toolbar, click the Explore Blocks tool ( ).

• Type expblocks and then press Enter.

2 In either the Details or Images view, select the block you want to save.

3 On the IntelliCAD Explorer toolbar, click the Save Block To Disk tool ( ).

4 In the Save Block dialog box, select the folder in which you want to save the 
block.

5 In the File Name field, type a name for the new drawing file (or accept the default, 
in which case the new drawing name is the same as the name of the block), and 
then click Save.    

NOTE You can also work with external references using the Xref Manager. For 
details, see “Working with external references” on page 348. 
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Working with dimension styles    

From the IntelliCAD Explorer, you can use the Dimension Styles element to cut, 
copy, and paste dimension styles from one drawing to another.     

TIP You can select the dimension style and use the Windows shortcut keys (Ctrl+A to 
select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to accomplish the same 
results. You can use these shortcut keys with all other IntelliCAD Explorer elements 
as well.

A dimension style contains the settings that control the appearance of a dimension. 
Although you cannot control these settings from within the IntelliCAD Explorer, you 
can use the Dimension Settings dialog box to control settings related to the appear-
ance of arrows, lines, text, units, and other formatting characteristics. 

To display the IntelliCAD Explorer Dimension Styles element

Do one of the following:    

• Choose Settings > Explore Dimension Styles.

• Choose Tools > IntelliCAD Explorer, and then click the Dimension Styles ele-
ment.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter. 

A To display the Dimension Styles settings, select Dimension 
Styles.

B Lists the names of dimension styles defined in the current 
drawing.

C Click the Dimension Style Name column head to sort by 
name.

A

B

C 



W O R K I N G  W I T H  T H E  I N T E L L I C A D  E X P L O R E R 217
Creating and naming dimension styles 
By using the Dimension Styles element in combination with the Dimension Settings 
dialog box, you can create new dimension styles, modify them, and copy them into a 
different drawing. 

NOTE  Dimension style names created or renamed in IntelliCAD can have up to 31 
characters and cannot include spaces. IntelliCAD will, however, display longer 
dimension style names and names containing spaces, such as dimension styles cre-
ated in AutoCAD 2000.

To create a dimension style

1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click New.

3 Type the name of the new dimension style.

4 Click Create.

5 In the Dimension Settings dialog box, click one of the other tabs, and then change 
the dimension settings as necessary.

Repeat this step for each tab, as needed.

6 To end the command, click OK.

To change a dimension style name in the current drawing

1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Do one of the following:

• Select the dimension style, choose Edit > Rename, type a new name, and then 
press Enter.

• Click the dimension style name you want to change, type a new name, and then 
press Enter.

• Right-click the dimension style name you want to change, and from the shortcut 
menu, select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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To copy a dimension style from one drawing to another

1 Do one of the following:

• Choose Settings > Explore Dimension Styles.

• On the Settings toolbar, click the Explore Dimension Settings tool ( ).

• Type expdimstyles and then press Enter. 

2 Right-click the dimension style name you want to copy.

3 From the shortcut menu, select Copy.

4 In the left pane, select the drawing to which you want to copy the dimension style.

5 Click the Dimension Styles element for that drawing.

6 In the right pane, right-click, and then from the shortcut menu, select Paste.

NOTE  Each drawing contains a dimension style named Standard. You cannot delete 
this dimension style, but you can rename it from within the IntelliCAD Explorer or 
modify its properties in the Dimension Settings dialog box.    
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Getting drawing information

IntelliCAD stores accurate, detailed information about all the entities in a drawing. 
You can get details about an existing drawing and its entities using the tools for mea-
suring distances and calculating areas. You can also track the amount of time you 
spend editing a drawing. This section explains how to:

• Measure distances along an entity.

• Measure distances and angles.

• Divide an entity into a number of equal segments.

• Calculate areas.

• Display information about entities in a drawing.

• Track the amount of time spent editing a drawing.

Many of the functions described in this section require that you set IntelliCAD to the 
Advanced experience level.

Topics in this chapter

Specifying measurements and divisions........................................................... 220

Calculating areas.............................................................................................. 223

Calculating distances and angles ..................................................................... 227

Displaying information about your drawing .................................................228
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Specifying measurements and divisions      

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal 
segments or mark off intervals of a specific length along an entity. (Note that divide is 
not the same as break.) For example, you may want to place station-point markers 
every 50 feet along the centerline of a roadway or divide the plan view of a window 
into three equal-width sections of glass, placing a mullion at each division point.    

To specify measurements and divisions, use these commands:

• For the length of the segments, use the Measure command.

• For the number of equal-length segments, use the Divide command.

You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With 
either command, you can identify the segments by placing either a block or point 
entity at the end of each interval. If you use points, you can snap to the ends of inter-
vals using the point entity snap. The appearance of the point entities is determined by 
the current point display type, which you control in the Drawing Settings dialog box.    

To use a block as the marker, the block must already be defined in the current draw-
ing. You can further indicate whether to rotate the block to align perpendicularly to 
the entity you are measuring or dividing.   

IntelliCAD begins measuring or dividing based on the point at which you select the 
entity and the type of entity with which you are working. For most entities, measuring 
starts from the endpoint closest to the point you used to select the entity. If you select 
the entity to be measured or divided using a method other than pointing (for example, 
using a window or fence selection), the program prompts you to specify the end from 
which you want to begin measuring.

Block not aligned with entity. Block aligned with entity.
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Measuring intervals on entities
You can mark specified length increments along a selected entity using either a point 
entity or a block.    

To measure intervals along an entity and mark them using point entities

Advanced experience level

1 Do one of the following:

• Choose Modify > Measure.

• On the Modify toolbar, click the Measure tool ( ).

• Type measure and then press Enter.

2 Select the entity.

3 Specify the segment length, and then press Enter.    

To measure intervals along an entity and mark them using blocks 

Advanced experience level

1 Do one of the following:    

• Choose Modify > Measure.

• On the Modify toolbar, click the Measure tool ( ).

• Type measure and then press Enter.

2 Select the entity.

3 In the prompt box, choose Insert Blocks.

4 Type the name of the block you want to insert as the marker.

5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 
block so that its vertical alignment is always perpendicular to the entity or No-Do 
Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the segment length, and then press Enter.

When you select the entity by pointing, intervals are measured from the end 
closest to the point at which you select the entity (A). Blocks or point entities (B) 
are placed along the entity at the specified interval.

A B
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Dividing entities into segments
You can place markers along a selected entity, dividing that entity into a specified 
number of equal-length segments. You can use either a point entity or a block to mark 
the segments.    

To divide an entity into segments and mark them using point entities

Advanced experience level

1 Do one of the following:    

• Choose Modify > Divide.

• On the Modify toolbar, click the Divide tool ( ).

• Type divide and then press Enter.

2 Select the entity.

3 Specify the number of segments, and then press Enter.    

To divide an entity into segments and mark them using blocks    

Advanced experience level

1 Do one of the following:

• Choose Modify > Divide.

• On the Modify toolbar, click the Divide tool ( ).

• Type divide and then press Enter.

2 Select the entity.

3 In the prompt box, choose Insert Blocks.

4 Type the name of the block you want to insert as the marker.

5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 
block so that its vertical alignment is always perpendicular to the entity or 
No-Do Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the number of segments, and then press Enter.

When you select the entity by pointing, divisions are marked beginning from the end closest to the 
point at which you select the entity (A). Blocks or point entities (B) are placed along the entity to 
mark it in equal intervals.

A

B
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Calculating areas       

You can calculate the area and perimeter of a polygon based on a series of points you 
specify or enclose with a circle or closed polyline. You can also determine the area of 
several combined entities and add or subtract the area of one or more entities from a 
total combined area.   

Calculating areas defined by points
You can find the area and perimeter of any closed region by specifying a series of 
points. The program calculates the area and perimeter of the space that is enclosed by 
an imaginary polygon consisting of straight-line segments connecting each point.

To calculate the area defined by points you specify

1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 Specify the first point.

3 Specify the second point.

4 Continue specifying points in sequence to define the perimeter of the area you 
want to measure.

As you select each successive point, the resulting polygon is displayed on the 
screen.

5 To complete the calculation, press Enter.

The area and perimeter of the region you defined are displayed. For example, the 
following type of information is displayed:

Area = 11.0583, Perimeter = 15.3092    

Select the points (A, B, C) that form a polygon. The area and 
perimeter of the region are then calculated.

A

C

B
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Calculating areas of closed entities
You can find the area of any closed entity. In addition, the program calculates either the 
circumference or the perimeter of the entity, depending on the type of entity you select.

To calculate the area of a closed entity

1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Find Area Of One Entity.

3 Select the entity.

The following type of information is displayed:

Area = 62.3837, Circumference = 27.9989

Calculating combined areas  
You can find the total area of several combined regions by specifying points or by 
selecting entities. You can also subtract the areas of entities or polygons from a 
running total.    

To add areas to calculate a combined area    

1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Add Areas Together.

3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Add Entities To Area, select the entities you want to 
add, and then press Enter to complete the calculations.

4 To complete the command, choose Done in the prompt box.
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To subtract areas when calculating a combined area    

1 Do one of the following:    

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Add Areas Together.

3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Add Entities To Area, select the entities you want to 
add, and then press Enter to complete the calculations.

4 In the prompt box, choose Subtract Areas.

5 Using one of the following methods, identify the area to be subtracted:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Subtract Entities From Area, select the entities you 
want to subtract, and then press Enter to complete the calculations.

6 To complete the command, choose Done in the prompt box.

To calculate the area of the gasket using the Area command, first add 
the area of the entire gasket (A), and then subtract the areas of the two 
circles (B and C).

A
B

C
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As you select entities, the program displays the calculations. If the command bar is 
displayed, the information appears there. If the command bar is not displayed, the 
program opens the Prompt History window and displays the calculations. The follow-
ing type of information is an example of what is displayed:

Entity • Add • Subtract • <First point>: Choose Add Areas Together

Adding: Entity • Subtract • <First point>: Choose Add Entities to Area

Adding area: <Select entities>: Select the first entity

Area = 64.6259, Perimeter = 33.3049

Total length = 33.3049

Total area = 64.6259

Adding area: <Select entities>: press Enter

Adding: Entity • Subtract • <First point>: Choose Subtract Areas

Subtracting: Entity • Add • <First point>: Choose Subtract Entities from 

Area

Subtracting area: <Select entities>: Select the first entity to subtract

Area = 3.1597, Circumference = 6.3012

Total length = 27.0036

Total area = 61.4662

Subtracting area: <Select entities>: Select the second entity to subtract

Area = 3.1597, Circumference = 6.3012

Total length = 20.7024

Total area = 58.3066

Subtracting area: <Select entities>: Press Enter

Subtracting: Entity • Add • <First point>: Choose Done
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Calculating distances and angles            

You can calculate the distance between any two points you select. The following 
information is displayed:          

• The distance between the points, measured in drawing units.

• Their angle in the xy plane.

• Their angle measured from the xy plane.

• The change (delta) in the x, y, and z distances between the two points.       

To calculate the distance between two points and their angle

1 Do one of the following:    

• Choose Tools > Inquiry > Distance.

• On the Inquiry toolbar, click the Distance tool ( ).

• Type distance and then press Enter.

2 Specify the first point.

3 Specify the second point.

The following type of information is displayed:

Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º

Delta X = 11.3878, Delta Y = 6.8418, Delta Z = 0.0000  

TIP  To use specific points on selected entities, use entity snaps to select the precise 
points on the entities.     

Use the Distance command to calculate the distance (A) between two points (B 
and C), the angle in the xy plane (D), the angle from the xy plane, and the delta 
x (E), delta y (F), and delta z distances between the two points.

A

B D

E

F

C
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Displaying information about your drawing      

You can display a variety of information about a drawing and the entities it contains, 
including:    

• Information in the drawing database about selected entities.

• The current drawing status.

• The time spent working on the drawing.

This information is displayed in the Prompt History window and in the command bar.    

Displaying information about entities
You can display information about the selected entities. The information varies, 
depending on the type of entities you select. All of the listings display the following 
information:    

• Entity type.     

• Layer.

• Color.

• Linetype.   

• The location of the entity (its xyz-coordinates relative to the current user 
coordinate system [UCS]).     

• The current space (model space on the Model tab or paper space on a Layout tab).     

• The size of the entity (the information varies, depending on the entity type).    

To display information about an entity

Advanced experience level     

1 Do one of the following:

• Choose Tools > Inquiry > List Entity Info.

• On the Inquiry toolbar, click the List Entity Info tool ( ).

• Type list and then press Enter.

2 Select one or more entities.

3 Press Enter.

TIP  To return to the drawing window, press F2.
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The following type of information is displayed:

------ Circle ---------------------------------------------------

Handle: 2C

Current space: Model

Layer: 0

Color: BYLAYER

Linetype: CONTINUOUS

Handle: 4C

Current space: Model

Center point: X= -5.8583 Y= 7.2752 Z= 0.0000

Radius: 4.4562

Circumference: 27.9989

Area: 62.3837

Displaying the drawing status
You can display information about the current status of a drawing, including:    

• Drawing name.

• Limits.     

• Insertion base point.     

• Snap and grid settings.

• Current layer, color, and linetype.     

• Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).    

To display the drawing status

Advanced experience level

Do one of the following:    

• Choose Tools > Inquiry > Drawing Status.

• Type status and then press Enter.
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The following type of information is displayed:    
Current drawing name: Site Plan

Drawing limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Paper space limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Screen width (pixels): 971

Screen height (pixels): 569

Insertion base is: X=0.0000 Y=0.0000 Z=0.0000

Snap resolution is: X=0.5000 Y=0.5000 Z=0.0000

Grid spacing is: X:0.5000 Y:0.5000 Z=0.0000

Current layer: 0

Current color: BYLAYER

Current linetype: BYLAYER

Current elevation: 0.0000

Current thickness: 0.0000

Fill: on

Grid: off

Ortho: off

Snap: off

Blips: off

Drag: on

Command echo: on

Positive angle direction: Counterclockwise

Angular units: Decimal degrees

Dimension units: Decimal

Pick box height: 3

Entities in drawing: 288

Tracking time spent working on a drawing
You can display information about the amount of time you have spent working on a 
drawing, including:    

• The date and time the drawing was created.

• The date and time the drawing was most recently saved.    

• The total amount of time spent working on the drawing.

• The time spent working on the drawing during the current editing session.    

You can turn the elapsed-time timer on and off or reset it to zero.   
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To display the timer information

Advanced experience level    

1 Do one of the following:

• Choose Tools > Inquiry > Time Variables.

• On the Inquiry toolbar, click the Time Variables tool ( ).

• Type time and then press Enter.

2 Select any of the prompt box options:

• Choose Timer On to turn the elapsed timer on.

• Choose Timer Off to turn the elapsed timer off.

• Choose Display Timer to redisplay the timer information.

• Choose Reset Timer to reset the elapsed timer to zero.

3 In the prompt box, choose Cancel to exit the command.

Each time you display the timer information, the following type of information is 
displayed:

The current time is Fri Dec 19 09:58:43 1997

Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090

Drawing was last updated on: Thur 18 Dec 1997 at 09:58:43.3040

Total editing time: 1  2: 35:4.2345

Elapsed timer (on): 0  1: 21:5.6324    
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Modifying entities

IntelliCAD provides many editing tools for modifying a drawing. You can easily 
move, rotate, or stretch drawing entities, or change their scale. When you want to 
remove an entity, you can delete it with a few clicks of the mouse. You can also make 
multiple copies of any entity and copy entities from one drawing to another. 

You can modify most entities using general-purpose editing commands, many of 
which are located on the Modify toolbar and the Modify menu. Some complex enti-
ties require special commands. This section explains how to:

• Select entities using entity-selection methods and grips.

• Change the properties of entities.

• Rearrange entities by moving, rotating, or changing the display order.

• Resize entities by stretching, scaling, extending, trimming, or editing their lengths.

• Break and join entities.

• Group entities.

• Edit polylines.

• Explode entities.

• Create chamfers and fillets.

Topics in this chapter

Selecting entities............................................................................................... 234

Modifying the properties of entities................................................................... 240

Deleting entities ................................................................................................ 242

Copying entities ................................................................................................ 242

Rearranging entities.......................................................................................... 248

Resizing entities................................................................................................ 251

Breaking and joining entities............................................................................. 259

Grouping entities............................................................................................... 261

Editing polylines................................................................................................ 264

Exploding entities.............................................................................................. 270

Chamfering and filleting entities........................................................................ 271
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Selecting entities       

You can create a selection set that consists of one or more entities before you modify 
them. Use any of the following methods to create a selection set:    

• Choose a command or tool first, and then select entities.

• Select entities first, and then choose a command or tool (most entities).

• Select entities by pointing, and then use grips to modify them.

Displaying selected entities highlighted
You can specify whether to display selected entities highlighted, which makes the 
selection set easier to see. By default, the highlighting feature is turned on.    

To turn the highlighting feature on or off

1 Do one of the following:     

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the Display tab.

3 In the Change Settings For box, select Display.

4 Select or clear the Highlight Item When Selected check box.

5 Click OK. 

Entity-selection methods    
When you choose a command that requires you to select entities (when you’re delet-
ing or changing entity properties, for example), you can use any of the following 
selection methods by choosing them in the prompt box or entering them in the com-
mand bar:    

• Select all entities (ALL) Selects all entities in the current drawing.    

• Add to set (+ or A) Adds one or more entities to the selection set.   

• Subtract from set (- or R) Removes one or more entities from the selection set.  

• Previous selection (P) Selects entities included in the previous selection set.    

• Last entity in drawing (L) Selects the entity most recently added to the drawing.    

• Window-Inside (W) Selects entities contained entirely within a rectangular selec-
tion window.    

• Crossing window (C) Selects entities contained within or crossing the boundary of 
a rectangular selection window.    

• Outside window (O) Selects entities falling completely outside a rectangular selec-
tion window.    
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• Window polygon (WP) Selects entities contained entirely within a polygon selec-
tion window.    

• Crossing polygon (CP) Selects entities contained within or crossing the boundary 
of a polygon selection window.    

• Outside polygon (OP) Selects entities falling completely outside a polygon selec-
tion window.    

• Window circle (WC) Selects entities contained entirely within a circular selection 
window.    

• Crossing circle (CC) Selects entities contained within or crossing the boundary of 
a circular selection window.    

• Outside circle (OC) Selects entities falling completely outside a circular selection 
window.    

• Point (PO) Selects any closed entities that surround the selected point.    

• Fence (F) Selects entities crossing a line or line segments.    

• Select by Properties (PRO) Selects entities that match a particular set of proper-
ties—for example, all entities on a particular layer or drawn in a certain color.    

You can also use a few selection methods automatically, without displaying the 
prompt box. For example, you can simply click to select entities, or you can use a 
Window-Inside or Crossing Window by defining the opposite corners of a rectangu-
lar selection window. The direction in which you define the points of the rectangle 
(left-to-right or right-to-left) determines which type of window you create.

To create a Window-Inside

1 Click to select a point in the drawing.    

2 Click to the right of the first point to select a second point in the drawing. 

This method is most commonly referred to as simply a window or selection window.

Window-Inside by selecting the first (A) and second (B) 
points.

Resulting selection.

A

B
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To create a Crossing Window

1 Click to select a point in the drawing.    

2 Click to the left of the first point to select a second point in the drawing.    

In addition to a rectangular window, you can define a selection window using other 
shapes such as a polygon, circle, or fence (a multisegmented line that selects entities 
it crosses).

To select entities using Window Polygon 

1 Activate an entity-modification command.    

2 In the prompt box, choose Window Polygon.

3 Specify the vertices of the polygon.

4 To complete the selection polygon, press Enter. 

Crossing Window by selecting the first (A) and second 
(B) points.

Resulting selection.

A

B

Window Polygon by specifying the vertices of the 
polygon (A, B, and C).

Resulting selection.

A

C

B
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To select entities using Fence 

1 Activate an entity-modification command.

2 In the prompt box, choose Fence.

3 Specify the endpoints of the Fence segments.

4 To complete the Fence, press Enter.    

To select entities using their properties

1 Activate an entity-modification command.

2 In the prompt box, choose Select by Properties.

3 Choose an option for selection: Color, Layer, Linetype, Name, Thickness, Type, 
Value (of attributes, text, or multi-line text), Width (of polylines), or Location.

4 Make your selections, depending on the option you chose.

5 To complete the selection, press Enter.  

Choosing the command first    
When you choose an entity-modification tool or command, the program prompts you 
to select entities and displays a prompt box from which you can choose a selection 
method. You can select individual entities or use other techniques such as selection 
windows to select multiple entities.

When you select entities, you add them to the selection set. After you select at least 
one entity, you can remove entities from the selection set. To finish adding entities to 
the selection set, press Enter. Most entity-modification commands then act on the 
entire selection set.    

Fence by specifying the endpoints of the fence segments 
(A, B, and C).

Resulting selection.

A

B

C
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Selecting entities first    
You can select entities first and then choose how to modify them. As you select each 
entity, it is highlighted with small squares called grips, which appear at strategic 
points on the entity.    

The locations of the grips depend on the type of entity selected. For example, grips 
appear at the endpoints and midpoint of a line, at the quadrant points and center point 
of a circle, and at the endpoints, midpoint, and center of an arc.   

After you select one or more entities, you can choose an entity-modification com-
mand, such as Copy or Move, from the Modify menu or toolbar. You can also click 
the right mouse button to display a shortcut menu containing the entity-modification 
commands appropriate for the selected entities, and then choose the command from 
the menu.

When you select entities and then issue a command, the program immediately acts on 
the entities you’ve selected. In many cases, a command-specific prompt box provides 
additional options for that editing operation. If you want to modify the selection set at 
that point, right-click to display the prompt box with the selection options and choose 
the option you want. To redisplay the command-specific prompt box, right-click 
again.

Deselecting entities
If an entity is no longer needed in a selection set, you can deselect it to remove it from 
the selection set.

To remove an entity from the selection set

1 Press Shift, and then select the entity again.

NOTE Pressing Shift while selecting entities using a crossing window removes all 
entities from the specified selection set.

To remove all entities from the selection set

1 Press Escape.

Examples of grip locations.
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Turning grips on and off
You can turn the use of grips on and off and control the size and color of grips.

To change grip settings

1 Do one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type ddgrips and then press Enter.

2 In the Drawing Settings dialog box, click the Display tab.

3 In the Change Settings For list, click Grips.

4 Change the desired settings, and then click OK.    

Editing with grips
To use grips for editing, you select an entity to display the grips, and then click a grip 
to make it active. The grip you select depends on the type of entity you’re modifying 
and the editing operation you’re performing. For example, to move a line entity, drag 
it by its midpoint grip. To stretch the line, drag one of the endpoint grips. You do not 
need to enter a command when using grips.    

A Click to activate grips for all selected entities.

B Click to assign the color for grips.

C Specify the grip size.

D Displays the current grip size.

A
D

C

B
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Modifying the properties of entities    

You can change the layer, thickness, linetype, color, and linetype scale of one or 
more entities. Depending on the type of entity or entities you select, you can also 
change other properties, such as the start point and endpoint of lines, the center point 
and radius of circles, and the vertices of polylines.    

You can modify all the properties of all entities simultaneously. For example, using 
the entprop command, select all entities on a particular layer, and then move the enti-
ties to another layer by simply selecting a name from the Layer text box. Addition-
ally, using the select command and the Select by Properties option, select all blue 
entities and change their color to green.

In the Entity Properties dialog box, changes that you make in the Layer, Color, Thick-
ness, Lineweight, Linetype, Linetype Scale, and Print Style (if using named print 
style tables) fields affect all selected entities. If you select several entities that all have 
different properties, the default value initially is Varies. Changes that you make in the 
entity tabs, such as Circle, Line, and Arc, affect all selected entities of that type. You 
can select the entities to be changed using any entity-selection method.    

To modify properties of entities 

1 Do one of the following:

• Choose Modify > Properties.    

• On the Modify toolbar, click the Properties tool ( ).

• Type entprop and then press Enter.

2 Select the entities, and then press Enter.

3 Make changes to the desired properties, and then click OK.

TIP Use the Entity Properties toolbar to change the properties of selected entities. 
Note that the Entity Properties toolbar settings that display when no entities are 
selected determine the properties of new entities when you draw them. 
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The Entity Properties dialog box, shown in the following illustration, has two sec-
tions. The All Selected Entities section (the upper part of the dialog box) displays 
properties common to all selected entities, such as Layer, Color, Lineweight, Line-
type, Linetype Scale, Thickness, and Print Style (if using named print style tables). 
This portion of the dialog box is equivalent to the dialog box displayed by the 
AutoCAD ddchprop command. 

The lower section of the Entity Properties dialog box contains options specific to the 
selected entities. Each tab displays the properties appropriate for the entity. This fea-
ture is equivalent to repeatedly applying the AutoCAD ddmodify command to one 
entity at a time  

The IntelliCAD Entity Properties dialog box.
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Deleting entities

You can remove entities from a drawing. You can delete entities using any of the 
entity-selection methods.    

To delete a selection set    

1 Do one of the following:

• Choose Edit > Delete.

• On the Standard toolbar, click the Delete tool ( ).

• Type delete and then press Enter.

2 Select the entities, and then press Enter.

TIP  Typing the Undelete command restores the most recently deleted selection set. If 
you have made additional modifications since deleting the entities, use Undelete 
rather than Undo to restore those entities without reversing those modifications.    

Copying entities    

You can copy one or more entities, making one copy or multiple copies within the 
current drawing. You can also copy entities between drawings.    

Use any of the following methods to copy entities within the current drawing:

• Create a copy at a location referenced from the original.

• Create a copy aligned parallel to the original.

• Create a copy as a mirror image of the original.

• Create several copies in a rectangular or circular pattern.

Copying entities within a drawing
You can duplicate entities within the current drawing. The default method is to create 
a selection set and then specify a starting point, or base point, and an endpoint, or dis-
placement point, for the copy. You can also make multiple copies or copy the selec-
tion set to a location you specify, using a direction vector.     
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To copy a selection set    

1 Do one of the following:

• Choose Modify > Copy.

• On the Modify toolbar, click the Copy tool ( ).

• Type copy and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the insertion point. 

5 Continue specifying insertion points to place additional copies.

6 To complete the command, press Enter.       

NOTE The COPYMODE system variable controls whether you are prompted for mul-
tiple copies.

To make a single copy of an entity, select the 
entity to copy (A), base point (B), and then 
displacement point (C).

Result.

To make multiple copies of an entity, select the 
entity to copy (A), specify the base point (B), and 
then specify the displacement points (C, D, and 
E).

Result.

A B

C

A

B
C

D
E
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Copying between drawings
You can use the Clipboard to cut or copy entities from one drawing to another. 
Cutting removes the selected entities from a drawing and stores them on the 
Clipboard. Copying duplicates the selected entities from a drawing and places them 
on the Clipboard.     

To cut entities to the Clipboard

1 Select the entities you want to cut.

2 Do one of the following:   

• Choose Edit > Cut.

• On the Standard toolbar, click the Cut tool ( ).

• Type cutclip and then press Enter.

To copy entities to the Clipboard

1 Select the entities you want to copy.

2 Do one of the following:

• Choose Edit > Copy.

• On the Standard toolbar, click the Copy tool ( ).

• Type copyclip and then press Enter.

Anything that you can copy to the Clipboard can be pasted into a drawing. The format 
in which the program adds the Clipboard contents to the drawing depends on the type 
of information in the Clipboard. For example, if you copy IntelliCAD drawing enti-
ties to the Clipboard, the program pastes them into the drawing as IntelliCAD enti-
ties. If you copy items to the Clipboard from other programs, they are pasted into the 
current drawing as embedded ActiveX® objects. 

To paste entities from the Clipboard

1 Do one of the following:     

• Choose Edit > Paste.

• On the Standard toolbar, click the Paste tool ( ).

• Type pasteclip and then press Enter.

2 Specify the insertion point. 

Making parallel copies
You can use the parallel feature to copy selected entities and align them parallel to the 
original entities at a specified distance. You can make parallel entities using arcs, cir-
cles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infinite lines.    

Making parallel copies of curved entities creates larger or smaller curves, depending 
on which side of the original entity you place the copy. For example, placing a paral-
lel copy of a circle outside the circle creates a larger concentric circle; positioning the 
copy inside the circle creates a smaller concentric circle.
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To make a parallel copy by specifying the distance 

1 Do one of the following:

• Choose Modify > Parallel.

• On the Modify toolbar, click the Parallel tool ( ).

• Type parallel and then press Enter.

2 Specify the distance by selecting two points or by entering a distance.

3 Select the entity to copy.

4 Specify on which side of the entity to place the parallel copy.

5 Select another entity to copy, or press Enter to complete the command.   

To make a parallel copy passing through a point

1 Do one of the following:     

• Choose Modify > Parallel.

• On the Modify toolbar, click the Parallel tool ( ).

• Type parallel and then press Enter.

2 In the prompt box, choose Through Point.

3 Select the entity to copy.

4 Specify the point for the entity to pass through.

5 Repeat steps 3 and 4, or press Enter to complete the command.    

To make a parallel copy, specify the distance between copies 
by entering a distance or selecting two points (A and B), select 
the entity to copy (C), and specify on which side to place the 
copy (D).

Result.

A

B

C

D

To make a parallel copy passing through a point, select the entity to copy (A) and then specify the through 
point (B).

A

B
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Mirroring entities    
You can create a mirror image of an entity. You mirror the entity about a mirror line, 
which you define by specifying two points in a drawing. You can delete or retain the 
original entities.    

To mirror entities

1 Do one of the following:     

• Choose Modify > Mirror.

• On the Modify toolbar, click the Mirror tool ( ).

• Type mirror and then press Enter.

2 Select the entity, and then press Enter.

3 Specify the first point of the mirror line.

4 Specify the second point of the mirror line.

5 In the prompt box, choose one of the following:

• Yes, Delete Entities – deletes the original entities.

• No, Keep Entities – retains the original entities. 
  

Arraying entities   
You can copy an entity in a rectangular or polar (circular) pattern, creating an array. 
For a rectangular array, you control the number of copies in the array by specifying 
the number of rows and columns. You also specify the distance between each row 
and column. For a polar array, you control the number of copies that compose the 
array and whether to rotate the copies.      

To mirror an entity, select it (A), and then specify the 
first point (B) and second point (C) of the mirror line.

Result.

A B

C



M O D I F Y I N G  E N T I T I E S 247
To create a polar array    

1 Do one of the following:

• Choose Modify > Array.

• On the Modify toolbar, click the Array tool ( ).

• Type array and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Polar.

4 Specify the center point of the array.

5 Specify the number of items to array, including the original selection set.

6 Specify the angle the array is to fill, from 0 to 360 degrees.

The default setting for the angle is 360 degrees. Positive values create the array in a 
counterclockwise direction; negative values create the array in a clockwise direc-
tion.

7 In the prompt box, choose one of the following:

• Yes, Rotate Entities – rotates entities as they are arrayed.

• No, Do Not Rotate – retains the original orientation of each copy as it is arrayed. 
  

To create a rectangular array

1 Do one of the following:     

• Choose Modify > Array.

• On the Modify toolbar, click the Array tool ( ).

• Type array and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Rectangular.

4 Type the number of rows.

5 Type the number of columns.

6 Specify the distance between the rows.

7 Specify the distance between the columns. 

To create a polar array, select the entity to copy (A), specify the center point of the array (B), and then 
specify the number of items to array, the angle the array is to fill, and whether to rotate the items.

A

B
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Rearranging entities    

You can move one or more entities, and you can also rotate entities about a specified point. 
If you have entities that overlap, you can also change the display order. 

Moving entities    
You can move entities around within the current drawing or from one drawing to 
another. The default method is to create a selection set and then specify a starting 
point, or base point, and an endpoint, or displacement point, to define the relocation 
of the entities. You can also relocate the entities using a direction vector.    

To move a selection set

1 Do one of the following:     

• Choose Modify > Move.

• On the Modify toolbar, click the Move tool ( ).

• Type move and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the displacement point.    

To create a rectangular array, select the entity to copy (A), type the number of rows and columns, and then 
specify the distance between each row (B) and column (C).

A

B

C

To move an entity, select it (A), and then specify the 
base point (B) and the displacement point (C).

Result.

A

B

C
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You can also move entities using grips. To move an entity using grips, select the 
entity to display its grips, and then click a grip and drag it. The grip you select 
depends on the type of entity you’re modifying. For example, to move a line entity, 
select the midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, 
select the center point grip. Not all entities can be moved using grips.    

To move an entity using grips

1 Select the entity.

2 Click a grip to select it.

3 Drag the entity to where you want to relocate it.

4 Click to release.

Rotating entities    
You can rotate entities about a specified point at a specified rotation angle or by an 
angle referenced to a base angle. The default method rotates the entities using a rela-
tive rotation angle from their current orientation.    

To rotate a selection set

1 Do one of the following:     

• Choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool ( ).

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the rotation point.

4 Specify the rotation angle.    

To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the rotation 
angle (C).

A
B

C
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To rotate a selection set in reference to a base angle

1 Do one of the following:

• Choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool ( ).

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the rotation point.

4 In the prompt box, choose Base Angle.

5 Specify the base angle.

6 Specify the new angle.  

  

Reordering entities 
When multiple entities overlap, you can change the order in which they are displayed 
and printed. You can move entities to the front, back, or on top or below of another 
entity.

To reorder entities:      

1 Do one of the following:

• Choose Tools > Draw Order.

• On the Tools toolbar, click the Draw Order tool ( ).

• Type draworder and then press Enter.

2 Select the entity you want to reorder, and then press Enter.

3 In the prompt box, specify the new drawing order, and then press Enter.

4 If you are reordering above or under, select the entity you want the first entity to 
be above or below, and then press Enter.

NOTE  The SORTENTS system variable automatically turns on, which may affect sys-
tem performance.

To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point (B), select the 
base angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify 
the point representing the new angle (D).

A

B C

D
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Resizing entities    

You can change the size of an entity or set of entities by stretching, scaling, extend-
ing, trimming, or editing their lengths.     

Stretching entities    
You can change the size of entities by stretching them. When you stretch entities, you 
must select the entities using either a crossing window or a crossing polygon. You 
then specify a displacement distance or select a base point and a displacement point. 
Entities that cross the window or polygon boundary are stretched; those completely 
within the crossing window or crossing polygon are simply moved.    

To stretch an entity

1 Do one of the following:

• Choose Modify > Stretch.    

• On the Modify toolbar, click the Stretch tool ( ).

• Type stretch and then press Enter.

2 In the prompt box, choose Crossing Window or Crossing Polygon.

3 Select the entities, and then press Enter.

4 Specify the base point.

5 Specify the second point of displacement.    

To stretch an entity using grips, you select it to display its grips and then select a grip 
to make it the active grip. This becomes the base point. Then you move the active 
grip to a new location. The grip you select depends on the type of entity you’re modi-
fying. For example, to stretch one corner of a rectangle, select the corner point grip. 
To stretch a line, select an endpoint grip. Not all entities can be stretched using grips.     

To stretch entities, select them using a crossing window (A) or crossing polygon, and then specify the base 
point (B) and displacement point (C).

A

B

C
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To stretch an entity using grips

1 Select the entity.

2 Click a grip to activate it.

3 Drag the grip.

4 Click to release.    

Scaling entities
You can change the size of a selected entity by scaling it in relation to a base point. 
You can change the size of an entity by specifying a base point and a length, which is 
used as a scale factor based on the current drawing units, or by specifying a scale fac-
tor. You can also use a scale factor referenced to a base scale factor, for example, by 
specifying the current length and a new length for the entity.    

To scale a selection set by a scale factor

1 Do one of the following: 

• Choose Modify > Scale.

• On the Modify toolbar, click the Scale tool ( ).

• Type scale and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the scale factor.    

To stretch an entity using grips, select the entity 
(A), select a grip (B), and drag the grip to its new 
location (C).

Result.

A
B

C

To scale an entity by a scale factor, select the entity (A), 
and then specify the base point (B) and the scale factor.

Result.

A
B
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You can also scale some entities using grips. To scale an entity, you select the entity, 
and then click a grip. You then change the size of the entity by moving the grip. The 
grip you select depends on the type of entity you’re modifying. For example, to scale 
a circle, select a quadrant point grip.

To scale an entity using grips

1 Select the entity.

2 Click a grip to select it.

3 Drag the grip.

4 Click to release.  

Extending entities    
You can extend entities so that they end at a boundary defined by other entities. You 
can also extend entities to the point at which they would intersect an implied bound-
ary edge. When extending entities, you first select the boundary edges, and then spec-
ify the entities to extend, selecting them either one at a time or using the fence 
selection method.    

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, 
ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab 
can act as boundary edges.

To extend an entity

1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more entities as boundary edges, and then press Enter.

3 Select the entity to extend.

4 Select another entity to extend, or press Enter to complete the command.

To scale using grips, select the entity (A), click a grip (B), and 
scale the entity by dragging the grip to its new
location (C).

Result.

A

B

C
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To extend an entity to an implied boundary    

1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.

3 In the prompt box, choose Edge Mode.

4 In the prompt box, choose Extend.

5 Select the entity to extend.

6 Select another entity to extend, or press Enter to complete the command.    

To extend entities, select the boundary edge (A), and then 
select the entities to extend (B).

Result.

A

B
B

Select the boundary edge (A), and then select the entities to 
extend (B).

Result.

A
B

B
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To extend several entities using the fence selection method    

1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.

3 In the prompt box, choose Fence.

4 Specify the first point of the fence.

5 Specify the second point of the fence.

6 Specify the next fence point, or press Enter to complete the command.

  

When you extend a wide polyline, its centerline intersects the boundary edge. 
Because the end of the polyline is always cut at a 90-degree angle, part of the polyline 
may extend past the boundary edge. A tapered polyline continues to taper until it 
intersects the boundary edge. If this would result in a negative polyline width, the 
ending width changes to 0.        

Select the boundary edge (A), and then specify the 
first point (B) and second point (C) of the fence. 

Result.

A

B

C

A tapered polyline (A) continues to taper until 
it intersects the boundary edge (B).

Result.

A

A

B
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Trimming entities    
You can clip, or trim, entities so they end at one or more implied cutting edges 
defined by other entities. You can also trim entities to the point at which they would 
intersect an implied cutting edge. When trimming entities, you first select the cutting 
edges and then specify the entities to trim, selecting them either one at a time or using 
the fence selection method.    

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 
polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports 
on a Layout tab can act as cutting edges. An entity can be both a cutting edge and one 
of the entities being trimmed.

To trim an entity

1 Do one of the following:

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 Select the entity to trim.

4 Select another entity to trim, or press Enter to complete the command.    

To trim an entity to an implied boundary

1 Do one of the following:     

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 In the prompt box, choose Edge Mode.

4 In the prompt box, choose Extend.

5 Select the entity to trim.

To trim entities, select the cutting edge (A), and then select 
the entities to trim (B).

Result.

A

B
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6 Select another entity to trim, or press Enter to complete the command.    

To trim several entities using the fence selection method

1 Do one of the following:     

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 In the prompt box, choose Fence.

4 Specify the first point of the fence.

5 Specify the second point of the fence.

6 Specify the next fence point, or press Enter to complete the command.     

Editing the length of entities   
You can change the length of entities or the included angle of arcs. Use any of the fol-
lowing methods to change the length of an entity:    

• Dynamically drag the endpoint or angle.

• Specify an incremental length or angle measured from an endpoint.

• Specify the new length as a percentage of the total length or angle.

• Specify a new length or included angle.

You can change the length of arcs, lines, and open polylines.

Select the implied boundary edge (A), and then select 
the entities to trim (B).

Result.

A

B

Select the boundary edge (A), and then specify the first 
point (B) and second point (C) of the fence.

Result.

A B

C
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To change the length of an entity by dragging

1 Do one of the following:     

• Choose Modify > Edit Length.

• On the Modify toolbar, click the Edit Length tool ( ).

• Type editlen and then press Enter.

2 In the prompt box, choose Dynamic.

3 Select the entity you want to change.

4 Specify the new endpoint or included angle. 
  

Select the entity (A), and then select the new 
endpoint (B).

Result.

A
B

A B
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Breaking and joining entities    

You can break an entity into two parts, removing a portion of the entity in the pro-
cess. You can also join two entities into a single entity.    

Breaking entities
You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When 
breaking entities, you must specify two points for the break. By default, the point you 
use to select the entity becomes the first break point; however, you can use the First 
option to select a break point different from the one that selects the entity.    

To break an entity

1 Do one of the following:     

• Choose Modify > Break.

• On the Modify toolbar, click the Break tool ( ).

• Type break and then press Enter.

2 Select the entity.

3 Specify the second break point.    

To select an entity and then specify the two break points

1 Do one of the following:

• Choose Modify > Break.

• On the Modify toolbar, click the Break tool ( ).

• Type break and then press Enter.

2 Select the entity.

3 In the prompt box, choose First.

4 Specify the first break point.

5 Specify the second break point.

Select the entity (A), and then specify the second break 
point (B).

Result.

A

B
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TIP  To break an entity in two without removing a portion of the entity, specify the 
same point for the first and second break points by typing the at sign (@) and press-
ing Enter instead of specifying the second break point.    

Joining entities
You can join two entities into a single entity. You can join either two lines or two arcs. 
The two lines must be parallel; the two arcs must share the same center point and radius.    

When you join two lines, the farthest endpoints remain at their existing locations; the 
program draws a new line between these points. Arcs are joined counterclockwise, 
from the first arc you select to the second.

To join two entities

1 Do one of the following:

• Choose Modify > Join.

• On the Modify toolbar, click the Join tool ( ).

• Type join and then press Enter.

2 Select the first arc or line.

3 Select the second arc or line.  

Select the entity (A), and then specify the first (B) and 
second (C) break points.

Result.

A
B

C

Select the first arc or line (A), and then select the 
second arc or line (B).

Result.

A

A

B

B
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Grouping entities   

A group is a collection of entities saved together as one unit. After you select the enti-
ties that belong in the group, you can later add more entities, remove entities, and 
reorder the entities. If necessary, you can also ungroup the entities at any time to 
work with the entities separately.

The Group dialog box controls the settings for all groups in a drawing. 

Creating groups 
When you create a group, you enter a group name and description, and then select the 
entities for the group. 

To create a group

1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 Under Create New Group, enter the name and description of the group.

3 Click Selectable if you want all entities in the group to be selected when you select 
one entity of the group in the drawing.
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4 Click Select Entities and Create Group.

5 Select the entities for the group, and then press Enter.

6 In the Group dialog box, click OK.

TIP You can enter the name of a group in the command bar when selecting entities.

Modifying groups

To modify a group and its entities

1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 Select the group you want to modify.

3 Under Modify Selected Group, do one or more of the following:

• Enter a new name, and then click Rename Group.

• Enter a new description, and then click Change Group Description.

• Select whether you want the group to be selectable in the drawing.

• Click Add Entities to Group, select the entities to add to the group, and then 
press Enter.

• Click Remove Entities from Group, select the entities to remove from the group, 
and then press Enter.

4 In the Group dialog box, click OK.



M O D I F Y I N G  E N T I T I E S 263
To change the order of entities in a group 

1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 Under Modify Selected Group, click Reorder Entities.

3 In the Reorder Grouped Entities dialog box, select the group you want to reorder.

4 To see the order of entities in the group, click Highlight. Follow the prompts that 
display to view the entities one by one.

5 To reverse the order of all entities in the group, click Reverse Order.

6 To change the order of specific entities or a range of entities:

• In Remove from Position, enter the current position of the entity. 

• In Place to Position, enter the new position of the entity. 

• In Number of Entities, enter the number of entities or range of entities to reorder. 
For example, if you are changing the order of only one entity, enter 1. 

• Click Reorder.

NOTE The entities in a group are numbered 0, 1, 2, 3, and so on.

7 Click OK, and then click OK again.

Ungrouping entities
When you ungroup entities, the entities remain in the drawing but the group is deleted 
from the drawing.

To ungroup entities

1 Do one of the following:

• Choose Tools > Group.

• On the Tools toolbar, click the Group tool ( ).

• Type group and then press Enter.

2 Select the group to delete.

3 Under Modify Selected Group, click Ungroup Entities.

4 Click OK.
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Editing polylines    

You can modify any type of two-dimensional or three-dimensional polyline. Entities 
such as rectangles, polygons, and donuts, as well as three-dimensional entities such as 
pyramids, cylinders, and spheres, are all variations of polylines that you can edit.    

You can edit a polyline by opening or closing it, by changing its overall width or the 
widths of individual segments, and by converting a polyline with straight line seg-
ments into a flowing curve or an approximation of a spline. In addition, you can use 
the Edit Polyline tool to edit individual vertices, adding, removing, or moving verti-
ces. You can also add new segments to an existing polyline, change the linetypes of a 
polyline, and reverse the direction or order of the vertices.    

To modify a polyline, you first select the polyline, and then select a polyline editing 
option. The available options vary depending on whether the selected polyline is a 
two-dimensional or three-dimensional entity. If the selected entity is not a polyline, 
the Edit Polyline tool provides the option of turning it into one. You can convert only 
arcs and lines into polylines. If several arcs or lines are joined endpoint to endpoint, 
they can all be selected and turned into one polyline.    

To convert an entity into a polyline

1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the entity.

3 In the prompt box, choose Yes-Turn Into Polyline.

4 In the prompt box, choose another option, or choose Done to complete the 
command.

Opening and closing polylines
When you close a polyline, the program draws a straight polyline segment from the 
last vertex of the polyline to the first vertex. Opening a polyline removes the closing 
segment. When you select a polyline for editing, the prompt box displays either the 
Open or Close option, depending on whether the polyline you select is closed or 
open.    
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To close an open polyline

1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Close.

4 In the prompt box, choose another option, or choose Done to complete the 
command.    

Curving and decurving polylines   
You can convert a multisegment polyline into a smooth curve using either the Fit or 
Spline option. The Fit option creates a smooth curve connecting all the vertices. The 
Spline option computes a smooth curve that is pulled toward the vertices but passes 
through only the first and last vertices. The Decurve option removes Fit or Spline 
curves and arcs, leaving straight segments between the vertices.    

Closing an open polyline adds a straight 
polyline segment between the first (A) and last 
(B) vertices.

Result.

A B
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To fit a curve to a polyline

1 Do one of the following:    

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Fit.

4 In the prompt box, choose another option, or choose Done to complete the 
command.

  

Joining polylines    
You can add an arc, line, or polyline entity to an existing open polyline, forming one 
continuous polyline entity. To join an entity to a polyline, that entity must already 
share an endpoint with an end vertex of the selected polyline.    

When you join an entity to a polyline, the width of the new polyline segment depends 
on the width of the original polyline and the type of entity you are joining to it:

• A line or an arc assumes the same width as the polyline segment for the end vertex 
to which it is joined.

• A polyline joined to a tapered polyline retains its own width values.

• A polyline joined to a uniform-width polyline assumes the width of the polyline to 
which it is joined.    

Original polyline. After applying Fit curve. After applying Spline.
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To join an arc, line, or polyline to an existing polyline 

1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Join.

4 Select the arc, line, or polyline to join.

5 In the prompt box, choose another option, or choose Done to complete the 
command.

Changing the polyline width    
You can change the width of an entire polyline, applying a uniform width to the entire 
entity or tapering the polyline uniformly along its entire length.    

To apply a uniform width to an entire polyline    

1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Width.

4 Specify the new polyline width.

5 In the prompt box, choose another option, or choose Done to complete the 
command.

To taper a polyline uniformly along its length

1 Do one of the following:     

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Taper.

4 Specify the starting width.

5 Specify the ending width.

6 In the prompt box, choose another option, or choose Done to complete the 
command.
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Editing polyline vertices    
You can use the Edit Vertices option to modify individual polyline vertices. When 
you select this option, the program switches into a special vertex editing mode and 
places an x on the first vertex. The x indicates the vertex you are editing. The Next 
and Previous options move the x to the next or previous vertex. You can edit only one 
vertex at a time.    

When editing vertices, you can modify the polyline in the following ways:

• Convert a polyline segment into a curve by specifying a new tangent angle.

• Break a polyline into two separate polylines.

• Insert a new vertex after the current vertex.

• Move the current vertex.

• Straighten the polyline segment between two vertices.

• Change the width of the polyline segment between two vertices.

To move a polyline vertex    

1 Do one of the following:

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Edit Vertices.

4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the vertex you want to move.

5 In the prompt box, choose Move.

6 Specify the new location for the vertex.

7 In the prompt box, choose another option, or choose Exit to stop editing vertices.

8 In the prompt box, choose another option, or choose Done to complete the 
command.    

Select the polyline (A), move the current vertex 
marker to the vertex you want to move (B), and then 
specify the new vertex location (C).

Result.

A

B

C
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To taper the width of an individual polyline segment

1 Do one of the following:     

• Choose Modify > Edit Polyline.

• On the Modify toolbar, click the Edit Polyline tool ( ).

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Edit Vertices.

4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the first vertex of the segment you want to taper.

5 In the prompt box, choose Width.

6 Specify the starting width.

7 Specify the ending width.

8 In the prompt box, choose another option, or choose Exit to stop editing vertices 
and update the display.

9 In the prompt box, choose another option, or choose Done to complete the 
command.    

Select the polyline (A), move the current vertex 
marker to the first vertex of the segment you want to 
taper (B), and then specify the new starting and 
ending widths for that segment.

Result.

A B
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Exploding entities    

You can convert a complex entity, such as a block or polyline, from a single entity 
into its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, 
or leader reduces it to a collection of individual line and arc entities that you can then 
modify individually. Blocks are converted to the individual entities, possibly includ-
ing other, nested blocks that composed the original entity.                                               

With the following exceptions, exploding an entity usually has no visible effect on a 
drawing:

• If the original polyline had a width, the width information is lost when you explode 
it. The resulting lines and arcs follow the centerline of the original polyline.    

• If you explode a block containing attributes, the attributes are lost, but the original 
attribute definitions remain.    

• Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be dif-
ferent after exploding an entity, because they will adopt the default color, linetype, 
lineweight, and print style until inserted into another block.    

To explode an entity

1 Do one of the following:

• Choose Modify > Explode.

• On the Modify toolbar, click the Explode tool ( ).

• Type explode and then press Enter.

2 Select the entities to explode.

3 Press Enter.
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Chamfering and filleting entities             

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 
line to create a beveled edge. A fillet connects two entities with an arc of a specified 
radius to create a rounded edge. If both entities you are working with are on the same 
layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 
chamfer or fillet is drawn on the current layer.                                     

The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer 
and fillet settings. The portions of the entities that extend beyond the chamfer or fillet 
are normally deleted when you create the chamfer or fillet. You can retain these 
original entities, however, by changing the settings in the dialog box.    

A Click to remove or retain portions of entities that 
extend beyond the chamfer or fillet.

B Click to create a chamfer using two chamfer 
distances (distance-distance method).

C Specify the first and second chamfer distances 
when using the distance-distance method.

D Specify the chamfer length and angle when 
using the distance-angle method.

E Click to create a chamfer using the chamfer 
length and angle (distance-angle method).

F Click to specify the fillet radius by selecting two 
points in the drawing.    

G Specify the fillet radius.

A

D

B
E
F

G

C
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Chamfering entities    
You can connect two nonparallel entities by extending or trimming them and then 
joining them with a line to create a beveled edge. You can chamfer lines, polylines, 
rays, and infinite lines. When creating a chamfer, you can specify how far to trim the 
entities back from their intersection (distance-distance method), or you can specify 
the length of the chamfer and the angle it forms along the first entity (distance-angle 
method).    

When chamfering a polyline, you can chamfer multiple segments between two 
selected polyline segments, or you can chamfer the entire polyline.

To chamfer two entities using the distance-distance method

1 Do one of the following:     

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.

3 In the Drawing Settings dialog box, click the Entity Modification tab.

4 Under Chamfer Distances And Angles, click Distance-Distance.

5 Under Chamfer Distances And Angles, specify the first and second chamfer
distances.

6 Click OK.

7 Select the first entity.

8 Select the second entity.    

Select the first (A) and second (B) entities. The chamfer is drawn, based on the first (C) and second (D) 
chamfer distances.

A

B

C

D
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To chamfer two entities using the distance-angle method

1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.

3 In the Drawing Settings dialog box, click the Entity Modification tab.

4 Under Chamfer Distances And Angles, click Distance-Angle.

5 Under Chamfer Distances And Angles, specify the chamfer distance and angle.

6 Click OK.

7 Select the first entity.

8 Select the second entity.

  

To chamfer all vertices in a polyline

1 Do one of the following:     

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Polyline.

3 Select the polyline.    

Select the first (A) and second (B) entities. The chamfer is drawn, based on the distance measured along 
the first entity (C) and the angle (D) formed with the first entity.

A

B

C

D

Original polyline. Result after chamfering.
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To chamfer selected vertices in a polyline

1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 Select the polyline along the segment where you want to begin the chamfer.

3 Select the polyline along the segment where you want to end the chamfer.    

Filleting entities    
You can connect two entities with an arc of a specified radius to create a rounded 
edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, 
rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When 
filleting a polyline, you can fillet multiple segments between two selected segments, 
or you can fillet the entire polyline.    

To fillet two entities

1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 In the prompt box, choose Fillet Settings.

3 In the Drawing Settings dialog box, specify the fillet radius.

4 Click OK.

5 Select the first entity.

6 Select the second entity.    

Select the polyline along the (A) and (B) 
segments.

Result after chamfering.

A B

Select the first (A) and second (B) entities. Result after filleting.

A

B
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To fillet an entire polyline

1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 In the prompt box, choose Polyline.

3 Select the polyline.    

To fillet selected vertices in a polyline

1 Do one of the following:    

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 Select the polyline along the segment where you want to begin the fillet.

3 Select the polyline along the segment where you want to end the fillet.    

Select the polyline (A). Result after filleting.

A

Select the polyline along the (A) and (B) 
segments.

Result after filleting.

A B
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When you fillet circles and arcs, more than one fillet can exist between the entities. 
The point at which you select the entities determines the fillet.    

You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or 
ray; the second entity can be a line, ray, or infinite line. The diameter of the fillet arc 
is always equal to the distance between the parallel entities. The current fillet radius is 
ignored.         

Select entities (A and B). Results after filleting.

B

A

B

A

B

A

B

A

Original entities. Result after filleting.
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Working with text

You can insert text into your drawing and control its appearance, allowing you to pro-
vide additional information for your IntelliCAD drawings. This section explains how 
to:

• Create line text.

• Create paragraphs.

• Create text styles.

• Format text.

• Change text.

• Change paragraph text.

• Check the spelling of text.

• Use an alternate text editor.

• Working with text written in different languages.

Topics in this chapter

Creating line text ..............................................................................................278

Creating paragraph text....................................................................................279

Working with text styles....................................................................................281

Formatting text .................................................................................................282

Changing text ...................................................................................................285

Using an alternate text editor ...........................................................................293

Working with text written in different languages ...............................................295
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Creating line text       

When you create text, you end each line of text by pressing Enter. Each line of text is 
created as a separate entity that you can modify.

To create text 

1 Do one of the following:           

• Choose Insert > Text.

• On the Draw 2D toolbar, click the Text tool ( ).

• Type dtext and then press Enter.    

2 Specify the insertion point for the first character.    

3 Specify the height of the text.

4 Specify the text rotation angle.     

5 Type the text, and then press Enter at the end of each new line.

6 To complete the command, press Enter again.

TIP  If you’ve already created text and want new text to appear immediately below the 
previous text, choose Insert > Text. When prompted for an insertion point, press 
Enter. The new text will keep the same height and rotation angle as the previous text.
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Creating paragraph text    

Paragraph text consists of one or more lines of text or paragraphs that fit within a 
boundary width that you specify. Each paragraph text entity you create is treated as a 
single entity regardless of the number of individual paragraphs or lines of text it 
contains.    

When you create paragraph text, you first determine the paragraph’s boundary width 
by specifying the opposite corners of a rectangle. The paragraph text automatically 
wraps so that it fits within this rectangle. The first corner of the rectangle determines 
the default attachment point of the paragraph text. You can change the location of the 
attachment point in reference to the rectangle, and you can determine the direction in 
which text flows within the rectangle. You can also select the text and paragraph for-
mat, text style, text height, and the rotation angle of the entire paragraph text entity.    

To create paragraph text 

1 Do one of the following:

• Choose Insert > Multiline Text.

• On the Draw 2D toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.    

2 Select the first corner of the text area.

3 In the MTEXT prompt box, select the properties you want to change, or proceed 
directly to step 4. 

You can select these properties in steps 7 and 8.

4 Select the second corner of the text area.

5 In the Multiline Text dialog box, click the Text tab.

6 In the window, type the text you want. 

To create paragraphs, press Enter and continue typing.

7 Make any selections or changes you want to the following:

• Font, text height, bold, italic, underline, and color. 

• Indents on the ruler. Move the upper left arrow to define the first line indent, 
move the lower left arrow to define the paragraph indent, and move the right 
arrow to define the right indent.

• Tabs on the ruler. Click the ruler to create tabs, move any tab marker to modify 
its location, and drag any tab off the ruler to delete it.

Your selections affect highlighted text, or if no text is highlighted, new text when 
you type it.

8 Click the Properties tab, and make selections or changes you want to the text 
Style, Justification, Width, and Rotation.           

9 Click OK.
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TIP You can paste text from the Clipboard into the Multiline Text dialog box.    

       

A Click to view and select text attributes.

B Select the text font.

C Mark the first line indent, paragraph indent, right 
indent, and tabs.

D Type and select text.

E Select or type a zoom magnification.

F Select BYBLOCK, BYLAYER, the color of your 
choice, or choose Select Color to select from 
additional colors.

G Click to undo the previous action.

H Click to bold, italicize, and underline text.

I Select or type the text height.

A Click to view and select text style and text box 
properties.

B Select a text style.

C Mark the first line indent, paragraph indent, right 
indent, and tabs.

D Type and select text.

E Select or type the text box angle.

F Select or type the text width.

G Select the text box justification.

A

D

B
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Working with text styles    

When you add text to a drawing, it uses the current text style. Text style determines 
the font, size, angle, orientation, and other characteristics.           

Every drawing has a default text style, named Standard, which initially uses the 
icad.fnt font. You cannot delete the Standard style, but you can rename it or modify 
it. You can change the font, the size of the font, and the obliquing angle applied to it. 
If you change the font or orientation of an existing style, all existing text entities cre-
ated using that style are automatically updated to reflect the new font or orientation. 
Changing any other characteristic has no effect on existing text. You also can create 
and use an unlimited number of additional text styles.        

The text style determines the characteristics shown in the following table.                   

To create a text style     

1 Do one of the following:     

• Choose Settings > Explore Text Styles.

• On the Settings toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Choose Edit > New > Style.

3 Type a new text style name, or press Enter to accept the default name.

4 Choose Edit > Properties to open the Styles dialog box.

5 Under Text Font, select the name, style, and language of the font you want to use.      

6 Under Text Measurements, enter the Fixed Text Height, Width Factor, and 
Oblique Angle measurement.    

7 Under Text Generation, select the check boxes you want to indicate the direction 
for printed text to appear.

Style characteristics 
Characteristic Default Description

Style name Standard The name of the style, up to 31 characters.

Font file icad.fnt The font file on which the style is based.

Text height 0 The character height. A value of 0 prompts for text height upon insertion. 

Width factor 1 The horizontal expansion or compression of the text. Values less than 1 compress the text; 
values greater than 1 expand the text.

Obliquing angle 0 The slant of the text, in degrees. Negative values slant the text to the left; positive values slant 
the text to the right.

Backward No Determines whether text appears backward.

Upside down No Determines whether text appears upside down.

Vertical No Determines whether text has a vertical orientation.
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8 Close the Styles dialog box, then close the IntelliCAD Explorer dialog box.

9 To begin using the new style, choose Insert > Text. 

10 In the prompt box, select Use Defined Style.

Formatting text    

When you create text, you choose the text style and set the alignment. The style deter-
mines the font characteristics for the text. For line text, the alignment determines how 
the text aligns with the text insertion point. For paragraph text, the alignment deter-
mines the location of the attachment point in relation to the paragraph text boundary 
and the direction in which text flows within the boundary.         

Setting the line text style
You can set the text style before you specify the insertion point. You select the text 
style by typing the name of a previously defined style.       

To specify a line text style

1 Do one of the following:     

• Choose Insert > Text.

• On the Draw 2D toolbar, click the Text tool ( ).

• Type dtext and then press Enter.

2 In the prompt box, choose Use Defined Style.

3 Type the name of a previously defined text style, and then press Enter.        

To display a list of available text styles, type a question mark (?), and then press 
Enter.    

4 Specify the text insertion point.     

5 Specify the text height.     

6 Specify the rotation angle.    

7 Type the text line, and then press Enter.

8 To complete the command, press Enter again.
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Setting the paragraph text style
You can set the paragraph text style before you specify the insertion point. You select 
the text style by typing the name of a previously defined style.

To specify a paragraph text style

1 Do one of the following:

• Choose Insert > Multiline Text.

• On the Draw 2D toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.

2 Specify the first point of the Multiline Text box.

3 In the prompt box, choose Text Style.

4 Type the name of a previously defined text style, and then press Enter.

5 Specify the text height.

6 Specify the rotation angle.

7 Specify the opposite corner of the Multiline Text box.

8 Type the text, and then press Enter.

9 To complete the command, press Enter again.

Setting the line text alignment    
When you create text, you can set the text alignment before you specify the insertion 
point. You set the alignment by choosing it in the prompt box. By default, text is left 
justified. You can align text at the left, center, or right and at the top, middle, or base-
line of the text or at the bottom of descending letters.                  

A Top left

B Middle left

C Left

D Bottom left

E Center

F Bottom center

G Bottom right

H Baseline

I Right

J Middle right

K Top right

L Middle

M Middle center

N Top center

J
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You can also align text so that it fits or aligns between two points. The Align option 
creates text that scales up or down while maintaining a constant height/width ratio; 
the Fit option expands or compresses the text to fit between the two points.        

To specify the line text alignment

1 Do one of the following:       

• Choose Insert > Text.

• On the Draw 2D toolbar, click the Text tool( ).

• Type dtext and then press Enter.    

2 In the prompt box, choose an alignment option, or choose Justification Options to 
display all the justification options.

3 Specify the text insertion point, and then continue creating the line text.

Setting the paragraph text alignment
When you create paragraph text, you can set the text alignment by specifying the 
attachment point location in relation to the paragraph text boundary and the direction 
in which text flows within the boundary. You can set the paragraph text alignment 
either in the prompt box displayed after you specify the first corner of the paragraph 
text boundary or from the Multiline Text dialog box. You can specify the attachment 
point at the top left, top center, top right, middle left, middle center, middle right, bot-
tom left, bottom center, or bottom right. The paragraph text can flow left to right, 
right to left, top to bottom, or bottom to top.

Text aligned between two points maintains a 
constant height/width ratio.

Text fit between two points expands or compresses 
to fit.
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Including special text characters    
You can use control codes to overscore or underscore text or to include special char-
acters. Both overscore and underscore can be active at the same time. To include con-
trol codes, as you type text, type two percent symbols (%%) followed by the special 
control code or character. A single percent sign is treated as a normal text character. 
A triple-percent control code is provided for those instances where a control-code 
sequence must follow a percent sign in the text.                         

Changing text    

Changing line text
You can edit and modify the text as you would any other drawing entity. That is, you 
can delete, move, rotate, and scale text.                      

To edit text     

1 Do one of the following:     

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the text entity.

3 In the Text field, edit the text, and then click OK.

Special text characters   
Control code Function

%%o Toggles overscore mode on and off.

%%u Toggles underscore mode on and off.

%%d Draws a degree symbol (º).

%%p Draws the plus-or-minus symbol (±).

%%c Draws the circle diameter symbol (Ø).

%%% Forces a single percent sign.

%%nnn Draws special character number nnn.

Text created using special text characters: Ut wisi %%uenim%%d ad%%p%%u minim %%c %%oveniam.
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To change text properties

1 Do one of the following:           

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool( ).

• Type ddedit and then press Enter.

2 Select the text entity.

3 Under Text Settings, change the text properties you want.

4 Click OK.     

    

A Click to change layer.

B Click to change color.

C Click to change print style (available only for 
drawings that use named print style tables).

D Specify new text insertion point or justification.

E Specify text height.

F Specify text rotation angle.

G Edit the existing text.

H Specify the width factor.

I Specify the obliquing angle.

J Select to insert backward text.

K Select to insert upside-down text.

L Click to change text style.

M Click to change text justification.

N Click to select a new text insertion point. or 
justification

O Click to attach a hyperlink to the text.
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Changing paragraph text
You can modify the text as you would any other drawing entity. That is, you can 
delete, move, rotate, and scale text.

To edit paragraph text

1 Do one of the following:

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

2 Select the text entity.

3 Edit the text in the Contents field of the Entity Properties dialog box.

4 To apply font style changes to the text, click Full Editor.

5 Click OK.

To change paragraph text properties

1 Do one of the following:

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

2 Select the text entity.

3 Change the text properties you want under the Text section of the Entity Properties 
dialog box.

4 To apply font style changes to the text, click Full Editor.

5 Click OK.
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A Click to change layer.

B Click to change color.

C Click to change print style (available only for 
drawings that use named print style tables).

D Specify new attachment point.

E Specify text height.

F Specify width of text boundary rectangle.

G Specify text rotation angle.

H Edit the existing text.

I Click to change font styles.

J Click to change text style.

K Click to change direction in which text flows.

L Click to change attachment point in relation to text 
boundary rectangle.

M Click to select a new attachment point.

N Click to attach a hyperlink to the text.
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Checking the spelling

Checking the spelling of text
You can use the Spell command to check the spelling of single-line text, multiline 
text, paragraph text, attributes, attribute definitions, and dimension text.          

To check the spelling of text     

1 Do one of the following:     

• Choose Tools > Spelling.

• On the Standard toolbar, click the Spelling tool ( ).

• Type spell and then press Enter.

2 Select one or more text entities.

3 In the Check Spelling dialog box, misspelled words display one at a time. Do one 
of the following for each found word:

• Keep text unchanged — Click Ignore to keep the found word unchanged in the 
drawing, or click Ignore All to keep all instances of the found word unchanged 
in the drawing.

• Change text — Select or type a word in the Suggestions box, then click Change 
to change the found word in the drawing to the new text, or click Change All to 
change all instances of the found word in the drawing.

4 Click Add if you want to add the currently found word to a list of custom spelling 
words. The Check Spelling dialog will recognize the added word as spelled cor-
rectly the next time the word is checked for spelling.
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Customizing the spelling words
Most drawings contain text that is not recognized as spelled correctly, even though it 
is spelled correctly. For example, if your company name Zaffer, Inc. appears in all of 
your drawings, the company name will appear as misspelled every time you check the 
spelling of drawing text. You can easily add words to a custom dictionary so that any 
word in the custom dictionary is recognized as spelled correctly. 

The custom dictionary is independent of any spelling dictionary you have chosen to 
use. You can check the spelling of text using one dictionary, check the spelling of the 
same or other text using a different dictionary, and in both cases your custom dictio-
nary is used.

A Displays the current dictionary.

B Displays the misspelled word and its context in the 
drawing.

C Displays (or you can type) a new word to replace the 
misspelled word in the drawing.

D Click to select a new word to replace the currently 
found misspelled word.

E Click to select a new dictionary or modify a custom 
dictionary.

F Click to add the suggested word to the custom 
dictionary.

G Click to suggest additional words based on the 
selected word in the Suggestions list.

H Click to change all instances of the misspelled word 
to the suggested word.

I Click to change a single instance of the misspelled 
word to the suggested word.

J Click to skip all instances of the misspelled word.

K Click to skip a single instance of the misspelled word 
without changing it.

L Move the slider to zoom in or out on the text.

A

C

D

E

I
H

B

K

F
G

L
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To create and manage a custom dictionary

1 Do one of the following: 

• Choose Tools > Spelling.

• On the Standard toolbar, click the Spelling tool ( ).

• Type spell and then press Enter.

2 Select one or more text entities.

3 In the Check Spelling dialog box, click Change Dictionaries.

4 To add a custom word, type a word in Custom Dictionary Words, then click Add.

5 To delete a custom word, select a word in Custom Dictionary Words, then click 
Delete.

6 Click OK.

TIP You can also add custom words to the custom dictionary directly during spell 
checking of text. In the Check Spelling dialog, click Add to add the currently found 
word to the custom dictionary.

A Type a word for the custom dictionary.

B Displays the words in the custom dictionary.

C Click to delete the currently selected word from the 
custom dictionary.

D Click to add the current word in the edit box (A) to the 
custom dictionary.

E Click to select a different custom dictionary.

F Displays the custom dictionary filename. You can 
type a new path and filename or click Browse to 
select a file.

A

B

D

E

F

C
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Changing the dictionary
The Spell command compares text found in the drawing with correctly spelled words 
in an installed dictionary (.dic file). There are many different dictionaries that can be 
used with IntelliCAD, including dictionaries in different languages. You can down-
load and install a new dictionary or use a dictionary already installed on your com-
puter. 

To download and install a new dictionary 

1 Choose Tools > Spelling, select one or more text entities, then in the Check Spell-
ing dialog box, click Change Dictionaries.

2 Click Download.

3 From the web page that displays (or from a different web page), download the 
desired dictionary.

4 Unzip the contents of the downloaded file to \MyDocuments\Spelling, or the loca-
tion where you installed spelling dictionaries for IntelliCAD.

5 Click Change Dictionaries again, which will load the newly installed dictionary.

6 In Main Dictionary, select the desired dictionary.

7 Click OK.

A Select the desired spelling dictionary. B Click to open the default Internet browser to a web 
page where you can download spelling dictionaries in 
different languages.

A

B
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To use a dictionary already installed on your computer 

1 Do one of the following:

• Copy the existing dictionary (.dic file) to \MyDocuments\Spelling, or to the 
location where you install spelling dictionaries for IntelliCAD.

• Add the folder of the existing dictionary to the list of folders where IntelliCAD 
searches for dictionaries. Choose Tools > Options, click Paths/Files and add the 
folder location to the Dictionary paths. For more details, see “Changing the 
options on the Paths/Files tab” on page 478. 

2 Choose Tools > Spelling, select one or more text entities, then in the 
Check Spelling dialog box, click Change Dictionaries.

3 In Main Dictionary, select the desired dictionary.

4 Click OK.

Using an alternate text editor

IntelliCAD includes a built-in text editor for creating paragraph text using the Multi-
line Text command. You can also specify an alternate text editor for the Multiline 
Text command. 

Selecting an alternate text editor    
Before you can use an alternate text editor, you must specify the editor by setting the 
MTEXTED system variable. 

To select an alternate text editor     

1 Type mtexted and then press Enter. 

2 Enter the path and name of the executable file for the text editor you want to use to 
create or edit multiline text. For example, to use Microsoft® Wordpad, you would 
type something similar to the following (adjusting the path name as necessary):

C:\Program Files\Windows\Accessories\Wordpad.exe

Creating paragraph text in an alternate text editor    
After you set up IntelliCAD to use an alternate text editor, you can start using it to 
include text in your drawings. 
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To use an alternate text editor     

1 Do one of the following:     

• Choose Insert > Multiline Text.

• On the Draw 2D toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter. 

2 Select the first and second corners of the text area.

3 In the Multiline Text dialog box, click the Text tab.

4 In the window, type the text you want, using the special characters from the table 
shown next to achieve special formatting. Enter \P to end a paragraph and start a 
new paragraph on the next line. For example, to use an alignment value of 1 and 
stack two numbers to display them as a fraction:

{\A1;\S1/2;}\P 

5 When your text is complete, save the changes and exit the text editor. 

Special formatting characters   
Format characters Function

\0...\o Toggles overscore mode on and off.

\L...\l Toggles underscore mode on and off.

\~ Inserts a nonbreaking space.

\\ Inserts a backslash.

\{...\} Inserts an opening and closing brace.

\Cvalue; Sets the color to a specified value.

\File name; Sets the font based on a specified font file name.

\Hvalue; Sets the text height to a specified value.

\Hvaluex; Sets the text height to a multiple of the current text height.

\S...^...; Stacks the subsequent text at the /, #, or ^ symbol.

\Tvalue; Adjusts the space between characters, from 0.75 to 4 times.

\Qangle; Changes obliquing angle.

\Wvalue; Changes width factor to produce wide text.

\A Sets the alignment value.

\P Ends paragraph.

\p[i],[l],[tX1,X2,...,X32] Formats paragraph: i = first line indent; l = paragraph offset; t = tab 
positions.
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Working with text written in different languages

You can include text in your drawings that is written in different languages.

Using Unicode characters
IntelliCAD supports the Unicode character encoding standard, which enables you to 
display and write text in different languages using different letters. Unicode fonts 
contain many more characters than typically defined in a system. 

For more details about using special characters, see “Including special text charac-
ters” on page 285 in this chapter. You can also use a different text editor; see “Using 
an alternate text editor” on page 293 in this chapter. 

Specifying character sets for drawings
The character set used to display text in drawings typically depends on the character 
set specified by your operating system, for example, ANSI_1252 is Latin 1, 
ANSI_1253 is Greek, and ANSI_1254 is Turkish. This is also called the code page.

IntelliCAD allows you to manage which code page is assigned to a drawing when 
you open the drawing or after you open it. This unique feature is usually not neces-
sary if you distribute drawings within the same geographic region, but it can be very 
helpful when sharing or distributing drawings between different geographic regions. 
Changing the code page is highly desirable especially in geographic regions where 
several languages are used that require different character sets to display text prop-
erly.

Setting the code page doesn’t change the language of your text; instead it specifies 
the character set in which the text displays. Some fonts can display its characters sev-
eral different ways depending on the code page setting.

There are two system variables that relate to the code page of a drawing:

• SYSCODEPAGE — Character set defined for your operating system.

• DWGCODEPAGE — Character set defined for an individual drawing that over-
rides the operating system code page.

Special Unicode characters   
Control code Function

\U+00B0 Draws a degree symbol (º).

\U+00B1 Draws the plus-or-minus symbol (±).

\U+2205 Draws the circle diameter symbol (Ø).
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To manage how code pages are assigned to drawings

1 Type codepage and then press Enter.

The Code Page Manager dialog box opens.

2 If you want to convert the drawing to use a different code page, in Drawing Code 
Page, select the desired code page.

3 Select one of the following options:

• No conversion when a drawing is opened — Keeps the drawing code page 
unchanged when you open a drawing.

• Always open this dialog when a drawing is opened — Opens the Code Page 
Manager dialog box every time you open a drawing.

• Only open this dialog when the drawing and system code pages differ — Opens 
the Code Page Manager dialog box only when the operating system code page 
is different from the drawing code page. This setting can be helpful if you 
sometimes send or receive drawings created using a code page that is different 
from the one used by your operating system.

• Automatically convert the code page when a drawing is opened — Always use 
the same code page when opening drawings (the Code Page Manager dialog box 
will not open).

4 If you selected to automatically convert the code page, select one of the following:

• Use alternate code page — When converting drawings automatically, always 
use the code page that you select.

• Use system code page — When converting drawings automatically, use the 
code page defined for the operating system (this is the code page displayed for 
the SYSCODEPAGE system variable).

TIP If you want to always use the code page assigned to a drawing, choose No Con-
version when a Drawing is Opened (this is the default setting). You can change the 
drawing code page after opening a drawing, if necessary. If you want to always use 
the code page specified for your operating system, choose Automatically Convert the 
Code Page, and then choose Use System Code Page.
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A Displays the code page for your operating system.

B Select the code page for the current drawing. 

C Choose to keep the drawing code page unchanged 
when you open a drawing.

D Choose to open the Code Page Manager dialog box 
every time you open a drawing.

E Choose to open the Code Page Manager dialog box 
only when the operating system code page is 
different from the drawing code page.

F Choose to always use the same code page when 
opening drawings (the Code Page Manager dialog 
box will not open).

G Choose to always use the operating system code 
page when opening drawings (available only if you 
selected to automatically convert drawings).

H Choose to always use the selected code page when 
opening drawings (available only if you selected to 
automatically convert drawings).

I Click to preview the first text entity using the current 
code page settings. 

J Click to preview the next text entity using the current 
code page settings.

B

E
F

A

J

I

H

G

C
D
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Dimensioning your drawing

The IntelliCAD dimensioning tools let you add measurements to a drawing. You can 
quickly add dimensions by simply pointing to entities. You can also add tolerance 
symbols to your drawings. 

The program’s many dimensioning variables let you control the appearance of the 
dimensions. With dimension styles, you can save dimension variable settings so you 
can reuse them without having to re-create them.

This section explains how to:

• Create dimensions as linear, angular, diametral, radial, and ordinate.

• Create leaders and annotations.

• Edit dimensions.

• Use dimension styles and variables.

• Add geometric tolerances.

• Control dimension tolerance.

• Control alternate dimension units.

Topics in this chapter

Understanding dimensioning concepts............................................................. 300

Creating dimensions ......................................................................................... 302

Editing dimensions............................................................................................ 313

Understanding dimension styles and variables ................................................ 316

Adding geometric tolerances ............................................................................ 327



300 C H A P T E R  1 2
Understanding dimensioning concepts  

You can create five basic types of dimensions: linear, angular, radial, diametral, and 
ordinate. You can create dimensions for existing entities by selecting them, or you 
can create dimensions by selecting points within a drawing. For example, you can 
create a linear dimension either by selecting the entity to be dimensioned or by speci-
fying the first and second extension line origins.             

When you create a dimension, the program draws it on the current layer, using the 
current dimension style. Each dimension has an associated dimension style, which 
controls the appearance of the dimension, such as the types of arrowheads, text style, 
and colors of various components. You can modify existing dimension styles by 
changing one of the dimension variable settings and then updating the dimension 
style to reflect the new settings.    

Each dimension you create consists of several parts. A dimension line shows where a 
dimension begins and ends. When you create an angular dimension, the dimension 
line is a dimension line arc that subtends the measured angle.    

A Radial dimension.

B Vertical linear dimension.

C Angular dimension.

D Linear continued dimensions.

E Aligned dimension.

F Diametral dimension.

G Horizontal linear dimension.

H Linear baseline dimension.

A

B

C

D

E
F

H

G
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Extension lines, also called projection lines, are lines that extend away from the entity 
for which you are creating a dimension, so that you can place the dimension line 
away from the entity. Arrowheads form the termination at each end of the dimension 
line.   

Dimension text contains the measured dimension and can also include prefixes, suf-
fixes, tolerances, and other optional text. As you insert dimensions, you can control 
the dimension text and specify its position and orientation.        

Dimensions can also contain other optional components. A leader is a line leading 
from a feature of the drawing to an annotation. Leaders begin with an arrowhead, and 
you can use them to place a dimension away from the dimension line or to add notes. 
When you create a radial dimension, you can add a center mark, which is a small 
cross that marks the center of a circle or an arc, or you can add centerlines, which are 
crossing lines that extend out from the center of a circle or an arc.      

A Extension line.

B Arrowhead.

C Dimension line.

D Dimension text.

A
B

C D

Leader. Center mark. Centerlines.
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Creating dimensions  

You can create dimensions by:    

• Selecting the entity to dimension and specifying the dimension line location.

• Specifying the extension line origins and the dimension line location.

When you create dimensions by selecting an entity, the program automatically places 
the extension line origins at the appropriate definition points based on the type of 
entity you select. For example, the definition points are located at the endpoints of 
arcs, lines, and polyline segments. When you create dimensions by specifying the 
extension line origins, the points you specify determine the definition points. To 
establish these points precisely, use entity snaps.    

You can create dimensions in model space or paper space.

Creating linear dimensions  
Linear dimensions annotate linear distances or lengths and can be oriented horizon-
tally, vertically, or aligned parallel to an existing entity or to the selected extension 
origin points. After you create a linear dimension, you can add a baseline dimension 
or a continued dimension. A linear baseline dimension inserts an additional dimen-
sion from a common first extension line origin of a previous linear dimension. A lin-
ear continued dimension continues a linear dimension from the second extension line 
of a previous linear dimension.    

TIP  To select precise ordinate points, use entity snaps.
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To create a horizontal or vertical dimension

1 Do one of the following:     

• Choose Insert > Dimensions > Linear.

• On the Dimensioning toolbar, click the Linear tool ( ).

• Type dimlinear and then press Enter.    

2 Press Enter, and then select the entity to dimension.    

Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.            

To insert a linear dimension by selecting the entity, select the 
entity (A) to dimension, and then specify the dimension line 
location (B).

Result.

To insert a linear dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line 
location (C).

Result.

A

B

A

BC
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To create an aligned dimension    

1 Do one of the following:     

• Choose Insert > Dimensions > Aligned.

• On the Dimensioning toolbar, click the Aligned tool ( ).

• Type dimaligned and then press Enter.    

2 Press Enter, and then select the entity to dimension.

Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.        

To insert an aligned dimension by selecting the entity, select 
the entity (A) to dimension, and then select the dimension line 
location (B).

Result.

To insert an aligned dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line 
location (C).

Result.

A

B

A

C B
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To create a linear baseline dimension

NOTE  Before you can use this procedure, you must first create a dimension.

1 Do one of the following:    

• Choose Insert > Dimensions > Baseline.

• On the Dimensioning toolbar, click the Baseline tool ( ).

• Type dimbaseline and then press Enter.    

2 To select a starting dimension, press Enter.

3 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension for the baseline. Select the 
origin of the next extension line, and then press Enter.

The program automatically places the new baseline dimension above or below the 
previous dimension line. The distance between the two dimension lines is determined 
by the Baseline Offset value in the Dimension Settings dialog box.         

To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select as many additional points as you want (C).

A B

C

Result.
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To create a linear continued dimension

NOTE  Before you can use this procedure, you must first create a dimension.

1 Do one of the following:    

• Choose Insert > Dimensions > Continue.

• On the Dimensioning toolbar, click the Continue tool ( ).

• Type dimcontinue and then press Enter.     

2 To select a starting dimension, press Enter.

3 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension to continue.

4 To add continued dimensions, continue selecting extension line origins.

5 To end the command, press Enter twice.        

To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select another extension line origin (C).

Result.

A B

C
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Creating angular dimensions   
Angular dimensions annotate the angle measured between two lines. You can also 
dimension an angle by selecting an angle vertex and two endpoints. After you create 
an angular dimension, you can add a baseline dimension or a continued dimension. 
An angular baseline dimension inserts an additional dimension from a common first 
extension line origin of a previous angular dimension. An angular continued dimen-
sion continues an angular dimension from the second extension line of a previous 
angular dimension.       

To dimension an angle encompassed by an arc    

1 Do one of the following:     

• Choose Insert > Dimensions > Angular.

• On the Dimensioning toolbar, click the Angular tool ( ).

• Type dimangular and then press Enter.    

2 Select the arc.

3 Specify the dimension arc location.          

To dimension the angle subtended by an arc, select 
the arc (A), and then specify the dimension arc 
location (B).

Result.

A

B



308 C H A P T E R  1 2
To dimension an angle between two lines

1 Do one of the following:    

• Choose Insert > Dimensions > Angular.

• On the Dimensioning toolbar, click the Angular tool ( ).

• Type dimangular and then press Enter.

2 Select one line.

3 Select the other line.

4 Specify the dimension line location.    

Creating diametral and radial dimensions  
Diameter and radius dimensions annotate the radii and diameters of arcs and circles. 
You can optionally include centerlines or center marks.    

To create a diametral dimension    

1 Do one of the following:    

• Choose Insert > Dimensions > Diameter.

• On the Dimensioning toolbar, click the Diameter tool ( ).    

• Type dimdiameter and then press Enter.    

2 Select the arc or circle.

3 Specify the dimension line location.     

Select one line (A), select the other line (B), and then specify 
the dimension line location (C).

Result.

A

B
C

Select the circle (A), and then specify the 
dimension line location (B).

Result.

A B



D I M E N S I O N I N G  Y O U R  D R A W I N G 309
To create a radial dimension

1 Do one of the following:     

• Choose Insert > Dimensions > Radius.

• On the Dimensioning toolbar, click the Radius tool ( ).

• Type dimradius and then press Enter.    

2 Select the arc or circle.

3 Specify the dimension line location.     

Creating ordinate dimensions
An ordinate dimension annotates the perpendicular distance from an origin or base 
point (the origin of the current user coordinate system [UCS]). Ordinate dimensions 
consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures dis-
tances along the x-axis; a y-ordinate dimension measures distances along the y-axis.    

As you select ordinate points, the program automatically determines whether the 
point is an x- or y-ordinate based on which direction you drag the second point. You 
can also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimen-
sion text is always aligned with the ordinate leader lines, regardless of the text orien-
tation specified by the current dimension style.     

Select the circle (A), and then specify the 
dimension line location (B).

Result.

A B

Ordinate dimensions measure the distance along the x- or y-axis from an origin to a selected ordinate point.
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To create an ordinate dimension

1 Do one of the following:     

• Choose Insert > Dimensions > Ordinate.

• On the Dimensioning toolbar, click the Ordinate tool ( ).

• Type dimordinate and then press Enter.    

2 Select the point for ordinate dimension.

3 Specify the ordinate leader endpoint.     

TIP  To select precise ordinate points, use entity snaps.

Select the ordinate point (A), and then specify the ordinate leader endpoint (B).

A B
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Creating leaders and annotations
Leaders consist of a line or series of lines that connects a feature in a drawing to an 
annotation. Generally, you place an arrowhead at the first point. An annotation, cre-
ated as dimension text, is placed immediately adjacent to the last point. By default, 
the text placed at the end of the leader line consists of the most recent dimension. You 
can also type an annotation as a single line of text.    

To create a leader and an annotation

1 Do one of the following:     

• Choose Insert > Dimensions > Leader.

• On the Dimensioning toolbar, click the Leader tool ( ).

• Type dimleader and then press Enter.    

2 Specify the starting point of the leader.

3 Specify the endpoint of the leader line segment.

4 Specify additional leader line segment endpoints.

5 After you specify the last endpoint, press Enter.

6 Type the annotation, or press Enter to accept the most recent dimension as the 
default annotation.     

Specify the starting point of the leader (A) 
and the endpoint of the leader line segment 
(B).

Result.

A

B
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Dimensioning model space entities in paper space
To increase efficiency, you can separate your drawing model from annotations using 
the Model and Layout tabs. 

It takes time to display dimensions, title blocks, keynotes, and other annotations. If 
you draw these on a Layout tab, display-time and visual clutter are reduced when you 
work on your model (on the Model tab). IntelliCAD allows you to dimension model 
space entities on either the Model tab or a Layout tab — you can make the choice 
depending on the method that works best for your needs. 

To dimension model space entities in paper space

1 Click a Layout tab.

2 Create at least one layout viewport. For details, see “Creating layout viewports” 
on page 368. 

3 Lock the desired layout viewport by doing the following:

• Right-click the edge of the layout viewport that you want to use for creating 
dimensions.

• Choose Properties.

• Mark Lock Viewport, and then click OK.

Locking the viewport is not required, but it is extremely helpful when you zoom or 
pan in the layout viewport; it prevents the viewport scale and view center from 
changing.

TIP You may want to place the layout viewports on their own layer and after lock-
ing the layout viewports, hide the layer that contains them. This allows you to 
work within the layout viewport without it cluttering your display or selections.

4 Make sure you are working in paper space by verifying that the Model/Paper 
Space toggle in the status bar begins with “P.” If necessary, switch to paper space 
by double-clicking the Model/Paper Space toggle in the status bar.

5 Create a dimension. You can select the model space entities directly, specify defi-
nition points, or use entities snaps to help accurately select the definition points.

The dimension is created in paper space.

For more details about using paper space and model space, see “Understanding paper 
space and model space” on page 362. 
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Editing dimensions  

You can use grips to edit entity dimensions. You can also edit the dimension text. 
You can rotate dimension lines and dimension text at any angle, and you can reposi-
tion the dimension text anywhere along the dimension line. 

Making dimensions oblique    
Extension lines are normally created at a perpendicular angle to the dimension line. 
You can change the angle of the extension lines, however, so that they tilt relative to 
the dimension line.    

To make oblique extension lines

1 Do one of the following:     

• Choose Insert > Dimensions > Make Oblique.

• On the Dimensioning toolbar, click the Make Oblique tool ( ).

• Type dimedit, press Enter, and then in the prompt box, choose Oblique Lines.    

2 Select the linear dimension, and then press Enter.

3 Type the obliquing angle, and then press Enter.        

TIP  To align the oblique angle if you don’t know the exact measurement, use snaps to 
pick two points on the entity.

Editing dimension text
You can rotate the text of an existing dimension, move the dimension text to a new 
position, or replace selected dimension text with new text. You can also restore 
dimension text to its original position as defined by the current dimension style.        

When you rotate or replace selected text, you specify the change first, and then select 
one or more dimensions to which to apply the change. All the selected dimensions are 
updated simultaneously.

Select the dimension to be made oblique (A), and then type 
the obliquing angle.

Result.

A
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To rotate dimension text

Advanced experience level      

1 Do one of the following:

• Choose Insert > Dimensions > Rotate Dimension Text.

• On the Dimensioning toolbar, click the Rotate Dimension Text tool ( ).

• Type dimedit, press Enter, and then in the prompt box, choose Rotate Text.

2 Type the new dimension text angle, and then press Enter.

3 Select the dimension to be rotated, and then press Enter.    

NOTE The dimension text angle is relative to the dimension line. If the dimension text 
rotation is set to zero, the text angle is defined by the dimension type and the dimen-
sion style.   

To move dimension text

Advanced experience level    

1 Do one of the following:

• Choose Insert > Dimensions > Reposition Dimension Text.

• On the Dimensioning toolbar, click the Reposition Dimension Text tool ( ).

• Type dimtedit and then press Enter.

2 Select the dimension to reposition text.

Select the dimension to be rotated (A), and then 
type the rotation angle.

Result.

A
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3 Select the new text position.      

To restore dimension text to its home position    

Advanced experience level     

1 Do one of the following:

• Choose Insert > Dimensions > Restore Text Position.

• On the Dimensioning toolbar, click the Restore Text Position tool ( ).

• Type dimedit, press Enter, and then in the prompt box, choose Restore Text.

2 Select the dimension text to restore, and then press Enter.

To replace existing dimension text with new text    

Advanced experience level    

1 Do one of the following:

• Choose Insert > Dimensions > Edit Dimension Text.

• On the Dimensioning toolbar, click the Edit Dimension Text tool ( ).

• Type dimedit and then in the prompt box, choose Edit Text.

2 Type the new dimension text, and then press Enter.

3 Select the dimension to be replaced, and then press Enter.

Select the dimension to be moved (A), and then 
select the new text position (B).

Result.

A
B
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Understanding dimension styles and variables  

Dimensions that you insert are created using the current dimension style. You can 
create, save, restore, and delete named dimension styles.    

To display information about the current dimension style and compare it with other 
style names, you can use the dimstyle command.

Dimension styles provide a way for you to change various settings that control the 
appearance of dimensions. You can then save those settings for reuse. If you don’t 
define a dimension style before creating dimensions, the program uses the Standard 
dimension style, which stores the default dimension variable settings. Each option in 
the Dimension Settings dialog box relates to a variable that you can set manually. See 
the online Command Reference for more information.

To create a dimension style

1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click New.

3 Type the name of the new dimension style.

4 Click Create.

5 In the Dimension Settings dialog box, click one of the other tabs, and then change 
the dimension settings as necessary.

Repeat this step for each tab, as needed.

6 To end the command, click OK.

To select a dimension style

1 Do one of the following:

• Choose Settings > Dimension Settings, select a dimension style from the list, 
and then click OK.

• On the Dimensioning toolbar, select a dimension style from the list.

• Type setdim, press Enter, select a dimension style from the list, and then click 
OK.
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To rename a dimension style

1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click Rename.

3 In the Rename list, click the dimension style to be renamed.

4 In the To box, type the new dimension style name.

5 Click Rename.

6 Click OK.

To delete a named dimension style

1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click Delete.

3 Select the dimension style to delete.

4 Click Delete.

5 Click OK.

To display information about the current style

1 Type dimstyle and then press Enter.   

2 Type v and then press Enter to display information about the variables.

3 Type the dimension style name, and press Enter.

Controlling dimension arrows   
You can control the appearance and size of arrowheads or tick marks placed at the 
ends of dimension lines. Any changes you make affect the current dimension style. 
The arrowheads you choose display in the image tile on the right side of the Dimen-
sion Settings dialog box.    

You can choose from a number of arrowhead types. You can specify different arrow-
heads for each end of a dimension line and for leader lines. The Starting arrow corre-
sponds to the first extension line; the Ending arrow corresponds to the second 
extension line. Blocks defined in the drawing also display in the three Arrowhead 
lists as user-defined arrows. You can use these blocks to create and assign your own 
arrowheads.

The Arrow Size value determines the size of the arrowhead, measured in drawing 
units. You can also use tick marks instead of arrowheads.    
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To choose an arrowhead

1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.    

2 Click the Arrows tab.   

3 In the Starting Arrowhead or Ending Arrowhead list, click to select the Starting or 
Ending arrowhead, respectively.

4 In the Leader Arrowhead list, click to select a leader arrowhead for leader lines.

5 Click OK.

NOTE  You can also specify leader arrow types using the DIMLDRBLK system vari-
able.  

A Type or select arrowhead size.

B Click to select a starting arrowhead, or click the 
arrowhead picture to scroll the list automatically.

C Click to select an ending arrowhead, or click the 
arrowhead picture to scroll the list automatically.

D Click to select a leader arrowhead, or click the 
arrowhead picture to scroll the list automatically.

E Select to enable tick marks instead of 
arrowheads.

F Type or select tick mark size.

A

B

C

D

E
F
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Controlling dimension format  
You can control the way dimension text and arrowheads are placed in relation to the 
dimension lines. Any changes you make affect the current dimension style. The 
image tile on the right side of the Dimension Settings dialog box shows the appear-
ance of dimensions based on the current dimension style settings.       

The program determines whether both dimension text and arrowheads will fit 
between the extension lines by comparing the distance between the extension lines to 
the size of the dimension text, the size of the arrowheads, and the amount of space 
required around dimension text. The program applies the best fit method based on the 
available space. If possible, both the dimension text and arrowheads are placed 
between the extension lines. If both will not fit between the extension lines, you can 
determine how text and arrowheads are placed using the Fit Method settings on the 
Dimension Settings dialog box.     

To format dimensions     

1 Do one of the following:    

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.    

2 Click the Format tab.

3 Click the Fit option that you want.

4 Specify the Distance option that you want.

5 Click OK. 

NOTE You can also specify how dimension text and arrows are arranged using the 
DIMATFIT system variable. You can specify how dimension text is moved using the 
DIMTMOVE system variable.

Text and arrowheads placed 
outside extension lines.

Text placed between extension 
lines and arrowheads outside 
extension lines.

Text placed above 
dimension line with a leader 
connecting the text to the 
dimension line.
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A Click to place both text and arrowheads inside 
the extension lines when both do not 
automatically fit between them.

B Click to place text only between extension lines 
and arrowheads outside extension lines when 
both do not fit between them.

C Click to fit either text or arrowheads between 
extension lines when both do not fit between 
them.

D Click to automatically determine the best fit 
method.

E Click to place text beside the dimension line with 
a leader when both text and arrowheads do not 
fit between the extension lines.

F Click to place text above the dimension line with 
a leader connecting the text to the dimension line 
when both text and arrowheads do not fit 
between the extension lines.

G Click to place text above the dimension line 
without a leader when both text and arrowheads 
do not fit between the extension lines.

H Type or select the distance around the 
dimension text.

A
B
C
D

E
F
G

H
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Controlling line settings  
You can control settings affecting dimension lines, extension lines, and center marks. 
Any changes you make affect the current dimension style. The image tile on the right 
side of the Dimension Settings dialog box shows the appearance of the dimensions 
based on the current dimension style settings.        

To set the color for dimension lines    

1 Do one of the following:     

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Click the Lines tab.

3 Make your selections.

4 Click OK.

A Extend past dimension.

B Baseline offset.

C Offset from origin.

A

B

C
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A Type or select center mark size. Positive values 
create a center mark. Negative values create 
centerlines.

B Type or select the baseline offset distance (the 
distance to offset successive dimension lines 
when creating baseline dimensions) and the 
offset from origin (the distance extension lines 
are offset from their origin points).

C In Dimensions, type or select the distance that 
extension lines extend beyond dimension lines. 
In Obliques, type or select the distance that 
dimension lines extend beyond extension lines.  

D Select the dimension lineweight and the 
dimension line color.

E Select the extension lineweight and the 
extension line color.

F Select to prevent the creation of the first and 
second dimension lines.

G Select to prevent the creation of the first and 
second extension lines.

H Select to prevent the creation of dimension lines 
outside extension lines.

I Select to draw dimension lines between 
extension lines when text and arrows are placed 
outside extension lines.

A

B

C

D

E

F
G
H
I
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Controlling dimension text  
You can control the settings affecting the appearance of dimension text. Any changes 
you make affect the current dimension style. The image tile on the right side of the 
Dimension Settings dialog box shows the appearance of the dimensions based on the 
current dimension style settings.         

To align dimension text with the dimension line    

1 Do one of the following:     

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.     

2 Click the Text tab.     

3 Make your selections.

4 Click OK.

       

Text between extension lines aligned 
horizontally.

Text between extension lines 
aligned with dimension line.
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A Click to select the text style used for dimension 
text.

B Type or select the text height, measured in 
drawing units.

C Type a prefix or suffix to be appended to 
dimension text.

D Click to display the IntelliCAD Explorer, Text Styles 
element.

E Click to select the dimension text color.

F Select to align text placed between the extension 
lines with the dimension line.

G Select to align text placed outside the extension 
lines with the dimension line.

H Select to force text between the extension lines.

I Type or select the vertical text offset distance.

J Click to select the horizontal or vertical justification 
of dimension text.

K Formats integers in superscript after the specified 
number of decimal places.

A

B

C

D
E
F
G
H
I

J

K



D I M E N S I O N I N G  Y O U R  D R A W I N G 325
Controlling dimension units  
You can determine the appearance and format of the primary and alternate dimension 
units. The image tile on the right side of the Dimension Settings dialog box shows the 
appearance of the dimensions based on the current dimension style settings.         

To round off dimensions        

1 Do one of the following:     

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.    

2 Click the Units tab.

3 In the Round Linear Distances field, type or select the nearest value to which you 
want to round off dimensions.

4 Click OK. 

NOTE You can also specify units for linear dimensions using the DIMLUNIT system 
variable. You can specify fraction formats using the DIMFRAC system variable.

     

Round off distance set to .0100 
(original dimension before 
rounding).

Round off distance set to 0.2500. Round off distance set 
to 1.0000.
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A Select the linear dimension format.

B Type or select the number of decimal places you 
want displayed in linear dimension text.

C Enter the marker symbol used for decimals.

D Type or select the nearest value to which you 
want to round off linear distances.

E Select to prevent the inclusion of leading zeros 
or the inclusion of feet in dimension text when 
the dimension is less than one foot.

F Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in dimension text when 
the number of inches is zero.

G Select the angular dimension format.

H Type or select the number of decimal places you 
want displayed for angular dimension text. 
Select whether to suppress leading or trailing 
zeros.

I Type or select the scale factor applied to all 
dimensions.

J Type or select the linear scale factor applied to 
all lengths measured by dimensioning 
commands.

A
B

C
D
E

G
H

I
J

F
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Adding geometric tolerances    

Geometric tolerances indicate the maximum allowable variations in the geometry 
defined by a drawing. IntelliCAD draws geometric tolerances using a feature control 
frame, which is a rectangle divided into compartments.    

Each feature control frame consists of at least two compartments. The first compart-
ment contains a geometric tolerance symbol that indicates the geometric characteris-
tic to which the tolerance is applied, such as location, orientation, or form. For 
example, a form tolerance may indicate the flatness or roundness of a surface. The 
geometric tolerance symbols and their characteristics are shown in the following 
table.                                                                   

Geometric tolerance symbols

Symbol Characteristic Type

Position Location

 Concentricity or coaxiality Location

 Symmetry Location

 Parallelism Orientation

 Perpendicularity Orientation

 Angularity Orientation

 Cylindricity Form

 Flatness Form

 Circularity or roundness Form

 Straightness Form

 Profile of a surface Profile

 Profile of a line Profile

 Circular runout Runout

 Total runout Runout
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The second compartment contains the tolerance value. When appropriate, the toler-
ance value is preceded by a diameter symbol and followed by a material condition 
symbol. The material conditions apply to features that can vary in size. The material 
condition symbols and their meanings are shown in the following table.      

The tolerance value can then be followed by primary, secondary, and tertiary datum 
reference letters, along with the material conditions of each datum. Datum reference 
letters are generally used as reference tolerances to one of up to three perpendicular 
planes from which a measurement is made, although datum reference letters can also 
indicate an exact point or axis.       

When two tolerances apply to the same geometry, you can also add a composite toler-
ance consisting of a primary tolerance value followed by a secondary tolerance value. 
To make a tolerance even more specific, it can also contain a projected tolerance con-
sisting of a height value followed by a projected tolerance symbol. For example, you 
can use a projected tolerance to indicate the perpendicularity of an embedded part.       

Material conditions

Symbol Definition

At maximum material condition (MMC), a feature contains the maximum amount of 
material stated in the limits.

At least material condition (LMC), a feature contains the minimum amount of 
material stated in the limits.

Regardless of feature size (RFS) indicates that the feature can be any size within 
the stated limits.

A Geometric characteristic symbol.

B Diameter symbol.

C Tolerance value.

D Material condition symbol.

E Datum reference.

A B C D E
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To add a geometric tolerance

1 Do one of the following:     

• Choose Insert > Dimensions > Tolerance.

• On the Dimensions toolbar, click the Tolerance tool ( ).

• Type tolerance and then press Enter.    

2 To display the geometric tolerance symbols, on the first line, click the Sym box.

3 Click to select a geometric tolerance symbol.

4 Under Tolerance 1, click the Dia box to add a diameter symbol.

5 In the field, type the first tolerance value.

6 To display the material condition symbols, click the M.C. box.

7 Click to select a material condition.

8 Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if 
appropriate.

9 Under Datum 1, type the primary datum reference letter.    

10 To display the material condition symbols, click the M.C. box.

11 Click to select a material condition.

12 Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate.

13 In the second row, repeat steps 2 through 12 to add composite tolerances, if 
appropriate.

14 In the Height box, type a projected tolerance zone height value, if appropriate.

15 To insert a projected tolerance zone symbol, click the Projected Tolerance Zone 
box, if appropriate.

16 Click OK.

17 In the drawing, specify the location of the feature frame.
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Controlling dimension tolerance   
You can create dimensions as either tolerance or limits dimensions. When creating a 
tolerance dimension, you can control the upper and lower tolerance limits as well as 
the number of decimal places of the dimension text. The image tile on the right side 
of the Dimension Settings dialog box shows the appearance of tolerance and limits 
dimensions based on the current dimension style settings.    

A Use this row to include composite tolerances.

B Type a projected tolerance height value.

C Type a datum identifier.

D Click to include a projected tolerance symbol.

E Click to select the material condition symbol for tertiary 
data.

F Type the tertiary datum reference letter.

G Click to select the material condition symbol for 
secondary datum.

H Type the secondary datum reference letter.

I Click to select the material condition symbol for primary 
datum.

J Type the primary datum reference letter.

K Click to select the material condition symbol for the 
second tolerance value.

L Type the second tolerance value.

M Click to include a diameter symbol for the second 
tolerance value.

N Click to select the material condition symbol for the first 
tolerance value.

O Type the first tolerance value.

P Click to include a diameter symbol for the first tolerance 
value.

Q Click to select a geometric tolerance symbol.

A

Q P O LM J H FI G E

DB

C

N K

Tolerance dimension. Limits dimension.
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To create a tolerance dimension

1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Click the Tolerance tab.

3 Select the Append Dimension Tolerances check box.

4 Type or select the lower tolerance limit.

5 Type or select the upper tolerance limit.

6 Click OK.

7 Insert the dimension.   

A Select to insert dimensions as upper and lower 
tolerance limits.

B Select to include plus and minus tolerance 
values with the dimension text.

C Type or select the minimum tolerance or lower 
limit value.

D Type or select the maximum tolerance or upper 
limit value.

E Type or select the number of decimal places 
displayed in limits or tolerance dimensions.

F Select to prevent the inclusion of leading zeros 
or the inclusion of feet in dimension limits when 
the dimension is less than one foot.

G Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in dimension limits when 
the number of inches is zero.

A
B

C
D

E

F
G
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Controlling alternate dimension units   
You can include alternate dimensions in addition to the primary dimension text. You 
can also determine the appearance and format of the alternate dimensions, including 
the scale factor applied to generate alternate dimensions. The image tile on the right 
side of the Dimension Settings dialog box shows the appearance of the dimensions 
based on the current dimension style settings.    

To create an alternate dimension

1 Do one of the following:

• Choose Settings > Dimension Settings.

• On the Settings toolbar, click the Dimension Settings tool ( ).

• Type setdim and then press Enter.

2 Click the Alternate Units tab.

3 Select the Enable Alternate Units check box.

4 Type or select the scale factor.

5 In the Suffix field, type a suffix to be appended to the alternate dimension.

6 Click OK.

7 Insert the dimension.

Alternate dimension created using a scale factor of 25.4, with an appended suffix.
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A Select to include alternate dimensions.

B Select to prevent the inclusion of leading zeros 
or the inclusion of feet in alternate dimensions 
when the dimension is less than one foot.

C Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in alternate dimensions 
when the number of inches is zero.

D Type or select the number of decimal places 
displayed in alternate dimensions.

E Type or select any rounding for alternate 
dimensions.

F Type or select the scale factor applied to 
measured dimensions to generate the alternate 
dimensions.

G Click to select the format for alternate 
dimensions.

H Type a prefix or suffix to be appended to 
alternate dimensions.

I Type or select the number of decimal places 
displayed in limits or tolerances included as part 
of alternate dimensions.

J Select to prevent the inclusion of leading zeros 
or the inclusion of feet in limits or tolerances 
included as part of alternate dimensions.

K Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in limits or tolerances 
included as part of alternate dimensions. 

A
B
C
D
E
F

G
H

I
J
K
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13

Working with blocks, attributes, and 
external references

Blocks, attributes, and external references provide mechanisms for managing entities 
in your drawings and for including additional information with the standard drawing 
entities. With blocks, you can combine numerous entities into a single entity, and 
then reuse it, inserting multiple copies. With attributes, you can associate text, such as 
part numbers or prices, with blocks, and then extract the text-attribute information to 
a separate file, such as a database, for further analysis. With external references, you 
can link separate reference drawing files to a drawing to combine information without 
adding the contents of the reference drawings to the current drawing. If you make 
changes to the referenced file, all references are updated automatically.

This section explains how to:

• Create, insert, and redefine blocks.

• Create, edit, and insert attributes.

• Extract attribute data to a separate file.

• Attach and work with external references.

Topics in this chapter

Working with blocks .......................................................................................... 336

Working with attributes ..................................................................................... 342

Working with external references...................................................................... 348
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Working with blocks    

Usually, blocks are several entities combined into one that you can insert into a draw-
ing and manipulate as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks are 
stored as part of the drawing file.        

Blocks can help you better organize your work, quickly create and revise drawings, 
and reduce drawing file size. Using blocks, you can create a library of frequently used 
symbols. Then you can insert a symbol as a block rather than redraw the symbol from 
scratch.    

After you create a block from multiple entities, you save it once, which also saves 
disk space. You insert only multiple references to a single block definition. You can 
change the block definition to quickly revise a drawing, and then update all instances 
of the block.    

If you insert a block that contains entities originally drawn on layer 0 and assigned 
color and linetype BYLAYER, it is placed on the current layer and assumes the color 
and linetype of that layer. If you insert a block that contains entities originally drawn 
on other layers or with explicitly specified colors or linetypes, the block retains the 
original settings.    

If you insert a block that contains entities originally assigned color and linetype 
BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities 
adopt the color and linetype of the layer onto which they are inserted. If the block is 
assigned an explicit color or linetype, such as red or dashed, those entities adopt those 
qualities.    

A procedure called nesting occurs when you include other blocks in a new block that 
you are creating. Nesting is useful when you want to combine and include small com-
ponents, such as nuts and bolts, into a larger assembly and you need to insert multiple 
instances of that assembly into an even larger drawing.    

Creating blocks 
The tools and commands for creating blocks appear on the Tools toolbar and the 
Tools menu, respectively, when you set the program to the Advanced experience 
level. You can also use the IntelliCAD Explorer to create blocks.    

You can create blocks in two ways:

• By saving a block for use within the current drawing only.        

• By saving the block as a separate drawing file that you can insert into other draw-
ings.

When you create a block, you specify its name, its insertion point, and the entities that 
compose the block. The insertion point is the base point for the block and serves as 
the reference point when you later insert the block into a drawing.    
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To create a block for use within a current drawing

Advanced experience level    

1 Do one of the following:

• Choose Tools > Create Block.

• On the Tools toolbar, click the Create Block tool ( ).

• Type block and then press Enter.

2 Type a name for the block, and then press Enter.

3 Specify the insertion point for the block.

4 Select the entities that you want in the block, and then press Enter.

The block is created and exists only in the current drawing. The entities you select 
are removed from the display, because they are now part of the block.

5 To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.     

NOTE If you frequently restore original entities after you define a block, you can cus-
tomize the program to add the Undelete command to a menu or toolbar.

You can create a block as a separate drawing file that you can insert into other drawings.

To save a block as a separate drawing file    

Advanced experience level    

1 Do one of the following:

• Choose Tools > Save Block To Disk.

• On the Tools toolbar, click the Save Block To Disk tool ( ).

• Type wblock and then press Enter.

2 In the File Name field, type the name of the drawing file you want to create.

3 Click Save.

4 In the prompt box, choose one of the following:

• Multiple Blocks This option saves one or more existing block entities to a 
separate drawing file. When prompted, type the name of the block(s).

• All Entities This option immediately saves the entire drawing to a separate 
drawing file.

• Select Entities This option saves those entities you select to a separate drawing 
file. When prompted, specify the insertion point for the block, select the entities 
for the block, and then press Enter.
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NOTE When saving multiple blocks or saving the entire drawing as a separate draw-
ing file, the program assigns the 0,0,0 coordinate as the insertion base point. You can 
change the base point by opening the drawing and redefining the block.

Inserting blocks   
You can insert blocks and other drawings into the current drawing. When you insert a 
block, it is treated as a single entity. When you insert a drawing, it is added to the cur-
rent drawing as a block. You can then insert multiple instances of the block without 
reloading the original drawing file. If you change the original drawing file, those 
changes have no effect on the current drawing unless you redefine the block by rein-
serting the changed drawing.      

You can also insert blocks from another drawing into the current drawing, using the 
IntelliCAD Explorer. Both drawings must be open at the same time to do this. see 
Chapter 8, “Working with the IntelliCAD Explorer.”   

When you insert a block or drawing, you must specify the insertion point, scale, and 
rotation angle. The block’s insertion point is the reference point specified when you 
created the block. When you insert a drawing as a block, the program takes the speci-
fied insertion point as the block insertion point. You can change the insertion point, 
however, by first opening the original drawing and redefining the block.        

To insert a block    

1 Display the Insert Block dialog box by doing one of the following:    

• Choose Insert > Block.

• On the Draw 2D toolbar, click the Block tool ( ).

• Type ddinsert and then press Enter.

2 In the Insert Block dialog box, under Insert, click Block Name.

3 In the Block Name box, select the name of the block you want to insert.

4 Click Insert.

5 Specify the insertion point for the block.

6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.
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To insert an entire drawing into the current drawing

1 Do one of the following:     

• Choose Insert > Block.

• On the Draw 2D toolbar, click the Block tool ( ).

• Type ddinsert and then press Enter.

2 In the Insert Block dialog box, under Insert, click From File.

3 Type the path and the drawing file name, or click Browse to specify the file from 
the Insert Drawing dialog box, and click Open.

4 Click Insert.

5 Specify the insertion point for the block.

6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.

NOTE You can specify the insertion point, scale factors, and rotation angle in the 
Insert Block dialog box before inserting the block. You can also control whether the 
block is exploded back into its original component entities after insertion. Under 
Positioning, clear the Position Block When Inserting check box, and specify the 
appropriate coordinates. If you want to explode the block immediately, select the 
Explode Upon Insertion check box.        
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Redefining blocks    
You can redefine all instances of a block within the current drawing. To redefine a 
block that was created in the current drawing, you create a new block using the same 
name. You can update all the blocks in the current drawing by redefining the block. If 
the block was inserted from a separate drawing file that was subsequently updated, 
reinsert that block to update all other instances in the current drawing.    

A Click and then enter the path and drawing file 
name to insert the entire drawing file as a block.

B Click to position the block when inserting.

C Specify the insertion point, scale factors, and 
rotation angle before you insert the block 
(available only when Position Block When 
Inserting is cleared).

D Click to explode the block on insertion. 

E Specify columns, column spacing, rows, and row 
spacing.

F Click to insert the block.

G Click to select the block insertion point in the 
drawing before inserting the block (available only 
when the Position Block When Inserting check 
box is cleared).

A

B

C

E

F

G

D



W O R K I N G  W I T H  B L O C K S ,  A T T R I B U T E S ,  A N D  E X T E R N A L  R E F E R E N C E S 341
To redefine a block in the current drawing

Advanced experience level    

1 Do one of the following:

• Choose Tools > Create Block.

• On the Tools toolbar, click the Create Block tool ( ).

• Type block and then press Enter.

2 Type the name of the block you want to redefine, and then press Enter.

3 In the prompt box, choose Yes-Redefine Block.

4 Specify the insertion point for the block.

5 Select the entities for the block, and then press Enter.

The block is immediately redefined, and all instances of the block in the drawing 
are updated. The entities you select for inclusion in the block are removed from 
the drawing, because they are now part of the block.

TIP To restore the original entities to the drawing while retaining the new block, type 
undelete or oops.    

You can update all instances of a block inserted from a separate drawing by reinsert-
ing the drawing.

Exploding blocks
You can explode an inserted block to its original component entities. When you 
explode a block, only that single instance of the block is affected. The original block 
definition remains in the drawing, and you can still insert additional copies of the 
original block. If you explode a block that contains attributes, the attributes are lost, 
but the original attribute definitions remain.    

Exploding dissociates component entities to their next simplest level of complexity; 
blocks or polylines in a block become blocks or polylines again

To explode a block

1 Do one of the following:

• Choose Modify > Explode.

• On the Modify toolbar, click the Explode tool ( ).

• Type explode and then press Enter.

2 Select the block.

3 Press Enter.
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Working with attributes    

An attribute is a particular entity that you can save as part of a block definition. 
Attributes consist of text-based data. You can use attributes to track such things as 
part numbers and prices. Attributes have either fixed or variable values. When you 
insert a block containing attributes, the program adds the fixed values to the drawing 
along with the block, and you are prompted to supply any variable values.        

After you insert blocks containing attributes, you can extract the attribute information 
to a separate file and then use that information in a spreadsheet or database to produce 
a parts list or bill of materials. You can also use attribute information to track the 
number of times a particular block is inserted into a drawing.    

Attributes can be visible or hidden. Hidden attributes are neither displayed nor 
printed, but the information is still stored in the drawing and written to a file when 
you extract it.        

Defining attributes    
You add an attribute to a drawing by first defining it and then saving it as part of a 
block definition. To define an attribute, you specify the characteristics of the 
attribute, including its name, prompt, and default value; the location and text format-
ting; and optional modes (hidden, fixed, validate, predefined, and locked).        

To define an attribute          

Advanced experience level

1 Do one of the following:

• Choose Tools > Define Attributes.

• On the Tools toolbar, click the Define Attributes tool ( ).

• Type ddattdef and then press Enter.

2 In the Define Attribute dialog box, type the name, prompt, and default value.

3 Under Insert Coordinates, specify the location of the attribute, or click Select to 
select a point in the drawing.

4 Under Attribute Flags, select the optional attribute modes.

5 Under Text, specify the text characteristics.

6 To add the attribute to the drawing, do one of the following:

• Click Define to add the attribute and keep the dialog box active so you can 
define another attribute.

• Click Define And Exit to add the attribute and end the command.
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A Type the name you want to assign to the 
attribute.         

B Enter the identifying prompt information 
displayed when you insert a block containing the 
attribute.

C Enter the default or constant value. For variable 
attributes, the default value is replaced by the 
actual value when you later insert a block 
containing the attribute.

D Specify the x-, y-, and z-coordinates for the 
attribute insertion point.

E Select to create a hidden attribute.

F Select to create a fixed-value attribute.

G Select to create an attribute whose value must 
be validated when you later insert a block 
containing the attribute.    

H Select to create an attribute whose value is 
defined and not requested when you later insert 
a block containing the attribute, but that you can 
edit after the block is inserted. 

I Select to lock the position of the attribute within 
the block.

J Click to add the attribute and keep the dialog box 
active so you can define another attribute.

K Click to add the attribute and end the command.

L Specify the text rotation angle, or click to specify 
the rotation angle by selecting two points in the 
drawing.    

M Specify the text height, or click to specify the 
height by selecting two points in the drawing.

N Choose the text justification.

O Choose the text style from those styles already 
defined in the drawing.

P Click to specify the attribute insertion point by 
selecting a point in the drawing.

A
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Editing attribute definitions    
You can edit an attribute definition before you associate it with a block and before it 
is saved as part of a block definition.         

To edit an attribute definition           

Advanced experience level

1 Do one of the following:

• Choose Modify > Edit Text.

• On the Modify toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the attribute definition text to edit.

3 Modify the attribute name, prompt string, default value, and other attribute defini-
tion characteristics.

4 Click OK.   

A Modify the name assigned to the attribute.    

B Modify the prompt that displays when you insert the 
attribute into the drawing.

C Modify the identifying prompt information displayed 
when you insert a block containing the attribute.

D Modify the attribute insertion point.

E Modify the attribute text style and appearance.

F Modify the attribute insertion flags to create hidden, 
fixed-value, locked, validated, or defined attributes.

A
B
C
D

F

E
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Attaching attributes to blocks
You can attach attributes to a block after you define it and select it as one of the enti-
ties to include. Include the attributes when the program prompts you for the entities to 
include in the selection set for a block. After the attribute is incorporated into a block, 
the program prompts you each time you insert the block, so you can specify different 
values for the attributes each time you insert it into a new drawing.    

Editing attributes attached to blocks
You can edit the attribute values of a block that has been inserted into a drawing.           

To edit an attribute attached to a block     

Advanced experience level

1 Do one of the following:

• Choose Tools > Edit Block Attributes.

• On the Tools toolbar, click the Edit Block Attributes tool ( ).

• Type ddatte and then press Enter.

2 Select the block to edit.

The Edit Block Attributes dialog box displays all the attributes attached to the 
block you select.

3 Edit the attribute values as necessary.

4 Click OK. 
    

A Identifies the name of the block.

B Displays the names of all 
attributes attached to the block.

C Click to select attribute.

D Type the new value for the 
selected attribute.

E Click to update the attribute 
values and exit.

F Displays the value of each 
attribute attached to the block.

G Displays the prompt for each 
attribute attached to the block.

A
B

C

D

G
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Extracting attribute information    
You can extract attribute information from a drawing and save it to a separate text file 
for use with a database program. You can save the file in any of the following for-
mats:      

• Comma Delimited Format (CDF) Contains one line for each instance of a block, 
with individual attribute fields separated by commas. Character string fields are 
enclosed with single quotation marks. You must specify a template file when 
extracting to a CDF file.       

• Space Delimited Format (SDF) Contains one line for each instance of a block. 
Each attribute field has a fixed length; there are no separators or character string 
delimiters. You must specify a template file when extracting to a SDF file.       

• Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx 
file) containing all the information about each block, including the insertion 
points, rotation angles, and attribute values. No template file is required.       

Before extracting attributes to a CDF or SDF file, you must create a template file. The 
template file is an ASCII text file that specifies the attribute data fields to be written 
in the extract file. Each line of the template file specifies one attribute field. 
IntelliCAD recognizes 15 different fields, which contain elements such as the block 
name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is 
inserted, and so on. You can include any of these fields. The template file must 
include at least one attribute name.        

Each line in the template file must start with the field name. Block name and inser-
tion-point values must begin with BL:. The next nonblank character must be either a 
C (indicating a character string field) or an N (indicating a numeric field). This char-
acter is then followed by three digits indicating the width of the field (in characters). 
The final three digits indicate the number of decimal places (for numeric fields). In 
the case of character fields, the last three digits must be zeros (000). A typical tem-
plate file is similar to the one shown here:              
    

A Field name.

B Block name. Block names must 
begin with BL:.

C Insertion point. Insertion-point 
values must begin with BL:.

D Attribute tags.

E Number of decimal places for 
numeric fields or 000 for 
character fields.

F Field width for character or 
numeric fields.

G C for character fields; N for 
numeric fields.

A

B

C

D

E
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To create a template file

1 Create a template file using any ASCII text editor (such as Microsoft® Notepad or 
Microsoft® WordPad) or a word-processing program such as Microsoft® Word.

2 Include the necessary fields in the template file.

3 Save the template file in ASCII text format.

To extract attribute information 

1 Do one of the following:

• Choose Tools > Extract Attributes.

• On the Tools toolbar, click the Extract Attributes tool ( ).

• Type ddattext and then press Enter.

2 Click Select, specify the entities from which to extract attributes, and then press 
Enter.

3 Specify the format of the extracted file.

4 For CDF and SDF formats, specify the template file.

5 Specify the extract output file. 

6 Click Extract.

  

A Click to select blocks in the drawing containing 
attributes you want to extract.

B Click to specify the format of the extracted file.

C Specify the template file for CDF and SDF 
extracts.

D Specify the extract output file.

E Click to extract attributes.

F Click to specify the output file using a file dialog 
box.

G Click to specify the template file using a file 
dialog box.

H Indicates the number of blocks with attributes 
selected for extraction.

A

F

B

C
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G
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Working with external references           

You can link entire drawings to the current drawing as external references. Unlike 
inserting a drawing as a block, in which you add all the entities from the separate 
drawing into the current drawing, external references attach a pointer to the external 
file. The entities in the external reference appear in the current drawing, but the enti-
ties themselves are not added to the drawing. Thus, attaching an external reference 
does not significantly increase the size of the current drawing file.        

External references provide additional capabilities not available when you insert a 
drawing as a block. When you insert a drawing as a block, the entities are stored in 
the drawing. Any changes you make to the original drawing are not reflected in the 
drawing in which you inserted it. When you attach an external reference, however, 
any changes you make to the original drawing file are reflected in the drawings that 
reference it. These changes appear automatically each time you open the drawing 
containing the external reference. If you know that the original drawing was modi-
fied, you can reload the external reference anytime you’re working on the drawing.    

External references are useful for assembling master drawings from component draw-
ings. Use external references to coordinate your work with others in a group. External 
references help reduce drawing file size and ensure that you are always working with 
the most recent version of a drawing. However, if you send or receive drawings that 
contain external references, it is important to include with the master drawing all of 
the external references attached to it. When you open a drawing that contains external 
references, the source external reference files must be accessible for the external ref-
erences to display in the drawing.     

The Xref Manager helps you easily attach and work with external references.
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Attaching external references
Attaching a separate drawing to the current one creates an external reference. The 
external reference appears in the drawing as a block definition, but the drawing enti-
ties are linked rather than added to the current drawing. If you modify the linked 
drawing, the current drawing that contains the external reference is updated automati-
cally when you open it, or you can reload the external reference manually so it 
reflects the latest version of the external reference.            

When you attach an external reference, its layers, linetypes, text styles, and other ele-
ments are not added to the current drawing. Rather, these elements are also linked 
from the referenced file. 

A Click to display a detailed list or hierarchical tree. 

B Select an external reference to modify its 
attachment.

C Type or click Browse to specify the external 
reference location. 

D Type or click Browse to specify other search 
directories where external references may be 
located.

E Click to open the source drawing for the external 
reference.

F Click to make the external reference a permanent 
part of the drawing.

G Click to remove the external reference, but keep 
elements and path information for easy reloading.

H Click to update with changes from the external 
reference.

I Click to completely remove the external reference.

J Click to link a drawing.

A
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There are two ways you can attach an external reference:

• An attachment is an inserted drawing that contains a link to the original file. 
Attachments can themselves contain other, nested reference files. When you 
attach an external reference, any nested references contained in the file also appear 
in the current drawing.  

• An overlay is an inserted drawing that contains a link to the original file. Overlays 
allow you to lay a drawing on top of another drawing, similar to the way you work 
manually with transparencies. When a drawing that contains overlaid external ref-
erences is itself attached or overlaid as an external reference in another drawing, 
the overlays do not appear as part of the external reference. Use overlaying when 
you want to see reference geometry in a drawing but you do not need to include 
that geometry in drawings that will be used by others (nested external references).         

You can attach as many copies of an external reference file as you want. Each copy 
can have a different position, scale, and rotation angle.      

To attach an external reference           

1 Do one of the following:

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Click Attach. 

3 Specify the drawing file to attach as an external reference, and then click Open.

4 In Reference Type, choose how you want to insert the drawing:

• Attachment – inserts a copy of the drawing and includes any other drawings that 
are externally referenced within the referenced drawing.

• Overlay – lays a copy of a drawing over your original drawing; it does not 
include any nested external references from the externally referenced drawing. 

5 Make any additional selections.

6 Click OK.

7 If you marked Specify On-Screen for any items, follow the prompts to attach the 
external reference.
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Viewing the list of external references
You can view a list of the external references that are linked to the current drawing 
two different ways using the Xref Manager:    

• List View displays the external references in a list, which allows you to sort the list 
of references by name, status, size, type, date, or saved path.

• Tree View displays a hierarchical representation of the external references and the 
relationships between them. The tree view shows the level of nesting relationships 
of the attached external references.

To view a list of external references

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Click List View ( ) or Tree View ( ).

A Displays the external reference to attach, or select 
one from the list. 

B Select to save the folder location of the referenced 
drawing. If not selected, the referenced drawing 
must be located in the same folder as the current 
drawing.

C Click Attachment to link a drawing, including any of 
its own external references. Click Overlay to link a 
drawing, omitting any of its own nested external 
references.

D Choose to specify the insertion point in the 
drawing, or enter x-, y-, and z-coordinates.

E Choose to specify the scale in the drawing, or enter 
x-, y-, and z-scale factors.

F Choose to specify the rotation angle in the drawing, 
or enter a rotation angle.

G Click to locate and select a different external 
reference.

A
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Opening external references
From the Xref Manager you can quickly open the source drawing for any external 
reference. This is especially helpful if you are working with nested external refer-
ences, which you cannot bind or detach. From the Xref Manager, open the source 
drawing, make changes, and then save and close the source drawing. When the Xref 
Manager displays again, simply reload the external reference.

To open an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to open.

3 Click Open.

Removing external references 
Removing external references from the current drawing is easy with the Xref Man-
ager. You can unload an external reference, which keeps some information about the 
external reference in the current drawing for easy reloading later, or you can detach 
the external reference entirely.  

When you unload an external reference, you remove it from the current drawing. 
However, its elements, such as layers and linetypes, remain in the drawing and it is 
still listed in the Xref Manager. By detaching an external reference you remove it and 
all of its elements from the current drawing, and it is no longer listed in the Xref Man-
ager.

To unload an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to unload.

3 Click Unload.
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To detach an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to detach.

3 Click Detach.

NOTE Only the external references that are attached directly to the current drawing 
can be detached; nested external references cannot be detached.

Reloading external references
When you open or print a drawing, any external references in the drawing are updated 
automatically. If a drawing is already open and a referenced drawing is modified, you 
can update the current drawing manually to display the latest version of the refer-
enced drawing.     

You may also want to reload an external reference that has been unloaded tempo-
rarily.

To reload an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to reload.

3 Click Reload.
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Changing the path for external references
If the file associated with an external reference is moved to a different directory or 
renamed, the program displays a message indicating that it cannot load the external 
reference. You can re-establish the link to the file by doing any of the following:

• Change the path for the external reference.          

• Specify additional directories for IntelliCAD to search. This is especially helpful 
if you have several external references that have moved to a new directory.

To change the path for a single external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Select the external reference whose path you want to change.

3 In Xref Path, do one of the following:

• Enter a new filename or location. 

• Click Browse to locate and select the referenced drawing.

IntelliCAD reloads the specified external reference automatically.

NOTE You cannot recursively reference a drawing from the same original drawing.

To change the search paths for all external references in the drawing

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 In Additional Xref Search Paths, do one of the following:

• Enter a new directory and its path. Separate multiple paths with a semicolon, for 
example, c:\My Drawings;d:\My Drawings\Backup.

• Click Browse to locate and select a directory. 

IntelliCAD searches the specified directories; any found external references are 
reloaded automatically.
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Binding external references to drawings
External references are not part of the drawing. Rather, they are links to an externally 
referenced file. To provide a copy of a drawing containing external references to 
someone else, you must also provide all the external reference files. In addition, the 
person receiving the drawings must either re-create the same paths you used when 
linking the external references or change the paths for the external references.            

To provide a copy of a drawing that contains external references, it is often easier to 
first bind the external references to the drawing. Binding the external references 
makes them a permanent part of the drawing, which is similar to inserting a separate 
drawing as a block.

You can bind external references that are attached directly to the current drawing; you 
cannot bind nested external references.

To bind an existing external reference to a drawing

1 Do one of the following: 

• Choose Insert > Xref Manager.

• On the Tools toolbar, click the Xref Manager tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to bind.

3 Click Bind. 

4 Choose one of the following:

• Bind Binds the external reference and creates a unique name for each named 
entity, such as a layer or block, that is located in the external reference. For 
example, a layer named Electric in the external reference will be named 
Xref$0$Electric in the current drawing. If the current drawing already has a 
layer or block with the same name, the name is changed incrementally, for 
example, Xref$1$Electric.

• Insert Binds the external reference, but does not change the names of any named 
entities in the external reference. For example, a layer named Electric in the 
external reference will have the same name, Electric, in the current drawing. If 
the current drawing has a layer or block with the same name, the named entity 
in the external reference takes on the properties of the named entity in the 
current drawing.

5 Click OK.
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Clipping external references 
When you attach a drawing as an external reference, all of the referenced drawing 
displays in the current drawing. However, after you attach an external reference, you 
can define a clipping boundary that determines which portion of the referenced draw-
ing is visible or hidden.

You can edit, move, or copy clipped external references the same way you modify 
unclipped external references. The boundary moves with the reference. If an external 
reference contains nested clipped external references, they also appear clipped in the 
drawing. 

TIP In addition to clipping external references, you can also partially hide blocks 
using clipping boundaries.

Example of an external reference clipped using a clipping boundary. The clipping boundary is the rectangle 
in the top window.
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Adding a clipping boundary
When you create a clipping boundary, it affects only the display of the referenced 
drawing; it does not affect the original referenced drawing or any referenced geome-
try. The portion of the external reference within the clipping boundary is visible and 
the remainder of the external reference becomes hidden.

To define a rectangular clipping boundary

1 Do one of the following:

• Choose Modify > Xref Clip.

• Type xclip and then press Enter.

2 Select the external references to clip. If desired, you can also select blocks.

3 Press Enter.

4 Press Enter to create a new clipping boundary.

5 If prompted, press Enter to delete any existing boundaries.

6 Choose Rectangular.

7 Define the first corner of the clipping rectangle.

8 Define the second corner of the clipping rectangle.

The selected external references are clipped by the rectangle.

TIP You can first select all external references, right-click the selection, and then 
select Xref Clip from the shortcut menu.

To define a clipping boundary using a polyline

1 Draw a polyline where you want to clip external references.

2 Do one of the following:

• Choose Modify > Xref Clip.

• Type xclip and then press Enter.

3 Select the external references to clip. If desired, you can also select blocks.

4 Press Enter.

5 Press Enter to create a new clipping boundary.

6 If prompted, press Enter to delete any existing boundaries.

7 Choose Select Polyline.

8 Select the polyline to use as clipping boundary.
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Turning clipping boundaries on and off
You can turn xref clipping on or off. When a clipping boundary is turned off, the 
boundary does not display and the entire external reference is visible, provided that 
the geometry is on a layer that is on and thawed. When a clipping boundary is turned 
off, it still exists and can be turned on. However, deleting a clipping boundary is per-
manent.  

To turn clipping boundaries on and off

1 Do one of the following:

• Choose Modify > Xref Clip.

• Type xclip and then press Enter.

2 Select the desired external references.

3 Press Enter.

4 To turn off clipping boundaries, choose Off. To turn on existing clipping bound-
aries, choose On.

5 Press Enter. 

If you are turning off a clipping boundary, click the clipped portion of the external 
reference to view the previously hidden portion of the referenced drawing.

TIP When the XCLIPFRAME system variable is on (set to 1), you can select and print 
the clipping boundary frame.

Deleting a clipping boundary
If you no longer need a clipping boundary for an external reference, you can delete it.

To delete a clipping boundary

1 Do one of the following:

• Choose Modify > Xref Clip.

• Type xclip and then press Enter.

2 Select the desired external references.

3 Press Enter.

4 Choose Delete, and then press Enter.

5 Click the clipped portion of the external reference. 

The previously hidden portion of the referenced drawing displays.    
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Printing drawings

You can print a copy of your drawing exactly as you created it, or you can add 
formatting and specify print controls to change how your drawing looks when it is 
printed.

Sometimes you may require multiple printed drawings, each with a different look or 
layout. For example, you may need one printed drawing for a client presentation, 
along with several other variations for production contractors. For each type of 
printed drawing that you require, you can create a layout that defines its 
characteristics, including scale, area to print, print style tables, and more.

This section explains how to:

• Start printing right away.

• Set up a drawing to print multiple layouts from paper space on a Layout tab.

• Define how you want your drawing to look when it is printed.

• Print or plot your drawing.  

Topics in this chapter

Getting started printing......................................................................................360

Defining layouts for printing...............................................................................361

Customizing print options..................................................................................373

Printing or plotting your drawing........................................................................391
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Getting started printing

When you create a drawing, you do most of your work on the Model tab. At any time 
you can print your drawing to see how it looks on paper. It’s easy to get started print-
ing, and then later create layouts and custom print settings to enhance your printed 
output.

To start printing

1 From the Model tab, do one of the following:

• Choose File > Print.

• On the Standard toolbar, click the Print tool ( ).

If you click the Print tool, the Print dialog box does not display. Your drawing 
will be sent directly to the selected printer.

• Type print and then press Enter.

2 Click Print.

There are many options that you can set before printing, such as the scale of the draw-
ing, print area, print style tables, and more. For details, see “Customizing print 
options” on page 373 in this chapter. 

NOTE Type qprint and then press Enter to print the current viewport. The Print dialog 
box is bypassed and the drawing is sent directly to the selected printer.
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Defining layouts for printing

You can print your drawing directly from the Model tab where you created it, or you 
can create custom layouts for printing on Layout tabs. 

When printing from the Model tab, you can print your drawing exactly the way it 
appears, or you can modify the drawing before printing by adding dimensions, a leg-
end, or a title block.

You typically use the Layout tabs for printing if you require multiple print layouts. 
You may also want to use a Layout tab for printing even if you want your drawing 
printed only one way. For example, if you want to include large amounts of text on 
your printed drawing, you can add the text to a Layout tab so it does not clutter your 
drawing while you work on the Model tab.

Understanding layouts
When you create a drawing, you do most of your work on the Model tab. Each draw-
ing that you create can contain numerous layouts that simulate the paper on which 
you will print a copy of the drawing. Each of these layouts is created on a Layout tab.

You can prepare a separate layout for each way you want to print your drawing. The 
layout allows you to organize different views to control which portion of your draw-
ing prints and at what scale. 

Before you print, you can also include additional entities and layout settings that con-
trol how your drawing prints. Additional items only appear on the Layout tab, not on 
the Model tab. For example, a layout can contain dimensions, title blocks, legends, or 
keynotes that print with your model, but do not clutter the screen when you work with 
your model on the Model tab.

Use these general steps to prepare your drawing for printing multiple layouts:

1 On the Model tab, create your drawing.

2 Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can 
create a new Layout tab. For details about creating a new layout, see “Creating a 
new layout” on page 365 in this chapter. 

3 Create at least one layout viewport on the Layout tab. Use each viewport to help 
control which portion of the drawing prints and at what scale. For details, see 
“Working with layout viewports” on page 368 in this chapter. 

4 Include any additional items that may be required for the specific layout, such as 
dimensions, a legend, or a title block.

5 Specify additional settings for the layout, such as the scale of the drawing, print 
area, print style tables, and more. For details, see “Customizing print options” on 
page 373 in this chapter. 

6 Print or plot your drawing. For more details, see “Printing or plotting your draw-
ing” on page 391 in this chapter. 
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Understanding paper space and model space
When you start a drawing session, your initial working area is called model space. 
Model space is an area in which you create two-dimensional and three-dimensional 
entities based on either the World Coordinate System (WCS) or a user coordinate 
system (UCS). You view and work in model space while using the Model tab.

Your view of this area is a single viewport that fills the screen. You can create addi-
tional views on the Model tab, called viewports, which can show the same or differ-
ent two-dimensional or three-dimensional views, all of which are displayed in a tiled 
manner. You can work in only one of these viewports at a time on the Model tab, and 
you can print only the current viewport.                     
  

IntelliCAD provides an additional work area, called paper space. The contents of 
paper space represent the paper layout of your drawing. In this work area, you can 
create and arrange different views of your model similar to the way you arrange detail 
drawings or orthogonal views of a model on a sheet of paper. You can also add 
dimensions, keynotes, annotations, borders, title blocks, and other print-related 
entities in paper space, which reduces clutter when you work with your model in 
model space.              

You view and work in paper space while using a Layout tab. Each view, or layout 
viewport, that you create in paper space provides a window of your drawing in model 
space. You can create one layout viewport or several. You can place layout viewports 
anywhere on the screen; their edges can be touching or not; and you can print them all 
at the same time. 

Model space with two viewports.
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You do not need to use paper space to print your drawing, but it offers several advan-
tages: 

• Print the same drawing with different print settings that you save with each layout, 
for example, printer configuration files, print style tables, lineweight settings, 
drawing scale, and more.

• Add print-related entities that are not essential to the model itself, such as key-
notes or annotations, to reduce clutter when you work with your model in model 
space on the Model tab.

• For a single layout, create multiple layout viewports that print the model at differ-
ent views and scales.       

     

Paper space with layout viewports.
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Viewing drawings in paper space and model space
When you work in paper space on a Layout tab, you can still view your drawing in 
model space. First you need to create a layout viewport in paper space; this allows 
you to view your model space entities from paper space. 

Within a layout viewport you can modify and snap to model space entities while 
working in model space and even snap to model space entities from paper space. 
Snapping to model space entities from paper space allows you to accurately dimen-
sion model space entities in paper space. And although it is generally more conve-
nient to modify entities on the Model tab, there are often times when it is convenient 
to make modifications from a layout viewport on a Layout tab.

Zooming or panning the drawing in model space or paper space affects the entire 
drawing, unless you use multiple windows or viewports. Additionally, if you are 
working from paper space, you can lock the layout viewport so the viewport scale and 
view center do not change while panning and zooming in the layout viewport.

To view a drawing in model space on the Model tab       

Do one of the following:

• Click the Model tab.

• Right-click the Model/Paper Space toggle in the status bar, and then choose 
Model.

To view a drawing in paper space on a Layout tab   

Do one of the following:    

• Click one of the Layout tabs. 

• Type layout and then press Enter. In the prompt box, choose Set. Type a name for 
the layout you want to make current, and then press Enter.

• Double-click the Model/Paper Space toggle in the status bar. For example, double-
click “Model” or “M:Tab Name” in the status bar to switch to paper space.

• While using a Layout tab, type pspace and then press Enter. 

• While using a Layout tab, double-click outside of the layout viewport.

The first time you switch to a Layout tab, your drawing seems to disappear. This is 
normal. You must create at least one layout viewport to see your model. For details, 
see “Working with layout viewports” on page 368 in this chapter.         
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To view a drawing in model space on a Layout tab       

Do one of the following:

• Click the desired Layout tab, and then create and view a layout viewport. For more 
details, see “Working with layout viewports” on page 368 in this chapter. 

• Double-click the Model/Paper Space toggle in the status bar. For example, double-
click “P:Tab Name” in the status bar to switch to model space on the current Lay-
out tab.

• Type mspace and then press Enter.

• While using a Layout tab, double-click inside of the layout viewport.

Displaying the Model and Layout tabs
The Model and Layout tabs can be hidden, if desired. You may want to hide the tabs 
if you only work on the Model tab or if you use the command bar and status bar to 
switch between tabs.      

To turn the Model and Layout tabs display on or off

Do one of the following:

• Choose View > Model and Layout tabs.

• Choose Tools > Options > Display tab, and choose Show Tabs.

Creating a new layout
In IntelliCAD, you can create multiple layouts for a single drawing. Each layout rep-
resents a sheet of paper. For each layout you can specify the print area, print styles, 
print scale, lineweight scale, pen mappings, and add viewports, dimensions, a title 
block, and other geometry specific to the layout. The entities you add to a layout in 
paper space do not appear in model space.

Each layout requires at least one layout viewport. This viewport displays the draw-
ing’s model space entities. 

When you create a new drawing, the drawing automatically contains two default lay-
outs: Layout1 and Layout2. You can start by using one of the default layouts, you can 
create your own, or your can create a new layout from another template (.dwt) file, 
drawing (.dwg) file, or drawing interchange (.dxf) file. 

Each drawing can contain up to 255 layouts.

To create a new layout using the Layout1 or Layout2 tab

1 Click the Layout1 or Layout2 tab.

2 Set up at least one layout viewport. For details, see “Working with layout view-
ports” on page 368 in this chapter. 

3 If desired, rename the layout. For details, see “To rename a layout” on page 367 in 
this chapter. 
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To create a new layout using a new Layout tab 

1 Do one of the following:

• Choose Insert > Layout > New Layout.

• On the Layouts toolbar, click the New Layout tool ( ).

• Type layout, press Enter, and choose New. 

2 Type a unique name for your layout and then press Enter.

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

3 Set up at least one layout viewport. For details, see “Working with layout view-
ports” on page 368 in this chapter. 

To create a new layout from an existing file

1 Do one of the following:

• Choose Insert > Layout > Layout from Template.

• On the Layouts toolbar, click the Layout from Template tool ( ).

• Type layout, press Enter, and choose Template. 

2 Select the desired template, drawing, or drawing interchange file that contains the 
layout you want, and then click Open.

3 Select the layout(s), and then click OK. You can choose multiple layouts by hold-
ing down Ctrl while selecting layout names.

Reusing layouts from other files
Save time by re-using layouts that you have already created. Within the same draw-
ing, you may want to make a copy of a layout that contains most of the settings you 
want, and then make changes to the new copy. If you created layouts that you want to 
use again when you create new drawings, you can save the layouts as a drawing tem-
plate. 

To make a copy of a layout

1 Type layout and then press Enter. 

2 In the prompt box, choose Copy.

3 Type the name of the layout you want to copy, and then press Enter.

4 Type a name for the new layout, and then press Enter.

To save a layout as a drawing template

1 Type layout and then press Enter.    

2 In the prompt box, choose Save.

3 Type the name of the layout that you want to save, and then press Enter.

4 Specify the file name and location for the template, and then click Save.
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After you save a layout as a template, you can use the template when you create new 
drawings. You can also import the template’s layouts into another drawing.

Managing layouts in a drawing
You can rename layouts, delete layouts, and view a list of all layouts available in a 
drawing. You can also change the order in which the Layout tabs appear; the Model 
tab is always stationary. 

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, 
you can type layout to make your changes or choose View > Model and Layout Tabs 
to display the tabs.

To rename a layout 

1 Right-click the Layout tab to rename.

2 Type a new name for the layout.

3 Click OK.

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

To delete a layout 

1 Right-click the Layout tab to delete.

2 Click OK to confirm the deletion.

NOTE You cannot delete the Model tab or the last remaining Layout tab. To delete all 
geometry from the Model tab or a Layout tab, first select all geometry and then use 
the Erase command.

To reorder the Layout tabs  

1 Right-click the Layout tab you want to move.

2 Do one of the following:

• Choose Move Right, and then choose a new location.

• Choose Move Left, and then choose a new location.

To view a list of all layouts 

1 Type layout and then press Enter.

2 In the prompt box, choose ? to list all layouts.

3 Type s or press Enter to scroll through the layouts.
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Working with layout viewports
When you begin working in a drawing on the Model tab, it consists of a single view 
of your model. You may have created additional views by dividing the drawing space 
into multiple windows; each window is a separate viewport on the Model tab.       

On a Layout tab, you must create at least one layout viewport to see your model. 
However, you can create multiple layout viewports that display unique views of your 
model located in model space. Each layout viewport functions as a window into your 
model space drawing — with each window looking different from the next. You can 
customize the view center, scale, layer visibility, and contents of each layout view-
port. Each layout viewport is created as a separate entity that you can move, copy, or 
delete.     

Click any layout viewport to make it the current viewport, and then add or modify 
model space entities in that viewport, even while snapping to model space entities 
from paper space. Any changes you make in one layout viewport are immediately 
visible in the other viewports (if the other layout viewports are displaying that portion 
of the drawing). Zooming or panning in the current viewport affects only that view-
port.               

This section focusses on working with layout viewports in paper space on a Layout 
tab. For additional information about viewports in model space, see “Dividing the 
current window into multiple views” on page 147. 

Creating layout viewports
The first time you switch to a Layout tab, all of your model space entities disappear. 
You must create at least one layout viewport on the Layout tab to see your work. 

You can create layout viewports anywhere inside the drawing area. You can control 
the number of viewports created and the arrangement of the viewports.            

To create layout viewports

1 Do one of the following:

• Choose View > Layout Viewports.

• On the Views toolbar, click the Layout Viewports tool ( ).

• Type mview and then press Enter.

2 In the prompt box, choose Fit To View, Create 2 Viewports, Create 3 Viewports, 
or Create 4 Viewports, or specify two opposing corners to create a custom view-
port.

3 In the prompt box, choose the viewport orientation.

4 Do one of the following:

• To arrange the viewports to fill the current graphic area, in the prompt box, 
choose Fit To Screen.

• To fit the viewports within a bounding rectangle, specify the corners of a 
rectangle.
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TIP When you create a layout viewport, the layout viewport border is created on the 
current layer. You can make layout viewport borders invisible by creating a new 
layer before you create layout viewports and then turning off that layer after you cre-
ate the layout viewports. To select a layout viewport’s borders, you must turn that 
layer back on before you can rearrange or modify the layout viewport.

Viewing and scaling layout viewports
If you have created numerous layout viewports, your system performance may be 
affected. If necessary, you can turn a layout viewport on or off. Turning off a layout 
viewport does not delete the viewport or its contents; it simply turns off its display. 

You can also change how you view items within a layout viewport by specifying a 
scale factor, which changes how large or small model space entities appear within the 
layout viewport. 

You can create a single layout viewport, or you can divide the graphic area into two viewports arranged 
vertically (A) or horizontally (B); three viewports arranged left (C), right (D), above (E), 
below (F), vertically (G), or horizontally (H); or four viewports (I).

A B C

D E F

G H I
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To turn layout viewports on or off 

1 Click the desired Layout tab.

2 Do one of the following:

• Choose View > Layout Viewports.

• On the View toolbar, click the Layout Viewports tool ( ).

• Type mview and then press Enter.

3 Choose On or Off.

4 Select the edge of the layout viewport to turn on or off, and then press Enter.

To change the layout viewport scale 

1 Do one of the following:

• Choose Modify > Properties.    

• On the Modify toolbar, click the Properties tool ( ).

• Type entprop and then press Enter.

2 Select the edge of the layout viewport. 

3 In Scale, enter the scale at which you want to view model space entities from 
within the layout viewport.

4 Click OK.

To change the scale of model space entities relative to paper space  

1 Click the Model tab. 

2 Click a viewport to make it current.

3 Choose View > Zoom > Zoom.

4 Type the zoom scale factor relative to paper space by appending the suffix xp to 
the scale factor, and then press Enter. 

For example, to increase the scale of the entities in the viewport on the Model tab 
to twice the size of paper space units, type 2xp. To decrease the scale to half the 
size of paper space units, type .5xp.



P R I N T I N G  D R A W I N G S 371
Modifying layout viewports
After you create layout viewports, you can modify them as needed. On the Layout 
tab, you can snap to the viewport borders using entity snaps. You can copy, delete, 
move, scale, and stretch layout viewports as you would any other drawing entity. 

Additionally, you can lock a layout viewport so the viewport scale and view center do 
not change in model space while panning or zooming in the layout viewport. If you 
are working on model space entities from a Layout tab, locking the layout viewport 
prevents you from constantly changing the layout viewport scale and view center.

And assigning a UCS to each viewport allows you to quickly switch between layout 
viewports and immediately draw in a different UCS. This can greatly increase pro-
ductivity, especially when creating complex 3D models.

Modifying a layout viewport on a Layout tab does not affect the model space entities 
within the layout viewport.

To modify layout viewport properties

1 Click the desired Layout tab.

2 Do one of the following:

• Choose Modify > Properties.    

• On the Modify toolbar, click the Properties tool ( ).

• Type entprop and then press Enter.

3 Select the edge of the layout viewport you want to modify.

4 Adjust the center point, width, or height of the viewport.

5 In Scale, enter the scale at which you want to view model space entities from 
within the layout viewport.

6 Mark Lock Viewport to lock the viewport scale and view in model space while 
panning or zooming in the layout viewport.

7 Mark UCS per Viewport if you want to use a unique UCS for each layout view-
port.

8 Click OK.

NOTE You can select only layout viewports for modification. If you click a viewport 
on the Model tab, it makes that viewport active, not available for modification.  
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A Enter the center point of the layout viewport.

B Enter the width of the layout viewport.

C Enter the height of the layout viewport.

D Enter the scale used for viewing model space 
entities from within the layout viewport.

E Mark to use a unique UCS for each layout viewport.

F Mark to lock the viewport scale and view in model 
space while panning or zooming in the layout 
viewport.

G Click to select the center of the layout viewport in 
the drawing.

A

B
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G
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Customizing print options

Before you print, you can set up many aspects of printing: 

• Specify paper size and orientation.

• Select and configure a printer or plotting device.

• Specify the view and scale of a printed drawing, including which portion of a 
drawing to print, the print scale, and the origin of the print area.

• Choose whether to print and scale lineweights.

• Choose whether to implement print style tables to control colors, pen widths, line-
types, and lineweights.

• Open printer configuration (PCP) files; create and save PCP files.

Setting the paper size and orientation 
You can specify a paper size and paper orientation for all drawings. 

To select the paper size and orientation   

1 Do one of the following:

• Choose File > Print Setup. 

• Type psetup and then press Enter.

• Type print and press Enter, and then click Print Setup.

2 Select the paper size and paper orientation, and then click OK.

You can also adjust the orientation by printing a drawing upside down on the paper. 
Each layout in your drawing can specify whether to print upside down.      

To print a drawing upside down

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Advanced tab.

4 Select Print Upside Down.

5 Select Save Changes to Layout, and then click Apply to save your changes.
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Selecting a printer or plotter
You can specify a printer or plotter to be used when printing any drawing. You can 
print your drawing on any printer or plotter that is compatible with Windows, includ-
ing raster printers. 

To select a printer or plotter               

1 Do one of the following:

• Choose File > Print Setup. 

• Type psetup and then press Enter.

• Type print and press Enter, and then click Print Setup.

2 From the Printer Name list, select a printer or plotter, and then click OK.

Setting the scale and view
You can print or plot the entire drawing or a selected portion, depending on which 
options you select in the Print dialog box. You can choose to print what is visible on 
the screen, or you can specify to print an area of the drawing.

You can control the position of the drawing on the paper by specifying the origin of 
the print area, the location of the lower left corner of the print area, in relation to the 
lower left corner of the paper. The origin is normally set to 0,0, which places the 
lower left corner of the print area as close to the lower left corner of the paper as the 
printer or plotter will allow. You can specify a different origin, however, by 
specifying different coordinates.

When you create a drawing, you generally draw entities full-size. When you print the 
drawing, you can specify the scale of the resulting print or let the program adjust the 
size of the drawing to fit the paper. To print the drawing at a specific scale, specify 
the scale as a ratio of drawing units to printed units.

If you are printing from a Layout tab, the scale and view options you specify can be 
different for each layout that you create.

To automatically scale the drawing for printing

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Scale/View tab.

4 To scale the drawing to fit on one printed page, in Print Scale, select Scale to Fit.

5 Select Save Changes to Layout, and then click Apply to save your changes.
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To specify the scale factor yourself

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Scale/View tab.

4 In Print Scale, do one of the following:

• Select a pre-defined scale. For example, choose 1:2 if you want 1 printed unit 
(inch or millimeter) to equal 2 drawing units.

• Select Custom, and then under User Defined Scale, type the ratio of printed units 
of measure (inches or millimeters) to drawing units.

5 To specify the printed units of measure, click Inches or Millimeters.

6 Select Save Changes to Layout, and then click Apply to save your changes.

To specify a portion of the drawing to print 

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Scale/View tab.

4 Under Print Area, click one of the following:

• Current View – prints the view on the screen.

• Saved View – prints the selected saved view.

• Extents – prints the area that contains entities in the drawing.

• Limits – prints to the limits defined for the layout or drawing.

• Window – prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing.

If you clicked Window, you must specify the window. Under Windowed Print 
Area, enter the diagonal x- and y-coordinates of the window, or select the area on 
the screen. 

To print only the area in the window without considering whether there is extra 
space on the screen, select the Print Only Area Within Specified Window check 
box.

5 Under Entities To Print, click one of the following:

• All Entities Within Print Area – prints all drawing entities contained within the 
specified print area.

• Selected Entities Within Print Area – prints only the entities you select from 
within the specified print area. 
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6 Select Save Changes to Layout, and then click Apply to save your changes.

  

NOTE IntelliCAD saves your print settings each time you print. To restore the Intelli-
CAD default print settings, click Reset in the Print dialog box. 

A Displays either “Model” or the layout name to which 
the print settings apply. 

B Click to select the area of the drawing that you want 
to print.

C Type the x- and y-coordinates of the two opposing 
corners of the rectangular area to print; or, to 
specify coordinates in the drawing window, click 
Select Print Area.

D Select to print the area of the window while ignoring 
the aspect ratio to the remainder of the drawing.

E Click to specify drawing units and paper size in 
millimeters or inches.

F Specify the custom scale for the print area by typing 
the ratio of drawing units to printed inches or printed 
millimeters. (Available only if Custom is selected for 
Print Scale.)

G Select to fit the specified print area to the current 
paper size, select a scale ratio, or select to specify 
your own custom scale in User Defined Scale.

H Click to print only selected entities within the 
specified print area.

I Click to print all entities within the specified print 
area.

J Select to save the print settings for the model or 
layout.

K Select to print using the current print settings or 
using the settings from the last time you printed. 
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To specify the print area origin

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Origin of Print Area, do one of the following:

• To center the specified print area on the printed page, select the Center on Page 
check box.

• To specify an origin for the print area, type the x- and y-coordinates, or click 
Select Origin and then specify a point on the drawing.

5 Select Save Changes to Layout, and then click Apply to save your changes.

Choosing how lineweights print
If entities are assigned lineweights, you can control whether they print with the 
assigned lineweights. If you turn off lineweight printing, entities print with a default 
outline. You can also control whether lineweights print in proportion to the scale you 
set on the Scale/View tab.

Each layout in your drawing can specify whether to print and scale lineweights. 

To set lineweight options    

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print. 

• Type print and press Enter.

3 Click the Advanced tab.

4 Choose how you want to print lineweights:

• Print Lineweights – prints entities with their assigned lineweights. If not 
selected, entities print with a default outline.

• Scale Lineweights – prints lineweights in proportion to the scale you set on the 
Scale/View tab. If not selected, lineweights print at their assigned size without 
adjustments for the print scale. (A Layout tab must be active to scale 
lineweights.)

5 Select Save Changes to Layout, and then click Apply to save your changes.

NOTE Print styles can also affect how lineweights print. For details, see the next sec-
tion.
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NOTE IntelliCAD saves your print settings each time you print. To restore the Intelli-
CAD default print settings, click Reset in the Print dialog box. 

A Displays either “Model” or the layout name to which 
the print settings apply. 

B Select a print style table.

C Click to load print settings from a PCP file.

D Click to save the current configuration as a PCP 
file.

E Select to print the drawing upside down on your 
printer.

F Select to print entities with their assigned 
lineweights.

G Select to print lineweights in proportion to the scale 
you set on the Scale/View tab. (A Layout tab must 
be active.)

H Click to specify the print area origin by selecting a 
point within the drawing.

I Type x- and y-coordinates to specify the origin of 
the print area.

J Select to center the print area on the page.

K Click to make changes to the selected print style 
table.

L Click to create a new print style table.

M Select to save the print settings for the model or 
layout.

N Select to load print settings from the current layout 
(or model) or the last time you printed. 
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Using print styles
IntelliCAD uses print styles to change the appearance of your printed drawing with-
out modifying the actual entities in your drawing. Assigning print styles allows you to 
customize the color, pen width, linetype, and lineweight that are used to print your 
drawing.  

Print styles help you control what your drawing looks like when it is printed. Rather 
than describe what an entity looks like on your screen, print styles describe what an 
entity will look like when you print it. For example, you can map all yellow entities in 
your drawing to print in blue without modifying the actual entities. You could also 
map all yellow entities to print with whatever lineweight, linetype, or pen width that 
you specify.

Because print styles are saved in print style tables, which are files located on your 
computer, disk, or server, you can reuse them to help eliminate the need to reconfig-
ure your print settings each time you print a drawing. For example, you may have 
multiple clients who have their own printing preferences. You can save print styles in 
a named file for each of your clients. You can even share the file with co-workers, or 
store the files on a network to ensure that everyone in your office uses the same stan-
dards.

Understanding print style tables
A print style table is a collection of print styles that allows you to change the appear-
ance of your printed drawing without modifying the actual entities in your drawing. 
Each print style table is saved in a file that can be located on your computer, disk, or 
server.  

A drawing can use one type of print style table at a time. There are two types of print 
style tables:

• Color-dependent print style tables (CTB) contain a collection of print styles based on 
each of the 255 index colors available in a drawing. True colors and color books 
are not applicable to color-dependent print style tables. 

• Named print style tables (STB) contain a collection of print styles that you define. 
They can vary regardless of color. 

With color-dependent print style tables, you cannot assign print styles to individual 
entities or layers. To use these print styles, you assign a specific color to an entity or 
layer. When you specify a color-dependent print style table at printing time, the entity 
colors and layer colors map to color-based print styles in the print style table that you 
specify.

With named print style tables, you can assign named print styles to individual entities 
and layers. Entities and layers assigned print styles are printed according to the print 
style table that you specify at printing time. If you specify a print style for a specific 
entity, that print style overrides any print style assigned to the layer on which the 
entity resides. 
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Sometimes a named print style assigned to an entity or layer is not located in the print 
style table that is assigned to a layout or drawing. This can happen if the print style 
has been deleted from the named print style table or if you assign a different named 
print style table to the drawing that does not contain the named print style. In this 
case, the entity is printed using its default properties, which is similar to assigning the 
Normal print style to an entity or layer. If you plan on interchanging named print style 
tables within the same drawing, it’s a good idea to coordinate the tables to use the 
same print style names.

If a new drawing is based on a template, the new drawing uses the same type of print 
style table as the template. If a new drawing is created without a template, the type of 
print style table is specified in the New Drawing Wizard; by default, the new drawing 
uses the print style table type specified in Tools > Options on the Printing tab. Every 
drawing is designed to use print style tables, but you decide whether to implement 
them.  

Comparison of print style table types

Color-dependent print 
style table (CTB) Named print style table (STB)

Description Contains pre-defined print styles 
according to color; there is one print style 
for each of the 255 index colors available 
in the drawing. Entities with the same 
color are printed the same way. 

Contains unique print styles that you 
create. Entities with the same color can 
have different print settings. 

Example All blue entities print with a .5 millimeter 
lineweight.

One entity prints with a .7 millimeter 
lineweight; a second blue prints with a .5 
millimeter lineweight.

Number of 
print styles

255 (fixed). At least one (varies).

Print style 
names

Print style names range from “Color_1” 
to “Color_255”. You cannot rename print 
styles. 

You define new print style names. You 
can rename all print styles except the 
Normal print style.

Add, delete, 
and modify 
print styles

You can modify the existing print styles, 
but you cannot add or delete print styles.

You can add and delete print styles. You 
can modify all print styles except the 
Normal print style, which uses the 
default characteristics of the entity.
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Implementing print style tables
Every drawing is designed to use print style tables, but you decide whether to imple-
ment them. Even if you use one of the default print style tables available with Intelli-
CAD, using print style tables requires planning ahead of time to ensure that your 
drawing prints as planned.

For example, a single drawing of a floor plan might require the printing of the follow-
ing drawing sheets:

• Main Floor Plan Walls print with thick, black lines.

• Electrical Plan Walls print with normal gray lines, indicating that they are not the 
focus.

• HVAC Plan Walls print with normal gray lines, indicating that they are not the 
focus.

• Roof Plan Walls print with thin, gray lines and a hidden linetype, indicating that 
they are hidden under the roof in a plan view.

In this example, you can create four named print style tables, each containing a print 
style named “WallPstyle”. Each print style table contains its own settings for 
“WallPstyle” to control how the walls print. Assign WallPstyle to either the wall enti-
ties or to a wall layer. Then, assign a different named print style table each time you 
print, or create four layouts and assign a different print style table to each layout.

The following table describes, in order, the steps to get you started using both color-
dependent and named print style tables.

Create 
additional 
tables

Yes. Yes.

Assignment Current print style: New entities always 
assigned BYCOLOR.

Print styles: Assigned to colors in the 
print style table.

Print style tables: Assigned to a Layout 
tab or the Model tab.

Current print style: Assigned to new 
entities.

Print styles: Assigned to entities and 
layers.

Print style tables: Assigned to a Layout 
tab or the Model tab.

Legacy file 
support

You can import existing printer 
configuration files (PCP) files into the 
print style table. CTB files are similar to 
PCP files primarily used in previous 
versions of IntelliCAD. 

Not applicable.

Comparison of print style table types

Color-dependent print 
style table (CTB) Named print style table (STB)
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Getting started using print style tables

Color-
dependent Named Task Command Where to get details

X X Create a new drawing. Select a drawing 
template that uses the desired print style 
table type or choose it in the New Drawing 
Wizard.

File > New Creating a new drawing, page 40

X X (Optional) Create a new print style table. File > Print Styles Manager Creating new print style tables, 
page 384

X Assign colors to entities and layers that 
correspond with print style table settings.

Modify > Properties
Tools > IntelliCAD Explorer

Setting the current entity color, 
page 45; Modifying the properties 
of entities, page 240; Setting the 
layer color, page 185

X Set the current print style assigned to new 
entities.

Settings > Drawing Settings > 
Entity Creation tab; status 
bar; printstyle

Setting the current print style, 
page 49

X Assign print styles to entities. Modify > Properties; Entity 
Properties toolbar; printstyle

Modifying the properties of 
entities, page 240

X Use IntelliCAD Explorer to assign print 
styles to layers.  

Tools > IntelliCAD Explorer Setting a layer’s print style, page 
189

X X Assign a print style table to the Model tab, 
a layout, or to all layouts in the drawing.

File > Print > Advanced tab Assigning print style tables, page 
383

X X (Optional) Make changes to the assigned 
print style table.

File > Print Styles Manager
File > Print > Advanced tab

Modifying print style tables, page 
385

X X Print the drawing. File > Print Printing or plotting your drawing, 
page 391
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The following table describes how to further customize how print styles work within 
your drawings.

Assigning print style tables
Select a print style table before printing if you want to change how your drawing 
appears when you print it. Print style tables can modify how colors, pen widths, line-
types, and lineweights look when they are printed.

You can assign print style tables globally for all layouts (including the Model tab), or 
individually for the Model tab or a Layout tab. Assigning a print style table to an indi-
vidual layout allows you to further customize the layouts you use to print a drawing. 

However, assigning different named print style tables to various layouts may result in 
mismatched print style names; a named print style assigned to an entity or layer may 
not be located in the assigned print style table at print time. In this case, entities are 
printed using their default properties, which is similar to assigning the Normal print 
style to an entity or layer.

Further customizing print style tables

Task Command Where to get details

Copy, rename, or delete print style 
tables.

File > Print Styles Manager Copy, rename, or delete 
print style tables, page 
387

Change a drawing to use another type 
of print style table, for example, change 
a drawing that uses color-dependent 
print style tables to one that uses 
named print style tables. 

convertpstyles Changing a drawing’s 
print style table type, 
page 387

Convert a color-dependent print style 
table to a named print style table.

convertctb Converting print style 
tables, page 388

Change the default location where print 
style tables are stored.

Tools > Options > Paths/Files 
tab

Changing the options on 
the Paths/Files tab, page 
478

Customize how print styles work with 
new drawings that you create and older 
drawings that you open.

Tools > Options > Printing tab Changing the options on 
the Printing tab, page 488
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To assign print style tables

1 If necessary, click the desired Layout tab, or click the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Print Style Table (Pen Assignments), select a print style table that you cre-
ated or one of the following:

• None — Applies no print style table. Entities print according to their own 
properties.

• Icad — Uses the default print style table and its color assignments.

• Monochrome — Prints all colors as black.  

5 At the prompt, choose Yes to assign the print style table to all layouts in the draw-
ing, including the Model tab, or choose No to assign the print style table only to 
the individual layout listed in Layout Name on the Print dialog box.

6 Select Save Changes to Layout, and then click Apply to save your changes.

NOTE When your drawing was first created it was set up to use either color-depen-
dent or named print style tables. For details on converting a drawing to use a differ-
ent type of print style table, see “Understanding print style tables” on page 379 in 
this chapter. 

Creating new print style tables
IntelliCAD offers several print style tables to help you get started. If you want to cus-
tomize your print output further, you can create your own print style table. You can 
create a new print style table entirely from scratch, based on IntelliCAD registry set-
tings, or by importing a printer configuration file (PCP file).         

To create new print style tables

1 Do one of the following:

• Choose File > Print Styles Manager.

• Type stylesmanager and then press Enter.

2 Double-click Create a Print Style Table.

3 Complete the setup wizard. 

On the last wizard page, you can click Print Style Table Editor to set up the print 
styles for the table. For more details about the Print Style Table Editor options, see 
the next section.
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Modifying print style tables
When your drawing was created, it was set up to use color-dependent or named print 
style tables.  

Color-dependent print style tables (.ctb files) You can modify individual print styles 
within the table, but you cannot add, rename, or delete print styles. Color-dependent 
print style tables always have 255 print styles, each named for a specific color. Your 
changes affect all entities and layers assigned that color.  

Named print style tables (.stb files) You can add, modify, rename, and delete individual 
print styles within the table. However, you cannot modify, rename, or delete the Nor-
mal print style. Your changes affect all entities and layers that are assigned that print 
style name.  

TIP If you can’t remember what type of print style table is assigned to your drawing, 
use the PSTYLEMODE system variable to determine the print style table type.

Each print style within a print style table specifies a color, pen numbers, linetype, and 
lineweight. IntelliCAD recognizes additional characteristics for compatibility with 
AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line 
join style, and fill style.        

When specifying print style characteristics, be sure to consider the limitations of your 
output device.

NOTE It is recommended that you only modify print style tables that you have created. 
If you modify a default print style table that came with IntelliCAD, you overwrite the 
original information which is then lost.

To modify print style tables

1 Do one of the following:

• Choose File > Print Styles Manager.

• Type stylesmanager and then press Enter.

2 Double-click the print style table you want to modify.

3 Click the General tab, and then do any of the following:

• Enter a new table description.

• Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor 
to non-ISO linetypes used for any print style in the current print style table. This 
also applies to fill patterns, which are not used in IntelliCAD, but are recognized 
for compatibility with AutoCAD.

• Enter a scale factor to apply to non-ISO linetypes used for any print style in the 
current print style table.
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4 Click the Properties tab, and then do any of the following:

• Make format changes to a print style by selecting it in the Print Styles list, then 
make color, pen map, linetype, or lineweight changes for the print style. Your 
changes are saved automatically for the selected print style.

• Add a new print style by clicking Add Style. Enter a new name, and then click 
OK. Select the options for the print style. (Available for named print styles 
only.)

• Rename a print style by selecting it in the Print Styles list. Single-click the print 
style again, and then enter a new name. (Available for named print styles only.)

• Delete a print style by selecting it in the Print Styles list. Click Delete Style. 
(Available for named print styles only.)

5 Click OK.

A Select a print style to modify it. 

B Enter a description for the selected print style.

C Click to create a new print style. (Named print 
style tables only.)

D Click to delete the selected print style. (Named 
print style tables only.)

E Click to modify the list of available lineweights for 
the current print style table.

F Click to save the print style table with a new name 
or in a new location.

G Choose a lineweight for the selected print style.

H Choose a linetype for the selected print style.

I Type or scroll to the width of the virtual pen for the 
selected print style (for printers that don’t have 
physical pens, such as laser or inkjet printers).

J Type or scroll to the width of the physical pen for 
the selected print style.

K Choose a color for the selected print style.

A

B

C
D E

F

G

H

I
J

K
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Copy, rename, or delete print style tables
Copy, rename, or delete a print style table just as you would any other file on your 
computer. Regardless of which print style table type your drawing uses, you can use 
the Print Style Manager to manage both color-dependent and named print style tables.

To copy, rename, or delete print style tables

1 Do one of the following:

• Choose File > Print Styles Manager.

• Type stylesmanager and then press Enter.

2 Select a print style table. 

Color-dependent print style tables are .ctb files and named print style tables are 
.stb files.

3 Copy, rename, or delete the print style table just as you would any other file on 
your computer.

Changing a drawing’s print style table type
When your drawing was created, it was set up to use color-dependent print style 
tables (.ctb files) or named print style tables (.stb files). A drawing can use one type 
of print style table at a time. If necessary, after a drawing is created you can convert 
the drawing to use the other type of print style table.     

If you can’t remember what type of print style table is assigned to your drawing, use 
the PSTYLEMODE system variable to determine the print style table type.

To change a drawing to use named print style tables

1 If you want to reuse any of the existing print style information, convert your color-
dependent print style tables to named print style tables. For details, see “To con-
vert a color-dependent print style table to a named print style table” on page 388 in 
this chapter. 

2 Open the drawing that uses color-dependent print style tables (.ctb files).

3 Type convertpstyles, and then press Enter.

4 If you have already converted your individual color-dependent print style tables to 
named tables, click OK in the prompt that displays. 

If you have not converted the tables, click Cancel. First use convertctb to convert 
your color-dependent print style tables to named tables. If you do not, all of the 
print style information you specified in your drawing will be lost. 

5 Select a named print style table (.stb file) that you want to use with the drawing.

6 Click Open.

NOTE If you have not converted a color-dependent print style table to a named print 
style table, you will be warned that the table you have selected does not contain color 
mapping and the drawing cannot be converted.
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To change a drawing to use color-dependent print style tables

1 Open the drawing that uses named print style tables (.stb files).

2 Type convertpstyles, and then press Enter.

3 If you are sure you want to convert the drawing and lose all print style assign-
ments, click OK in the prompt that displays. 

If you do not want to lose the print style assignments, click Cancel.

NOTE Converting a drawing to use color-dependent print style tables will remove all 
of the named print style information from entities and layers. However, the named 
print style tables are not deleted from your computer.

Converting print style tables
You can convert a color-dependent print style table to a named print style table. You 
cannot convert a named print style table to a color-dependent print style table because 
color-dependent tables contain only print styles that are named after the 255 colors to 
which they map.        

Converting a color-dependent print style table to a named print style table can be 
helpful in the following situations:

• You don’t want to create a named print style table from scratch.

• You want to create a named print style table that has the same settings as a color-
dependent print style table, but with some new print styles or other custom set-
tings.

• You want to convert a drawing to use named print style tables and you want to 
reuse most of print styles already defined in a color-dependent print style table.

To convert a color-dependent print style table to a named print style table

1 Type convertctb, and then press Enter.

2 Select the color-dependent print style table (.ctb file) that you want to convert.

3 Click Open.

4 Enter a name for the new named print style table (.stb file).

5 Click Save. 

The print styles in the new table are named Style 1, Style 2, and so on. If want to use 
different print style names, rename the print styles before you assign them to entities 
and layers in your drawing. If you rename the print styles after assigning them, they 
will not match when you print your drawing. For information about renaming print 
styles, see “Modifying print style tables” on page 385 in this chapter. 
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Turning off print style tables
When you turn off print style tables, entities print according to their own properties. 
However, all of the print style information is saved so you can easily turn on print 
styles again. Actual print style table files are not deleted, and for drawings that use 
named print style tables, entities and layers retain their assigned print styles.  

To turn off print style tables

1 If necessary, click the desired Layout tab, or click the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Print Style Table (Pen Assignments), select None.

5 At the prompt, choose Yes to turn off print style tables for all layouts in the draw-
ing, including the Model tab, or choose No to turn off print style tables only for 
the individual layout listed in Layout Name on the Print dialog box.

6 Select Save Changes to Layout, and then click Apply to save your changes.

Reusing print settings
After you set up print settings for a drawing or layout, you can save them and reuse 
them again using printer configuration files. 

Printer configuration files store the printer information you create for specific 
drawings or layouts, which eliminates the need to completely reconfigure your print 
settings each time you print a drawing. Printer configuration files also allow you to 
share and reuse print settings between different drawings and layouts.

IntelliCAD supports the printer configuration (PCP) file format used by AutoCAD. 
This feature makes it possible to use existing PCP files saved in AutoCAD, as well as 
to save your IntelliCAD print configuration settings to a PCP format.

TIP You can convert an AutoCAD PC2 file to PCP format using the Device And 
Default selection feature in the AutoCAD Print dialog box.

The printer configuration files that you specify can be different for each layout that 
you create.
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To save print settings in a PCP file    

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Advanced tab.

4 Specify the desired print settings.

5 Under Printer Configuration File, click Save.

6 Name the file, and then click Save.

To assign a PCP file    

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Printer Configuration File, click Open.

5 Locate and select the PCP file, and then click Open.

6 Select Save Changes to Layout, and then click Apply to save your changes.

PCP files created before IntelliCAD 6 contain obsolete PenMap/Width settings that 
you can convert to use with print style tables. Import the PCP file to create a new 
color-dependent print style table. For details, see “Creating new print style tables” on 
page 384 in this chapter.  

TIP It is easy to reuse print settings from the last time you printed. In the Print dialog 
box under Use Settings, choose Previous Print.
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Printing or plotting your drawing

After you have configured your drawing and any layouts for printing, you are ready 
to print. If desired, you can preview your page before printing.

Previewing a drawing before printing
Viewing a drawing before printing gives you a preview of what your drawing will 
look like when it is printed. This helps you see if there are any changes you want to 
make before actually printing the drawing.

If you are using print style tables, the preview shows how your drawing will print 
with the assigned print styles. For example, the preview may display different colors 
or lineweights than those used in the drawing because of assigned print styles.

To preview a drawing before printing          

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print Preview.

• On the Standard toolbar, click the Print Preview tool ( ).

• Type ppreview and then press Enter.

3 After checking the preview image, do one of the following:

• To print the drawing, click Print Settings to display the Print dialog box.

• To return to the drawing, click Close.
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A Click to zoom in.

B Click to zoom out. If you have zoomed in 
several times, click multiple times to restore 
the entire preview image. 

C Click to display the Print Settings dialog box.

D Click to print the drawing.

E Click to close the preview and return to the 
drawing.

A B C D E
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Printing a drawing    
The Print dialog box is organized by tabs into two functional areas: scaling and view-
ing, and advanced printing options. The print setting options available under each tab 
were described in the previous sections. 

NOTE You cannot print a rendered image directly to a printer. To print a rendered 
image, you must first save the drawing to a different format and then print it from 
another graphics program.

To print a drawing

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Print.

• On the Standard toolbar, click the Print tool ( ).

If you click the Print tool, the Print dialog box does not display. Your drawing 
will be sent directly to the selected printer.

• Type print and then press Enter.

3 From the Print dialog box, make any adjustments to the settings.

4 Click Print.

NOTE Instead of using the print settings you saved with your layout, you can select 
Previous Print in the Use Settings list to print according to the settings used the last 
time you printed. If necessary, you can click Reset to restore the IntelliCAD default 
print settings.
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Drawing in three dimensions

Paper drawings typically represent two-dimensional views of three-dimensional 
objects. With IntelliCAD, you can create three-dimensional models of three-dimen-
sional objects.

This section explains how to:

• View entities in three dimensions.

• Create three-dimensional entities.

• Edit entities in three-dimensional space.

• Edit three-dimensional solids.

• Display hidden-line and shaded views of three-dimensional entities.

The tools and commands for many of the functions described in this section appear 
on the Draw 3D toolbar and the Insert menu, respectively, when you set the program 
to the Advanced experience level.

Topics in this chapter

Viewing entities in three dimensions .................................................................396

Creating three-dimensional entities...................................................................399

Editing in three dimensions ...............................................................................425

Editing three-dimensional solids .......................................................................430

Hiding, shading, and rendering .........................................................................441
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Viewing entities in three dimensions 

You can view an IntelliCAD drawing from any position in three-dimensional space. 
From any selected viewing position, you can add new entities and modify existing 
entities. You can also generate hidden-line and shaded views from any viewing posi-
tion.  

Setting the viewing direction 
You view three-dimensional drawings by setting the viewing direction. The viewing 
direction establishes the viewing position, the Cartesian coordinate corresponding to 
the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a 
drawing from the default viewpoint (0,0,1), you see a plan view of the drawing.    

On the View toolbar, you can view a three-dimensional drawing using any of the fol-
lowing methods:

• Preset Viewpoints ( )    

• Dynamic View Control ( )

• Plan View ( )

You can change the viewing direction to look at the drawing from a different vantage 
point or to work on a three-dimensional model from a different orientation.

To set a new viewing direction    

1 Do one of the following:

• Choose View > Preset Viewpoints.

• On the View toolbar, click the Preset Viewpoints tool ( ).

• Type setvpoint and then press Enter.

2 Click the preset view you want to use. 
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You can dynamically rotate the viewpoint within the xy plane and relative to the xy 
plane, and you can pan and zoom the drawing. As you change the viewpoint settings, 
the drawing display automatically updates.    

To dynamically set a view direction    

1 Do one of the following:

• Choose View > Dynamic View Control.

• On the View toolbar, click the Dynamic View Control tool ( ).

• Type viewctl and then press Enter.

2 Click the appropriate tools to dynamically change the viewpoint.

3 To complete the command, click OK.

A Click to select a non-axis viewpoint.

B Click to select the previous viewpoint.

C Click to select a viewpoint aligned with an axis.

A

C

B
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You can set the current viewing direction to the plan view of the current user coordi-
nate system (UCS), a previously saved UCS, or the World Coordinate System 
(WCS).

To display a plan view of the current drawing

1 Do one of the following:    

• Choose View > Plan View.

• On the View toolbar, click the Plan View tool ( ).

• Type plan and then press Enter.

2 In the prompt box, choose one of the following:

• Current displays the plan view of the current UCS.

• UCS displays the plan view of a saved UCS. The program prompts you for the 
name of the UCS.

• World displays the plan view of the WCS.

A Indicates the current viewpoint.

B Click to pan the drawing.

C Click to display the Preset Viewpoints dialog box.

D Click to update the drawing display whenever 
you click a tool.

E Click to zoom extents.

F Click to zoom out.

G Click to zoom in.

H Shows the current viewpoint orientation.

I Type or select the rotation angle increment.

J Click to rotate the view about a predefined axis.

A

B

C

D

F
G

E

H

I

J
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Creating three-dimensional entities   

IntelliCAD supports the following types of three-dimensional models:   

• Wire-frame models, which consist of lines and curves that define the edges of a 
three-dimensional entity. You can create a wire-frame model by drawing lines, 
arcs, polylines, and other two-dimensional entities anywhere in three-dimensional 
space. Wire-frame models have no surfaces; they always appear as outlines. 
Because you must individually draw and position each entity that makes up a 
wire-frame model, creating one can be exacting and time-consuming.       

• Surface models, which consist of both edges and the surfaces between those 
edges. You can create a surface model by applying elevation and thickness to two-
dimensional planar entities or by using specific three-dimensional entity-creation 
commands. Surface models consist of individual planes forming a faceted, polyg-
onal mesh.

• 3D solids, which are three-dimensional ACIS entities that consist of faces and 
edges. 3D solids appear to have volume and are easier to work with than wire-
frame and surface models. IntelliCAD supports viewing and limited editing of 3D 
solids, including moving, rotating and scaling. Additionally, some versions of 
IntelliCAD allow you to create and more completely edit 3D solids. 

Applying elevation and thickness
By default, the program creates new two-dimensional entities with a zero elevation 
and thickness. The easiest way to create a three-dimensional entity is to change the 
elevation or thickness property of an existing two-dimensional entity.        

The elevation of an entity is its z-coordinate position in relation to the xy plane in 
which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the 
xy plane of the current UCS. Positive elevations are above this plane; negative eleva-
tions are below it.    
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The thickness of an entity is the distance it is extruded above or below its elevation. A 
positive thickness extrudes the entity upward in the positive z direction of the entity; 
a negative thickness extrudes it downward in the negative z direction. The thickness 
is applied uniformly to the entire entity. You can extrude any two-dimensional entity 
into a three-dimensional entity by changing the thickness of the entity to a nonzero 
value. For example, a circle becomes a cylinder, a line becomes a three-dimensional 
plane, and a rectangle becomes a box.      

You can create three-dimensional entities using any of the following methods:

• Draw two-dimensional entities in three-dimensional space.    

• Convert two-dimensional planar entities into three-dimensional entities by apply-
ing elevation and thickness.

• Convert two-dimensional planar entities into three-dimensional entities by revolv-
ing or extruding.

• Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, 
and wedges. 

NOTE Three-dimensional solids are drawn as true solids with versions of IntelliCAD 
that support three-dimensional ACIS solids. Three-dimensional solids that you can 
create include: box, cone, cylinder, dish, dome, pyramid, sphere, torus, and wedge.

You can change the default elevation and thickness values to create new entities with 
an elevation and thickness already applied.

To set the current elevation    

1 Display the current elevation setting by doing one of the following:

• Choose Settings > Elevation.

• On the Settings toolbar, click the Elevation tool ( ).

• Type elev and then press Enter.

2 Specify the New Current Value For Elevation, and then press Enter. 

Two-dimensional entities. Two-dimensional entities with thickness added.
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To set the current thickness    

1 Display the current thickness setting by doing one of the following:

• Choose Settings > Thickness.

• On the Settings toolbar, click the Thickness tool ( ).

• Type thickness and then press Enter.

2 Specify the New Current Value For Thickness, and then press Enter.

To set the current elevation and thickness using a dialog box    

1 Display the Drawing Settings dialog box by doing one of the following:

• Choose Settings > Drawing Settings.

• On the Settings toolbar, click the Drawing Settings tool ( ).

• Type settings and then press Enter.

2 Click the 3D Settings tab.

3 In the Change Settings For list, click Surfaces.

4 To change the current thickness, in the Current 3D Thickness box, type a new 
thickness value or click the arrows to select a new thickness.

5 To change the current elevation, in the Current 3D Elevation box, type a new ele-
vation value or click the arrows to select a new elevation.

6 Click OK.

  

A Type or select the current three-dimensional 
thickness.

B Type or select the current three-dimensional 
elevation.

A
B
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To change the thickness and elevation of an existing entity    

1 Do one of the following:

• Choose Modify > Properties.

• On the Modify toolbar, click the Properties tool ( ).

• Type entprop and then press Enter.

2 Select the entity, and then press Enter.

IntelliCAD displays the Entity Properties dialog box. The exact appearance of the 
dialog box depends on the type of entity you select.

3 To change the thickness, in the Thickness box, type a new thickness value or click 
the arrows to select the new thickness.

4 To change the elevation, in the Z coordinate box, type a new elevation value or 
click the arrows to select the new elevation.    

5 Click OK.

NOTE When you change the thickness of an entity, you do not change the entity type. 
If you want to extrude an entity and convert it to a three-dimensional solid, use the 
Extrude command.    

 

A Type or select the new thickness. B Type or select the new elevation.   

A

B
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Creating three-dimensional faces 
You can create a three-dimensional face, which consists of a section of a plane in 
three-dimensional space. You define a three-dimensional face by specifying the x,y,z 
coordinates of three or more corners. After you specify the fourth point, the program 
continues to prompt you for additional faces by alternating prompts for the third point 
and fourth point to allow you to build a complex three-dimensional entity. Each 
three- or four-sided plane is created as a separate three-dimensional face entity.    

To create a three-dimensional face    

Advanced experience level

1 Do one of the following:

• Choose Insert > 3D Entities > Face.

• On the Draw 3D toolbar, click the Face tool ( ).

• Type face and then press Enter.

2 Specify the first point of the three-dimensional face.

3 Specify the second, third, and fourth points.

4 Specify the third and fourth points for additional faces. 

5 To complete the command, press Enter.

TIP Any or all edges of a three-dimensional face can be invisible to allow you to more 
accurately model entities with holes in them. As the program prompts you for the cor-
ner points, in the prompt box, choose Invisible Edge to make the next edge invisible.      

An example of a three-dimensional model created using three-dimensional faces.
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Creating rectangular meshes
You can create a three-dimensional rectangular mesh consisting of four-sided poly-
gons. You determine the size of the mesh by specifying the number of vertices along 
the primary (M-direction) and secondary (N-direction) mesh axes and then specifying 
the coordinates for each vertex.    

To create a rectangular mesh    

Advanced experience level

1 Do one of the following:

• Choose Insert > 3D Entities > Mesh.

• On the Draw 3D toolbar, click the Mesh tool ( ).

• Type mesh and then press Enter.

2 Specify the number of vertices along the primary mesh axis.

3 Specify the number of vertices along the secondary mesh axis.

4 Specify the coordinates for each vertex.

Specifying the coordinates for the last vertex completes the mesh and ends the 
command. 

TIP Although creating rectangular meshes manually can be exacting, they are useful 
for representing complex surfaces such as three-dimensional terrain models. The 
Mesh tool is most useful when combined with scripts or LISP programs that mathe-
matically calculate the coordinates of the vertices.      

An example of a three-dimensional terrain model created using rectangular meshes.
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Creating polyface meshes
You can create a polygon mesh consisting of faces connecting three or more vertices. 
You first determine the coordinates of each vertex and then define each face by enter-
ing the vertex numbers for all the vertices of that face. As you create each face, you 
can control the visibility and color of each edge and assign each edge to specific lay-
ers.    

To create a polyface mesh    

Advanced experience level

1 Do one of the following:    

• Choose Insert > 3D Entities > Polyface Mesh.

• On the Draw 3D toolbar, click the Polyface Mesh tool ( ).

• Type pface and then press Enter.

2 Specify the coordinates of each vertex.

After each vertex that you specify, the next vertex number is displayed, and you 
are prompted for the coordinates of the vertex. Specify the coordinates, and then 
press Enter. Continue to specify the coordinates for each numbered vertex.

3 To finish specifying vertex coordinates, press Enter.

4 Specify the vertex numbers that define the first face. 

You specify the face by entering the vertex numbers that were defined when you 
specified coordinates in step 2. Each face can be composed of three or more num-
bered vertices.

5 To finish defining the first face, press Enter.

6 Specify the next face by entering its vertex numbers.

7 To complete the command, press Enter.

TIP To make an edge invisible, type the vertex number as a negative value.    

Creating ruled surface meshes
You can create a ruled surface, which is a three-dimensional polygon mesh that 
approximates the surface between two existing entities. You select the two entities 
that define the ruled surface. These entities can be arcs, circles, lines, points, or 
polylines.
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To create a ruled surface mesh   

Advanced experience level

1 Do one of the following:

• Choose Insert > 3D Entities > Ruled Surface.

• On the Draw 3D toolbar, click the Ruled Surface tool ( ).

• Type rulesurf and then press Enter.

2 Select the first defining entity.

3 Select the second defining entity.

TIP To control the density of the mesh, change the values for the Number of M-Direc-
tion Surfaces. Choose Settings > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces value. Or, on the Settings toolbar, use the Drawing 
Settings tool ( ) to display that dialog box.

Creating extruded surface meshes
You can create an extruded surface, which is a three-dimensional polygon mesh that 
approximates the surface generated by extruding a path curve along a direction vec-
tor. You select the two entities that define the path curve and direction vector. The 
length of the direction vector determines the distance the path curve is moved along 
the direction vector. The extruded entity can be an arc, circle, line, or polyline. You 
can choose a line or open polyline as the direction vector. The resulting mesh consists 
of a series of parallel polygonal planes running along the specified path. 

Select the first (A) and second (B) defining entities. The resulting ruled surface mesh.

A

B
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To create an extruded surface mesh      

Advanced experience level

1 Do one of the following:

• Choose Insert > 3D Entities > Extruded Surface.

• On the Draw 3D toolbar, click the Extruded Surface tool ( ).

• Type tabsurf and then press Enter.

2 Select the entity to extrude.

3 Select the extrusion path.

TIP To control the density of the mesh, change the values for the Number of M-Direc-
tion Surfaces. Choose Settings > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces. Or, on the Settings toolbar, use the Drawing Set-
tings tool ( ) to display that dialog box.

NOTE An extruded mesh is different from an extruded solid. If you want to extrude an 
entity and convert it to a three-dimensional solid, use the Extrude command.

Creating revolved surface meshes
You can create a surface of revolution, which is a three-dimensional polygon mesh 
that approximates the surface generated by rotating a two-dimensional profile around 
an axis. You select the two entities that define the profile and the axis. You also spec-
ify the starting angle and the number of degrees to revolve the profile.

Revolving the profile 360 degrees creates a closed three-dimensional mesh. The 
Number Of M-Direction Surfaces value determines the mesh density (the number of 
mesh segments) in the M-direction (around the axis of revolution). The N-Direction 
Mesh Density value determines the mesh density (the number of mesh segments) in 
the N-direction (along the axis of revolution).

Select the entity to extrude (A) and the 
extrusion path (B).

The resulting extruded 
surface mesh.

A B
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To create a revolved surface mesh    

Advanced experience level

1 Do one of the following:

• Choose Insert > 3D Entities > Revolved Surface.

• On the Draw 3D toolbar, click the Revolved Surface tool ( ).

• Type revsurf and then press Enter.

2 Select the entity to revolve.

3 Select the entity to be used as the axis of revolution.

4 Specify the starting angle.

5 Specify the number of degrees to revolve the entity.

TIP To control the density of the mesh, change the values for the Number Of M-Direc-
tion Surfaces and N-Direction Mesh Density. Choose Settings > Drawing Settings, 
and then click the 3D Settings tab. Under Change Settings For, select Surfaces. 
Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direc-
tion Mesh Density values. Or on the Settings toolbar, use the Drawing Settings tool 
( ) to display that dialog box. 

Select the entity to be revolved (A) and the 
axis of revolution (B).

The resulting revolved surface 
mesh.

A

B
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Creating edge-defined Coons surface patch meshes
You can create a surface called a Coons surface patch, a mesh connecting four edges. 
You select the entities that define the edges. Edge entities can be arcs, lines, or 
polylines. The four edge entities must form a closed loop and share endpoints. A 
patch is a bicubic surface (one curve extends in the M-direction and the other in the 
N-direction) interpolated between the four adjoining edges. You can select the edges 
in any order. The first edge you select determines the M-direction of the mesh.

To create an edge-defined Coons surface patch mesh    

Advanced experience level

1 Do one of the following:

• Choose Insert > 3D Entities > Coons Surface.

• On the Draw 3D toolbar, click the Coons Surface tool ( ).

• Type edgesurf and then press Enter.

2 Select the first edge.

3 Select the second, third, and fourth edges.

TIP To control the density of the mesh, change the value for the Number of M-Direc-
tion Surfaces and N-Direction Mesh Density. Choose Settings > Drawing Settings, 
and then click the 3D Settings tab. Under Change Settings For, select Surfaces. 
Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direc-
tion Mesh Density values. Or on the Settings toolbar, use the Drawing Settings tool 
( ) to display that dialog box.

Select the entities to be used as the four 
edges (A, B, C, and D).

The resulting Coons surface patch mesh.

A
B

C

D
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Creating boxes     
You can create rectangular boxes, or cubes. A box consists of six rectangular surface 
planes. The base of the box is always parallel with the xy plane of the current UCS. 
You position the box by specifying either a corner or the center of the box. You deter-
mine the size of the box by either specifying a second corner and the height; defining 
the box to be a cube and then providing its length; or specifying the length, width, and 
height.   

NOTE  The box is created as a three-dimensional ACIS solid.

To create a box  

1 Do one of the following:

• Choose Insert > 3D Entities > Box.

• On the Solids toolbar, click the Box tool ( ).

• Type box and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.   

To create a box as a three-dimensional surface

To create a box as a surface instead of as a solid, the procedure is similar.   

1 Do one of the following:

• On the Draw 3D toolbar, click the Box tool ( ).

• Type ai_box and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

C

B
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Creating wedges
You can create three-dimensional wedges consisting of five surface planes. The base 
of the wedge is always parallel with the xy plane of the current UCS with the sloped 
face opposite the first corner. The height is always parallel with the z-axis. You posi-
tion the wedge by specifying either a corner or the center of the wedge. You deter-
mine the size of the wedge by either specifying a second corner and the height; 
defining the wedge based on a cube having a given length; or specifying the length, 
width, and height.    

NOTE  The wedge is created as a three-dimensional ACIS solid.

To create a wedge    

1 Do one of the following:

• Choose Insert > 3D Entities > Wedge.

• On the Solids toolbar, click the Wedge tool ( ).

• Type wedge and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.  

To create a wedge as a three-dimensional surface 

To create a wedge as a surface instead of as a solid, the procedure is similar.   

1 Do one of the following:

• On the Draw 3D toolbar, click the Wedge tool ( ).

• Type ai_wedge and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height. 

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

C

B
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Creating cones
You can create three-dimensional cones defined by a circular base and tapering to a 
point perpendicular to the base. The base of the cone is always parallel with the xy 
plane of the current UCS; the height of the cone is always parallel with the z-axis. 
You position the cone by specifying the center of the base. You determine the size of 
the cone by specifying either the radius or the diameter of the base and the height.    

NOTE  The cone is created as a three-dimensional ACIS solid.

To create a cone   

1 Do one of the following:

• Choose Insert > 3D Entities > Cone.

• On the Solids toolbar, click the Cone tool ( ).

• Type cone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the radius or diameter.

4 Specify the height.  

To create a cone as a three-dimensional surface

To create a cone as a surface instead of as a solid, the procedure is similar.   

1 Do one of the following:

• On the Draw 3D toolbar, click the Cone tool ( ).

• Type ai_cone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the radius or diameter.

4 Specify the height.

Center of the base (A), the radius of the base (B), and the height (C).

A

C

B
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Creating pyramids
You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides 
of the resulting pyramid can meet at a point (the apex) or can form a three- or four-
edged top. The sides of a four-sided pyramid can also meet along a ridge defined by 
two points. The base of the pyramid is always parallel with the xy plane of the current 
UCS. You position the pyramid by specifying a corner of the base. You determine the 
size of the pyramid by specifying the base points and either the apex, the corners of 
the top surface, or the endpoints of the ridge.       

NOTE  The tetrahedron and pyramid are created as three-dimensional ACIS solids.

To create a tetrahedron    

1 Do one of the following:

• Choose Insert > 3D Entities > Pyramid.

• On the Solids toolbar, click the Pyramid tool ( ).

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second and third points.

4 In the prompt box, choose Tetrahedron.

5 Specify the apex of the tetrahedron.

The first point (A), second point (B), and third point (C) of the base, and the apex (D).

A

B

C

D
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To create a pyramid with a planar top  

1 Do one of the following: 

• Choose Insert > 3D Entities > Pyramid.

• On the Solids toolbar, click the Pyramid tool ( ).

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second, third, and fourth points.

4 In the prompt box, choose Top Surface.

5 Specify the first point on the top surface of the pyramid.

6 Specify the second, third, and fourth points.

.

To create a pyramid as a three-dimensional surface

To create a pyramid as a surface instead of as a solid, the procedure is similar. 

1 Do one of the following:

• On the Draw 3D toolbar, click the Pyramid tool ( ).

• Type ai_pyramid and then press Enter.

2 Specify the points as described previously.

The first point (A), second point (B), third point (C), and fourth point (D) of the base, and the first point (E), 
second point (F), third point (G), and fourth point (H) of the top surface.

A

B

C

D

E

F
G

H
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Creating cylinders
You can create cylinders defined by a circular base. The base of a cylinder is always 
parallel with the xy plane of the current UCS; the height of a cylinder is always paral-
lel with the z-axis. You position a cylinder by specifying the center of the base. You 
determine the size of a cylinder by specifying either the radius or diameter of the base 
and the height.

NOTE  The cylinder is created as a three-dimensional ACIS solid. 

To create a cylinder   

1 Do one of the following:

• Choose Insert > 3D Entities > Cylinder.

• On the Solids toolbar, click the Cylinder tool ( ).

• Type cylinder and then press Enter.

2 Specify the center of the base of the cylinder.

3 Specify the radius or diameter.

4 Specify the height.

To create a cylinder as a three-dimensional surface

To create a cylinder as a surface instead of as a solid, the procedure is similar. 

1 Do one of the following:

• On the Draw 3D toolbar, click the Cylinder tool ( ).

• Type ai_cylinder and then press Enter.

2 Specify the center, radius, and height as described previously.

Center of the base (A), radius of the base (B), and the height (C).

A

B

C
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Creating spheres
You can create spheres. The latitude lines of a sphere are always parallel with the xy 
plane of the current UCS; the central axis is always parallel with the z-axis. You posi-
tion a sphere by specifying its center point. You determine the size of a sphere by 
specifying either its radius or its diameter.

NOTE  The sphere is created as a three-dimensional ACIS solid. 

To create a sphere    

1 Do one of the following:

• Choose Insert > 3D Entities > Sphere.

• On the Solids toolbar, click the Sphere tool ( ).

• Type sphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

To create a sphere as a three-dimensional surface

To create a sphere as a surface instead of as a solid, the procedure is similar. 

1 Do one of the following:

• On the Draw 3D toolbar, click the Sphere tool ( ).

• Type ai_sphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

4 Specify the number of longitudinal sections that are perpendicular to the xy plane.

5 Specify the number of latitudinal sections that are parallel to the xy plane.

Center (A) and radius (B) of the sphere. The resulting sphere.

A

B
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Creating dishes
You can create a three-dimensional dish. The latitude lines of a dish are always paral-
lel with the xy plane of the current UCS; the central axis is always parallel with the z-
axis. You position a dish by specifying its center point. You determine the size of a 
dish by specifying either its radius or its diameter.

NOTE  The dish is created as a three-dimensional ACIS solid. 

To create a dish      

1 Do one of the following:

• Choose Insert > 3D Entities > Dish.

• On the Solids toolbar, click the Dish tool ( ).

• Type dish and then press Enter.

2 Specify the center of the dish.

3 Specify the radius or diameter.

.

To create a dish as a three-dimensional surface

To create a dish as a surface instead of as a solid, the procedure is similar. 

1 Do one of the following:

• On the Draw 3D toolbar, click the Dish tool ( ).

• Type ai_dish and then press Enter.

2 Specify the center and radius or diameter as described previously.

Center (A) and radius (B) of the dish.

A

B
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Creating domes
You can create a three-dimensional dome. The latitude lines of a dome are always 
parallel with the xy plane of the current UCS; the central axis is always parallel with 
the z-axis. You position a dome by specifying its center point. You determine the size 
of a dome by specifying either its radius or its diameter.

NOTE  The dome is created as a three-dimensional ACIS solid. 

To create a dome    

1 Do one of the following:

• Choose Insert > 3D Entities > Dome.

• On the Solids toolbar, click the Dome tool ( ).

• Type dome and then press Enter.

2 Specify the center of the dome.

3 Specify the radius or diameter.

To create a dome as a three-dimensional surface

To create a dome as a surface instead of as a solid, the procedure is similar. 

1 Do one of the following:

• On the Draw 3D toolbar, click the Dome tool ( ).

• Type ai_dome and then press Enter.

2 Specify the center and radius or diameter as described previously.

Center (A) and radius (B) of the dome.

A

B
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Creating tori
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 
diameter of a ring is always parallel with the xy plane of the current UCS. A torus is 
constructed by revolving a circle about a line drawn in the plane of the circle and par-
allel with the z-axis of the current UCS. You position a torus by specifying its center 
point. You determine the size of a torus by specifying its overall diameter or radius 
and the diameter or radius of the tube (the circle being revolved).

NOTE  The torus is created as a three-dimensional ACIS solid. 

To create a torus    

1 Do one of the following:

• Choose Insert > 3D Entities > Torus.

• On the Solids toolbar, click the Torus tool ( ).

• Type torus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body of the torus.

Center (A) and radius of the whole torus (B), and the radius of the body (C).

A

B C
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To create a torus as a three-dimensional surface

To create a torus as a surface instead of as a solid, the procedure is similar.  

1 Do one of the following:

• On the Draw 3D toolbar, click the Torus tool ( ).

• Type ai_torus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body of the torus.

5 Specify the number of longitudinal sections that are perpendicular to the xy plane.

6 Specify the number of latitudinal sections that are parallel to the xy plane.

Creating regions   
You can convert a closed entity into a two-dimensional region. After you create a 
region, you can modify it using the various three-dimensional tools. For example, you 
can create a region from a square, and then extrude the square to create a three-
dimensional cube.

You can create regions from closed entities, such as polylines, polygons, circles, 
ellipses, closed splines, and donuts.        

Creating regions typically has no visible effect on a drawing. However, if the original 
entity had a width or lineweight, that information is lost when you create the region.    

To create a region

1 Do one of the following:

• Choose Modify > Region.

• On the Modify toolbar, click the Region tool ( ).

• Type region and then press Enter.

2 Select the entities to create the region.

3 Press Enter.

The command bar displays a message that describes how many regions were cre-
ated.
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Creating extruded solids
You can create three-dimensional solids by extruding closed entities, such as 
polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You can 
extrude the entity along a selected path, or you can specify its height and taper angle.

To create an extruded solid    

1 Do one of the following:

• Choose Insert > 3D Entities > Extrude.

• Type extrude and then press Enter.

2 Select the entity to extrude.

3 Select the extrusion path, or specify the height.

Select the entity to extrude (A) and the extrusion path 
(B).

The resulting extruded 
solid.

A B
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Creating revolved solids
You can create three-dimensional solids by revolving closed entities, such as 
polylines, polygons, circles, ellipses, and regions. You can revolve the entity about a 
defined axis, line, polyline, or two points.

To create a revolved solid    

1 Do one of the following:

• Choose Insert > 3D Entities > Revolve.

• Type revolve and then press Enter.

2 Select the entity to revolve.

3 Do one of the following to define the axis of revolution:

• Specify a start point and an end point.

• Type o and press Enter to select an entity that determines the axis.

• Type x and press Enter to select the x-axis.

• Type y and press Enter to select the y-axis.

4 Specify the angle of revolution.

Select the entity to revolve (A) and the axis (B) about 
which to revolve it., followed by the angle of 
revolution.

The resulting revolved 
solid.
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Creating composite solids
You can create composite three-dimensional solids by combining, subtracting, and 
finding the intersection of two or more solids. 

To combine solids    

1 Do one of the following:

• Choose Modify > Solids Editing > Union.

• On the Solids Editing toolbar, click the Union tool ( ).

• Type union and then press Enter.

2 Select the entities to combine.

To subtract solids    

1 Do one of the following:

• Choose Modify > Solids Editing > Subtract.

• On the Solids Editing toolbar, click the Subtract tool ( ).

• Type subtract and then press Enter.

2 Select the entities to subtract from one another.

Select the entities to combine (A and B). The resulting combined 
solid.

A

B

Select the entities to subtract (A and B). The resulting solid.

A

B
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To intersect solids    

1 Do one of the following:

• Choose Modify > Solids Editing > Intersect.

• On the Solids Editing toolbar, click the Intersect tool ( ).

• Type intersect and then press Enter.

2 Select the entities to intersect.

Select the entities to combine (A and B). The resulting combined 
solid.
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Editing in three dimensions

You can copy, move, rotate, array, mirror, and align two-dimensional and three-
dimensional entities in both two-dimensional and three-dimensional space. You can 
also change and edit properties of three-dimensional entities much like you change 
and edit properties for two-dimensional entities. When you modify three-dimensional 
entities in two-dimensional space, you modify the entity in relation to the current 
UCS. 

Rotating in three dimensions
You can rotate selected entities about a specified axis in three-dimensional space. 
You select the entities to rotate and then define the axis of rotation either by specify-
ing two points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis 
of the current UCS; or aligning the axis with the current view.

To rotate an entity about an axis in three dimensions  

1 Do one of the following:

• Choose Modify > 3D Rotate.

• On the Modify toolbar, click the 3D Rotate tool ( ).

• Type rotate3D and then press Enter.

2 Select the entities to rotate, and then press Enter.

3 Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, 
Zaxis.

4 Specify the rotation angle.

5 Specify the reference angle.

Select the entities to rotate (A), specify the endpoints 
of the axis of rotation (B and C), and then specify the 
rotation angle (D).

Result after rotating the entities.

B

D
CA
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Arraying in three dimensions
You can copy selected entities and arrange them in a three-dimensional rectangular or 
polar (circular) pattern. For a rectangular array, you control the number of copies in 
the array by specifying the number of rows and columns and the number of levels. 
You also specify the distance between each. For a polar array, you specify the axis 
around which to array the entities, the number of copies of the entities to create, and 
the angle subtended by the resulting array.

To create a three-dimensional rectangular array   

1 Do one of the following:

• Choose Modify > 3D Array.

• On the Modify toolbar, click the 3D Array tool ( ).

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Rectangular.

4 Type the number of rows in the array.

5 Type the number of columns.

6 Type the number of levels.

7 Specify the vertical distance between the rows.

8 Specify the horizontal distance between the columns.

9 Specify the depth between the levels.

To create a three-dimensional rectangular array, select the entity to copy (A), type the 
number of rows, columns, and levels, and then specify the distance between each row (B), 
column (C), and level (D).

AB

C

D
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To create a three-dimensional polar array         

1 Do one of the following: 

• Choose Modify > 3D Array.

• On the Modify toolbar, click the 3D Array tool ( ).

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Polar.

4 Type the number of copies to make, including the original selection set.

5 Specify the angle the array is to fill, from 0 to 360 degrees.

The default setting for the angle is 360 degrees. Positive values create the array in 
a counterclockwise direction; negative values create the array in a clockwise 
direction.

6 In the prompt box, choose one of the following:

• Yes-Rotate Entities to rotate entities as they are arrayed.

• No-Do Not Rotate to retain the original orientation of each copy as it is arrayed.

7 Specify the center point of the array.

8 Specify a second point along the central axis of the array.

To create a three-dimensional polar array, select the entity to copy (A), type the number of copies to make, 
specify the angle the array is to fill (B), and then specify the center point of the array (C) and a second point 
along the central axis of the array (D).

A

B

C

D
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Mirroring in three dimensions
You can create a mirror image of selected entities in three-dimensional space. You 
mirror the entities about a mirror plane that you define by either specifying three 
points; selecting an existing two-dimensional planar entity; aligning the plane parallel 
with the xy, yz, or xz plane of the current UCS; or aligning the plane with the current 
view. You can delete or retain the original entities.

To mirror an entity about a three-dimensional plane     

1 Do one of the following:

• Choose Modify > 3D Mirror.

• On the Modify toolbar, click the 3D Mirror tool ( ).

• Type mirror3D and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose 3 Points, or press Enter to select the default.

4 Specify the first point on the mirror plane.

5 Specify the second and third points on the plane.

6 In the prompt box, choose one of the following:

• Yes-Delete Entities to delete the original entities.

• No-Keep Entities to retain the original entities.

Select the entity to mirror (A), and then specify 
the first point (B), second point (C), and third 
point (D) defining the mirror plane.

The resulting mirrored entity.            

A
D C

B
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Aligning in three dimensions
You can align selected entities with other entities in three-dimensional space. You 
select the entities you want to align, and specify one, two or three pairs of points to 
align the selected entities.

To align an entity an entity with another     

1 Do one of the following:

• Choose Modify > Align.

• On the Modify toolbar, click the Align tool ( ).

• Type align and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the first source point.

4 Specify the first destination point

5 Specify additional source and destination points if desired (up to three pairs).

        

Select the entities to align, and then specify the 
first source point (A), the first destination point 
(B), the second destination point (C), and the 
second destination point (D). You can specify up 
to three pairs of source/destination points.

The resulting mirrored entity.

C D

A

B
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Editing three-dimensional solids

You can edit three-dimensional solids in several unique ways, including: chamfer, fil-
let, section, and slice. You can also modify individual faces and edges of solids, as 
well as imprint, separate, shell, and check solids.

You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, 
dishes, domes, pyramids, spheres, tori, and wedges.

Chamfering and filleting solids
You can chamfer or fillet a three-dimensional solid much like you chamfer or fillet a 
two-dimensional entity.

To chamfer a solid          

1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 Select the edge of the base surface to chamfer. (One of two surfaces adjacent to 
the selected edge will be highlighted.)

3 Do one of the following:

• To select a different surface, type n and press Enter. 

• To use the current surface, press Enter.

4 Specify the base surface distance (measured from the selected edge to the base 
surface).

5 Specify the adjacent surface distance (measured from the selected edge to the 
adjacent surface).

6 Do one of the following:

• Specify the edges to chamfer.

• To select all edges around the base surface, type l and press Enter.

To fillet a solid   

1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 Select the edge of the solid to fillet.

3 Specify the fillet radius.

4 Select additional edges to fillet, and press Enter to fillet.
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Sectioning and slicing solids
You can section or slice a three-dimensional solid, region, or body (typically a sheet). 

When you section a solid, you obtain an “inside view” by creating a cross-section 
through the solid as a region or block. When you section a region or body, the result-
ing intersections are curves. 

When you slice a solid, region, or body, you create a new entity by cutting the origi-
nal entity and removing a specific side.

To section an entity

1 Do one of the following:

• Choose Insert > 3D Entities > Section.

• On the Solids toolbar, click the Section tool ( ).

• Type section and then press Enter.

2 Select the entities to cross-section.

3 Do one of the following:

• Specify three points to define the cross-section plane. (The first point defines the 
origin, while the second point defines the x-axis and the third point defines the 
y-axis.)

• Type o and press Enter to select an entity that defines the cross-sectional plane.

• Specify an axis by typing the appropriate letter and pressing Enter.

To slice an entity

1 Do one of the following:

• Choose Insert > 3D Entities > Slice.

• On the Solids toolbar, click the Slice tool ( ).

• Type slice and then press Enter.

2 Select the entities to slice.

3 Do one of the following:

• Specify three points to define the cross-section plane. (The first point defines the 
origin, while the second point defines the x-axis and the third point defines the 
y-axis.)

• Type o and press Enter to select an entity that defines the cross-sectional plane.

• Specify an axis by typing the appropriate letter and pressing Enter.

4 Specify which side to retain, or type b to retain both sides.
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Modifying faces
You can edit three-dimension solids by extruding, moving, rotating, offsetting, taper-
ing, deleting, or copying individual faces. You can also change the color of individual 
faces.

To extrude a solid face

1 Do one of the following:

• Choose Modify > Solids Editing > Extrude Face.

• On the Solids Editing toolbar, click the Extrude Face tool ( ).

2 Select the entity with the face you want to extrude.

3 Select the face(s) to extrude, and press Enter.

4 Do one of the following:

• Specify the height of extrusion.

• Type p and press Enter to select a path for extrusion.

5 If you specified a height, specify a taper angle.

Select the entity to extrude, and then specify the 
face(s) to extrude (A), and the height of 
extrusion or path.

The resulting entity with the face extruded to 
position (B).
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To move a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Move Face.

• On the Solids Editing toolbar, click the Move Face tool ( ).

2 Select the entity with the face you want to move.

3 Select the face(s) to move, and press Enter.

4 Specify a base point.

5 Specify an end point.

Select the entity, and then specify the 
face(s) to move (A), the base point (B), 
and the end point (C).

The resulting entity with the face moved 
to the new position.

C

A B
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To rotate a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Rotate Face.

• On the Solids Editing toolbar, click the Rotate Face tool ( ).

2 Select the entity with the face you want to rotate.

3 Select the face(s) to rotate, and press Enter.

4 Specify a base point.

5 Specify another point on the rotation axis.

6 Specify the rotation angle.

Select the entity, and then specify the face(s) to 
rotate (A), the base point (B), a second point on 
the rotation axis (C), and a rotation angle.

The resulting entity with the face rotated to position 
(D).
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To offset a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Offset Face.

• On the Solids Editing toolbar, click the Offset Face tool ( ).

2 Select the entity with the face you want to offset.

3 Select the face(s) to offset, and press Enter.

4 Specify an offset distance.

To taper a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Taper Faces.

• On the Solids Editing toolbar, click the Taper Face tool ( ).

2 Select the entity with the face you want to taper.

3 Select the face(s) to taper, and press Enter.

4 Specify a base point.

5 Specify another point along the axis.

6 Specify a taper angle.

Select the entity, and then specify the face(s) to 
offset (A) and the distance to offset.

The resulting entity with the face offset to position 
(B).
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To delete a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Delete Face.

• On the Solids Editing toolbar, click the Delete Face tool ( ).

2 Select the entity with the face you want to delete.

3 Select the face(s) to delete, and press Enter.

Select the entity, and then specify the face(s) to 
taper (A), a base point, a second point along the 
taper axis, and a taper angle.

The resulting entity with the face tapered to position 
(D).

Select the entity, and then specify the face(s) to 
delete (A).

The resulting entity with the face deleted.
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To copy a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Copy Face.

• On the Solids Editing toolbar, click the Copy Face tool ( ).

2 Select the entity with the face you want to copy.

3 Select the face(s) to copy, and press Enter.

4 Specify a base point.

5 Specify an end point.

To color a face 

1 Do one of the following:

• Choose Modify > Solids Editing > Color Face.

• On the Solids Editing toolbar, click the Color Face tool ( ).

2 Select the entity with the face you want to color.

3 Select the face(s) to color, and press Enter.

4 Specify a color.

Select the entity, and then specify the face(s) to 
copy (A), the base point (B), and the end point 
(C).

The resulting entity with the face copied.
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Modifying edges
In addition to modifying faces of solids, you can modify individual edges. You can 
copy individual edges or change the color of individual edges.

To copy an edge 

1 Do one of the following:

• Choose Modify > Solids Editing > Copy Edge.

• On the Solids Editing toolbar, click the Copy Edge tool ( ).

2 Select the entity with the edge you want to copy.

3 Select the edge(s) to copy, and press Enter.

4 Specify a base point.

5 Specify an end point.

Select the entity, and then specify the face(s) to 
color (A).

The resulting entity with the face colored.

Select the entity, and then specify the edge(s) to 
copy (A), the base point (B), and the end point 
(C).

The resulting entity with the edge copied.
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To color an edge 

1 Do one of the following:

• Choose Modify > Solids Editing > Color Edge.

• On the Solids Editing toolbar, click the Color Edge tool ( ).

2 Select the entity with the edge you want to color.

3 Select the edge(s) to color, and press Enter.

4 Specify a color.

Imprinting solids
You can modify the face of a solid by imprinting another entity on it. For example, 
you can imprint a line, arc, or polyline onto the face of a box.

To imprint a solid entity 

1 Do one of the following:

• Choose Modify > Solids Editing > Imprint.

• On the Solids Editing toolbar, click the Imprint tool ( ).

2 Select the solid entity you want to imprint.

3 Select the entity you want to imprint on the solid.

Separating solids
You can separate solids that have been combined. After you separate them, they are 
separated into individual solids.

To separate solids 

1 Do one of the following:

• Choose Modify > Solids Editing > Separate.

• On the Solids Editing toolbar, click the Separate tool ( ).

2 Select the solid you want to separate.
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Shelling solids
You can create a shell or a hollow thin wall from your 3D solid entity. IntelliCAD 
offsets existing faces to create new faces.

To shell a solid 

1 Do one of the following:

• Choose Modify > Solids Editing > Shell.

• On the Solids Editing toolbar, click the Shell tool ( ).

2 Select the entity you want to shell.

3 Remove any faces you don’t want to include.

4 Specify an offset distance.

Cleaning solids
You can remove redundant edges or vertices from solids when they are not needed.

To clean a solid 

1 Do one of the following:

• Choose Modify > Solids Editing > Clean.

• On the Solids Editing toolbar, click the Clean tool ( ).

2 Select the entity you want to clean.

Select the entity, and then select faces to 
remove (A) and (B), then specify an offset 
distance.

The resulting shelled entity.
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Checking solids
You can check whether a selected entity is a valid three dimensional ACIS solid. If it 
is a valid 3D solid, you can modify the entity using the 3D solid editing commands; if 
not, you cannot edit the entity using these commands. 

To check a solid 

1 Do one of the following:

• Choose Modify > Solids Editing > Check.

• On the Solids Editing toolbar, click the Check tool ( ).

2 Select the entities to check.  

Hiding, shading, and rendering

As you create three-dimensional entities, the program displays both wire-frame and 
surface models in wire-frame view, which makes it difficult to visualize your three-
dimensional models. To better visualize the model, you can remove all the lines that 
are hidden behind other entities or surfaces when seen from the current viewpoint.

Shading goes a step further by removing hidden lines and then assigning flat colors to 
the visible surfaces, making them appear solid. Shaded images are useful when you 
want to quickly visualize your model as a solid entity, though they lack depth and 
definition.

Rendering provides an even more realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections, giving your model a 
photo-realistic look. As shown in the following illustrations, when you render a 
model, the program removes hidden lines and then shades the surfaces as though they 
were illuminated from imaginary light sources.   

Wire-frame model. Hidden-line image. Shaded image. Rendered image.
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Creating hidden-line images
Creating a hidden-line view of your drawing removes all the lines that are hidden 
behind other surfaces when seen from your vantage point. When you remove hidden 
lines or shade a model, the program treats the entities differently, depending on how 
you created them. Wire-frame models always appear transparent, because they have 
no surfaces. Surface models appear filled, with surfaces applied to all visible sides. 

To create a hidden-line image

Do one of the following: 

• Choose View > Rendering > Hide.

• On the Rendering toolbar, click the Hide tool ( ).

• Type hide and then press Enter. 

Creating shaded images
Creating a shaded image of your drawing removes hidden lines and then applies 
shading to the visible surfaces based on their entity color. Because they are intended 
to provide a quick visualization, shaded images do not have a light source and use 
continuous colors across surfaces, causing them to appear flat and unrealistic.   

To create a shaded image

Do one of the following: 

• Choose View > Rendering > Shade.

• On the Rendering toolbar, click the Shade tool ( ).

• Type shade and then press Enter.

To control the appearance of the shaded image, choose Settings > Drawing Settings, 
and then click the 3D Settings tab and select the options you want. You can shade the 
surfaces and edges of the model in four ways: 

• Faces shaded; edges not highlighted. 

• Faces shaded; edges highlighted in the background color.

• Faces filled in the background color; edges drawn using the entity color (similar to 
a hidden-line view).

• Faces filled using the entity color; edges highlighted in the background color.

Before creating a hidden-line image. After removing hidden lines.
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Creating rendered images
Creating a rendered image of your drawing removes hidden lines and then shades the 
surface as though it were illuminated from multiple light sources. 

Full rendering creates a photo-realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections. You can illuminate 
your image with spotlights, distant lighting to simulate sunshine, and ambient light. If 
you choose not to customize the light sources, the program generates default light 
sources for you.

Rays from these imaginary light sources are traced as they reflect off and refract 
through the surfaces of the model, a process called ray tracing. Ray tracing deter-
mines where shadows fall and how reflections on shiny materials such as metal and 
glass appear. You can modify the reflective properties of the materials that make up 
your model to control how the light rays reflect off its surfaces. 

Full rendering automatically creates a base on which your model is displayed, if you 
don’t already have one, so it does not appear suspended in space. A background is 
also automatically added to the image. A background such as a cloudy sky or an 
imported raster graphic such as a stone wall can also be added behind the image, 
making it even more realistic.

To create a quickly rendered image

Do one of the following: 

• Choose View > Rendering > Render.

• On the Rendering toolbar, click the Render tool ( ).

• Type render and then press Enter.

To create a fully rendered image

Do one of the following:    

• Choose View > Rendering > Full Render.

• On the Rendering toolbar, click the Full Render tool ( ).

• Type fullrender and then press Enter.
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Fully rendered image.
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Creating custom rendered images
IntelliCAD allows you to create custom rendered images by applying materials, 
backgrounds, and lighting (including shadows) to your drawing:

• Materials Specify materials for different surfaces and define how the materials 
map to those surfaces. Predefined materials are available in the materials library, 
which can be customized further using the built-in editor. You can choose to use 
procedural or bitmap materials.

• Backgrounds Specify the background or backdrop for a rendered image. Several 
predefined backgrounds are available. By default, no background is used and it 
appears black. The background is an infinite, planar surface and reflects off of any 
reflective surfaces in your model. The background is not affected by lighting how-
ever, so no shadows or highlights are seen on the background.

• Lighting Specify the placement of lights, light color, and light intensity to deter-
mine how your drawing or scene is lit, including shadows and reflections in the 
scene. Lights can be placed either outside the field of view or inside to illuminate 
different areas of the scene. Several predefined lighting controls are available, 
including ambient lighting, diffuse lighting, specular reflections, specular high-
lights, and transparency.  

To apply materials, backgrounds, and lighting

1 Do one of the following: 

• Choose View > Rendering, and then choose Materials, Backgrounds, or 
Lighting.

• On the Rendering toolbar, click the Materials tool ( ), Backgrounds ( ), 
or Lighting tool ( ).

• Type materials, backgrounds, or lighting and then press Enter.

2 Make your selections.

NOTE You can specify additional options by choosing View > Rendering > Render 
Settings. For more information about creating custom rendered images, click Help in 
any of the Render dialog boxes.
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Printing a rendered image
You cannot print a rendered image directly to a printer. Instead, you must first save 
the drawing to a different format — either a bitmap (.bmp), JPEG (.jpg), TIFF (.tif), 
TrueVision TGA (.tga), or Portable Network Graphic (.png). After you save a 
rendered image, you can print it from another graphics program. 

To save a rendered image of your drawing

1 Create a rendered image of the drawing.

2 Do one of the following:

• Choose View > Rendering > Render Settings.

• On the Rendering toolbar, click the Render Settings tool ( ).

• Type setrender and then press Enter.

3 On the Rendering tab, click Save Last Image.

4 Enter a file name and path.

5 In Save As Type, choose the file format.

6 Click Save.
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Working with other programs

IntelliCAD offers great flexibility in its capability to be used with other programs. 
You can include an IntelliCAD drawing in a Microsoft® Word document or insert a 
Microsoft® Excel spreadsheet containing a parts list into an IntelliCAD drawing. To 
include IntelliCAD drawings in other programs and documents from other programs 
in IntelliCAD drawings, you either link or embed them. You can also save Intelli-
CAD drawings in other file formats that can be used directly with other programs or 
send IntelliCAD drawings to coworkers via e-mail.

This section explains how to:

• Save and view snapshots.

• Use images in your drawings.

• Use object linking and embedding.

• Export IntelliCAD drawings to other file formats.

• Send drawing files via e-mail.

• Use IntelliCAD with the Internet.

Topics in this chapter

Saving and viewing snapshots ......................................................................... 448

Using images in a drawing................................................................................ 449

Using data from other programs in IntelliCAD drawings................................... 458

Using IntelliCAD data in other programs .......................................................... 464

Using IntelliCAD with the Internet..................................................................... 472
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Saving and viewing snapshots

You can save snapshots of a drawing to view later. A snapshot saves the current 
drawing in either *.emf, *.wmf, or *.sld format exactly as it appears on the screen. A 
snapshot is not a drawing file. You cannot edit or print the snapshot; you can only 
view it.

You can use snapshots in the following ways:

• Make presentations by showing snapshots of your drawings.

• Reference a snapshot of a drawing while working on a different drawing.

• Present a number of snapshots as a slide show by using scripts.

When you view a snapshot, it temporarily replaces the current drawing. When you 
refresh the display of the current drawing (by redrawing, panning, zooming, minimiz-
ing, maximizing, or tiling), the snapshot image disappears, and you are returned to 
the current drawing.

You create a snapshot by saving the current view as a snapshot. A snapshot does not 
include any entities on layers that are not currently visible. The contents of the snap-
shot also depend on the current drawing space. In model space, the snapshot shows 
only the current viewport. In paper space, the snapshot contains all visible viewports.

To create a snapshot 

1 Display the drawing exactly as you want to capture it as a snapshot.

• Choose Tools > Make Snapshot.

• On the Tools toolbar, click the Make Snapshot tool ( ).

• Type msnapshot and then press Enter.

2 In the Create Snapshot dialog box, specify the name of the snapshot file you want 
to create.

3 From the Files Of Types list, choose either *.emf, *.wmf, or *.sld.

4 Click Save.

The current drawing remains on the screen, and the snapshot is saved to the directory 
that you specify. You can view previously saved snapshots, and you can also view 
snapshots created using AutoCAD.
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To view a snapshot

1 Do one of the following: 

• Choose Tools > View Snapshot.

• On the Tools toolbar, click the View Snapshot tool ( ).

• Type vsnapshot and then press Enter.

2 In the View Snapshot dialog box, specify the name of the snapshot file you want 
to view.

3 Click Open.

IntelliCAD displays the snapshot in the current drawing window.

Using images in a drawing

You can modify and view raster images directly inside of IntelliCAD. You can load, 
edit, and modify multiple images as overlays or underlays to your IntelliCAD draw-
ings. The images can be selected for use with IntelliCAD commands by selecting the 
image frame, which can be turned on or off for printing or selection purposes.

IntelliCAD support numerous image file formats, including BMP, JPG, GIF,  EMF, 
TIF, PNG, WMF, and many more.

Attaching images
When you attach an image to a drawing, the image displays in the drawing but is not 
saved in the drawing. The image file remains saved in its original location on your 
computer, network, or other media. 

If you send or receive drawings that contain images, it is important to include with the 
drawing all of the image files attached to it. When you open a drawing that contains 
images, the source image files must be accessible for the images to display in the 
drawing.

To attach an image

1 Do one of the following:

• Choose Image > Attach Image.

• On the Image toolbar, click the Attach Image tool ( ).

• Type imageattach and then press Enter.

2 Specify a file to attach, and then click Open.
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3 In Image Path will be Saved As, enter a different image file location, if necessary. 
You can click [ > ] to choose how you want to save the image path:

• Full Path — The image is referenced using its full path, for example, c:\My 
Pictures\MyImage.jpg. Use this option if the image is saved in a folder unrelated 
to the current drawing folder.

• Relative Path — The image is referenced using a path relative to the current 
drawing folder, for example, ..\My Pictures\MyImage.jpg. Use this option if the 
image is stored in a subfolder of the current drawing folder.

• File Name Only — The image is referenced using its file name in the current 
drawing folder, for example, MyImage.jpg. Use this option if the image is saved 
in the same folder as the current drawing.

4 In the Attach Image dialog box, specify the position, scale, rotation, transparency, 
and clipping options, and then click OK. 

NOTE Transparency works for images that support alpha transparency, that is, 
images that have at least one color that can be viewed as a transparent color.

5 In the drawing, specify an insertion point, scale, and rotation if you chose to spec-
ify those on the screen.
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TIP You can also attach images using the Image Manager. Choose Image > Image 
Manager, and then click Attach to specify an image and then attach it, or if you 
want to quickly add another occurrence of an image already located in the draw-
ing, select the image in the Image Manager and then click Add.

A Enter a different image file location, if necessary.

B Choose to place the image automatically in the 
drawing using specifications located in a positioning 
file. Enter the TWF file associated with the image or 
click [...] to select it.

C Choose to specify the insertion point in the drawing 
upon insertion, or enter coordinates.

D Choose to specify the size of the image in the 
drawing upon insertion, or enter the size values.

E Choose whether to turn clipping display on or off for 
the image.

F Choose whether entities located under the image are 
visible (for images that support alpha transparency).

G Choose to specify rotation in the drawing upon 
insertion, or enter how many degrees to rotate the 
image to the left.

H Click to view image information, including color depth 
and resolution. 

I Choose to save the image path as its full path, 
relative path to the current drawing folder, or file 
name in the current drawing folder.

B

C

E
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D

G
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H

I
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Modifying images
You can modify an image by changing its brightness, contrast, fade, size, rotation, or 
transparency. These changes affect the image in the drawing only — not the original 
image file.

In addition to modifying a single image or multiple images that you select, you can 
also modify all occurrences of an image within a drawing. For example, if your com-
pany logo appears in multiple locations throughout a drawing, you can use the Image 
Manager to specify the changes once and apply them to all occurrences of the logo.

You can use other IntelliCAD commands for typical modifications, such as Delete, 
Move, Layer, and more. 

To modify images

1 Do one of the following:

• Choose Image > Image Manager.

• On the Image toolbar, click the Image Manager tool ( ).

• Type image and then press Enter.

TIP You can also modify images by selecting one or more images in a drawing, 
and then choosing Modify > Properties.

2 In the Images list, select the image you want to modify. If there is more than one 
occurrence of the image in the drawing, do one of the following:

• To modify all occurrences of the image, select a top-level image in the list.

• To modify a single occurrence of the image, expand a top-level image in the list, 
and then select the individual image.

3 Adjust the Brightness, Contrast, and Fade by moving the slider to the setting you 
want or by entering an exact number. The image preview shows how your changes 
will affect the image. 

TIP If you want to restore the image to the default brightness, contrast, and fade 
settings, click Reset.

4 Adjust the Size by making changes to the width (X) and height (Y) in drawing 
units. Mark Keep Aspect Ratio if you want the width and height to change 
together to retain the aspect ratio of the image.

5 Adjust the Rotation by entering the number of degrees you want to rotate the 
image to the left. Zero degrees indicates no rotation.

6 Mark Use Transparency if you want entities located under the image to be visible 
(for images that support alpha transparency, that is, images that have at least one 
color that can be viewed as a transparent color).
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7 Mark Show Clipping Boundary if you want to show the image clipped, if a clip-
ping boundary is defined for the image. Unmarking this option displays the whole 
image, even if a clipping boundary is defined.

8 Click OK. 

A Click a top-level image to modify all occurrences 
located in the drawing. Expand a top-level image and 
click an individual image to modify that occurrence 
only.

B Move the slider or enter an exact number for image 
brightness.

C Move the slider or enter an exact number for image 
contrast.

D Move the slider or enter an exact number for image 
fade, which fades the image without displaying 
entities located under the image.

E Click to return to the default brightness, contrast, and 
fade settings.

F Enter the width (X) and height (Y) in drawing units. 
Mark Keep Aspect Ratio to change width and height 
together.

G Choose whether to turn clipping display on or off for 
the image.

H Choose whether entities located under the image are 
visible (for images that support alpha transparency).

I Enter how many degrees to rotate the image to the 
left.

A
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Changing the display of images
You can change the following for how all images display in a drawing:

• Image quality — Images can display in high or low resolution.

• Image frames — Images can display with or without frames on their edges.

Changing the display quality for all images
High quality displays images in high resolution and requires more system resources. 
Draft quality displays images in low resolution and consumes fewer system 
resources. Changing the quality setting affects all images in the drawing.

To change the display quality for all images

1 Do one of the following: 

• Choose Image > Image Quality.

• On the Image toolbar, click the Image Quality tool ( ).

• Type imagequality and then press Enter.

2 Choose High or Draft.

Turning image frames on or off for all images
When image frames are turned on, a frame displays and prints on the edge of all 
images in the drawing. When image frames are turned off, none of the images display 
or print with a frame, which also makes images unselectable. Each image frame dis-
plays with the properties (layer, color, linetype, etc.) that are assigned to the image.

Turning image frames off may be helpful, for example, if the images are part of a 
background in the drawing.

To turn image frames on or off for all images

1 Do one of the following: 

• Choose Image > Display Image Frame.

• On the Image toolbar, click the Display Image Frame tool ( ).

• Type imageframe and then press Enter.

2 Choose On or Off.
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Clipping images
You can clip images so that only a portion of the image is visible in a drawing. The 
visible portion can be in the shape of a rectangle or polygon.

Image clipping can be turned on an off. If you turn off clipping for an image, the 
entire image is visible provided that the image is on a layer that is on and thawed. The 
clipping information is retained however, and you can turn clipping back on at any 
time. 

If you delete clipping from an image, the clipping is removed permanently but the 
image itself remains in the drawing.

To clip an image in the shape of a rectangle

1 Make sure that image frames are turned on — so you can select images — by 
choosing Image > Display Image Frame, and then choose On.

2 Do one of the following:

• Choose Image > Clip Image.

• On the Image toolbar, click the Clip Image tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image you want to clip.

4 If prompted, choose New to create a new clipping boundary.

5 Choose Rectangle.

6 Define the first corner of the clipping rectangle.

7 Define the opposite corner of the clipping rectangle.

Only the portion of the image located within the clipping rectangle is visible.

To clip an image in the shape of a polygon

1 Make sure that image frames are turned on — so you can select images — by 
choosing Image > Display Image Frame, and then choose On.

2 Do one of the following:

• Choose Image > Clip Image.

• On the Image toolbar, click the Clip Image tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image you want to clip.

4 If prompted, choose New to create a new clipping boundary.

5 Choose Polygon.

6 Select the points for the polygon, and then press Enter when the polygon is com-
plete.

Only the portion of the image located within the clipping polygon is visible.
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To turn clipping on or off for an image

1 Make sure that image frames are turned on — so you can select images — by 
choosing Image > Display Image Frame, and then choose On.

2 Do one of the following:

• Choose Image > Clip Image.

• On the Image toolbar, click the Clip Image tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image for which you want to turn clipping on or off.

4 Choose On or Off.

To remove clipping from an image

1 Make sure that image frames are turned on — so you can select images — by 
choosing Image > Display Image Frame, and then choose On.

2 Do one of the following:

• Choose Image > Clip Image.

• On the Image toolbar, click the Clip Image tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image for which you want to remove clipping.

4 Choose Delete.

Unloading and reloading images
If you find that including an image affects system performance, you can unload it so 
only the image frame displays to mark its location. If you want an unloaded image to 
print, reload it before printing. You may also want to reload an image if the original 
file contains new content.

To unload and reload an image

1 Do one of the following: 

• Choose Image > Image Manager.

• On the Image toolbar, click the Image Manager tool ( ).

• Type image and then press Enter.

2 In the Images list, select the desired image. If there is more than one occurrence of 
the image in the drawing, do one of the following:

• To unload or reload all occurrences of the image, select a top-level image in the 
list.

• To unload or reload a single occurrence of the image, expand a top-level image 
in the list, and then select the individual image.
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3 Do one of the following: 

• To unload the image so only its outer edge displays, click Unload.

• To reload the image so its contents display and print, click Reload.

Changing the path for images
If the file associated with an image is renamed or moved to a different location, the 
program displays a message indicating that it cannot load the image. You can re-
establish the link to the file by changing the path for the image.

To change the path for an image

1 Do one of the following: 

• Choose Image > Image Manager.

• On the Image toolbar, click the Image Manager tool ( ).

• Type image and then press Enter.

2 In the Images list, select the desired image. If there is more than one occurrence of 
the image in the drawing, do one of the following:

• To change the path for all occurrences of the image, select a top-level image in 
the list.

• To change the path for a single occurrence of the image, expand a top-level 
image in the list, and then select the individual image.

3 Click the [...] button.

4 Select the file with its new name or in its new location, and then click Open.

5 Click Set Path.
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Deleting images
Once an image is no longer required in the drawing, you can delete it from the draw-
ing. Deleting an image removes it from the drawing, and from the list of images in the 
Image Manager dialog box. 

To delete an image

1 Do one of the following: 

• Choose Image > Image Manager.

• On the Image toolbar, click the Image Manager tool ( ).

• Type image and then press Enter.

2 In the Images list, select the image you want to delete. If there is more than one 
occurrence of the image in the drawing, do one of the following:

• To delete all occurrences of the image, select a top-level image in the list.

• To delete a single occurrence of the image, expand a top-level image in the list, 
and then select the individual image.

3 Click Detach. 

Using data from other programs in IntelliCAD drawings

You can include data from other programs in IntelliCAD drawings by using either 
embedding or linking. The method you choose depends on the type of object or file 
you want to include in your IntelliCAD drawing and what you want to do with it after 
it is there.

Embedding objects into drawings
Embed an object into your IntelliCAD drawing when you want to keep all the data 
you work with in one file or if you want to transfer the file to other computers. You 
can embed data from programs that support object linking and embedding.

For example, if you want to distribute data about a department’s computer equipment 
along with an IntelliCAD drawing of the department’s floor plan, you can embed a 
Microsoft® Excel spreadsheet into the floor plan.

When you embed data from another program, IntelliCAD becomes the container for 
that data. The object embedded in the IntelliCAD drawing becomes part of the 
IntelliCAD file. When you edit the data, you open its program from within the 
IntelliCAD drawing.
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Any changes you make to the embedded data exist only in the IntelliCAD drawing, so 
it is not necessary to keep that data in a separate file. If the data does exist in a sepa-
rate file, the original file does not change when you modify the embedded object in 
IntelliCAD. Also, changes to the original file do not affect the embedded object in the 
IntelliCAD drawing.

To embed another program’s object into an IntelliCAD drawing

1 Open the file that contains the data you want.

2 In the file, select the data you want to embed in the IntelliCAD drawing.

3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4 In the IntelliCAD window, display the drawing in which you want to embed the 
object.

5 Choose Edit > Paste, or click the Paste tool ( ) on the Standard toolbar.

The data on the Clipboard is pasted into the drawing as an embedded object. The 
object appears in the center of the view, but you can select and move it by moving 
the cursor.

To embed an object from an existing file within IntelliCAD      

1 Do one of the following:

• Choose Insert > Object.

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.

3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select a file.

4 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

5 Click OK.

The first page of the file appears in the IntelliCAD drawing, unless you chose to 
display it as an icon. You can select the object and drag to reposition it.
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To create a new embedded object from within IntelliCAD

1 Do one of the following:

• Choose Insert > Object.

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create New.

3 From the Object Type list, select the type of object you want to create, and then 
click OK.

The program for creating that object opens within IntelliCAD. If the program is 
compatible with ActiveX, it opens in place (within the other program) in the 
IntelliCAD drawing; otherwise, the program opens in its full window.

4 Create the object in the other program.

5 If the program is running within the other document (in place), click anywhere 
outside the embedded object to close the program.

If the program is running in its full window, choose File > Exit.

Linking objects to drawings
If another program supports ActiveX, you can link its data to IntelliCAD drawings. 
Use linking when you want to include the same data in many files. When you update 
the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing 
program, and you want to include it in the title block of every drawing you create 
with IntelliCAD, you can link it to each IntelliCAD drawing. When you change the 
original logo in the drawing program, the IntelliCAD drawing updates automatically.

When you link data from another program, the IntelliCAD drawing stores only a ref-
erence to the location of the file in which you created the data. You link data from a 
saved file, so IntelliCAD can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly 
increase the file size of the IntelliCAD drawing. However, links require some mainte-
nance. If you move any of the linked files, you need to update the links. In addition, if 
you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing, or 
you can do so only when you specify. Anytime a link is updated, changes made to the 
object in its original file also appear in the IntelliCAD drawing, and the changes also 
appear in the original file if they were made through IntelliCAD.
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To link a file to an IntelliCAD drawing

1 Save the original file. 

Because a link consists of a reference to the original file, you must save the file 
before you can link to it.

2 In the original file, select the data you want in the IntelliCAD drawing.

3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4 Display the IntelliCAD drawing to which you want to link the file.

5 In IntelliCAD, choose Edit > Paste Special.

6 In the Paste Special dialog box, select Paste Link.

7 Click OK.

To create a linked object from within IntelliCAD   

1 Display the IntelliCAD drawing in which you want to display the linked object.

• Choose Insert > Object

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.

3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select the file using a file dialog box.

4 Select the Link check box.

5 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

6 Click OK.

The first page appears in the IntelliCAD drawing, unless you chose to display it as 
an icon. To reposition the object, select and drag it.

Editing an embedded or linked object from within IntelliCAD
You can modify an embedded or linked object in its original program from within 
IntelliCAD. When you modify an embedded object, you change the object only in 
IntelliCAD, not its original file (if you pasted the object from an existing file). When 
you modify a linked file, however, you open and change the original file.

Most programs include a submenu of actions you can perform on an embedded or 
linked ActiveX object. Usually, the commands for editing ActiveX objects are Edit 
and Open. If the object is embedded and its program supports in-place editing, the 
Edit command opens the object in place. The Open command opens the object in the 
full program window. In IntelliCAD, this command appears at the bottom of the Edit 
menu.
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To edit an embedded or linked object 

• In the IntelliCAD drawing, double-click the object.

If the object is embedded and the program in which you created the object supports 
in-place editing, the object opens in place.

If the object is linked, or if its program does not support in-place editing, the other 
program opens in its full window and displays the object.

Importing files created in other formats
You can import the following files:

• Drawing Exchange Format files with a .dxf file extension. This file type is an 
ASCII or binary description of a drawing file.

• Design Web Format files with a .dwf file extension. DWF™ files are used to dis-
tribute a drawing for others to view in a Web browser, review, and edit using free 
Autodesk® software and tools.

• Drawing templates with a .dwt file extension. This file type contains predefined 
settings that you can reuse when you create new drawings.

• Three-dimensional entities saved with an .sat file extension. This file type contains 
three-dimensional ACIS solids saved as an .sat file. 
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Importing a DXF, DWF, or DWT file
Importing DXF files, two-dimensional DWF files, and DWT files is similar to open-
ing a standard drawing file.

To import a DXF, DWF, or DWT file 

1 Use one of the following methods: 

• Choose File > Open. 

• On the Standard toolbar, click the Open tool ( ).

• Type open and then press Enter. 

2 Choose the folder that contains the drawing. 

3 In Files of Type, choose the type of drawing you want to import. 

4 Choose the file you want to open. 

5 Click Open.

Importing an ACIS file
An ACIS file contains three-dimensional solids, regions, or bodies that are saved as 
an ASCII .sat file.

To import an ACIS file

1 Do one of the following:

• Choose File > Acis In.

• Type acisin, and then press Enter. 

2 Choose the directory containing the SAT file. 

3 Choose the SAT file you want to open. 

4 Click Open. 
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Using IntelliCAD data in other programs

You can use any of the following methods to include IntelliCAD data in a document 
created in another program:

• Embedding

• Linking

• Dragging

• Exporting

• E-mailing

The method you choose depends on the capabilities of the other program and how 
you want to work with the IntelliCAD data after you’ve placed it in the other 
document.

NOTE Each method except exporting uses ActiveX to integrate data from different 
programs. With ActiveX, you can open IntelliCAD drawings from within the other 
program to modify the IntelliCAD drawings.

Embedding drawings
When you embed an IntelliCAD drawing, it becomes part of the other program’s doc-
ument file. When you edit the drawing, you edit only the version that is embedded in 
the other document.

Embedding is useful when you don’t want to maintain a link to the IntelliCAD draw-
ing for the data you include in the other document. Edits made to the new drawing do 
not affect the original drawing. To transfer the file to other computers, you can trans-
fer all the data in one file, but embedded objects increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft® 
Word, you can either create a new embedded IntelliCAD drawing or embed an exist-
ing IntelliCAD drawing.

To create an IntelliCAD drawing in another document

1 In the document, choose Insert > Object (or the equivalent command for that 
program).

2 In the dialog box, click the options for creating a new file. 

3 Under Object Type, choose IntelliCAD Drawing, and then click OK.

4 Create the IntelliCAD drawing.

5 If IntelliCAD is running in its own window, choose File > Exit.

If IntelliCAD is running within the other document (in place), click somewhere in 
the document outside the IntelliCAD drawing to close IntelliCAD.
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6 To edit the IntelliCAD drawing from within the document, double-click the 
drawing.

TIP You can also embed an existing IntelliCAD drawing from within another docu-
ment. Follow step 1 in the preceding procedure, and then click the option for creating 
an object from an existing file.

To embed selected IntelliCAD entities

1 In IntelliCAD, select the entities you want to embed.

2 Choose Edit > Copy (or press Ctrl+C).

3 Open the document in which you want to embed the entities. 

4 Choose Edit > Paste (or the equivalent command).

To embed an entire IntelliCAD drawing

1 Open the document in which you want to embed the drawing.

2 Choose Insert > Object.

3 Click Create From File.

4 Click Browse, and then choose the file you want to embed.

5 Click Insert, and then click OK.

Editing an embedded IntelliCAD object in place
In many ActiveX-compatible programs you can edit an embedded IntelliCAD object 
without leaving the program (or container application). This is called in-place editing. 
A different set of IntelliCAD menus and toolbars temporarily replaces most of the 
menus and controls in the active window while you edit the IntelliCAD object.       

To edit an embedded IntelliCAD object in place

1 In the container application, double-click the embedded IntelliCAD object.

A different set of IntelliCAD menus and controls appears.

2 Edit the IntelliCAD drawing.

3 Click anywhere outside the drawing window to exit the in-place editing controls.

Linking drawings
When you link an IntelliCAD drawing to another document, the other document con-
tains only a reference to the IntelliCAD drawing file, rather than the actual drawing. 
You link data in a saved IntelliCAD file so that the other program can find the data 
and display it.     

Linking works well when you want to include the same IntelliCAD data in more than 
one document. When you update the data, you need update it in only one location. 
The versions that are linked to other documents reflect the changes automatically.
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Linking an IntelliCAD file to another document does not increase the file size the 
way embedding an IntelliCAD object does. However, links require more 
maintenance. To transport the data, you must make sure to transfer all linked files to 
the other computer.

To link an IntelliCAD file to another document

1 Open the drawing you want to link.

NOTE Because a link is a reference to a file, you can link only files that are saved to a 
location on a disk. If you haven’t saved the drawing you want to link, choose 
File > Save.

2 In the other program, open the document in which you want to include the 
IntelliCAD drawing.

3 Choose that program’s command for inserting objects.

In Microsoft® Office programs, choose Insert > Object. In the Object dialog box, 
click the Create From File tab. Specify the name of the drawing file you want to 
link. Select the Link To File check box, and then click OK.

The drawing appears in the document, with a link to the original IntelliCAD file.

Dragging IntelliCAD drawings into other programs
If the other program in which you want to include IntelliCAD drawings is compatible 
with ActiveX, an alternative to pasting drawings with menu commands is to drag 
drawing file icons from Windows Explorer into the other document. Dragging and 
dropping drawings does not use the Clipboard, so data on the Clipboard is not 
affected. 

When you drag an IntelliCAD drawing file from Windows Explorer, you link or 
embed the entire drawing in the other document. When you drag the file, the cursor 
changes in response to the action you take.

TIP Before you drag a drawing, position the Windows Explorer window and the other 
program’s window so you can see the file icon and the document in which you want 
to drop it.

How the cursor changes

Cursor appearance Action

Drag to embed the selected file to the other 
document. 

Cannot drop drawings in that document.
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To drag and embed drawings into another document

• Select the icon for the drawing file, and then drag the drawing into the document.

Exporting drawings
You can save or export IntelliCAD drawings in a number of different formats for use 
with other programs. When you save a drawing in a different format, the program 
saves all the entities in the drawing to the new file. Or, you can choose which entities 
are included in the new file.  

You can also export ACIS solids, regions, and surfaces to an ASCII file (*.sat) that 
you can use in other programs.

Export formats

Format File extension Details

AutoCAD Drawing DWG AutoCAD versions 2007, 2004, 2000, R14, 
R13, or R11/12

ASCII AutoCAD Drawing 
Exchange Format

DXF AutoCAD versions 2007, 2004, 2000, R14, 
R13, or R11/12

Binary AutoCAD Drawing 
Exchange Format

DXF AutoCAD versions 2007, 2004, 2000, R14, 
R13, or R11/12  

Bitmap BMP Graphics file

Enhanced Windows Metafile EMF Graphics file

Windows Metafile WMF Graphics file

Portable Document Format PDF Distribute your drawing to others for using with 
Adobe® Acrobat® Reader® and Adobe® 
Acrobat

Design Web Format DWF Distribute your drawing to others for using with 
Autodesk® software and tools

Scalable Vector Graphics SVG Graphics file format and Web development 
language 
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Exporting to a DWG, DXF, BMP, EMF, WMF,  or SVG file
Exporting to a file is similar to saving a standard drawing file.

To export a drawing to a DWG, DXF, BMP, EMF, WMF, or SVG file 

1 Do one of the following:

• Choose File > Export To File.

• Type export and then press Enter.

2 In the Export Drawing As File dialog box, under Save As Type, choose the file 
format.

3 Specify the name of the file you want to create.

4 Click Save.

5 If the selection prompt box displays, choose the entity-selection method, and then 
create the selection set. 

6 When you have finished selecting entities, press Enter.

Exporting to a PDF file
PDF files allow you to distribute your drawing to others for viewing in Adobe® Acro-
bat® Reader®, which is free software that users can download. PDF files can also be 
viewed, reviewed, and edited in Adobe® Acrobat.

To export a drawing to a PDF file 

1 Do one of the following:

• Choose File > Export To File.

• Type export and then press Enter.

2 In Save As Type, choose Portable Document Format (pdf).

3 Specify the name of the file you want to create.

4 Click Save.

5 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export. 

6 When you have finished selecting entities, press Enter.

7 Choose the options for how you want to export to the PDF file.

8 Click Export.
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A Click to include fonts within the PDF file, otherwise 
system fonts are used. If selected, TrueType fonts 
are embedded within the exported PDF file, which 
can cause very large file sizes in some cases. 

B Click to export TrueType font text as geometry 
instead of text.

C Click to export SHX font text as geometry instead of 
text.

D Click to optimize geometry processing, for example, 
save arcs as bezier curves instead of an 
enumeration of lines, save separated segments with 
equal ends and equal attributes as one polyline, and 
save rectangles as rectangles instead of four lines.

E Choose whether to export only the current, active 
layout, or all layouts in the drawing.

F Enter details if you want to save the information as 
properties for the PDF file.

G Enter the width and height of the paper for the 
layouts you are exporting. This will be the width and 
height of the page in the PDF file.

H Choose the desired unit of measure for the paper 
size: millimeters or inches.

I Select a paper size for the layouts you are exporting. 
This will also be the page size in the PDF file. If you 
want to specify your own custom paper size, choose 
Custom Size.

J Click to use the same paper size that is defined for 
the exported layouts. If this check box is unmarked, 
specify a different paper size in the Size list.

A
B
C
D

F

J

H

GE

I
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Exporting to a DWF file
DWF files allow you to publish your drawings so they can be viewed on the Internet 
using a Web browser. IntelliCAD exports your drawing to a Design Web Format 
(.dwf) file, which can be viewed in a Web browser if Autodesk® DWF Viewer is also 
installed on the computer. DWF Viewer is a free tool from Autodesk®.

You can export your drawing to a 2D DWF file or a 3D DWF file. 2D DWF files 
have smaller file sizes, but cannot be viewed in three dimensions. 3D DWF files can 
be viewed in three dimensions using the Autodesk® DWF Viewer, but have larger file 
sizes.

To export a drawing to a 2D DWF file

1 Do one of the following:

• Choose File > Export To File.

• Type export and then press Enter.

2 In Save As Type, choose Design Web Format (dwf).

3 Specify the name of the file you want to create.

4 Click Save.

5 Choose how you want to export:

• DWF File Version — Choose the DWF file version you want. Version 4.2 can 
export entities on the Model tab only (no layouts). Version 5.5 can export the 
current layout only. Version 6.0 can export the current layout or all layouts.

• DWF File Format — Choose the desired file format. Compressed binary files 
have a smaller file size than uncompressed binary files. ASCII files have the 
largest file size.

• Layout to Export — Choose whether to export the current layout only, or all 
layouts in the drawing.

6 Click OK.

7 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export. 

8 When you have finished selecting entities, press Enter.
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To export a drawing to a 3D DWF file

1 Do one of the following:

• Choose File > Export To File.

• Type export and then press Enter.

2 In Save As Type, choose 3D DWF.

3 Specify the name of the file you want to create.

4 Click Save.

5 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export. 

6 When you have finished selecting entities, press Enter.

Exporting to an ACIS file
You can export ACIS entities such as surfaces, regions, and solids to an ACIS file in 
ASCII (SAT) format. 

To export an ACIS file

1 Do one of the following:

• Choose File > Acis Out.

• Type acisout and then press Enter. 

2 Select the ACIS entities you want to save. 

3 Specify the name of the file you want to create. 

4 Click Save. 

Sending drawings through e-mail
You can send an IntelliCAD drawing to another user via e-mail. IntelliCAD is com-
patible with e-mail programs that support the Messaging Application Program Inter-
face (MAPI) protocol.

To include a drawing file in an e-mail message

1 While the drawing file is open, choose File > Send Mail.

If your mail program is not already running, it starts; a new e-mail message con-
taining the IntelliCAD icon and file name appears.

2 Address the e-mail, type a message, and send the e-mail message as you would 
any other message.

To view an IntelliCAD file sent by e-mail 

• Open the e-mail message, and then double-click the IntelliCAD icon.

NOTE IntelliCAD software must be installed on the computer used to open drawings 
in e-mail.
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Using IntelliCAD with the Internet

You can use IntelliCAD to access the Internet and exchange drawing information and 
perform other tasks, including: 

• Add hyperlinks to a drawing.

• Publish drawings to the Internet.

• Drag drawings (.dwg files) directly from a Web site into IntelliCAD.

• Access the Internet during a drawing session.

NOTE You will need Internet Explorer Version 5.0 or later and access to the Internet 
to fully use these features.

Add hyperlinks to a drawing 
In your IntelliCAD drawings, you can include hyperlinks, which are pointers that 
take you to another location, such as a Web address or a file on a particular computer. 
You can attach a hyperlink to any entity in your drawing. Then, when you select that 
entity, you can open the link and jump to the specific Web address or file location. 
You can create absolute hyperlinks, which store the full path to a file, or relative 
hyperlinks, which store a partial path relative to a base folder or a Uniform Resource 
Locator (URL).

NOTE To open files associated with hyperlinks, the PICKFIRST system variable must 
be set to On. 

To create a hyperlink

1 Type hyperlink and then press Enter.

2 Select an entity or entities that you would like to associate with a hyperlink; then 
press Enter to display the Edit Hyperlink dialog box.

3 Do one of the following: 

• Click Browse to specify a file.

• In the Link to File or URL box, type a Web address.

4 If you want to use a common path for all hyperlinks in the drawing, select the Use 
relative path for hyperlinks check box. Relative paths provide flexibility if you 
move files to a different folder, since you can change multiple hyperlink paths at 
once, rather than change them all individually. 
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5 Click OK to close the Edit Hyperlink dialog box.

NOTE The HYPERLINKBASE system variable defines the relative path used for all 
hyperlinks in the current drawing. To use the default drawing path, leave the value 
blank by entering a period (".").

To remove a hyperlink

1 Type hyperlink and then press Enter.

2 Select an entity or entities with a hyperlink; then press Enter to display the Edit 
Hyperlink dialog box.

3 Click Remove Link. 

4 Click OK to close the Edit Hyperlink dialog box.

To access a hyperlink

1 Select an entity with a hyperlink.

2 Right-click anywhere in the drawing area.

3 In the pop-up menu, choose Open Link.
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Publishing drawings to the Internet
You can publish your drawings so they can be viewed on the Internet using a Web 
browser. IntelliCAD exports your drawing to a Design Web Format (.dwf) file, which 
can be viewed in a Web browser if DWF Viewer is also installed on the computer. 
DWF Viewer is a free tool from Autodesk®.

For details about creating a DWF file, see “Exporting to a DWF file” on page 470 in 
this chapter. 

Inserting drawings from a Web site
Some Web sites are configured to allow you to drag drawings from the Web site 
directly into your drawing. You can drag-and-drop drawings from any Web site that 
supports the Autodesk® i-drop® technology. 

To insert a drawing from a Web site

1 Open your Web browser.

2 Navigate to a Web site that supports Autodesk® i-drop. 

3 Position the Web browser and IntelliCAD windows so they are both visible.

4 Click the drawing in your Web browser and drag it to your drawing in IntelliCAD.

The drawing file is downloaded and inserted into your drawing in IntelliCAD.

Accessing the IntelliCAD Web site during a drawing session
In addition to using hyperlinks to access the Internet, you can access a company Web 
site at any time. At the Web site, you can obtain company information as well as 
product information and news.

To access the IntelliCAD Web site

1 Do one of the following: 

• Choose Help > IntelliCAD on the Web.

• Type onweb and then press Enter.

2 Navigate to the section of your choice on the IntelliCAD Web site.
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Customizing IntelliCAD

You can customize IntelliCAD in a number of ways. For example, you can change 
the appearance of many aspects of the program and modify the existing menus and 
toolbars or create new ones. This section explains how to: 

• Set the program’s preferences.

• Customize menus and toolbars.

• Customize the keyboard.

• Create aliases for frequently used commands.

• Customize entities.

• Create and use scripts.

• Use add-on programs with IntelliCAD.

• Use a digitizer tablet for menu selection and calibrated drawing.  

Topics in this chapter

Setting and changing options............................................................................476

Customizing menus...........................................................................................491

Customizing toolbars.........................................................................................498

Customizing the keyboard.................................................................................508

Creating aliases ................................................................................................511

Customizing entities ..........................................................................................514

Creating and replaying scripts...........................................................................518

Programming IntelliCAD....................................................................................521

Using a digitizer tablet .......................................................................................526
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Setting and changing options

You can change many of the options that control the program’s behavior and appear-
ance, such as setting the experience level, specifying file paths and default files, and 
configuring display features.

Changing the options on the General tab
In the Options dialog box, the General tab contains settings for experience level and 
save options. You can also set VBA security.

Setting the experience level You can control which menus and tools are available by 
setting the experience level. You can choose from the following experience levels: 

• Beginner Menus and toolbars display only basic commands. 

• Intermediate Menus and toolbars display most two-dimensional entity creation 
and modification commands.

• Advanced Menus and toolbars display all available commands. 

Saving your drawings automatically To avoid losing data in the event of a power fail-
ure or other system error, save your drawing files often. You can configure the pro-
gram to periodically save your drawings automatically. The Minutes setting 
determines the interval between automatic saves. The program restarts this interval 
timer whenever you save the drawing file.        

When AutoSave is enabled, the program creates a copy of your drawing. The file is 
saved in the folder specified in Options > Paths/Files for Temporary Files, with the 
file extension specified in the AutoSave Drawing Extension box (by default, .SV$).

Setting the default Save As format You can control the default file format that you 
want to display in the Save Drawing As dialog box. For example, if you use the Save 
As command to save most of your drawings in a legacy file format, you can select 
that file format as the default so you don’t have to select it each time you save a draw-
ing using the Save As command.This setting has no effect on saving existing or new 
drawings using commands other than Save As — IntelliCAD always saves existing 
drawings in their current file format and saves new drawings with the most current 
file format.   

Setting how drawings are opened If you regularly open drawings that contain errors 
or damaged data, for example, if you are a new IntelliCAD user and your original 
drawings were created using different CAD software, you can enable Open Drawings 
using Recover. This option automatically checks all drawings for errors when using 
the Open command, and attempts recovery, as needed. Viewing warning messages 
when opening drawings allows you to know which files are being fixed by Intelli-
CAD and what errors have occurred; however, you can also choose to hide the warn-
ings.
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Disabling VBA CommonProject macros Each time you start IntelliCAD, macros are 
automatically loaded for the Visual Basic Application (VBA) CommonProject. If you 
do not plan to use VBA, disabling the macros may improve performance. In addition, 
disabling the macros can enhance security if you are running IntelliCAD at a low 
security level.

To change the options on the General tab 

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the General tab.

3 Under Experience level, select Beginner, Intermediate, or Advanced.

4 Under AutoSave, select the check box to enable the AutoSave feature, and select 
the frequency.

If you want to change the default extension assigned to your AutoSave files, type 
the new extension in AutoSave Drawing Extension.

5 Under Save As, select the default drawing format that displays when using the 
Save As command. You can always specify a different format in the Save Draw-
ing As dialog box. 

6 If you want to use the Recover command automatically each time you use the 
Open command, mark the check box for Open Drawings using Recover. 

If you want to hide warnings when errors are found in a drawing, mark the check 
box for Hide Warnings when Opening Drawings using Recover. Errors will still 
be logged in an ASCII file with an .adt extension.

7 If you do not want the CommonProject macros to be loaded when you start Intelli-
CAD, under VBA Security, click the check box for Disable VBA CommonProject 
Macros On Startup.

8 When you have finished, click OK.
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Changing the options on the Paths/Files tab 

You can specify locations for various file types such as those used for drawings, 
fonts, and menus in the Options dialog box on the Paths/Files tab. You can even 
specify multiple paths for the same file type. In addition, you can change the names 
of the default system files that are used for functions such as font mapping and error 
logging.

Specifying the user paths 
You can enter paths to your IntelliCAD directories by typing them into a Location 
field in the Options dialog box. This feature includes directories for drawings, fonts, 
help, external references, menus, hatch patterns, blocks, print style tables, print output 
files, temporary files, templates, and color books. IntelliCAD searches directories for 
support files in the following order:

• The IntelliCAD program directory.

• The current drawing directory.

• The Windows search path.

• The search path specified in the Options dialog box. 

A Click to enable AutoSave feature. 

B Select the default file format that displays when 
saving  drawings using the Save As dialog box.

C Select to check all drawings for errors when 
using the Open command, and attempt recovery, 
as needed.

D Select to hide warning messages when opening 
drawings, if the check box Open Drawings using 
Recover is marked.

E Click to disable VBA CommonProject macros on 
startup. (Available if supported by your version of 
IntelliCAD.)

F Type the file extension for AutoSaved files.

G Enter frequency of AutoSave in minutes.

H Select the experience level.

H
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You can enter multiple paths for each item. If, for example, the Drawings item has 
more than one directory associated with it, you can specify multiple paths by separat-
ing them with a semicolon. IntelliCAD searches the directories in the order in which 
they are listed.

To specify a user path

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Paths/Files tab.

3 Under Location, click the item in the User Paths list whose path you want to spec-
ify, and type the path.

If you do not know the path or directory name, click Browse, and then browse to 
the location of the directory you want.

4 When you have finished, click OK.

Changing the default system files 
You can change the default system files, including the log file, default template, alter-
nate font, and font mapping file.

To change a default system file

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Paths/Files tab.

3 In the lower half of the dialog box, under File, click the file name for the default 
system file you want to change, and type in a new file name. 

If you don’t know the file name, click Browse, and then browse to the location of 
the file you want.

4 Type a new name.

5 When you have finished, click OK.
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The following figure shows the Options dialog box with the User Paths and System 
Files sections identified.   

Changing the options on the Display tab
In the Options dialog box, the Display tab contains settings for displaying the 
command bar, IntelliCAD window, menus, and real-time view rotation.

Setting the command lines to track IntelliCAD tracks the commands and command 
prompts you used most recently. You can control the number of lines that the pro-
gram keeps in memory as you work. The default value is 256. You can display the 
commands in the Prompt History window. To display the Prompt History window, 
press F2. To close the window, press F2 again. 

Enabling Up/Down arrows in command history By default, using the keyboard arrows 
pans your view of the drawing. If you prefer to scroll the command history using the 
up and down arrows, you can mark the Use Up/Down Arrows for Command History 
Navigation check box. Then when you use the up and down arrows, previous com-
mands display and the other prompt input is skipped. This can be a convenient way to 
review and even repeat previous commands. 

Displaying tabs and scroll bars Hiding window elements if you do not use them can 
help increase drawing space in the IntelliCAD window.

To show or hide the Model tab and Layout tabs, select the Show Tabs check box. You 
may want to hide the tabs if you only work on the Model tab or if you use the com-
mand bar and status bar to switch between tabs.

A Click to select a new default file.

B Select the default file to change.

C Click to select new default folder.

D Directory path specified by user.

D

C

B

A
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To show or hide the scroll bars that display on the right side and bottom of the Intelli-
CAD window or viewport, select the Show Scroll Bars check box. You may want to 
hide the scroll bars if you only use the Pan command to scroll drawings.

Enabling continuous view rotation  When you use the Real-Time Sphere command to 
rotate your view of entities, you typically move the mouse to rotate the view. If you 
want the rotation to continue after you release the mouse, turn on the Continuous 
Inertial Motion in Real Time check box. The rotation also continues when you use the 
Real-Time X, Real-Time Y, and Real-Time Z commands.

Changing the zoom direction of the mouse wheel By default when working in a 
drawing and using the mouse wheel, you spin the mouse wheel forward to zoom in 
and spin it backward to zoom out. If you want to reverse the zoom direction relative 
to the zoom wheel, that is, spin the wheel forward to zoom out and spin it backward 
to zoom in, enable the Reverse Mouse Wheel Zoom Direction check box. This can be 
especially helpful if you use the mouse with your left hand.

Setting the graphics screen color By default, drawings are displayed on a black back-
ground. You can change this color and specify the background screen color that you 
want. 

Displaying prompt boxes When a command offers several options, a prompt box is 
displayed with those options. If you prefer to select options by typing, you can turn 
off the prompt boxes by clearing the Display Prompt Boxes check box. 

Setting automatic menu loading The first time you start IntelliCAD, a default menu is 
loaded, and the Automatic Menu Loading check box in the Options dialog box is 
checked. The Automatic Menu Loading feature allows you to load drawings with 
associated menus without overwriting the default menu. You can turn off the Auto-
matic Menu Loading option.

To change the options on the Display tab

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Display tab.

3 Select the options you want.

4 When you have finished, click OK.
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A Type or select the maximum number of 
command lines to track.

B Click to show or hide the Model and Layout tabs.

C Click to show or hide scroll bars.

D Click to show or hide prompt boxes.

E Click to toggle automatic menu loading on or off.

F Select to zoom out when spinning the mouse 
wheel forward and zoom in when spinning the 
mouse wheel backward.

G Select to continue rotating the view when using 
the Real-Time Sphere, Real-Time X, Real-Time 
Y, and Real-Time Z commands. 

H Click to select screen color.

I Select to use Up and Down arrows for scrolling 
the command history instead of panning.
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Changing the options on the Crosshairs tab
In the Options dialog box, on the Crosshairs tab, you can control how the crosshairs 
display. To help you differentiate the x-, y-, and z-axes, a different color is assigned 
to each. You can change the default axes colors to any color you want. In addition, 
you can specify the size of the crosshairs display, enable grips attraction for the cur-
sor, and you can elect to use crosshairs as the default pointer shape.   

To change the options on the Crosshairs tab

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Crosshairs tab.

3 Select the options you want.

4 When you have finished, click OK.

A For each axis, click Color and select an axis 
color from the palette.

B Select to always display the pointer as the 
crosshairs (instead of the small box).

C Select to move the crosshairs automatically to 
grips within a certain range. 

D Enter or scroll to a number for the grips attraction 
range. Higher points increase the range of the 
attraction.

E Enter or scroll to a number for the percentage of 
the screen to be used by the crosshairs cursor.

A

B

C D

E
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Changing the options on the Profiles tab
IntelliCAD allows you to customize the settings that control your drawing environ-
ment, and then save and restore those settings in a profile. For example, if you prefer 
working with custom menus and toolbars, you can save these settings as your own 
profile. 

Profiles can be helpful if you have multiple users with different preferences, or if you 
are a single user who works on various projects that require unique settings. You can 
even export your profile and bring it with you when you work on a different com-
puter. 

Understanding the settings saved in profiles
Profiles save many settings that control the drawing environment. Once you start 
using a profile, it automatically tracks and stores changes that you make to your 
drawing environment.

Some settings are saved immediately, but some require that you exit IntelliCAD and 
then start IntelliCAD again. This is because profiles save settings from your com-
puter’s registry and some settings are only saved to the registry when you exit Intelli-
CAD.  

Creating profiles
Create profiles if you want to save your custom drawing environment settings. This 
can be helpful if you have two or more drawing environments that you use regularly.

When you create a new profile, the current drawing environment settings are auto-
matically saved with the new profile.

Settings saved in profiles

Setting Location When saved

Toolbar settings Tools > Customize, Toolbars tab Exit and restart of IntelliCAD

Menu settings Tools > Customize, Menus tab Immediately

Keyboard settings Tools > Customize, Keyboard tab Immediately

Alias settings Tools > Customize, Aliases tab Immediately

Window elements on/off 
status and their various 
settings

View > Command Bar
View > Model and Layout Tabs
View > Prompt History Window
View > Scroll Bars
View > Status Bar

Exit and restart of IntelliCAD

Tablet configurations Settings > Tablet Immediately

User paths Tools > Options, Paths/Files tab Immediately

System variables Typed in command bar Varies — some saved immediately 
and some upon exit and restart of 
IntelliCAD
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To create a profile

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Click Create.

4 Enter a name, a description (optional), and then click OK.

5 In the Options dialog box, click OK.

6 Make changes to your drawing environment.

IntelliCAD automatically saves the settings to the new profile. 

NOTE In some cases, for example, with toolbars, you need to exit and restart Intelli-
CAD before the settings are saved with the profile. This is because profiles save set-
tings from your computer’s registry and some settings are only saved to the registry 
when you exit IntelliCAD. 

 

A Displays the name of the currently loaded profile.

B Select a profile to load it or modify it.

C Displays a description of the profile.

D Click to restore the selected profile to the system 
default settings.

E Click to open a profile stored in an .arg file.

F Click to save the selected profile in an .arg file.

G Click to delete the selected profile.

H Click to rename the selected profile.

I Click to make a copy of the selected profile.

J Click to load the selected profile and make it the 
active profile.

K Click to create a new profile.
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Loading a profile
While you work in IntelliCAD, you can load the custom settings of any profile. The 
current profile when you exit IntelliCAD is automatically loaded when you start 
IntelliCAD again.

To load a profile

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the desired profile.

4 Click Set Current.

Restoring the default settings
At any time you can return to the default drawing environment settings that were 
installed with IntelliCAD. 

If the Default profile is unchanged, simply load it to restore the default settings. If the 
Default profile is deleted or changed, reset an existing profile (one that you no longer 
need) to replace its contents with the default settings.

To restore default settings using an unchanged Default profile

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the Default profile.

4 Click Set Current.

To restore default settings without using the Default profile

NOTE Resetting a profile erases all of the profile’s custom settings. Do this only if you 
are certain you no longer need the selected profile.

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select a profile that you no longer need; all of it’s custom settings will be erased. 

If necessary, create or copy a profile to use for restoring the default settings.

4 Click Reset. 
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Managing profiles
Once you start using profiles, you may need to rename, copy, or delete them. Copy-
ing a profile is a quick way to create a new profile based on an existing profile.

To rename a profile

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to rename.

4 Click Rename.

5 Make any necessary changes to the name or description, and then click OK.

To copy a profile

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to copy.

4 Click Copy.

5 Enter a new name, a description (optional), and then click OK.

To delete a profile

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to delete.

4 Click Delete.
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Working with profiles on multiple computers
If you use multiple computers and you like to work with our own drawing environ-
ment settings, save time by bringing your profile with you.

On your computer, export your profile to an .arg file. Bring the file with you to the 
other computer using a disk, E-mail, network, or some other method. When you start 
working at another computer, simply open and load your profile instead of recreating 
your preferred drawing environment.

To export a profile to a file

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile to export.

4 Click Export.

5 Specify a location and name for the exported file, and then click Save.

To open a profile from a file

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Click Import.

4 Locate and select the profile (.arg file), and then click Open.

5 Make any necessary changes to the name or description, and then click OK.

6 (Optional) To load the imported profile, select it, and then click Set Current.

Changing the options on the Printing tab
In the Options dialog box, on the Printing tab, you can determine several printing set-
tings, including headers, footers, and print style tables.

Creating headers and footers You can include header and footer information such as 
a date and time stamp, your name and company name, or other information that you 
want to appear at the top or bottom of printed drawings. Header and footer settings 
are set globally for all drawings.

Specifying print style settings Print styles change the appearance of your printed 
drawing without modifying the actual entities in your drawing. Use the Printing tab to 
specify initial print style settings for new drawings created without a template and for 
older drawings when opened (older drawings that were created before print styles 
were available, for example, before AutoCAD 2000). Drawings that are already open 
are not affected.
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For more details about print styles and print style tables, see “Using print styles” on 
page 379. 

To change the options on the Printing tab

1 Do one of the following: 

• Choose Tools > Options. 

• Type config and then press Enter.

2 Click the Printing tab.

3 Select the options you want.

4 When you have finished, click OK.

A Type the content for the header and footer, or 
select it from the lists.

B Select to use color-dependent or named print 
style tables for new drawings created without a 
template.

C Select a print style table to use with new 
drawings.

D For color-dependent tables, displays BYCOLOR 
(not selectable); for named tables, select the 
print style to assign to layer zero. 

E For color-dependent tables, displays BYCOLOR 
(not selectable); for named tables, select the 
print style to assign to new entities.

F Click to create or change print style tables that 
can be selected on the Printing tab or elsewhere 
in IntelliCAD.

A

B

C

D

E

F
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Changing the options on the Snapping tab
In the Options dialog box, on the Snapping tab, you can control how entity snaps 
work, including fly-over snapping. Fly-over snapping is a visual aid to help you 
see and use entity snaps more efficiently. 

To change the options on the Snapping tab

1 Do one of the following: 

• Choose Tools > Options. 

• Type config and then press Enter.

• Choose Settings > Entity Snap > Entity Snap Settings and click Fly-Over.

2 Click the Snapping tab.

3 Select the options you want.

4 When you have finished, click OK. 

A Select to display an extra image on the cursor to 
show which entity snap is active. (Available even 
if fly-over snapping is turned off.)

B Select to turn on fly-over snapping.

C Select to turn on fly-over snap tooltips, which 
indicate the type of snap that was used to select 
the marked location.

D Select to turn on the fly-over snap aperture box. 
Entities found within the aperture box are 
available for selection, making it easier to find 
and select entity snap points.

E Type or scroll to the tolerance size for the fly-
over snap aperture box. Higher numbers 
increase the distance from the cursor in which 
entities are found.

F Type or scroll to the thickness of the fly-over 
snap marker.

G Type or scroll to the size of the fly-over snap 
marker.

H Click to choose the color of the fly-over snap 
marker.

I Select to turn on the display of fly-over snap 
markers in all views when you are using more 
than one viewport.

J Select to turn on fly-over snap markers, which 
mark snap points on entities.

A

B

C

G

H
D

E

F

I
J
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Customizing menus

You can customize a current menu and save your changes as an IntelliCAD menu 
file. You can also load both existing IntelliCAD (*.icm) and AutoCAD (*.mnu, 
*.mns) menu files. You customize menus using the Customize dialog box.     

To display the Customize dialog box

1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

  

A To make a menu item current, choose it from the 
list.

B Contains the command string assigned to the 
current menu item.

C Contains the text displayed in the status bar for 
the current menu item.

D Click to import an existing menu file from another 
source.

E Click to save the current menu to a different 
location.

F Click to reset the current menu, rejecting any 
changes you have made.         

G Click to display the Options dialog box for further 
customization options.

H Click to add the selected command to the current 
menu item.

I Click to rename the current menu item.

J Click to insert a Menu Item, a Menu Sub-Item, a 
Spacer, or Context Menu Item, or a Context 
Menu Sub-Item.

G

H

I

JA

B
C

D E F
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Understanding menu compatibility
MNU files are menu files created by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. IntelliCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus. 
 

To see how IntelliCAD reads AutoCAD menu source files

1 Type menu and then press Enter. 

2 Under Files Of Type, select AutoCAD Menu File (mnu).

3 In the Open Menu dialog box, go to the AutoCAD Support folder and select the 
Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000).

4 To load the AutoCAD menu file into IntelliCAD, click Open.

The IntelliCAD menu bar now looks identical to the AutoCAD menu bar.

5 To see how it works, choose a few commands from the menu bar, such as File > 
Open or Draw > Line.

6 To restore IntelliCAD to its default menu, choose Tools > Customize, and then 
click the Menus tab and click Reset. 

7 To restore the IntelliCAD default toolbars, choose Tools > Customize, and then 
click the Toolbars tab and click Reset.

Creating new menus and commands
You can create a new menu by inserting a menu item at the top level of the Menu 
Tree. Then you can add commands to the new menu item. You can also add sub-
menus and modify existing menu names and commands by adding, deleting, and 
rearranging them. 

IntelliCAD support of specific sections in AutoCAD MNU and MNS files

Menu section Definition IntelliCAD support

***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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NOTE A green bullet in front of a menu item or command indicates that the menu item 
or command is available for you to use at the experience level you have set. A red 
bullet in front of a menu item or command indicates that the menu item or command 
is not available for you to use at the experience level you have set. To change your 
experience level, choose Tools > Options.

To create a new menu 

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu name above which you want to add a new 
menu.

4 Choose Insert > Menu Item.

5 Type a name for the new pull-down menu, and then press Enter.

6 Click Close.

To see the new menu, you must perform the following steps for adding a command to 
the menu.

To add a command to a menu 

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu to which you want to add the new command.

4 Choose Insert > Menu Sub-Item.

5 Type a name for the new command, and then press Enter.

6 Assign a command string to the command you added by doing one of the 
following:

• In the Available Commands list, choose the command, and then click Add 
Command.

• In the Command box, type the command string, and then click Add Command.

7 In the Help String box, type the text to be displayed in the status bar when the cur-
sor is positioned over the new command.

8 To add another command, repeat steps 3 through 7.

9 When you have finished, click Close.
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TIP When you type a name for a new command, you can specify an access key by 
including an ampersand (&) immediately preceding the letter you want to use as the 
access key. Be sure not to assign the same access key to more than one menu or com-
mand within a menu. For example, if you add a command named Quick Line to the 
Insert menu, including an ampersand immediately preceding the letter Q causes that 
letter to appear underlined in the menu. You can then select that command by dis-
playing the menu and pressing the Q key. 

To rename a menu item 

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu item you want to rename.

4 Click Rename.

5 Type a new name for the menu item by typing over the highlighted name, and then 
press Enter.

6 Click Close.

To delete a menu item 

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu item you want to delete.

4 Click Delete.

5 In the Confirmation dialog box, click Yes to delete the menu item.

6 Click Close.

NOTE Deleting a menu item that has sub-items below it in the Menu Tree also deletes 
all those sub-items.
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Setting the experience levels for menus
You can set the experience levels for menu items you create, and you can change the 
experience levels for existing commands.

To set the experience levels for a command 

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the command.

4 Click Options.

5 In the Menu Customization Options dialog box, under Experience Level, select 
the experience levels that you want for the command.

6 Click OK.

7 Click Close.

NOTE Select all the experience levels above the lowest level you want to use. Com-
mands appear in the menu only at the experience levels you specify. If you select 
Intermediate without also selecting Advanced, the commands will appear only when 
you set the experience level to Intermediate.

Saving menu files
IntelliCAD automatically saves any changes you make to the current menu. You can 
also create and save your custom menus. The program automatically saves all menu 
files with the *.icm file extension. 

To save the current menu to a file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 Click Export.

4 In the Select Menu File dialog box, specify the directory and file name you want 
to use to save the menu file.

5 Click Save.

6 Click Close.

NOTE Saving a menu does not save any toolbars that you created or modified.
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Loading menu files
You can replace the current menu file with other custom menus. The program loads 
both AutoCAD (*.mnu, *.mns) and IntelliCAD (*.icm) menu files. 

To load a menu file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Menus tab.

3 Click Import.

4 From the Files Of Type list, choose either *.icm, *.mnu, or *.mns.

5 Select the menu to load.

6 Click Open.

7 Click Close.

NOTE Loading a new menu replaces only the menu. It does not replace any custom 
toolbars you may have defined.

Creating custom shortcut menus
With IntelliCAD, you can create a custom shortcut menu for commands you want to 
use frequently. You access the shortcut menu by holding down the Shift key and 
clicking the right mouse button or by clicking the mouse wheel (if you have one). 
Using any ASCII text editor, you construct the menu to conform to the Custom short-
cut menu syntax and definitions as shown here:

***MENUGROUP=group_name

***POP0

**menu_name

[menu_name]

ID_item_name [item_string]command

***HELPSTRINGS

ID_item_name[help_string]

Shortcut menu syntax and explanations

Item Explanation

group_name Menu group name.

menu_name Shortcut menu name.

item_name Menu item name.
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To create a custom shortcut menu 

The following example describes how to build a custom menu that includes line, 
hatch, dtext, circle, and erase commands.

1 Open any ASCII text editor.

2 Type the following characters exactly as shown here:

***MENUGROUP=example

***POP0

**IntelliCAD

[IntelliCAD]

ID_Line [Line]^C^C_line

ID_Hatch [Hatch]^C^C_hatch

ID_Dtext [Dtext]^C^C_dtext

ID_0 [Circle Rad]^C^C_circle

ID_Erase [erase]^C^C_erase

***HELPSTRINGS

ID_LINE [Draws a line]

ID_HATCH [Fills an enclosed area with a nonassociative hatch pattern]

ID_DTEXT [Displays text on screen as it is entered]

ID_CIRCLE [Creates a circle]

ID_ERASE [Removes objects from a drawing]

3 Save the file as example.mnu to the IntelliCAD 6.1 folder.

item_string Menu item string (typically, the command name). The menu item string 
appears in the shortcut menu. To specify an access key for a command, insert 
an ampersand (&) immediately before the letter you want to use as the access 
key. Do not assign the same access key to more than one command.

command Command string. Begin the command string with "^C^C" (e.g., ̂ C^C_LINE) 
unless the command is transparent.

help_string Help string. The text in the help string appears in the status bar when you 
place the cursor over the menu item.

Shortcut menu syntax and explanations

Item Explanation
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To use the custom shortcut menu

1 Open IntelliCAD.

2 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

3 Click the Menus tab.

4 Click Import.

5 Select the custom shortcut menu file.

6 Select the Append To Current Menu check box, and then click Open. 

If you don’t select this box, the custom shortcut menu deletes all current menus.

7 Click Close.

8 Select an entity in your drawing, and then hold down Shift and click the right 
mouse button.

9 Click the shortcut command that you want.

To restore the shortcut menu defaults

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

2 Click Reset.

Customizing toolbars

IntelliCAD provides toolbars so that you can access frequently used commands. You 
can customize these toolbars by adding or removing tools or by rearranging the orga-
nization of tools. You can also create custom toolbars. Toolbars are saved as integral 
parts of the program. Although you cannot export custom toolbars for use by others, 
you can load toolbars created as part of AutoCAD menus. You customize toolbars 
using the Customize dialog box and clicking the Toolbars tab.  

To display the Customize dialog box

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter. 

2 Click the Toolbars tab.

3 Customize the toolbars using the procedures that follow the illustration here. 
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Creating a new toolbar
You can create a new toolbar by dragging a tool from the Customize dialog box and 
dropping it anywhere except on another toolbar. IntelliCAD immediately creates a 
new toolbar and assigns it a default name. Then you can add tools to the new toolbar. 
You can also add, delete, or modify tools on any existing toolbar. 

When you create a toolbar using tools from the Buttons area of the Customize dialog 
box, the ToolTip, Help String, and Command fields are filled in automatically with 
default information. You can edit this information for each tool. 

To create a new toolbar

1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 In the Categories list, choose a category to display its associated tools.

4 Click and drag a tool outside the Customize dialog box and onto an open area of 
the screen.

A The Categories list shows available toolbar 
categories.

B Contains the string displayed as a ToolTip for the 
current tool.

C Contains the text displayed in the status bar for 
the current tool.

D Contains the command string assigned to the 
current tool.

E Displays the available tools for the selected 
category.

A

B
C
D

E
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5 Modify the ToolTip, Help String, and Command fields as needed.

6 Click Close.

To add a tool to a toolbar 

1 Make sure the toolbar you want to modify is visible.

2 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

3 Click the Toolbars tab.

4 In the Categories list, choose a category to display its associated tools.

5 Click and drag a tool onto the toolbar.

6 Modify the ToolTip, Help String, and Command fields as needed.

7 To add another tool, repeat steps 4 through 6.

8 Click Close.

To delete a tool from a toolbar

Make sure the toolbar you want to modify is visible.

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Drag the tool you want to delete off of the toolbar.

4 Click Close.

To add space between tools on a toolbar 

Make sure the toolbar you want to modify is visible.

1 Do one of the following: 

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 On the toolbar, drag the tool away from the tool beside it.

To avoid accidentally deleting a tool, do not drag a tool more than halfway past 
the edge of the toolbar.

4 Click Close.



C U S T O M I Z I N G  I N T E L L I C A D 501
Naming toolbars
When you create a toolbar, the program assigns it an arbitrary name, such as 
ToolBar1, ToolBar2, and so on. The toolbar name is displayed on the title bar when 
the toolbar is floating. You can rename a toolbar at any time.

In the Select Toolbars dialog box, you can rename toolbars, turn the display of tool-
bars on and off, choose to display large or small tools, choose to display toolbar tools 
in color or black and white, and control the display of ToolTips. 

To rename a toolbar

1 Do one of the following:

• Choose View > Toolbars.

• Type tbconfig and then press Enter.

2 From the Toolbars list, choose the toolbar that you want to rename. 

3 In the Toolbar Name field, replace the current name with the new toolbar name.

4 Click OK.   

Creating flyouts
A flyout displays a set of additional tools under a single toolbar tool. IntelliCAD uses 
flyouts to organize related tools and to conserve space on toolbars. A flyout is indi-
cated by a small triangle in the lower right corner of a tool. When you click a flyout 
tool, the other tools on the flyout extend from the original tool so you can select one 
of them. The flyout tool you select then becomes the default tool on the toolbar. You 
can add your own flyouts to toolbars.

A Select to display a toolbar.

B Choose the toolbar that you want to rename.

C Type a new name.

D Select to display large tools; clear to display 
small tools.

E Select to display color tools; clear to display 
black and white tools.

F Select to display ToolTips; clear to not display 
ToolTips.

G Click to customize the toolbars.

A

B

C

D
E
F

G
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To add a flyout to a toolbar

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Select the Insert As Flyout check box.

4 In the Categories list, choose a toolbar name to display its associated tools in the 
Buttons area.

5 From the Buttons area, click and drag a tool onto a toolbar outside the Customize 
dialog box.

6 Modify the ToolTip, Help String, and Command fields as needed.

7 To add another flyout tool, repeat steps 4 through 6.

8 Click Close. 

Setting the experience levels for tools
You can set the experience levels for toolbar tools you create, and you can change the 
experience levels for existing tools.

To set the experience levels for a tool

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Go outside the Customize dialog box to a toolbar, and click a tool to select it.

4 Go back to the Customize dialog box, and click Options.

5 Under User Level, select the experience levels you want for that tool.

6 Click OK.

7 Click Close.

NOTE Select all the experience levels above the lowest level you want to use. Tools 
appear in toolbars only at the experience levels you specify. If you select Intermediate 
without also selecting Advanced, the tool will appear only when you set the 
experience level to Intermediate.
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Creating custom toolbar tools
IntelliCAD provides tools for most of the available IntelliCAD commands. These 
tools appear on the Toolbars tab of the Customize dialog box. You can also create 
your own custom tools and incorporate them into your custom toolbars. To add a cus-
tom tool to a toolbar, you must first add one of the program’s standard tools and then 
replace it on the toolbar with your custom tool.

You create custom tools as bitmap (*.bmp) files using any paint or illustration pro-
gram capable of saving to a bitmap. Because you can configure toolbars to display 
either large or small tools and to display tools either in color or monochrome, create 
four different versions of each custom tool. Create custom tools using the following 
dimensions:

• Small tools: 16 x 15 pixels. 

• Large tools: 24 x 22 pixels.

NOTE If you attempt to use bitmaps that do not match these dimensions, the program 
will stretch or shrink (rather than crop) the bitmaps to fit the specified size. The 
resulting tools may not appear as originally intended.

To add a custom tool to a toolbar

Make sure the toolbar you want to modify is visible.

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Go outside the Customize dialog box to a toolbar, and click a tool in the toolbar to 
select it.

4 Go back to the Customize dialog box, and click Options.

5 In the Toolbar Customization Options dialog box, under Button Bitmaps, click the 
browse tool (indicated by an ellipsis) adjacent to the Small, Color Button list to 
display the Select Bitmap dialog box.

6 Select the bitmap you want to use for the small color tool.

7 Click Open.

8 Repeat steps 5 through 7 for the Large Color Button, Small Black and White But-
ton, and Large Black and White Button versions of your custom tool.

9 When you have finished, click OK.

10 Click Close.
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Importing toolbars
Toolbars are saved as integral parts of IntelliCAD. In IntelliCAD, you can load tool-
bars created as part of AutoCAD (*.mnu, *.mns) menus. Importing an AutoCAD 
menu file from the Toolbars tab of the Customize dialog box loads only the toolbar 
section of the menu file.

To import a menu file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Click Import.

4 Select the menu you want to load.

5 Click Open.

6 Click Close.

NOTE Importing an AutoCAD menu file from the Toolbars tab of the Customize dia-
log box replaces any custom toolbars you may have defined. Importing the menu file 
in this way, however, does not affect the current menu.

The Toolbar Customization Options dialog box.
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Creating toolbars that you can share as files
With IntelliCAD, you can manually create toolbars that you can share as files with 
other IntelliCAD users. You create the toolbar files using any ASCII text editor and 
the toolbar syntax and definitions shown here:

***MENUGROUP=group_name

***TOOLBARS

**toolbar_name

ID_toolbar_name [_Toolbar ("toolbar_name", orient, visible, xval, yval, 

rows)]

ID_button_name [_Button ("button_name", id_small, id_large)]command

***HELPSTRINGS

ID_button_name [help_string]

Toolbar syntax and explanations

Item Explanation

group_name Menu group name.

toolbar_name Toolbar name.

orient Orientation. Select Floating, Top, Bottom, Left, and Right (not case 
sensitive).

visible Visibility. Select Show or Hide (not case sensitive).

xval x coordinate, designated in pixels from left edge of screen. Suggested 
value: 200.

yval y coordinate, designated in pixels from top edge of screen. Suggested 
value: 200.

rows Number of rows

button_name Tool name. Appears as a ToolTip when user places cursor over button.

id_small Name of small (16 x 15 pixels) icon bitmap (BMP) file. This file must be 
located in the IntelliCAD 6.1 folder.

id_large Name of large (24 x 22 pixels) icon bitmap (BMP) file. This file must be 
located in the IntelliCAD 6.1 folder.

command Command string (Example: ^C^C_LINE).

help_string Help string. Appears in the status bar when cursor passes over the button.
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To create a toolbar that you can share

1 Open any ASCII text editor.

2 Type the following characters exactly as shown here:

***MENUGROUP=example

***TOOLBARS

**NewDraw

ID_ NewDraw [_Toolbar("NewDraw ", _Bottom, _Show, 200, 200, 1)]

ID_Line_0 [_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line

ID_Hatch [_Button("Hatch", Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch

ID_Dtext [_Button("Dtext", Idtext.bmp, IL_dtext.bmp)]^C^C_dtext

ID__0 [_Button("Circle Rad", Icirad.bmp, IL_cirad.bmp)]^C^Ccircle;

ID_Erase [_Button("Erase", Ierase.bmp, IL_erase.bmp)]^C^Cerase;

***HELPSTRINGS

ID_Line_0 [Creates straight line segments]

ID_Hatch [Fills an enclosed area with a nonassociative hatch pattern]

ID_Dtext [Displays text on screen as it is entered]

ID__0 [Allows user to draw a circle with a radius value]

ID_Erase [Removes objects from a drawing]

3 Save the file to the IntelliCAD folder with a *.mnu extension.

To copy an existing toolbar

Make sure the toolbar you want to copy is visible.

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

2 Click the Toolbars tab.

3 Go outside the Customize dialog box and select a tool on the existing toolbar that 
you want to copy. 

4 Copy the information from the ToolTip, Help String, and Command boxes and 
paste it into the corresponding lines in the text file. 

5 Save the file to the IntelliCAD folder with a *.mnu extension.
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To open the toolbar file on another computer

1 Copy the toolbar (MNU) file and all related custom bitmap (*.bmp) files to the 
IntelliCAD folder on the other computer.

2 Open IntelliCAD.

3 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

4 Click the Toolbars tab.

5 Click Import.

6 Select the new toolbar file.

7 Select the Append To Current Menu check box, and then click Open.

If you don’t select this box, the custom shortcut menu deletes all current menus. 

8 Click Close. 

To restore the toolbar defaults

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and press Enter.

2 Click Reset.
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Customizing the keyboard

IntelliCAD provides keyboard shortcuts so you can access frequently used com-
mands. You can customize these shortcuts and add new shortcuts using the Custom-
ize dialog box.

To customize the keyboard

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 To define a new shortcut key, enter the shortcut in the Press New Shortcut Key 
box.

4 To define a new command string, enter the command string in the Command box.

5 To import an existing keyboard shortcut file, click Import.

6 To save a keyboard shortcut to a file, click Export.

7 To add a command selected in the Available Commands pane to the shortcuts, 
click Add Command.

8 To insert a new keyboard shortcut, click New.
 

A Shows shortcuts already defined.

B Displays the shortcut key combination when 
adding a new shortcut.

C Contains the command string assigned to the 
shortcut.

A

B

C
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Creating a keyboard shortcut
You can assign macros to special keys and certain combinations of keys to create a 
keyboard shortcut. A macro consists of one or more commands that are displayed on 
the status bar as follows:

• A single command, such as QSAVE.

• A command with options, such as ARC;\A;\\.

• More than one command, such as ^C^C^CZOOM;E;QSAVE;QPRINT.

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a sin-
gle command name; a keyboard shortcut contains one or more macros. To activate a 
macro, you press the shortcut key; you do not need to press Enter as you do with an 
alias. A shortcut consists of the following keys:

• The function and the cursor control keys, as well as alphanumeric keys pressed in 
combination with the Ctrl, Alt, and Shift keys. The Shift key must be used in con-
junction with the Ctrl, Alt, and/or function keys. 

• Alphanumeric keys are those labeled A through Z and 1 though 0. 

• The cursor keys are the up, down, left, and right arrows and the Page Up, Page 
Down, Home, End, Insert, and Delete keys. 

• The function keys are those labeled F1 through F12.

To create a keyboard shortcut

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 Click New.

4 In the Press New Shortcut Key field, press Alt+A.

The program adds Alt+A to its list of Defined Keys.

5 In the Available Commands list, select Arc Center-Start-Angle.

6 Click Add Command.

The program adds the command to the Command field and enters the complete 
syntax for you:

^C^C^_CARC;C;\ \A; 

7 To save your changes and close the dialog box, click Close. 

8 To activate the Arc command with the center, start, and angle options, press 
Alt+A.
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To redefine an existing keyboard shortcut

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 In the Defined Keys list, select the shortcut you want to change.

4 In the Command field, change the command string assigned to the keyboard short-
cut by doing one of the following:

• Use the text cursor to delete the current command string, choose a new 
command in the Available Commands list, and then click Add Command.

• Edit the command string in the Command field.

5 Click Close.

To delete an existing keyboard shortcut

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 In the Defined Keys list, select the shortcut you want to delete.

4 Click Delete.

5 Click Close.

Saving keyboard shortcut files
IntelliCAD automatically saves any changes you make to the current keyboard short-
cuts. You can also create and save your own keyboard shortcut files. The program 
saves keyboard shortcut files with the *.ick file extension.

To save the current keyboard shortcuts to a file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 Click Export.

4 Specify the directory and file name you want to use to save the keyboard shortcut 
file.

5 Click Save.

6 Click Close.
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Loading keyboard shortcut files
You can replace the current keyboard shortcut file with other custom keyboard short-
cut files.

To load a keyboard shortcut file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 Click Import.

4 Select the file to load.

5 Click Open.

6 Click Close.

Creating aliases

IntelliCAD provides aliases for many commands. You can use aliases to issue fre-
quently used commands by entering one or two letters rather than the entire command 
name. 

The program also uses aliases to maintain command-name compatibility with 
AutoCAD. You can use the same aliases and keyboard shortcuts used by AutoCAD. 
In addition, IntelliCAD has enhanced several AutoCAD commands. For example, 
IntelliCAD added two useful options to the rectangle command: you can draw a 
rectangle as a square, and you can rotate a rectangle at an angle.

You can customize aliases, and you can add new aliases. You customize aliases using 
the Customize dialog box.

To display the Customize dialog box

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.
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Creating, redefining, and deleting aliases
To create a new command alias, you first define the alias and then assign it one of the 
available IntelliCAD commands.

To create a new alias

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 Click New.

4 In the Alias field, type the new alias.

5 In the Available Commands list, select the command you want to assign to the 
alias.

6 Click Assign.

7 Click Close.

A Shows aliases already defined.

B Contains the current alias.

C Displays the command assigned to the current 
alias.

B

A

C
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To redefine an existing alias

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 In the Aliases list, select the alias you want to change.

4 In the Available Commands list, select the command you want to assign to the 
alias.

5 Click Assign.

6 Click Close.

To delete an existing alias

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 In the Aliases list, select the alias you want to delete.

4 Click Delete.

5 Click Close.

Saving alias files
IntelliCAD automatically saves any changes you make to the current aliases. You can 
also create and save your own alias files. The program saves alias files with the *.ica 
file extension. You can also save alias files for use with AutoCAD by saving the files 
with the *.pgp file extension.

To save the current aliases to a file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 Click Export.

4 From the Save As Type list, choose either *.ica or *.pgp.

5 Specify the directory and file name you want to use to save the alias file.

6 Click Save.

7 Click Close.
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Loading alias files
You can replace the current alias file with other custom alias files. The program loads 
both AutoCAD (*.pgp) and IntelliCAD (*.ica) alias files.

To load an alias file

1 Do one of the following:

• Choose Tools > Customize.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 Click Import.

4 From the Files Of Type list, choose either *.ica or *.pgp.

5 Select the alias file to load.

6 Click Open.

7 Click Close.

Customizing entities

IntelliCAD provides ways to customize entities beyond common formats, dimen-
sions, and layers. Further customization includes using custom audio notes and using 
custom shape files.

Working with audio notes
In IntelliCAD you can record and attach audio notes, which are sound clips attached 
to entities and available for playback at any time. For example, audio notes in a fac-
tory floor plan can describe maintenance activities for specific areas of the factory 
and employees can play the audio notes to hear instructions.

When you include audio notes in your drawing, they are saved in the drawing file — 
not in a separate audio file. Note that this can increase the file size of your drawing. 
Audio notes created from an existing *.wav file are also saved in the drawing file and 
the separate *.wav file remains unchanged.

NOTE You can play audio notes in IntelliCAD only. 
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Attaching audio notes
Audio notes can be created from existing *.wav files. You can also record an audio 
note using any microphone that works with your computer. Many computers have a 
built-in microphone. If you do not have a microphone and you record an audio note, 
the audio note will contain no sound.

An audio note icon displays on entities that have attached audio notes. The icon is for 
display only and cannot be selected.

To record and attach an audio note to entities

1 Do one of the following:    

• Choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool ( ).

• Type audionote and then press Enter.

2 Select the desired entities, and then press Enter.

3 Choose Record.

4 Click Record to begin the audio note, and then speak into the microphone.

5 Click Stop to end the audio note.

6 To test the audio note, click Test, and then use Pause and Stop in the Test Audio 
Note area.

7 If necessary, you can record the audio note again. This overwrites the previous 
audio note for the entities you selected in Step 2.

8 Click Attach.

TIP To modify an audio note after you attach it to an entity, select the entity and re-
record the audio note using the previous steps.

To attach an audio note to entities using a .wav file

1 Do one of the following:    

• Choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool ( ).

• Type audionote and then press Enter.

2 Select the desired entities, and then press Enter.

3 Choose Attach.

4 Select the desired *.wav file, and then click Open.
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Selecting audio notes
Audio notes themselves cannot be selected. Instead, you select the entity that corre-
sponds to the desired audio note.

An audio note icon displays on entities that have attached audio notes. The icon is for 
display only and cannot be selected.     

To select audio notes

1 Do one of the following: 

• Choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool ( ).

• Type audionote and then press Enter.

2 Select the entity that is attached to the desired audio note, and then press Enter.

You cannot select the audio note icon that displays on the entity.

3 Choose an option to continue working with audio notes.

TIP You can change the appearance of audio note icons using the AUDIOICON, 
AUDIOICONCOLOR, and AUDIOICONSCALE system variables.

An audio note icon displays on an entity, signifying that an audio note 
is attached to the entity.
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Playing audio notes

To play audio notes

1 Do one of the following:

• Choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool ( ).

• Type audionote and then press Enter.

2 Select the entity that has the audio note you want to play, and then press Enter.

3 Choose Playback.

4 In the Playback dialog box, do the following:

• Click Play to begin playback.

• To pause the audio note temporarily, click Pause and then click Resume to 
continue.

• Click Stop to end playback.

5 Click OK.

Deleting audio notes
You can remove audio notes from selected entities. In some cases, you may want to 
remove extra audio notes to reduce the drawing file size. 

NOTE When you remove an audio note from an entity, the audio note is removed per-
manently and cannot be recovered. However, if the audio note was created using an 
existing *.wav file, that *.wav file is not removed.

To delete audio notes

1 Do one of the following: 

• Choose Tools > Audio Note.

• On the Tools toolbar, click the Audio Note tool ( ).

• Type audionote and then press Enter.

2 Select entities that have the audio notes you want to delete, and then press Enter. 

3 Choose Delete.

Using shape files
Shapes are entities that you define for use as drawing symbols and text fonts. You can 
specify the scale and rotation to use for each shape as you add it. 

To use shape files, you first load the compiled shape file that defines the shape. Then 
you use insert shapes from the file into your drawing. 
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To load a shape file

1 Type load and then press Enter.

2 In the Load Shape File dialog box, select a shape file.

3 Click OK to close the Load Shape File dialog box.

To use a shape file

1 Type shape and then press Enter.

2 Type a shape name and press Enter.

3 Specify an insertion point.

4 Specify a height.

5 Specify a rotation angle.

Creating and replaying scripts

IntelliCAD can record anything you type on the keyboard and any points you select 
in a drawing. You can save all of these actions to a script file (with the *.scr exten-
sion) and then repeat them by replaying the script. You can use scripts for succes-
sively repeating commands, showing snapshots in a slide show, or batch printing. 
You can also load and run script files created for use with AutoCAD.

IntelliCAD supports most AutoCAD customization files, including menus, script 
files, and LISP routines. IntelliCAD uses compatible linetypes, hatch patterns, units 
translation, and command aliases, but you can also substitute your own files for these. 
This feature allows you to continue to work with your favorite customized drafting 
environment.

A script is a form of text file. A script file contains one line of text or other data for 
each action. For example, when you type a command and press Enter, it is recorded 
on a line in the script file. When you select a point in a drawing, the coordinate of that 
point is recorded on a line in the script file. You can also create script files outside 
IntelliCAD using a text editor (such as Microsoft® Notepad or Microsoft® WordPad) 
or a word-processing program (such as Microsoft® Word) that saves the file in ASCII 
format. The file type and extension must be .scr.

Script files can contain comments. Any line that begins with a semicolon is consid-
ered a comment. The program ignores these lines when replaying the script. The 
Undo feature reverses the last command performed by the script.

IntelliCAD improves on scripts, AutoLISP, and ADS by providing additional func-
tions. For scripts, IntelliCAD includes a Script Recorder that records both command 
line entries and screen picks you make with your mouse. 
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After you activate the Script Recorder, every keyboard entry you make and any 
points you select in a drawing are recorded until you stop the Script Recorder. You 
can play back your script at any time.

CAUTION The Script Recorder does not record your use of toolbars, menus, or dialog 
boxes. Using these elements while recording a script causes unpredictable results.

To record a script 

1 Do one of the following:

• Choose Tools > Record Script.

• On the Tools toolbar, click the Record Script tool ( ).

• Type recscript and then press Enter.

2 Specify the name of the script file you want to create.

3 Click Save.

4 Type commands on the keyboard.

The Script Recorder records all keyboard entries and all points you select in the 
drawing, saving everything to the script file.

To stop recording 

Do one of the following: 

• Choose Tools > Stop Recording.

• On the Tools toolbar, click the Stop Recording tool ( ).

• Type stopscript and then press Enter.

To replay a script

1 Do one of the following:

• Choose Tools > Run Script.

• On the Tools toolbar, click the Run Script tool ( ).

• Type script and then press Enter.

2 In the Run Script dialog box, specify the name of the script file you want to run.

3 Click Open.

The program immediately runs the script, performing all the actions originally 
recorded.
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To append to a script

1 Do one of the following:

• Choose Tools > Record Script.

• On the Tools toolbar, click the Record Script tool ( ).

• Type rescript and then press Enter.

2 In the Record Script dialog box, select the Append To Script check box.

3 Select the existing script file to append.

4 Click Save.

5 Click Yes to the prompt asking whether you want to replace the existing script.

6 Repeat the procedure to enter additional commands and steps.

TIP To invoke a script automatically when you load IntelliCAD, in Windows Explorer, 
double-click a script file.
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Programming IntelliCAD

Another way you can customize IntelliCAD is to add custom programs written in any 
of several programming languages that run within IntelliCAD, including the follow-
ing:

• LISP

• Visual Basic for Applications (VBA)

• ADS

• DCL

• DIESEL

In IntelliCAD, you can run many programs originally created for use with AutoCAD. 
Specifically, you can use programs written entirely in AutoLISP with no modifica-
tion. In addition, you can run many ADS programs originally written for use with 
AutoCAD after first recompiling them using the IntelliCAD run-time libraries. Many 
AutoCAD third-party programs are compatible with IntelliCAD.

NOTE For information about programming for IntelliCAD, see the online Help for the 
IntelliCAD Developer’s Reference.

Using LISP routines 
IntelliCAD supports the LISP programming language and is compatible with 
AutoLISP, the implementation of the LISP language in AutoCAD. This means that 
you can load and run any AutoLISP program written for use with AutoCAD.

To load a LISP routine 

Advanced experience level

1 Do one of the following:

• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

• Drag and drop the LISP file into IntelliCAD.

2 In the Load Application Files dialog box, click Add File.

3 Select the LISP file that you want to load, and then click Open.

4 Click OK.   
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TIP You can also load a LISP routine by typing (load “d:/path/routine.lsp”) in the 
command bar (you must include the parentheses and the quotation marks), where d:/
path is the drive and path where the LISP routine is located on your computer, and 
routine.lsp is the LISP routine file name. 

A Lists the names of LISP and SDS files already 
loaded. 

B Click to add a LISP or SDS file name to the list.

C Click to remove the highlighted file name from 
the list.

D Click to load the highlighted file.

E Click to unload the highlighted file.

F Select to save the current list to the icadload.dfs 
file when you click Load, Unload, or OK. 

A

B

C D

E

F
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To run a LISP routine 

Advanced experience level

1 Do one of the following:

• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

2 In the Load Application Files dialog box, choose the routine you want to run 
(make sure that it is the only one selected), and then click Load.

Some LISP routines are created in such a way that you can run them by simply typing 
the name of the routine, or by typing a keyword, directly in the command bar. If noth-
ing happens when you attempt to run the LISP routine from within the Load Applica-
tion Files dialog box, turn on the display of the command bar or Prompt History 
window by choosing View > Command Bar or View > Prompt History Window, and 
look for an entry that is similar to the following: 

Loading D:\path\routine.lsp

C:KEYWORD

where D:\path\routine.lsp is the complete drive, path, and file name of the LISP rou-
tine. You may need to scroll back several lines in the command bar or Prompt History 
window to find the lines indicating where the LISP routine was loaded. You can run 
the LISP routine by typing the name of the routine or keyword appearing after the C 
drive designation. 

For example, if you loaded a LISP routine named drawbox.lsp and see the designa-
tion C:DRAWBOX in the command bar or Prompt History window, you can run the 
LISP routine by typing drawbox in the command bar.    

Using ADS applications 
To write AutoCAD applications in C or C++, Autodesk® uses the ADS (AutoCAD 
Development System). This is an API (applications programming interface) that pro-
vides a library to access AutoCAD-specific functions and drawing data. 

The equivalent in IntelliCAD is called SDS™, the Solutions Development System™. 
SDS is a C/C++ language interface compatible with the ADS interface in AutoCAD. 
Like scripts and AutoLISP, you can run your existing ADS applications in 
IntelliCAD. Simply recompile the source code using the SDS libraries provided on 
the IntelliCAD CD-ROM, or, if you use an AutoCAD program written by a third-
party vendor, contact that vendor for the IntelliCAD version.

IntelliCAD provides the Sds.H file, which redefines ADS function names to their 
SDS equivalents. SDS supports the AutoCAD dialog control language (DCL), which 
is used by ADS to define the look of a dialog box. You can use all DCL files unmod-
ified within SDS. 
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Understanding ADS compatibility
The primary difference between ADS and SDS is that all SDS functions have an sds_ 
prefix, and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. 
The exception is dialog-related SDS functions, which have a dlg_ prefix. IntelliCAD 
accepts either prefix. Other differences include the additional SDS functions listed in 
the following table. 

Some ADS functions are not supported in SDS, including:ads_arxload, 
ads_arxloaded, ads_arxunload, ads_ssgetx, ads_ssGetKwordCallbackPtr, 
ads_ssGetOtherCallbackPtr, adsw_acadMainWnd, and adsw_acadDocWnd. 

For more information

• Read the online documentation for SDS functions. 

• See the \IntelliCAD\Api\Sds folder, which contains the SDS include, header, and 
library files.

• See the \IntelliCAD\Api\Dcl folder, which contains the core DCL files.

Using DCL with IntelliCAD
IntelliCAD completely supports the AutoCAD DCL (dialog control language). DCL 
is used by AutoLISP functions to define the look of dialog boxes. You can use all 
DCL files unmodified within IntelliCAD.

SDS functions with no ADS equivalent

SDS function name Description

sds_grclear Clears all graphics from the drawing window; similar to the LISP 
(grclear) function.

sds_name_clear Clears the entity name or selection set.

sds_name_equal Verifies whether two entity names or selection sets are equal.

sds_name_nil Verifies whether the entity name or selection set has been 
cleared. 

sds_name_set Copies one entity name or selection set to another drawing.

sds_pmtssget Similar to the ads_ssget function, but allows you to display a 
prompt appropriate for the specific command, rather than the 
generic “Select object” prompt.

sds_point_set Copies a point from one variable to another.

sds_progresspercent Displays the percentage done in a progress bar.

sds_progressstart Starts the progress bar.

sds_progressstop Ends the progress bar.

sds_readaliasfile Loads the PGP file into IntelliCAD.

sds_sendmessage Sends a message to the IntelliCAD command line.

sds_swapscreen Flips the off-screen device context to the display.
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Using VBA
IntelliCAD can be customized using Visual Basic for Applications (VBA) through an 
integrated interface, available from the IntelliCAD menu. IntelliCAD features a broad 
range of objects, giving you the power to write your own custom applications that can 
run within IntelliCAD. 

To run a VBA macro        

Advanced experience level

1 Do one of the following:

• Choose Tools > Visual Basic > Macros.

• Type vbarun and then press Enter.

2 In the Run IntelliCAD VBA Macro dialog box, enter the name of an existing VBA 
macro, and then click Run.

You can also create, delete, and edit VBA macros from this dialog box.

To edit a VBA macro      

Advanced experience level

1 Do one of the following:

• Choose Tools > Visual Basic > Visual Basic Editor.

• Type vba and then press Enter.

2 Use the Visual Basic Editor to write or debug VBA macros.

For more information

• Read the online documentation for VBA, available both from the VBA Editor 
Help and from the IntelliCAD Help. 

• Many publications are available that explain how to program in Visual Basic and 
how to use VBA.

Using DIESEL with IntelliCAD
IntelliCAD supports AutoCAD DIESEL (Direct Interactively Evaluated String 
Expression Language). DIESEL is a separate interpretive programming language that 
allows you to customize the following:

• Status bar 

• Menus 

• LISP functions 

For more information

• Read the online documentation for DIESEL, available from the IntelliCAD Help. 

• Several publications and tutorials are available online that explain how to use 
DIESEL.
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Using a digitizer tablet

IntelliCAD supports tablets compatible with the TabletWorks driver and has its own 
tablet overlay. For instructions on installing the tablet driver and using the buttons on 
your pointing device, refer to your hardware documentation. 

Three options are available with the Tablet command: 

• Configure Maps the tablet overlay to the tablet itself. Configure the tablet if you 
plan to select IntelliCAD tools from the tablet overlay.

• Calibrate Maps points on the tablet, in absolute coordinates, to points on a draw-
ing. Calibrate the tablet if you intend to digitize points. This process is convenient 
for tracing paper drawings.

• Tablet ON/OFF Turns tablet calibration (digitizer mode) on and off. Use this to 
switch between tool selection and digitizer input. To use the tablet for tool selec-
tion, tablet mode must be turned off. 

Configuring the tablet
Before you begin to configure the tablet, slip the tablet overlay underneath the tab-
let’s plastic cover, and align it in accordance with the directions for your tablet. If 
your tablet does not have a plastic cover, align the overlay holes with the pegs on 
your tablet. 

IntelliCAD provides a default configuration for tablets measuring 12" by 12". If you 
choose to accept the default, be sure to verify that the commands in the grid are acti-
vated correctly. If the default alignment does not work for your tablet, you’ll need to 
begin the configuration process again and align the tablet yourself.
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To configure the tablet for menu input

1 Do one of the following:

• Choose Settings > Tablet > Configure.

• Type tablet, choose Configure, and then press Enter.

2 In response to the prompt to align the tablet, do one of the following:

• If your tablet is 12" by 12", choose No to accept the default alignment and 
conclude the configuration process. 

• To align the tablet yourself, choose Yes, and then continue with step 3.

3 Click the tablet pointer on the upper left alignment point of the overlay ( ). 

4 Click the tablet pointer on the lower left alignment point of the overlay ( ).

5 Click the tablet pointer on the lower right alignment point of the overlay ( ).

6 Click the tablet pointer on the lower left alignment point of the Workspace area of 
the overlay ( ).

7 Click the tablet pointer on the upper right alignment of the Workspace area of the 
overlay ( ).

To turn tablet mode on or off

1 Do one of the following:

• Choose Settings > Tablet > Tablet On (or Tablet Off).

• Type tablet, choose On or Off, and then press Enter.

• Press the F4 key to toggle tablet mode on or off.

• On the status bar, double-click TABLET to turn tablet mode on or off. 

Click points in the order shown to configure your tablet for menu input.

5

1

2

4

3
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Calibrating the tablet
You must specify at least two points for tablet calibration. However, the more points 
you specify, the more accurate the transformation between the tablet and the screen 
points. Specifying additional points is particularly useful if you plan to trace a paper 
drawing that is not orthogonal, such as an aerial photograph. 

Understanding transformation types
Depending on the number of points specified, you have a choice of transformation 
types to use, along with the type recommended for IntelliCAD. 

Transformation refers to the calculation of the points on the screen that correspond to 
points you digitize on the tablet.

• Orthogonal Preserves all angles between lines, preserves all relative distances, 
and, in general, preserves shapes. If you specify only two points, an orthogonal 
transformation is automatically generated. The orthogonal transformation type 
yields the most precise mapping between the digitized points on the tablet and the 
corresponding points on the screen.

• Affine Preserves parallel lines, but not necessarily the angles between intersecting 
lines. If you specified three points, IntelliCAD can no longer represent this map-
ping as an exact orthogonal transformation. Therefore, you have a choice of an 
exact affine transformation or a “best fit” orthogonal transformation.

• Projective Does not preserve parallel lines or angles. If you specify exactly four 
points, you have a choice of an exact projective transformation or a “best fit” 
orthogonal or affine transformation. 

Recommended and “best fit” transformation types

Number of points specified
Transformation type 
recommended “Best fit” (approximate)

2 Orthogonal None

3 Affine Orthogonal

4 Projective Orthogonal, Affine

5-10 None Orthogonal, Affine
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Choose the recommended type unless you know it will not be appropriate for what 
you are digitizing. The most appropriate type is not always the one with the least 
error; for example, you might digitize three points and select the orthogonal transfor-
mation, even though the affine transformation would yield a closer representation of 
your calibration entries.    

Digitizing by selecting points (1, 2, 3, and 4) on the tablet. Corresponding screen coordinates:

1 Coordinate specification X0, Y0, Z0

2 Coordinate specification X0, Y5, Z0

3 Coordinate specification X5, Y5, Z0

4 Coordinate specification X5, Y0, Z0

Screen result of orthogonal transformation after 
tracing polyline on tablet.

Screen result of affine transformation 
after tracing polyline on tablet.

Screen result of projective transformation after 
tracing polyline on tablet.

2

1 4

3

3

4

2

1



530 C H A P T E R  1 7
To calibrate your tablet for digitizing points

1 Do one of the following:

• Choose Settings > Tablet > Calibrate.

• Type tablet, choose Calibrate, and then press Enter.

2 Click a point on the tablet to define as the first calibration point.

3 Specify a point within the IntelliCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. 

4 Click a point on the tablet to define as the second calibration point.

Specify a point within the IntelliCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. To 
specify more than the two points required, click a point on the tablet to define as 
the third calibration point. You can enter up to 10 points.

5 Choose the transformation type, and then press Enter.

Customizing the tablet interface
You can customize the digitizer tablet interface by using the LISP commands 
integrated with IntelliCAD, even if you are not familiar with LISP. For instructions, 
see “Customizing the Tablet Interface” in the IntelliCAD online Help.
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Understanding AutoCAD compatibility

IntelliCAD was designed to interface with AutoCAD as seamlessly as possible. There 
are, however, some differences for which those accustomed to working in AutoCAD 
may need to adjust. This appendix provides information specifically for that audi-
ence.   
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Using enhanced AutoCAD commands in IntelliCAD

IntelliCAD enhances several AutoCAD commands by providing more options. For 
example, if you hold down the Shift key, IntelliCAD is placed temporarily in orthog-
onal mode, which you will find to be a useful feature for drawing at right angles. The 
following table lists examples of other commands with enhanced options.    

Enhanced IntelliCAD commands

Command
Enhanced 
option name Explanation

circle Arc Converts an arc to a circle.

donut 2point Determines the outside diameter of a donut by 
two pick points.

donut 3point Determines the outside diameter of a donut by 
three pick points.

donut RadTanTan Determines the outside diameter of a donut by 
tangent points.

line Angle Draws a line by angle, followed by a length.

line Length Draws a line by a length, followed by an angle.

msnapshot (mslide) and 
vsnapshot (vslide) 

EMF Saves and views screen images in enhanced 
metafile format.

msnapshot (mslide) and 
vsnapshot (vslide)

WMF Saves and views screen images in Windows 
metafile format.

parallel (offset) Both sides Copies an entity parallel on both sides.

plane (solid) Rectangle Draws a rectangular solid at any angle.

plane (solid) Square Draws a square solid at any angle.

plane (solid) Triangle Draws an equilateral solid at any angle.

rectangle Square Draws a square rectangle.

rectangle Rotated Draws a rotated rectangle.
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Using additional selection sets

IntelliCAD has additional selection-set options not found in AutoCAD. In particular, 
in the circle selection set, the Crossing Circle (CC), Outside Circle (OC), and Win-
dow Circle (WC) options select all entities relative to the same distance (radius) of a 
central pick point.

The following table lists and describes the additional selection sets in IntelliCAD.    

Additional selection set options

Selection mode Description

CC Crossing Circle: Selects all entities within and crossing a circular area.

D Selection method: Displays the Drawing Settings dialog box.

O Outside Window: Selects all entities outside a rectangular area; this is the 
inverse of the Crossing Circle option.

OC Outside Circle: Selects all entities outside a circular area.

OP Outside Polygon: Selects all entities outside a polygonal area; this is the 
inverse of the CP (Crossing Polygon) and WP (Window Polygon) options. 

PRO Properties: Selects all entities with specific properties, such as area, color, 
and layer.

WC Window Circle: Selects all entities within a circular area.
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Using additional IntelliCAD commands 

Although you can use the AutoCAD command structure with IntelliCAD, the pro-
gram has its own set of commands. IntelliCAD has numerous command names not 
found in AutoCAD, although many of these commands have an equivalent function 
in AutoCAD. When you type the AutoCAD equivalent, the IntelliCAD alias system 
activates the correct command. 

For example, the AutoCAD offset command is mapped to the IntelliCAD parallel 
command. You can type either offset or parallel in the command bar, or you can 
choose Modify > Parallel.

The following table lists optional IntelliCAD command names that you can use in 
place of AutoCAD command names to perform the equivalent AutoCAD function.    

Command differences in IntelliCAD

IntelliCAD 6 command AutoCAD 2007 command AutoCAD 2000/R14 command Action in IntelliCAD

audionote No equivalent No equivalent Creates and plays audio notes 
attached to entities.

cmdbar No equivalent No equivalent Positions the command 
window.

coordinate Ctrl+D or F6 Ctrl+D or F6 Changes the display of 
coordinates on the status line.

copyedata No equivalent No equivalent Copies extended entity data 
from one entity to another.

customize toolbar toolbar Displays the Customize dialog 
box.

deledata No equivalent No equivalent Deletes extended entity data 
from an entity.

delete erase erase Removes entities from the 
drawing.

dimension dim dim Switches to dimension mode.

editedata No equivalent No equivalent Edits extended entity data 
found in an entity.

editlen lengthen lengthen Changes the length of open 
entities.

editpline pedit pedit Edits polylines and 
polymeshes.

entprop ddmodify and ddchprop ddmodify and ddchprop Displays the Entity Properties 
dialog box.

esnap -osnap -osnap Sets entity snaps from the 
command line.

expblocks ddinsert ddinsert Displays the IntelliCAD 
Explorer - Blocks.
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expdimstyles ddim ddim Displays the IntelliCAD 
Explorer - Dimension Styles.

expfonts style style Displays the IntelliCAD 
Explorer - Styles.

explayers layer layer Displays the IntelliCAD 
Explorer - Layers.

explorer ddrename ddrename Displays the IntelliCAD 
Explorer.

expltypes linetype linetype Displays the IntelliCAD 
Explorer - Linetypes.

expucs dducs dducs Displays the IntelliCAD 
Explorer - UCS.

expviews ddview ddview Displays the IntelliCAD 
Explorer - Views.

face 3dface 3dface Draws three-dimensional 
faces with three or four 
vertices.

flatten No equivalent No equivalent Sets thickness to zero at user-
specified elevation.

font -style -style Displays the Text Style dialog 
box.

freehand sketch sketch Allows freehand sketching.

idpoint id id Returns the x-, y-, and z-
coordinates of a picked point.

infline xline xline Draws a line of infinite length.

join pedit join pedit join Joins lines and arcs.

mesh 3dmesh 3dmesh Draws a surface mesh.

moveedata No equivalent No equivalent Moves extended entity data 
from one entity to another.

msnapshot mslide mslide Makes an SLD, EMF, or WMF 
file of the current view.

orthogonal ortho ortho Toggles orthogonal mode.

parallel offset offset Copies an entity by a parallel 
offset distance.

plane solid solid Draws a two-dimensional solid 
plane.

pmthist F2 F2 Switches between the Prompt 
History window and the 
graphics screen.

polyline pline pline Draws a polyline.

ppreview preview preview Previews the print.

Command differences in IntelliCAD (continued)

IntelliCAD 6 command AutoCAD 2007 command AutoCAD 2000/R14 command Action in IntelliCAD
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print plot plot Prints the drawing.

printstyle plotstyle printstyle (not applicable before 
AutoCAD 2000)

Assigns a print style.

psetup No equivalent No equivalent Displays the Print Setup dialog 
box.

qprint No equivalent No equivalent Quickly prints the current 
viewport (window) with no 
options.

reassocapp No equivalent No equivalent Reassociates extended entity 
data with an application.

recscript No equivalent No equivalent Starts the Script Recorder.

rtrot 3dorbit No equivalent Rotates the view of entities.

rtrotx No equivalent No equivalent Rotates the view of entities 
while maintaining the x-axis.

rtroty No equivalent No equivalent Rotates the view of entities 
while maintaining the y-axis.

rtrotz 3dorbit No equivalent Rotates the view of entities 
while maintaining the z-axis.

saveall No equivalent No equivalent Saves all currently open 
drawings.

setcolor ddcolor ddcolor Displays the Color dialog box.

setdim ddim ddim Displays the Dimension 
Settings dialog box.

setesnap osnap osnap Displays the Drawing Settings 
dialog box with the Coordinate 
Input tab displayed.

setlayer ai_molc ai_molc Sets the current layer based 
on the selected entity’s layer.

settings No equivalent No equivalent Displays the Drawing Settings 
dialog box.

setucs dducs dducs Displays the User Coordinate 
Systems dialog box.

setvpoint No equivalent No equivalent Displays the Preset 
Viewpoints dialog box.

stopscript No equivalent No equivalent Stops running the script.

tipofday No equivalent No equivalent Displays the Tip of the Day.

undelete oops oops Restores the last deleted 
entity.

vba vbaide vbaide Opens the Visual Basic 
Applications editor.

vbaload vbaload vbaload Displays the VBA Add-In 
Manager dialog box.

Command differences in IntelliCAD (continued)

IntelliCAD 6 command AutoCAD 2007 command AutoCAD 2000/R14 command Action in IntelliCAD
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Recognizing subtle command differences

The commands listed below function slightly differently in IntelliCAD than in 
AutoCAD.    

vbarun vbarun vbarun Runs a VBA application.

vbaunload vbaunload vbaunload Unloads one or more VBA 
applications.

viewctl ddvpoint ddvpoint Sets the three-dimensional 
viewing direction via an 
interactive dialog box.

viewpoint vpoint vpoint Sets the three-dimensional 
viewing direction via the 
command line.

vsnapshot vslide vslide Displays an SLD, EMF, or 
WMF file in the current 
viewport.

Command differences in IntelliCAD (continued)

IntelliCAD 6 command AutoCAD 2007 command AutoCAD 2000/R14 command Action in IntelliCAD

Command function differences

IntelliCAD 
command

AutoCAD 
command Function in IntelliCAD

cal cal Displays the Windows calculator.

pan -pan Performs a vector pan instead of a real-time pan.

zoom -zoom Performs a stepped zoom instead of a real-time zoom.
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Identifying unsupported commands and features

A few AutoCAD commands and features are not supported in this release of Intelli-
CAD, as shown in the following table.

AutoCAD commands not supported by IntelliCAD

2008 Features: Annotation property, Multi-line Attributes, DGN Support, 
Ribbon, Info Center.

Commands: annoupdate, annoreset, attipedit, autopublish, 
dataextraction, datalink, datalinkupdate, dimbreak, diminspect, 
dimjogline, dimspace, dwflayers, freeweb, freespot, +layer, layerstate, 
mleader and mleader-related commands, objectscale, quickcui, 
recoverall, renderexposure, setbylayer, targetpoint, tpnavigate, and  
weblight.

2007 Features: Materials property, Shadow property

Commands: camera, helix, light, loft, planar, and sweep

2005 Features: Zoom to Selection, Layer States, Tables, Fields, Trimming 
Hatches, and Sheet Set Manager

Commands: archive, assistclose, field, markup, netload, 
newsheetset, opendwfmarkup, sheetset, table and -table, tableedit, 
tableexport, tablestyle, taskbar, texttofront, tinsert, updatefield, 
viewplotdetails, vpmax, and vpmin

2004 Features: Gradient Fills, Ctrl + O Clean Screen, Error Reporting, 
Reference Manager, External Reference Notification, Background 
Printing, and Miscellaneous Print Style Features (Dithering, 
Grayscale, Screening, Adaptive, Line End Styles, Line Join Styles, Fill 
Styles)

Commands: 3dorbitctl, jpgout, layout, pngout, publish, qnew, 
revcloud, tifout, toolpalettes, and xopen

2002 Features: Today window 

Commands: attext, and eattext

2000 Features: Parallel Entity Snap, Viewports with UCS and Elevation 
Settings, AutoTrack, True Color Raster Output

Commands: 3dclip, 3dcorbit, 3ddistance, 3dorbit, 3dswivel, 3dzoom, 
blockicon, camera, copybase, dbclose, dbconnect, dwgprops, 
adcclose, adcenter, adcnavigate, find, layoutwizard, model, olescale, 
pagesetup, partialload, partialopen, pasteblock, pasteorig, pcinwizard, 
plottermanager, properties, propertiesclose, psetupin, qleader, 
qselect, vports, refclose, refedit, refset, shademode, ucsman, 
vbaman, vlisp, vpclip, and whohas

R14 Features: Tracking Points and Command Bar File Open

Commands: xbind, rectang, and qdim

R13 Commands: arx, copylink, dsviewer, dxbin, edge, mline, mledit, 
treestat, and wmfopts
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Identifying what does not display

When a drawing containing AutoCAD proxy entities is loaded into IntelliCAD, the 
program displays the following message: “This drawing contains one or more entities 
that will not display. These entities WILL be stored and saved back into the draw-
ing.” 

The following table identifies which AutoCAD objects are not displayed in 
IntelliCAD. 

Advanced 
AutoCAD 
modules

ACIS commands (solids modeling): ameconvert, soldraw, solprof, 
solview, and stlout

ASE commands (AutoCAD SQL extension): aseadmin, aseexport, 
aselinks, aserows, aseselect, and asesqled

Internet commands: listurl, openurl, saveurl, and selecturl

Landscape commands: lsedit, lslib, and lsnew

PostScript commands: psdrag, psfill, psin, and psout

Render commands: fog, matlib, replay, saveimg, scene, setuv, 
showmat, stats, transparency, 3dsin, and 3dsout

AutoCAD commands not supported by IntelliCAD

AutoCAD objects not displayed in IntelliCAD

AutoCAD object Description

Arc aligned text Text that is aligned along the curve of an arc.

Camera Point at which a camera is inserted into a drawing.

Light Point at which a light is inserted into a drawing.

Read text Dynamically linked text that displays in a drawing but resides in an 
external file.

Tables Tables display as anonymous blocks but cannot be edited.
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Supporting AutoCAD customization

The following table lists and describes the ways IntelliCAD supports the AutoCAD 
customization files.  

Understanding menu compatibility

MNU files are menu files created by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. IntelliCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus 

IntelliCAD support of AutoCAD customization files

File extension Description

LIN Supported: Linetypes and complex linetypes with text and shapes. 

MNU and MNS Supported: Toolbar and menu macros.
Supported: ***POP0, ***POPn, and ***TOOLBAR sections.
Not supported: ***TABLET, ***BUTTONS, ***SCREEN, ***AUX, and ***ICON 
sections.

MIN Not supported: The multiline definition file is used by the AutoCAD mline 
command.

PAT Supported: Hatch patterns.

PGP Supported: Command aliases.
Not supported: External commands.

PSF Not supported: PostScript fill pattern file is used by the AutoCAD psfill 
command.

SHP and SHX Supported: Text fonts and shapes.

SLD Supported: Slide files.

UNT Supported: Unit translation file used by the LISP (cvunit) and SDS sds_cvunit 
functions to translate values from one unit of measurement to another.

IntelliCAD support of specific sections in AutoCAD MNU and MNS files

Menu section Definition IntelliCAD support

***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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Importing and exporting customization files

You can continue using aliases and menu files from AutoCAD by importing the 
appropriate file. You can import AutoCAD customization files and export IntelliCAD 
formats using the Customize dialog box. All of the files listed in the following table 
are in ASCII format, which means you can view and edit them with a text editor, such 
as Notepad. 

TIP You can manually add toolbar customizations to a MNU file. For more informa-
tion, see “Customizing toolbars” on page 498. 

Customizing files

Customization Import file formats Export file formats

Aliases PGP: AutoCAD aliases
ICA: IntelliCAD aliases
ICA: IntelliCAD aliases

PGP: AutoCAD aliases

Keyboard ICK: IntelliCAD keyboard ICK: IntelliCAD keyboard

Menus MNU: All AutoCAD menus
MNS: AutoCAD R13, R14 and 2000 
menus
ICM: IntelliCAD menu

ICM: IntelliCAD menu

Toolbars MNU: All AutoCAD menus None
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Programming IntelliCAD

IntelliCAD supports more AutoCAD application programming interfaces (APIs) than 
any other software, but not all of the AutoCAD APIs are available in IntelliCAD. The 
following table summarizes the AutoCAD APIs IntelliCAD supports.  

Understanding AutoLISP compatibility 
IntelliCAD adds LISP functionality that you will find useful. The following table lists 
functions that are unique to IntelliCAD LISP.  

IntelliCAD support of the AutoCAD programming interface

AutoCAD programming interface IntelliCAD support

Scripts (SCR files) Supported

AutoLISP (LSP files) Supported

Dialog Control Language (DCL files) Supported

AutoCAD Development System (ADS) Supported; source code must be 
recompiled

Visual Basic Applications (VBA) Supported, depending on your version 
of IntelliCAD

Direct Interactively Evaluated String Expression 
Language (Diesel)

Supported

AutoCAD SQL Interface (ASI) Not supported

Autodesk® Threaded Language Application System 
Toolkit (Atlast)

Not needed

AutoCAD Runtime Extension (ARx) Not supported

Additional IntelliCAD LISP functions

Unique LISP function Definition

(log10) Returns log base 10.

(lpad) Pads a text string with spaces to the left.

(rpad) Pads a text string with spaces to the right.

(tan) Returns the tangent.

(trim) Trims spaces from a string.
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Not all IntelliCAD LISP functions are completely compatible with AutoLISP func-
tions. The following table identifies IntelliCAD LISP functions that are partially 
compatible with AutoLISP functions.

In addition, IntelliCAD LISP does not support all AutoLISP functions. The following 
areas are not supported by IntelliCAD LISP:

• (acdimenableupdate), (acet-attsync), (acet-layerpmode), (acet-layerp-mark), 
(acet-laytrans), (acet-ms-to-ps), (acet-ps-to-ms), (defun-q), (defun-q-list-ref), 
(defun-q-list-set), (entmakex), (initdia), (namedobjdict), (ssnamex), and (tablet)

• ARX-related functions that run ARX applications

• (dict)-related functions

• (vl)-related functions for Visual LISP

• SQL-related functions that link AutoCAD entities with external database records. 
These functions start with ase_, for example, (ase_lsunite) and (ase_docmp)

Partially compatible LISP functions

LISP function Description

(menucmd) Supports P0 (cursor menu), P1 through P16 (the pull-down menus), 
and M (diesel expressions), but  does not support A (aux menus), B 
(button menus), I (icon menus), S (screen menu), or T (tablet menus).

(print1) Does not support Unicode characters, such as \U+00B0 (the degree 
symbol) and M+Nxxxx (multi-byte Unicode sequences).

(ssget) and (ssadd) Supports additional selection modes:
CC = Crossing Circle
O = Outside
OC = Outside Circle
OP = Outside Polygon
PO = POint
PRO = Properties
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IntelliCAD and AutoCAD list of terms

  

List of terms

IntelliCAD term Meaning for AutoCAD users

command bar command prompt area

edit length lengthen

entity object

entity snap object snap

entity snap precision aperture

fixed attribute constant attribute

follow continue

freehand sketch

hidden attribute invisible attribute

infinite line XLine

insert draw

orthogonal ortho

parallel offset

plane solid (2D)

predefined attribute preset attribute

print plot

print style plot style

prompt box context menu

Prompt History window text screen

reference grid grid

point snap node snap

snapshot slide (SLD)

validate attribute verify attribute



Glossary

2D  Two-dimensional locations defined by x- and y-coordinates.

3D  Three-dimensional locations defined by x-, y-, and z-coordinates.

3D DWF  Acronym for Three-Dimensional Design Web Format, which is a type of 
file that can be viewed in three dimensions using a Web browser, if Autodesk® DWF 
Viewer is also installed on the computer.

3D solids  Three-dimensional ACIS entity.

absolute coordinates  Coordinates defined in relation to the origin point of the cur-
rent user coordinate system. See also coordinate system, coordinates, origin, rela-
tive coordinates, user coordinate system, and World Coordinate System.

ActiveX  A mechanism for exchanging information between different programs 
whereby a copy of a source document is embedded or a pointer to a source document 
is linked to a target document. See also embed and link.

acute angles  Angles of fewer than 90 degrees.

alias  An abbreviation or alternative word for an IntelliCAD command.

aligned dimension  A dimension aligned parallel to an entity or measuring the dis-
tance between two points at any angle.

angle  The difference in direction between two nonparallel linear entities, measured 
in degrees or radians.

angular dimension  A dimension measuring the angle between two lines or sub-
tended by an arc.

angular unit  The unit of measurement for angles. Angular units can be measured in 
decimal degrees, degrees/minutes/seconds, grads, and radians.

annotation  Any text, dimensions, tolerances, or notes added to a drawing.

ANSI  Acronym for American National Standards Institute. In the context of text, a 
standard character set defined by ANSI used in computer-aided drafting.

arc  A segment of a circle or ellipse.

area  Measurement of a planar region or the calculated space within an entity. 

array  Multiple copies of selected entities in a circular or rectangular pattern.
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ASCII  Acronym for American Standard Code for Information Interchange, a com-
monly used system for assigning numbers to printable alphanumeric characters, 
punctuation, and symbols.

attribute  A component of a block containing specific text or numeric information. 
You can copy the information contained in an attribute from the drawing to an exter-
nal database.

attribute definition  An entity composed of a name, prompt for information, display 
characteristics, and default text that, when incorporated into a block, creates an 
attribute when the block is inserted into a drawing.

attribute name  Text that identifies an attribute within a block.

attribute text  The text containing an attribute’s information within a block.

B-spline curve  See spline. 

base point  A point on an entity that serves as its reference or insertion point. A 
point of reference when specifying relative distances.    

baseline  The line on which text characters appear to sit. The descenders of individ-
ual characters drop below the baseline.

baseline dimension  Multiple parallel dimensions measured from the same baseline 
origin.

bind  To convert an externally referenced drawing into a standard block definition.

blips  Temporary screen markers displayed in a drawing when you select a point. 
Also called marker blips.

block  One or more entities grouped together to create a single entity. See also 
nested block.

block definition  The name, base point, and entities grouped together when creating 
a block.

boundary polyline  A selected area bounded by a single closed entity or by multiple 
entities that intersect.

BYBLOCK  A property whereby an entity inherits the color, linetype, lineweight, or 
print style of any block that contains it.

BYLAYER  A property whereby an entity inherits the color, linetype, lineweight, or 
print style of its associated layer. 

CAD  Acronym for computer-aided design.

Cartesian coordinates  Coordinates defined using three perpendicular axes (x, y, 
and z) to define locations in three-dimensional space. See also cylindrical coordi-
nates, polar coordinates, and spherical coordinates.
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center line  A line used to indicate the center of a circle or an arc, usually consisting 
of a center mark and lines extending slightly beyond the diameter of the circle or the 
arc.

center mark  A cross marking the center of a circle or an arc.

chamfer  A beveled edge between two lines.

chord  A line connecting two points on a circle or an arc.

circumference  The measurement of the distance around a circle.

closed  A condition whereby the start point and endpoint of an entity are the same.

color-dependent print style table  A collection of print styles that determine how 
entities print according to their assigned color. See print style table. 

comma-delimited  Data that is separated by a comma to represent the end of a field.

command bar  A dockable window in which you type IntelliCAD commands and 
view prompts and other program messages.

cone  A three-dimensional entity where a vertex exists above or below the circular 
shape and where a surface has been applied between the vertex and the circular shape.

contiguous  Connected, unbroken, or uninterrupted. Entities that share the same 
endpoint.

continued dimension  A dimension measured from the previous extension line of 
an existing dimension, resulting in two or more dimensions positioned end to end. 

control point  A point used to define a spline.

Coons patch  A surface interpolated among three or four boundary curves.

coordinate filter  A function that extracts individual x-, y-, and z-coordinate values 
from different points to create a new composite point.

coordinate system  A system of points that represents the drawing space in relation 
to an origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the 
x- and y-axes represent horizontal and vertical directions, respectively. In three 
dimensions, the z-axis represents locations above and below the two-dimensional xy 
plane. Locations in the drawing can be represented using two-dimensional and three-
dimensional rectangular (Cartesian) coordinates, two-dimensional polar coordinates, 
three-dimensional polar (cylindrical) coordinates, and three-dimensional spherical 
coordinates. See also polar coordinates, relative coordinates, spherical coordi-
nates, user coordinate system, and World Coordinate System.

coordinates  A set of values that determines a location in two-dimensional or three-
dimensional space. See also absolute coordinates, Cartesian coordinates, polar 
coordinates, relative coordinates, and spherical coordinates.

coplanar  Lying within the same plane.
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crosshairs  A cursor that consists of two or three lines that intersect at the cursor 
location.

crosshatch  To fill an area with a pattern of evenly spaced perpendicular lines. See 
also hatch.

crossing circle  An entity-selection method that selects entities contained within or 
crossing the boundary of a circular selection window. 

crossing polygon  An entity-selection method that selects entities contained within 
or crossing the boundary of a polygon selection window. 

crossing window  An entity-selection method that selects entities contained within 
or crossing the boundary of a rectangular selection window. 

cube  A boxed, three-dimensional, geometric shape where length, width, and height 
are equal.

cursor  The insertion-point symbol on the screen. The appearance of the cursor 
changes based on the current task.

curve  A smooth, continuous path made up of linear and arc segments. Curve types 
include arcs, splines, circles, and ellipses. 

cylindrical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its z-coordinate 
value. See also polar coordinates and spherical coordinates.

datum-line dimensioning  See ordinate dimension.

default  An initial or predefined setting.

detach  To remove an external reference from a drawing. See also external refer-
ence.  

diameter  The distance across a circle or sphere.

digitizer tablet  A hardware input device that incorporates an electronic pad and a 
hand-held pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You 
can select tools from paper representations attached to the pad (called an overlay), 
providing access to all tools at once while freeing your screen space; and (2) you can 
input digital points into the computer that correspond to points on a paper drawing, 
photograph, or blueprint attached to the pad.

dimension  A measurement, as in height or width. In the context of drafting, a set of 
lines, arrowheads, and text used to indicate a measurement. 

dimension style  A named group of dimension variable settings that determines the 
appearance of the dimension. You can save multiple dimension styles for reuse.

dimension text  The measurement value. Dimension text can include prefixes, suf-
fixes, tolerances, and other annotations.
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dimension text rotation  The angle in degrees between the x-axis and the dimen-
sion text baseline.

dimension tolerance  A value specifying the allowed variation of a dimension (+ or 
– n).

dish  The lower half of a sphere. See also dome.

displacement point  The point to which a base, or reference, point will be relocated 
when moving or copying entities.

distance  The measure of space between two points.

dock  To position a toolbar or the command bar at the edge of the drawing window, 
where it locks into place. See also float.

dome  The upper half of a sphere. See also dish.

donut  A filled circle or flat ring created as a polyline.       

drawing extents  See extents.

drawing limits  See limits.

drawing unit  The linear measurement system used in a drawing. The user deter-
mines what a drawing unit represents, such as one inch, one centimeter, one foot, or 
one meter.

DWF  Acronym for Design Web Format, a file format for viewing drawings in a Web 
browser and distributing for review using free Autodesk® software and tools.

.dwg  A standard format used by CAD programs to store drawing files.

.dwt  A standard format used by CAD programs to store drawing templates, which 
are drawings that contain predefined settings that you can use when creating a new 
drawing. See also template.

DXF  Acronym for Drawing Exchange Format, a standard ASCII or binary file for-
mat for importing and exporting files between most CAD programs.

elevation  The z value measured from the xy plane. Positive values are above the xy 
plane; negative values are below the xy plane.

embed  A technique for exchanging information between different programs 
whereby a copy of the source document is stored in the target document. See also 
ActiveX and link.

EMF  Acronym for Enhanced Metafile, a file format with the type and extension of 
.emf. It is a native internal file format of Windows 98. EMF supports both raster and 
vector information and 24-bit RGB color. Most Windows-based programs support 
this format.

endpoint  The point at which a line or curve ends.
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entity  Any single basic item in a drawing. Entities include arcs, attributes, blocks, 
circles, dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and 
text.      

entity data  Any of a variety of additional information, such as text, numbers, and 
distances, that can be attached to drawing entities.

entity snap  A technique for accurately locating and specifying key geometric points 
on entities, such as endpoints and midpoints of lines, and center points and tangents 
of arcs and circles.

entity snap override  To disable or change an entity snap mode for a single input. 
See also entity snap and running entity snap.

Esnap  See entity snap.

explode  The conversion of a complex entity into its basic entities.

extension lines  Lines extending away from an entity being dimensioned so that 
you can place the dimension line away from the entity. Also called projection lines.

extents  The smallest rectangle that can contain all the entities in a drawing. Infinite 
lines and rays do not affect a drawing’s extents. See also limits.

external reference  A drawing that is linked to another drawing.

extrude  The process of converting a two-dimensional entity into a three-dimen-
sional entity by stretching (extruding) the two-dimensional entity along a straight 
path. Changing the thickness of a two-dimensional entity effectively extrudes it along 
its z-axis. See also tabulated surface.

face  A planar surface defined by three or four points.

fence  An entity-selection method that selects entities crossing a multisegmented 
line.

fillet  An arc that smoothly connects the end of one line to another.

float  To position a toolbar or the command bar away from the edges of the drawing 
window where it can be moved independently. See also dock.

freeze  To suppress the display of, and ignore the entities on, a specified layer when 
regenerating a drawing, thus accelerating the display of the drawing. See also thaw.

grid  An adjustable, regularly spaced pattern of dots on the screen, used as an aid in 
drawing and aligning entities. The grid is not printed.

grip  A small square displayed at key positions on an entity when the entity is 
selected that can be used to modify the entity by clicking and dragging.

halfwidth  The distance from the center of a wide polyline to its edge.
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hatch  To fill a selected area either with lines, crosshatching, or a hatch pattern. See 
also crosshatch.

hatch pattern  A pattern, often representing a material such as steel, wood, or sand, 
for filling selected areas.

hidden-line removal  A visualization technique in which all lines that are hidden 
behind other entities or surfaces from your viewpoint are clipped or removed, giving 
the image the appearance of a solid entity.

horizontal dimension  A linear dimension measuring a horizontal distance.

infinite line  A line extending infinitely in both directions.  

insertion point  The point where you place an entity into a particular space. A refer-
ence point by which an entity is inserted in a drawing. 

intersection  The point where two entities meet or cross.

isometric drawing  A drawing aligned with an isometric plane.

isometric plane  One of three planes representing the left, right, or top sides of an 
implied three-dimensional, orthogonal entity. Snap and grid points are aligned with 
the plane to constrain drawings.

layer  The computer equivalent of overlays used in manual drafting. A tool by which 
drawing components can be organized into related sets, such as plumbing, framing, 
and electrical systems of a house, each being drawn on its own layer.

layout  Similar to a sheet of paper, a representation of how a drawing will look when 
printed. 

layout viewport  A window in a Layout tab (paper space) that displays all or a por-
tion of a drawing’s model space entities. See also paper space and model space.

leader  A line leading from a feature of a drawing to an annotation.

limits  The user-defined boundary of a drawing, defined by its lower left and upper 
right corner coordinates. See also extents.

limits tolerance  Dimension text in which the measured dimension is replaced by 
the largest and smallest dimensions allowed, with the upper limit displayed above the 
lower limit. See also tolerance and variance tolerance.

linetype  The appearance of a line, defined as a solid (continuous) line or as a pattern 
of dashes, dots, and blank spaces.

lineweight  The width of a line, defined in millimeters or inches.

link  A technique for exchanging information between different programs whereby 
the target document maintains a pointer to the original source document. Any 
changes to the source document are reflected in all target documents containing links 
to the source. See also ActiveX and embed.
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LISP  Acronym for List Processing Language, a computer language invented in the 
late 1950s by John McCarthy for use in artificial intelligence. Because it is inter-
preted rather than compiled, and is relatively straightforward, it is a convenient lan-
guage for users to write routines to extend the set of commands and functionality of 
IntelliCAD.

lock  Prevents unauthorized access to drawing layers.

M direction  In a polygon mesh, the direction from the first to the second row. See 
also N direction.

macro  In menus and toolbars, several commands grouped together as one. Also 
Visual Basic for Applications code.

major axis  The longest distance across an ellipse, from one end to the other. See 
also minor axis.

marker blips  Temporary screen markers displayed in a drawing when you select a 
point. Also called blips.

MDI  Acronym for multiple-document interface. See multiple-document interface.

mesh  A set of connected polygon faces approximating a curved surface.

minor axis  The shortest distance across an ellipse, from one side to the other. See 
also major axis.

mirror  To create a reverse-image copy of selected entities by reflecting the entities 
symmetrically about a line or plane.

model space  The primary drawing area in which you create entities. See also paper 
space. 

multiple-document interface  The ability to view and work with different drawings 
simultaneously.

N direction  In a polygon mesh, the direction from the first to the second column. 
See also M direction.

named print style table  A collection of print styles that determine how entities 
print according to the print styles you create and assign to entities and layers. See 
print style table. 

named view  A saved view that can be recalled at a later time by specifying its name.

nested block  A block contained as part of the definition of another block. See also 
block.

nonassociative hatch  A hatch that is not associated with or linked to an entity.

oblique  Geometric lines or planes that are not parallel or perpendicular.

offset  See parallel.
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OLE  Acronym for Object Linking and Embedding. See ActiveX.

ordinate dimension  A measurement of the horizontal (x-ordinate) or vertical (y-
ordinate) distance from an established reference base point or datum.

origin  The intersection point of the coordinate system axes. In a Cartesian coordi-
nate system, the origin is the point at which the x-, y-, and z-axes intersect (the 0,0,0 
coordinate).

orthogonal  Having perpendicular slopes or tangents at the point of intersection.

orthogonal mode (ortho)  A drawing mode in which the entity creation is con-
strained to parallel the horizontal and vertical axes relative to the current snap angle.

orthographic projection  A drafting technique by which a three-dimensional item 
is described in two dimensions by showing it from various directions, most com-
monly front, top, and side views.

outside circle  An entity-selection method that selects entities falling completely 
outside a circular selection window. 

outside polygon  An entity-selection method that selects entities falling completely 
outside a polygon selection window. 

outside window  An entity-selection method that selects entities falling completely 
outside a rectangular selection window. 

pan  To shift the displayed view of a drawing without changing the magnification. 
See also zoom.

paper space  A two-dimensional work area similar to a sheet of paper, in which you 
can arrange different views of your model as layout viewports. See also model space.

parallel  Two or more coplanar lines that never intersect one another.

parallel dimension  See baseline dimension.

PDF  Acronym for Portable Document Format. PDF files can be viewed using 
Adobe® Acrobat Reader, which is free software that users can download; they can 
also be viewed, reviewed, and edited using Adobe® Acrobat.

perimeter  The distance around the boundary of an entity.

perpendicular  Entities at right angles to one another.

planar  Entities whose extents are situated entirely within a plane.

plane  Two-dimensional surface.

plan view  A view of the drawing from above, looking down the z-axis perpendicular 
to the xy plane of the current UCS.

point  A location in space specified by its x-, y-, and z-coordinates. A drawing entity 
consisting of a single x,y,z-coordinate location and represented by one of several 
symbols.        
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point filter  See coordinate filter.

polar array  Multiple copies of selected entities in a circular pattern.

polar coordinates  Coordinates describing a two-dimensional point on a two-
dimensional plane based on the point’s distance from the origin and its angle in the 
plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, rela-
tive coordinates, and spherical coordinates.

polygon  A closed single entity with three or more sides.  

polyline  A drawing entity composed of one or more connected line or arc segments 
treated as a single entity. 

print style  A collection of settings, including color, pen width, linetype, and line-
weight, that determine how a drawing looks when it is printed. See print style table.    

print style table  A collection of print styles that you can assign to the Model tab or 
to a Layout tab. Print style tables change how a drawing looks when you print it with-
out modifying the actual entities. See print style. 

profile  File that contains your preferred drawing environment settings. 

projection lines  See extension lines.

prompt box  A list of options displayed when a command or tool provides several 
choices.

Prompt History window  A window containing a history of the most recent com-
mands and prompts issued since you started the current session of IntelliCAD.

quadrant  One-fourth of a circle, arc, or ellipse entity. In the context of entity snaps, 
the option that snaps to points on a circle, arc, or ellipse at each quadrant.

radial dimension  A dimension that measures the radius of a circle or arc.

radian  A unit of angular measurement; 360 degrees equals 6.283185 or 2pi radians.

radius  The distance from the center of a circle or sphere to its periphery.

ray  A line that starts at a designated point and runs infinitely.

ray tracing  A visualization technique in which rays from imaginary light sources 
are traced as they refract off the surfaces of a model, determining where shadows fall 
and how reflections on shiny materials such as metal and glass appear.

rectangle  A four-sided, closed entity whereby opposite sides are equal in length.

rectangular array  Multiple copies of selected entities in a rectangular pattern con-
sisting of a specified number of columns and rows.

redo  To reverse the effect of previous undo commands. See also undo.

redraw  To quickly update or refresh the drawing screen display. See also regener-
ate.
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regenerate  To update or refresh the drawing screen display by recalculating the 
drawing from its database. See also redraw. 

region  A two-dimensional closed, surfaced, planar boundary.  

relative coordinates  Coordinates expressed in relation to a previous coordinate. 
See also absolute coordinates. 

render  A visualization technique in which all surfaces of a model are shaded as 
though they were illuminated from an imaginary light source located behind you as 
you face the screen. Rendered images are photo-realistic, having depth, shadow, 
reflection, and texture. 

revolve  Creating a three-dimensional surface entity by rotating a two-dimensional 
profile around an axis.

right-hand rule  A visual aid for remembering the relative directions of the positive 
x-, y-, and z-axes of a Cartesian coordinate system and the positive rotation direction 
about an axis.

rotate  To change the orientation of an entity, without modifying it, by repositioning 
it equidistant from, but at a new angle with respect to, a point or axis.

rotation angle  The angle by which an entity is displaced from its original location 
when rotating it about a point or axis.

rubber-band line  A ghosted image line that stretches dynamically on the screen 
with the movement of the cursor. The line extends between a fixed point and the cur-
sor position to provide dynamic feedback.

ruled surface  A three-dimensional polygon mesh that approximates a smooth sur-
face between two entities.

running entity snap  Setting an entity snap so that it continues for subsequent selec-
tions. See also entity snap and entity snap override.

scale  To resize an entity. To draw according to the proportions of an entity.

script  A set of commands stored in an ASCII script file and replayed in sequence by 
running the script.

SDS  Acronym for Solutions Development System, a C programming interface for 
developing specialized programs to run inside IntelliCAD.

segment  Any part of an entity bounded by two points.

selection set  One or more drawing entities selected on which one can operate as a 
single unit.

shade  To fill planar entities with solid colors for easier visualization.

snap angle  The angle around which the snap grid is rotated.

snap grid  An invisible grid that locks entity creation to a specified alignment and 
snap increment when Snap is enabled.
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snap resolution  The spacing between points on the snap grid.

snapshot  A raster representation of the current view of one’s drawing.

spherical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its angle up from 
the xy plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, 
and polar coordinates.

spline  A curve generated along the path of three or more control points. The curve 
passes through the start point and endpoint, but does not necessarily pass through the 
intermediate control points. 

status bar  The bar at the bottom of the IntelliCAD window that displays informa-
tion about the selected command or tool as well as the cursor coordinates, the name of 
the current layer, mode settings, and other information about drawing settings.

surface model  A three-dimensional model consisting of both edges and the sur-
faces between those edges. See also wire-frame model.

surface of revolution  A three-dimensional polygon mesh that approximates the 
surface generated by rotating a two-dimensional profile around an axis.

SVG  An acronym for Scalable Vector Graphic, which is a file format for working 
with interactive graphics, including a Web development language.

system variable  A setting or value that stores operating environment and command 
information (such as the drawing limits or global linetype scale factor).

tabulated surface  A three-dimensional polygon mesh that approximates the sur-
face generated by extruding a curve along a vector. See also extrude.

tangent  A line that passes through a single point on a curve.

template  A drawing with preset layers, linetypes, and other settings (and entities) 
that can be used as the basis for creating a new drawing. Templates are saved with a 
.dwt file extension.

text style  A named, saved collection of format settings that determines the appear-
ance of text.  

thaw  To redisplay a layer that was frozen. See also freeze.

thickness  An entity’s depth, as measured along its z-axis. The distance an entity is 
extruded above or below its elevation. See also elevation and extrude.

through point  In creating a parallel entity, a point through which the new entity 
passes.

tolerance  Dimension text indicating how much the actual dimension of a manufac-
tured component can vary from the specified dimension. See also limits tolerance 
and variance tolerance.
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tolerance command  A command that creates a feature-control frame used in 
mechanical geometric dimensioning and tolerancing.

toolbar  A collection of tools arranged on a palette that can be moved and resized 
anywhere on the screen.

torus  A donut-shaped, three-dimensional entity.

transparent command  A command started while another command is already 
active. You can use a command transparently by preceding it with an apostrophe.

true color  Colors defined using 24-bit color. There are more than 16 million true 
colors from which you can choose.

UCS  Acronym for user coordinate system. See user coordinate system.

UCS icon  A user coordinate system icon that shows the orientation of the coordinate 
axes, the location of the coordinate system origin, and the viewing direction relative 
to the xy plane.

undo  To reverse the effect of previous commands. See also redo.

unit  See drawing unit.

unlock  Free access to layers in a drawing that would be otherwise locked, thus pro-
hibiting them from being viewed or edited by another user.

user coordinate system  A Cartesian coordinate system with origins and orienta-
tion defined by the user. See also World Coordinate System.

variance tolerance  Dimension text in which a plus/minus value is appended to the 
specified dimension to indicate how much the actual dimension of a manufactured 
component can vary from the specified dimension. See also limits tolerance and tol-
erance.

VBA  Acronym for Visual Basic for Applications, a macro programming language 
embedded in programs that allows the user to customize the program.

vector  A means of describing a displacement using magnitude and orientation. For 
example, you can create a line entity, or move an entity, by specifying an initial point, 
a direction, and a distance.

vertex  The point of intersection of the sides of an angle. The start points or end-
points of a line or arc segment in a polyline.

vertical dimension  A linear dimension measuring a vertical distance.

view  A representation of a drawing or portion of a drawing from a specific view-
point in three-dimensional space.

viewpoint  A location in three-dimensional space for viewing one’s drafting.

viewport  A window that displays all or a portion of a drawing’s model space entities 
while in model space on the Model tab. See also model space and paper space.             
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viewport configuration  A named arrangement of windows that can be saved and 
restored.

WCS  Acronym for World Coordinate System. See World Coordinate System.

wedge  A three-dimensional entity that resembles a box divided along one side from 
one corner to the opposite corner; for example, a doorstop or a ramp.

window circle  An entity-selection method that selects entities contained entirely 
within a circular selection window. 

window inside  An entity-selection method that selects entities contained entirely 
within a rectangular selection window. 

window polygon  An entity-selection method that selects entities contained entirely 
within a polygon selection window. 

wipeout  An entity that displays with the current background color, so the details 
behind it do not display or print.

wire-frame model  A three-dimensional model consisting of lines and curves that 
define the edges of a three-dimensional entity. See also surface model.

WMF  Acronym for Windows metafile, a format containing vector and color informa-
tion to render entities.

World Coordinate System  The fixed Cartesian coordinate system used as the basis 
for defining other coordinate systems. See also user coordinate system.

xref  See external reference.

zoom  To increase or decrease the magnification of the display of a drawing. See also 
pan.   
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Symbols
- (hyphen characters) 149, 366, 367
$ (dollar signs) 149, 366, 367
% (percent signs) 285
& (ampersand character) 494
, (commas) 165
. (period characters) 166
< (angle brackets) 162, 164, 165
@ (at symbols) 260
_ (underscore characters) 149, 366, 367
± (plus or minus signs) 285
° (degree symbols) 285

Numerics
0 layer 181
24-bit color 59
2D DWF files 470
2-dimensional drawings

2-dimensional coordinate systems 159
coordinate systems 156
defined 545
isometric drawings 71
point filters 166
polar coordinates 162

2-dimensional entities
See also 2-dimensional entity types; entities
arraying in columns or rows 248
extruding to create 3-dimensional entities 399–402

2-dimensional entity types
arcs 93
circles 91
donuts 107
ellipses 96
elliptical arcs 97
freehand sketches 103
infinite lines 101
lines 90
planes 119
point entities 98
polygons 110
polylines 104
rays 100
rectangles and squares 108
splines 114

3D Array command or tool (3darray) 426, 427
3D DWF files 470
3D Mirror command or tool (mirror3d) 428
3D Rotate command or tool 425
3D solids 399
3-dimensional coordinate systems 164

defined 545
specifying locations with 163

3-dimensional drawings
compared to isometric 2-dimensional drawings 71
coordinate system icons 157
coordinate systems 156, 163
defined 545
point filters 167
setting viewpoints 396–399
snapping to entity intersections 80–81, 81–82
user coordinate systems 168
wire-frame and surface models 399

3-dimensional entities
3D solids 399
See also 3-dimensional entity types; entities
aligning 429
arraying copies of entities 426–427
creating regions 420
editing 425–429, 430–441
hiding lines in drawings 441
mirroring 428
rotating entities 425
shading surfaces 442
thickness and elevation 399–403

3-dimensional entity types
boxes 410
cones 412
cylinders 415
dishes 417
domes 418
edge-defined Coons surface patch meshes 409
extruded surface meshes 406
faces 403
polyface meshes 405
pyramids 413
rectangular meshes 404
regions 420
revolved surface meshes 407–409
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ruled surface meshes 405
spheres 416
tori 419, 421
wedges 411
wire-frame 441

3-Point Arc tool 93

A
absolute coordinates

See also coordinate systems; user coordinate sys-
tems (UCS); World Coordinate System (WCS)

defined 545
specifying locations with 159, 163

absolute size of point entities 98
access keys for commands 494
accuracy

drawing unit display 51
IntelliCAD compared to manual drafting 7–8
precise point locations with entity snaps 227

ACIS solids
boxes 410
combining 423
cones 412
cylinders 415
defined 545
dishes 417
domes 418
extruding 421
intersecting 424
pyramids 413
regions 420
revolving 422
spheres 416
subtracting 423
tetrahedrons 413
tori 419
wedges 411

acisin command 463
acisout command 471
ActiveX

defined 545
dragging drawings into other applications 466–467
editing linked or embedded objects 461, 465
linking drawings to other applications 465
linking objects to drawings 460–461
sharing drawing information and data 12

acute angles 545

Add To Set selection method 234
adding

aliases for commands 512
areas of entities 224
commands to menus 491, 493, 518
entities to selection sets 237
hyperlinks 472
keyboard shortcuts for commands 508
layouts for printing 361
space between tools 500
tools to toolbars 500

ADS programs 3, 4, 521
ADT files 43
advanced experience level

changing level 3, 32, 476
defines menus 32

aliases for commands
creating 512
defined 545
deleting 513
importing or exporting 513
redefining 513

align command 429
Align command or tool (align) 429
Aligned command or tool (dimaligned) 304
aligned dimensions

creating 304
defined 545
illustrated 300

aligning coordinate systems
with current view 170
with entities 168

aligning entities 429
aligning marker blocks on entities 221, 222
aligning text

on dimension lines 323
options 319

alternate dimension units, controlling 332
alternate font

setting the default file 479
alternate text editor 293
ambient light 443
American National Standards Institute (ANSI) defined 

545
American Standard Code for Information Interchange 

(ASCII) defined 546
ampersand characters 494
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angle brackets 162, 164, 165
angle drawing method

infinite lines 101
rays 100

angles
angle direction and base settings 52
calculating angle between points 227–228
defined 545
displaying instead of coordinates 158
drawing unit settings 51, 549
specifying for arcs 93, 94, 113
specifying for chamfering 272
specifying for dimension lines 307
specifying for grid 69
specifying for lines 90
specifying for rotated entities 249–251
specifying for text styles 198
specifying locations by 162
specifying text angle in text styles 201
spherical and cylindrical coordinates 164
zero angle settings 52

Angular command or tool (dimangular) 307
angular dimensions 307, 308

creating 307
defined 545
formatting dimension unit display 325

angular drawing units 545
angularity tolerance symbol 327
annotations

adding in paper space 362
creating as dimension text 311
defined 545

ANSI character sets 295
aperture for entity snaps 74
apostrophes 33
app command modifier 34, 82
Apparent Intersection Snap command (apparent) 81
appending scripts 520
appload command 521, 523
Arc command (arc) 93
Arc Start-Center-Angle tool 93
Arc Start-Center-End tool 94
architectural

drawing scale ratios 53
drawing units 50

arcs
adding lines to 90

angle dimensions for 307
center marks 301
converting donuts into arc entities 118
converting polyline segments to arcs 113
converting to circles 92
defined 545
diameter dimensions for 308
direction of 97
drawing methods 93
elliptical arcs 97
extending to boundaries 253
joining 260, 266–267
measuring and marking off intervals 220–223
moving with grips 249
polyline drawing methods 113
radius dimensions for 308

Area command or tool (area) 223, 545
calculating areas 223

ARG files (profiles) 488
arranging windows 146

See also views and viewports
Array command or tool (array) 248
arraying entities 246, 426, 545
arrows and arrowheads 301, 317–319
ASCII

AutoCAD files. See DXF files
defined 546
text files 346

assembling master drawings 348
assigning aliases to commands 512
at symbol 260
Attach Drawing tool (Blocks toolbar) 210, 214
attaching

attributes to blocks 345
external references 349
raster images 449

attachment points 279
See also insertion points

attributes
after exploding blocks 270
attaching to blocks 345
data in 336
defined 209, 546
definitions 342–344
editing definitions 344
extracting values 346–347
fixed or variable values 342
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flags 342
invisible data 342
names 546
overview 342–343
snapping to insertion points 79
text 546
updating values for 345
visible or hidden 342

Audio Note command or tool (audionote) 515, 516, 517
audio note icon 516
audio notes

attaching 515
deleting 517
overview 514
playing 517
selecting 516

Audit command (audit) 43
AutoCAD

alias files 513
command name compatibility 511
exporting IntelliCAD files as AutoCAD files 467–

471
font compatibility 199
importing toolbars from menu files 504
IntelliCAD compatibility 3, 531
loading menu files 491, 496
script files 518

AutoCAD Development System programs (ADS) 3, 4, 
521

AutoLISP programs 3, 4, 521–523
automatically

changing code pages 296
loading menus 481
loading profiles 486
reloading external references 353
running scripts 520
saving drawings 476

automating IntelliCAD functions 476
AutoSave 476
axes

changing display color 483
in coordinate systems 156, 159
in ellipse drawing methods 96
in elliptical arc drawing methods 97
rotating entities around 425

B
background 443, 445
background screen color 481
Backgrounds command or tool (backgrounds) 445
backward text 201, 281, 286
base 443
base points

See also origin points
defined 546
for copying entities 242
for entities to be moved 248
for scaling entities 252
for stretching entities 251

baseline
of text 546
offset in dimensions 321
text alignment 283

Baseline command or tool (dimbaseline) 305
baseline dimensions

adding to linear dimensions 302
angular baseline dimensions 307
creating 305
defined 546
illustrated 300

basing drawings on templates 40–41
basing layouts on templates 366
beginner experience level

changing level 3, 32, 476
defines menus 32
explained 3

best fit for dimension text and arrows 319–321
beveled edges on entities 271–274
binding external references 355, 546
bisect drawing method (infinite lines or rays) 100
BL notation in extracted attribute file fields 346
black-and-white

printing 384
tool icons 501, 503

blipmode command 153
blips

defined 546
displaying current settings 229
marker blips 153, 552
turning on or off 153

block command 337, 341
Block command (IntelliCAD Explorer) 212



I N D E X 563
Block command or tool (ddinsert) 338
Block toolbar 210
blocks

See also Xref Manager command or tool (xrm)
as interval markers 220
attributes 336–342
Blocks list in IntelliCAD Explorer 209
BYBLOCK property 45–47
clipping 356
copying to other drawings 174
creating 212, 336–338
definitions 342–344
deleting in IntelliCAD Explorer 175
editing definitions 344, 345
entity storage in files 348
exploding 270, 339, 341
external references 348–358
inserting 213, 338–340
inserting drawings as 213
insertion points 79, 211–213, 338–340
instances of 338, 340
listing 209
multiple instances of 336, 337
names in extracted attribute file fields 346
nesting 336
number of occurrences 211
overview 209, 336
redefining and updating 336, 340
reusing blocks and drawings 10
rotation angle and scale 339, 340
saving 336–338
saving as drawing files 215, 337
search path for files 478
snapping to insertion points 79

BMP files 503
bodies

slicing and sectioning 431
borders on drawings 362
borders on images 454
borders on viewports

as available in each view 8
setting as invisible 369

bottom-aligned text 283
boundaries

extending entities to 253–256
setting for paragraph text 279
trimming or clipping entities to 256–257

xref clipping 356
Box command or tool (box) 410
Break command or tool (break) 259
breaking entities into pieces

exploding blocks 341
exploding into components 270
splitting into two parts 259

brightness of images 452
B-Spline curves. See splines
buttons. See toolbars and tools
BYBLOCK property

after exploding 270
colors 45–46
creating blocks from entities on different layers 336
defined 546
linetypes 46–47, 190–192
lineweights 48
print styles 49

BYLAYER property
colors 185
creating blocks from entities on different layers 336
defined 546
linetypes 46, 187–198
lineweights 48

C
C character

closing entities 161
in extracted attribute file fields 346

CAD defined 546
calculating areas 223
calculations

area and perimeter 223
distances and angles 227–228
in IntelliCAD and manual drafting 11–12
scale factors and printed size 53–54

callout lines. See leaders in dimensions
Cartesian coordinates

See also cylindrical coordinates; polar coordinates; 
spherical coordinates

2-dimensional coordinate systems 159
3-dimensional coordinate systems 163
absolute and relative coordinates 160
defined 546
overview 7
understanding coordinate systems 156, 158

Cascade command 146, 177
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CDF files 346
center command 77
center lines

defined 547
for circles and arcs 301

center marks
defined 547
for circles and arcs 301
formatting 321–323

center points of entities
arcs 113
circles 91
dishes 417
domes 418
ellipses 96
elliptical arcs 97
polygons 110
snapping to 74, 76, 77
spheres 415

center points of views 144
Center Snap command (center) 77
center-aligned text 283
Center-Diameter circle method 91
Center-Radius circle method 91
chain dimensions. See continued dimensions
Chamfer command or tool (chamfer) 274
character sets for text display 295
character string fields in extracted attribute file fields 346
check spelling 289
checking

damaged files 43
damaged files when opening 476
solids 441

chords in arcs 93, 113, 547
Circle Center-Radius tool 91
Circle command (circle) 91
circle diameter symbol 285
Circle Radius-Tangent tool 92
circles

See also donuts 549
center marks 301
creating from arcs 92
diameter dimensions 308
drawing 116
measuring and marking off intervals 220
moving with grips 249
radius dimensions 309

circular
arrays of entities. See polar arrays of entities
runout tolerance symbol 327

circularity tolerance symbol 327
circumferences, defined 547
cleaning solids 440
Clear Entity Snaps command or tool (none) 75, 82
Clipboard

copying entities into other drawings 244
embedding objects into drawings 459
embedding objects into other applications 466
linking drawings into other applications 465

clipping
entities 256
external references 356
raster images 455

closed (entities), defined 547
closing

polylines 112, 264
prompt boxes 30
splines 116

coaxiality tolerance symbol 327
codepage command 296
color books

creating 62, 65
current entity color 45
loading 66
selecting a color 61
selecting for layers 186

Color dialog box 58, 60, 61, 180
color-dependent print style tables

changing a drawing’s table type 387
comparing with named tables 380
converting to named 388
copying, renaming, deleting 387
creating 384
default settings 488
defined 379
modifying 385

colors
applying shading 442–446
changing in entity properties 240
color books 61
creating blocks from entities on different layers 336
current settings 229
default layer color 180
dimension lines 321
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dimension text 324
displaying information about entities 228
grip color 239
index colors 58
layer settings 177, 185–187
mapping during printing 379
multiline text 279
overriding layer color 186
print styles 385
selecting entities by color 235
solid faces 437
status bar information 29
text entity color 286
true colors 59
working with 58

columns of entities. See arraying entities; rectangular ar-
rays of entities

combining entities
chamfering and filleting 271
finding area of combined entities 224–227
joining 260, 266
lines and arcs in polylines 112
solids 423

combining zooming and panning actions 144
Comma Delimited Format files 346, 547
command bar

Command Bar command 28
defined 547
displaying or hiding 28
illustrated 26
moving 25, 28
navigating with arrow keys 480
starting commands with 33

command strings for keyboard shortcuts 509–510
commands

active commands 32
adding to menus 493
aliases 511–518
AutoCAD command name compatibility 511
deleting from menus 494
displaying shortcut menus 27
ending 32
experience levels 476, 495
information in status bar 29
keyboard shortcuts for 509–511
loading custom programs 523
modifying commands 34

mouse shortcuts for 35
nesting several commands 33
prompt boxes 30
renaming 494
repeating 33
Script Recorder 35
starting 33
tracking history 34, 480

commenting
scripts 518

company names on printouts 488
complex entities

See also types of entities (polylines; rectangles; do-
nuts; and so on)

defined 107
exploding into components 270

complex hatch patterns 127
complex linetypes (IntelliCAD Explorer) 194
composite solids 423
composite tolerances 328–333
compressing or expanding text 281, 284
concentric entities. See donuts; tori
concentricity tolerance symbol 327
Cone command or tool (cone) 412
cones 412, 547
config command 477
configuring

code pages 296
IntelliCAD 475
layouts 361
print settings 373
printer configuration files 389

connecting entities
chamfering and filleting 271
joining 260, 266

constraining drawing
to drawing limits 56
to right angles 72, 73

construction lines. See infinite lines
construction planes. See user coordinate systems (UCS)
contiguous (entities), defined 547
Continue command or tool (dimcontinue) 306
continued dimensions

adding to linear dimensions 302
angular continued dimensions 307
creating 307
defined 547
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illustrated 300
continuous inertial motion 481
CONTINUOUS linetype 46, 48, 190
contrast of images 452
control codes for text 285
control points 115, 547
convertctb command 388
converting

2-dimensional entities to three dimensions 399
code pages 296
color-dependent print style tables 388
donut sides to arc entities 118
drawing’s print style table type 387
entities into components 270
entities to other linetypes before deleting 175
entities to other text styles before deleting 175
entities to polylines 264
plane sides to line entities 120
polygon sides to line entities 111
polyline segments to curves 265–266
polyline segments to entities 113
rectangle sides to line entities 108

converting arcs to circles 92
convertpstyles command 387, 388
Coons Surface command or tool (edgesurf) 409
Coons surface patch meshes 409, 547
coordinate filters (point filters) 166, 547
coordinate systems

2-dimensional coordinate systems 159
3-dimensional coordinate systems 163
absolute and relative coordinates 160
Cartesian coordinates 7, 156, 159, 546
copying to use in other drawings 174
cylindrical coordinates 165, 548
defined 547
deleting in IntelliCAD Explorer 175
icons for 157
listing 202–204
point filters 166, 168
polar coordinates 158, 162, 554
preset user coordinate systems 169
right-hand rule 163
spherical coordinates 164, 556
user coordinate systems 157, 168, 170, 371
World Coordinate System 157, 170, 202, 398, 558

Coordinate Systems list in IntelliCAD Explorer 169, 202
coordinates

See also coordinate systems
defined 547
displaying for entities 228
finding point coordinates 159
in ordinate dimensions 309
of drawing limits 56
viewpoints in three-dimensional drawings 396

coplanar (entities), defined 547
Copy command or tool (copy or copyclip) 243–244
Copy command or tool (IntelliCAD Explorer) 174–175
copyclip command 244
copying

layers to other drawings 175
layouts 366
print style tables 387
profiles 487
settings to other drawings 174
solid faces 437
text in Prompt History window 34

copying drawings
dragging into other applications 466–467
with external references for distribution 355

copying entities 242–248
arrays of entities 246, 426–427
mirroring entities 246, 428
parallel copies 244–246
to other drawings 149, 244

copying objects
embedding IntelliCAD data into other applications 

464–465
embedding objects into drawings 458
linking drawings to other applications 465
linking objects to drawings 460

corner points
of planes 119
of rectangles 108

correcting mistakes 36
Create Block command or tool (block) 337, 341
Create Snapshot dialog box 448
creating

audio notes 515
blocks 213
color books 62, 65
files in different formats 467
hyperlinks 472
layout viewports 368
print style tables 384
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printed drawings 359
printer configuration files 389
profiles 484

cropping
entities (trimming) 256, 272–274
external references 356
raster images 455

crosshairs
defined 548
entity snap target box 74

crosshatching 127, 548
See also hatch patterns and hatching

Crossing Circle selection method 235, 548
Crossing Polygon selection method 235, 251, 548
Crossing Window selection method 234, 236, 251, 548
CTB files

assigning 383
changing a drawing’s table type 387
compared with STB files 380
converting to STB files 388
creating 384
default settings 488
defined 379
modifying 385

cubes 410, 548
current editing session timer 230
current settings

layers 182
linetypes 191
lineweights 48
loading profiles 486
print styles 49
text styles 202
three-dimensional elevation and thickness 401
tools 174
user coordinate systems 205

Current tool (IntelliCAD Explorer) 202, 205
cursors

coordinate information in status bar 29
current position in coordinate systems 158
defined 548
entity snap cursor decoration 490
fly-over snap cursors 83, 490
magnifying glass cursor 142

curves. See also arcs; circles; ellipses; splines
curving polyline segments 265
Customize command (customize)

customizing aliases 511–518
customizing keyboard shortcuts 508–511
customizing menus 491–498
customizing toolbars and tools 499, 508

Customize dialog box
Aliases tab 511
Keyboard tab 508–511
Menus tab 491–498
Toolbars tab 498–508

customizing
IntelliCAD 36
text editor 293

customizing IntelliCAD options
aliases 511–518
coordinate systems 168
hatch patterns 127
keyboard shortcuts 508–511
menus 491–498
print settings 373
program settings 476–491
running custom programs 521–523
scripts for 518, 521
templates 40
toolbars and tools 25, 499

Cut command or tool (cutclip) 244
cutting entities

moving to other drawings 149
pasting in other drawings 244

Cylinder command or tool (cylinder) 415
cylinders 264, 415
cylindrical coordinates 165, 548

See also polar coordinates; spherical coordinates 
159

D
data

attaching to blocks. See attributes
attaching to drawings 11–12

data fields for extracted attribute files 346–347
databases

for drawing data 138
using information in drawings 11

dates
date stamps on printouts 488
tracking time spent on drawings 230

ddattdef command 342
ddatte command 345
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ddattext command 347
ddedit command 285, 289, 344
ddgrips command 239
ddinsert command 338
decimal

degrees in angular units 51
drawing units 51

decurving polyline segments 265
default profile 486
defaults

arc direction 97
code pages 295
colors 180
defined 548
drawing environment (profiles) 486
elevation 399
entity colors 45
icad.dwt template 25
layers 175
linetypes 46, 180, 187
lineweights 48, 154, 188
print style table settings 488
print styles 49, 189
text styles 281
thickness 399
values for attributes 342

Define Attributes
command or tool (ddattdef) 342
dialog box 342

defining
complex linetypes 194–197
dimension styles 316
keyboard shortcuts 509
linetypes 193–198
lineweights 48, 154
print settings 373
text styles 199
user coordinate systems 168, 204

definition points 302
degree symbols 285
Delete command or tool (delete) 242
Delete command or tool (IntelliCAD Explorer) 176
deleting

aliases 513
audio notes 517
clipping boundary 357, 455
commands from menus 494

custom programs 522
dimension styles 317
elements in IntelliCAD Explorer 175–177
entities 242
external references 352
freehand sketches 104
hyperlinks 473
images 458
keyboard shortcuts 510
layouts 367
lines in 3-dimensional entities 441–443
print style tables 387
profiles 487
segments of polylines 112
solid faces 436
xref clipping 358

delta distances, calculating 227
density of mesh surfaces 406, 407, 408, 409
descenders on text characters 283
deselecting entities 238
Design Web Format

exporting 462, 470
importing 462
opening files 41

detaching external references 548
See also Xref Manager command or tool (xrm)

Details tool (Block toolbar) 210
Diameter command or tool (dimdiameter) 308
diameter dimensions

creating 308
defined 548
illustrated 300

diameters
circles 308
donuts 117

DIESEL programs 525
dimaligned command 304
dimangular command 307
dimbaseline command 305
dimcontinue command 306
dimdiameter command 308
dimedit command

obliquing dimensions 313
replacing dimension text with new text 315
restoring dimension text to home position 315
rotating dimension text 314

dimension lines 323
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See also dimension text; dimensions and dimension 
styles; extension line

aligning text on 323
defined 300, 548

Dimension Settings command or tool (setdim)
arrows and arrowheads 318, 320
baseline dimension offset 305
creating, renaming, or deleting dimension styles 316
dimension line colors 321
formatting and positioning dimension text 319, 323
rounding off numbers 325

Dimension Settings dialog box
Arrows tab 318–319
Format tab 319
Lines tab 321
Text tab 323
Units tab 325–327

Dimension Style command 316
Dimension Styles (IntelliCAD Explorer) 216
dimension text

aligning on lines 323
defined 313, 548, 549
formatting and positioning text 313–315, 319–321, 

323–325
overview 301
replacing dimension text with new text 315
restoring dimension text to home position 315
rotating dimension text 313

dimension tolerance
controlling 330

dimension units, alternate 332
dimensions and dimension styles

See also dimension text
aligned dimensions 304
angular dimensions 307–308
arrows and arrowheads 317
baseline dimensions 305
creating dimensions 302–313
creating or deleting styles 316
diameter dimensions 308
dimension styles defined 300, 316–327
dimension variables 316, 549
dimensions defined 548
extension lines 301
in paper space 312
leaders and annotations 301, 311
line colors 321

line formats 321
linear dimensions 302–307
obliquing 313
ordinate dimensions 309
overview 300–302
radius dimensions 309
renaming styles 317
types of dimensions 300
units and rounding 325–327

dimleader command 311
dimlinear command 303
dimordinate command 310
dimradius command 309
dimtedit command 314
directory paths for files 478
disabling. See turning features on or off
Dish command or tool (dish) 417, 549
disk space requirements for IntelliCAD 24
displacement points

defined 549
for copying entities 242
for moving entities 248
for stretching entities 251

displaying
audio note icons 516
command bar 28
drawing information 228
embedded files as icons 459
entire drawings 145
layers 182–184
lineweights 154
lists of text styles 282
memory-intensive display elements 151
Model and Layout tabs 365, 480
multiple views of drawings. See also views and 

viewports 146
online Help 37
plan view of user coordinate systems 170
point entities 98
Prompt History window 34
reference grid 66
rotated views 141
scroll bars 481
shortcut menus 27
snapshots 449
text 295
text as boxes 151
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toolbars 27
ToolTips 27
warning messages 476
xref clipping boundaries 358

Distance command or tool (distance) 227
Distance-Angle chamfer method 272–273
Distance-Distance chamfer method 272
distances

calculating between points 227
defined 549
displaying instead of coordinates 158
specifying in chamfering 272
specifying locations by 162
spherical and cylindrical coordinates 163, 165

distant lighting 443
Divide command (divide) 220, 222
dividing display into multiple views. See views and view-

ports
dividing entities into equal segments 220
docking

defined 549
toolbars and command bar 25–29

dollar signs 149, 366, 367
Dome command or tool (dome) 418, 549
Donut command or tool (donut) 117
donuts

3-dimensional donuts (tori) 419, 421
converting sides to arc entities 118
defined 549
drawing 117
editing 264
filled or outlined 118

dots
in linetypes 193
point entities 98

doughnuts. See donuts 549
draft quality images 454
drafting manually compared to IntelliCAD 5–13
dragging

drawings from the Internet 474
drawings into other applications 466–467
moving entities with grips 249
new tools to toolbars 500

Draw 2D toolbar 27
Draw Freehand tool 103
Draw Order command or tool (draworder) 250
Draw Orthogonal tool 72, 73

Draw Point command (point) 98
drawing code page 295
drawing entities

3-dimensional faces 403
arcs 93
boxes 410
circles 116
cylinders 415
dishes 417
domes 418
donuts 117
edge-defined Coons surface patch meshes 409
ellipses 96
elliptical arcs 97
extruded surface meshes 407
freehand sketching 103
hatching entities 127
lines 90
planes 119
point entities 98
polyface meshes 405
polygons 110
polylines 111
pyramids 413
rays 100
rectangles 108
rectangular meshes 404
rendering 443
revolved surface meshes 407
ruled surface meshes 406
shading 442, 555
spheres 416
splines 114
squares 108
tori 419
wedges 411
wipeouts 121

drawing environment settings 484–488
Drawing Exchange Format files 346, 467–471, 549
Drawing Settings command or tool (settings)

Blips display 153
coordinate display in status bar 158
drawing limits 56–66
drawing units 50–53
elevation and thickness settings 401
entity snap target box 74
freehand sketch settings 103
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grid rotation 69
grid settings 66–71
grip display options 239
highlighting entities 234
highlighting settings 153
isometric snap and grid 71
linetype scale settings 47–50
linetype settings 46
lineweight settings 48
mesh surface settings 405, 407
orthogonal setting 72
point entity display 98
polar tracking setting 73
Quick Text feature 152
shaded surface settings 442
snap angle settings 70
snap spacing settings 69
text height settings 54

Drawing Settings dialog box - 3D Settings tab
elevation and thickness settings 401
mesh surface settings 407
shaded surface settings 442

Drawing Settings dialog box - Coordinate Input tab
drawing limits 56
entity snap settings 75
entity snap target box 75
grid rotation 69
grid settings 66
isometric snap and grid 71
mesh surface settings 406
orthogonal setting 72, 73
snap angle settings 70
snap spacing settings 69

Drawing Settings dialog box - Display tab
coordinate display in status bar 158
grip display options 239
highlighting entities 234
highlighting settings 153
Marker Blips display 153
Quick Text feature 153

Drawing Settings dialog box - Drawing Units tab 50
Drawing Settings dialog box - Entity Creation tab

entity color settings 45
freehand sketch settings 104
linetype scale settings 47
linetype settings 46
lineweight settings 48

point entity display 98
print style settings 49
text height settings 54–56

Drawing Settings dialog box - Entity Modification tab 
271–273

Drawing Status command (status) 229
drawing units

angular units 51–53
linear units 50
real-world units and 50
relationship to printed units 374
rounding in dimension display 325
scale factors and 53
text height and 54

drawings
See also 2-dimensional drawings; 3-dimensional 

drawings
3-dimensional and isometric drawings compared 71
adding audio notes 514
annotations, borders, and title blocks 362
blocks 213, 215, 338–342
code pages 295
copying entities to other drawings 149, 244
copying settings to other drawings 174
creating new drawings 25, 40
damaged files 42
default template 479
displaying entire drawings 145
displaying information about 228–231
drawing limits 54, 56, 145, 229, 549
drawing units 50
embedding or linking into other applications 464–

467
exporting 467
extents 100, 138, 145, 550
external references 10, 209, 214, 348
grid settings 66–69
isometric snap and grid 71
layer settings 44
layout viewports 368
linetype settings 46, 48
master and component drawings 348
moving around in 138
multiple drawings 3, 149
opening 41
orientation 373
orthogonal setting 72, 73
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paper size 373
passwords 86
printing 393
redrawing and regenerating 138
reusability 5, 8, 10, 174
saving 37
scale factors 53–54
search path for files 478
sending through e-mail 471
snap settings 74
tracking time spent on drawings 230
views 142
writing sketches into drawings 103

drivers for printers 374
dtext command

adding text to drawings 278
setting text style 282
specifying alignment 284

duplicating entities 242
DWF files

defined 549
exporting 470
importing 462
opening 41

DWG files
creating 40
defined 549
exporting IntelliCAD files as 467–471
IntelliCAD compatibility with 3
opening 41
saving 85

DWGCODEPAGE 295
DWT files

defined 549
importing 462
opening 41
saving 86

DXF files 346, 462, 467, 549
defined 549

DXX files 346
dynamic

panning 140
zooming 143

Dynamic View Control
command or tool (viewctl) 397
dialog box 397

dynamically rotating viewpoints in 3-dimensional draw-

ings 397

E
edgesurf command 409
Edit Block Attributes

command or tool (ddatte) 345
dialog box 345

Edit Dimension Text command or tool (dimedit) 315
Edit Length command or tool (editlen) 258
Edit Polyline command or tool (editpline)

curving and decurving 266
joining 267
moving polyline vertices 268
opening and closing 264
tapering polyline segments 269
width and tapering 267

Edit Text command or tool (ddedit)
changing text properties 286
editing attribute definitions 344
editing text 285

editing
color book files 62, 65
layout viewports 371
linked or embedded objects 461
polylines 264–270
print style tables 385
settings, single-click (IntelliCAD Explorer) 198
VBA programs 525

editing drawings
blocks 212
embedded IntelliCAD objects in other applications 

465
in model space 368
IntelliCAD compared to manual drafting 11
keyboard shortcuts 509
layers 175, 176, 180, 182, 185
linetypes 187, 191, 193
lineweights 188
linking objects to drawings 460
print styles 189
text styles 199–202, 281
user coordinate systems 204–206
views 207

editing entities
3-dimensional entities 425–429, 430–441
aligning 429
arraying 246, 426, 427
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attribute definitions 344
breaking and joining 259–260, 266
chamfering and filleting 271
changing properties 240
copying and pasting to other drawings 242
curving and decurving 265
cutting to Clipboard 244
deleting 242
dividing 222
editing length 257
elevation and thickness settings 402
exploding into components 270, 341
extending to boundaries 253
grouping 261–263
in model space 368
measuring 221
mirroring 246, 428
moving 248
moving polyline vertices 268
parallel entities 245
polylines 264
rotating 249, 425
scaling 252
selecting before editing 234–237
stretching 251
tapering polyline segments 267, 269
trimming 256
vertices 268–270
width of polylines 267
with grips 239

editing text
alignment settings 283
alternate text editor 293
changing character sets 295
changing text properties 286
editing attribute definitions 344
formatting 285
moving dimension text 314
replacing dimension text with new text 315
restoring dimension text to home position 315
rotating dimension text 314
spelling 289
text style settings 281
unicode characters 295

editlen command 258
editpline command

curving and decurving 266

joining 267
moving polyline vertices 268
opening and closing 264
tapering polyline segments 267, 269
width 267

elapsed-time timer 230
electronically mailing files 471
elements pane in IntelliCAD Explorer 173
Elevation command or tool (elev) 400
elevation in 3-dimensional entities 399

defined 549
entering coordinates 167
setting default elevation 400, 401

Ellipse Axis-Axis tool 96
Ellipse command (ellipse) 96
ellipses

drawing methods 96
moving with grips 249

Elliptical Arc Axis-Axis tool 97
Elliptical Arc command (ellipse) 97
e-mailing files 471
embedding

See also ActiveX; linking
defined 549
editing embedded objects 462, 465
IntelliCAD objects into other applications 464
objects into IntelliCAD drawings 458–461

EMF files
defined 549
exporting IntelliCAD files as 467
snapshot files 448

enabling features. See turning features on or off
end arrows 317
ending

commands 32
points for moving entities. See displacement points
script recording 519

Endpoint Snap command (endpoint) 76
endpoints of entities

defined 549
line entities 90
methods of drawing arcs 93, 112
snapping to 74, 76

engineering drawing
scale ratios 53
units 51

Enhanced Metafiles. See EMF files
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enlarging or reducing view of drawings 142
entities

See also types of entities (lines; rays; arcs; and so on) 
550

3-dimensional entities 399–409
area and perimeter 223
arraying copies of entities 246, 426
attaching audio notes 515
attributes 342–347
blocks 209, 212, 336–342
breaking and joining 259, 266
chamfering and filleting 271
color settings 185
complex entities 107
copying or duplicating 242
defined 550
deleting 242
displaying information about 228
editing in viewports 368
elevation and thickness 399
embedding into other applications 464
grips 238–240
linetypes 187
lineweights 188
measuring and marking off intervals 220
moving and rotating 248–251, 425
on deleted layers 175
polylines 264
print styles 189
printing 359
properties 240
resizing 251–258
selecting 182, 234, 302, 303
simple entities 113
text as 279
viewing in 3D drawings 396–399

Entity Data defined 550
Entity Properties dialog box

changing entity properties 240
editing attribute definitions 344
elevation and thickness settings 401
overriding layer color 186
overriding layer linetype 187
overriding layer lineweight 188
overriding layer print style 189

entity selection methods 234–237
entity snap

See also entity snap tools
angle and base point 69
aperture 74
command modifiers 34
controlling separately in multiple views 146
current settings 75, 229
defined 550
definition point locations 302
finding point coordinates with 159, 227
fly-over snapping 83, 490
isometric snap and grid 71
model space from paper space 364
one-time entity snaps 34, 74
origin 69
override 550
overview 7
positioning ordinate points 309
running entity snaps 74
snap resolution defined 556
spacing 69
status bar information 29, 75
target box 74–75
turning off settings 82

entity snap tools
Apparent Intersection Snap 81
Center Snap 75, 77
Clear Entity Snaps 75, 82
Endpoint Snap 75, 76
illustrated 75
Insertion Point Snap 75, 79
Intersection Snap 75, 80
Midpoint Snap 75, 76
Nearest Snap 75
overview 74
Perpendicular Snap 75, 77
Point Snap 75, 80
Quadrant Snap 75, 79
Quick Snap 82
Tangent Snap 75, 78

entprop command
changing entity properties 240
layout viewports 371
setting elevation and thickness 401

erase command. See Delete command or tool (delete)
erasing

eraser tool 104
freehand sketches 104
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segments of polylines 112
ESNAP setting in status bar 75
Esnap. See entity snap
exiting IntelliCAD 37
expanding or compressing text 281
expblocks command

creating and saving blocks 212
inserting blocks 213
inserting drawings as blocks 213
inserting external references 214
listing blocks 210
saving blocks as separate drawings 215

experience levels
changing level 3, 32, 476
explained 3
setting for menus or commands 476, 495
setting for toolbars 502

expfonts command
See also Explore Text Styles command or tool 556
creating new text styles 199, 281
current text style 202
editing text styles 201

explayers command
copying and pasting layers to other drawings 175
creating and naming layers 180
current layer settings 44, 182
deleting layers 176
displaying list of layers 177
hiding or freezing layers 183
layer color settings 186
layer linetype settings 187
layer lineweight settings 188
layer print settings 185
layer print style settings 189
locking and unlocking layers 184

Explode command or tool (explode)
converting donut sides to arc entities 118
converting plane sides to line entities 120
converting polygon sides to line entities 111
converting polyline segments to entities 113
converting rectangle sides to line entities 108
exploding blocks 341
exploding entities into components 270

exploded hatching 131
Explore Blocks command or tool (expblocks)

creating and saving blocks 212
inserting blocks 213

inserting drawings as blocks 214
inserting external references 214
listing blocks 211
saving blocks as separate drawings 215

Explore Coordinate Systems command or tool (expucs) 
203

Explore Layers command or tool (explayers) 172
copying layers to other drawings 175
creating and naming layers 181
current layer settings 44, 182
deleting layers 176
displaying list of layers 178
hiding or freezing layers 183
layer color settings 186
layer linetype settings 187
layer lineweight settings 188
layer print settings 185
layer print style settings 189
locking and unlocking layers 184
opening IntelliCAD Explorer 172

Explore Linetypes command or tool (expltypes)
creating new linetypes 193, 194
current linetype 191
listing linetypes 190
renaming linetypes 197

Explore Text Styles command or tool (expstyles)
creating new styles 281
creating new text styles 200
current text style 202
editing text styles 201
listing text styles 199

Explore Views command or tool (expviews)
listing views 206
saving and naming views 207

expltypes command
creating new complex linetypes 194
creating new linetypes 193
current linetype 191
listing linetypes 190
loading additional linetypes 192
renaming linetypes 197

Export To File command or tool (export) 468, 470
exporting

drawings 467
profiles 488

expstyles command 198
See also Explore Text Styles command or tool
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expucs command 203
See also Explore Coordinate Systems command or 

tool
expviews command 206, 207

See also Explore Views command or tool
Extend command or tool (extend)

extending to boundaries 253, 285
extending to implied boundaries 254, 286

extending
Apparent Intersection Snap 81
dimensions 321
entities to meet boundaries 253
Intersection Snap 80

extension lines
adding dimensions by selecting origins 302, 303
adding dimensions by specifying lines 302
arrows and arrowheads 317
defined 301, 550
formatting 321
obliquing 313

extension snaps 34, 80, 81
extents

See also limits
defined 550
displaying entire drawings 145
rays and 100
scroll bar indicators 138

Extract Attributes command or tool (ddattext) 347
extracting attribute data 342, 346–347
Extruded Surface command or tool (tabsurf) 407
extruding

3-dimensional entities 402, 550
solid faces 432
surface meshes 406

F
Face command or tool (face) 403
faces 403, 442, 550
fade of images 452
feature control frames 327
fence

defined 550
extending entities with 255
illustrated 237
trimming or clipping entities with 257

Fence selection method 235
fields in extracted attribute files 346

file formats
default Save As format 476
exporting 467
importing 462
IntelliCAD and AutoCAD files 3

file paths
for external references 354
for raster images 457

file size
blocks and 336
external references and 348
linked and embedded objects and 460, 466

files
aliases 511, 513
audio 515
basing on templates 40
creating 40
damaged 42, 476
default Save As format 476
embedding into drawings 459
embedding into other applications 464, 465
exiting 37
exporting 467
external references 214, 348
extracted attribute data 342, 346
fonts 199
importing 462
inserting as blocks 338
keyboard shortcuts 510
linking drawings into other applications 465
menus 495
opening 41
passwords 86
previewing before printing 391
print style tables 379
printing drawings 393
profiles 484
raster images 449
saving 37
saving blocks as drawings 337
scripts 518
search paths 478
sending through e-mail 471
shapes 517

Fill command or tool (fill)
filled or outlined lines on entities 108, 111, 113, 118
turning fill display on or off 151
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Fillet command or tool (fillet) 274
filleting

defined 271, 550
methods 274

filling entities
displaying current settings 229
donut lines 118
hatching 127
planes 119
polygon lines 111
polyline lines 113
rectangle lines 108
turning off display to improve performance 151

finding point coordinates 159
Fit Tolerance values for splines 115
fitting

text and arrowheads on dimensions 319
viewports to screen 368

fixed
attribute values 342
coordinate systems 157

flatness tolerance symbols 327
flipping entities (creating mirror images) 246, 428
flipping printed page 373
floating toolbars and command bar 25, 31, 32, 550
floating viewports

scale factor 370
flyouts on tools 32, 501–502
font map

setting the default file 479
fonts 198

AutoCAD fonts 199
character sets 295
defined 199
font files 281
in paragraphs 279
in text styles 281
search path for files 478

footers and headers on printouts 488
forcing text to fit 283, 319
form tolerance symbols 327–328
formatting lines in dimensions 321
formatting text

dimension text 323–325
text styles 281, 282

fractional drawing units 50
frames of images 454

frames of wipeouts 122
Freehand command (freehand) 103
freehand sketches

drawing and inserting 103
erasing 104
setting as polylines or lines 104

Freeze/Thaw tool (IntelliCAD Explorer) 180, 183, 184
freezing layers 177, 180, 183, 184, 550
Full Render command or tool (fullrender) 443
full-size drawings 53

G
gaps in linetypes 193
Geometric Tolerance dialog box 329
geometric tolerances 327
geometry, overlaying reference geometry 350
global linetype scale 47
greeking text (Quick Text feature) 152
grid settings

changing settings 66
controlling separately in multiple views 146
displaying current settings 229
grid defined 550
GRID setting in status bar 67
isometric snap and grid 68, 71
rotating grid 68, 69

grips
color and size 239
editing entities with 239
moving entities with 249
resizing dimensions with 314
resizing entities with 251
scaling entities with 252–253
selecting entities with 238
stretching entities with 251
turning on or off 239

grouped entities. See blocks
grouping entities 261–263

H
hand cursor (Pan tool) 139
hand method to determine coordinates 163
handles (entity grips). See grips
hardware requirements for IntelliCAD 24
hatch boundaries 127
Hatch command or tool (hatch) 127
hatch patterns and hatching
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adding to entities 127
IntelliCAD compatibility with AutoCAD files 3
search path for files 478

headers and footers on printouts 488
height of named views 206
height of text. See text height
Help

assistance for IntelliCAD 14
displaying online Help 37
search path for files 478

hidden
attributes 342
edges on 3-dimensional polyface meshes 405
lines 442

hidden-line removal, defined 551
Hide command or tool (hide) 442
hiding

command bar 28
entities using wipeouts 121
image frames 454
layers 182, 185
lines in 3-dimensional entities 442
Model and Layout tabs 365, 480
Prompt History window 34
reference grid 67
scroll bars 481
toolbars 27
ToolTips 27
warning messages 476
wipeout frames 122
xref clipping boundaries 358

hierarchical viewing, external references 351
high quality images 454
highlight command 153
highlighting entities

edges of shaded entities 442
turning highlighting on or off 234
when selected 153

horizontal
grid spacing 66–69
text orientation 281

horizontal dimensions
creating 302
defined 551
illustrated 300

horizontal drawing method
infinite lines 101

rays 100
HSL values 59
hue 59
hyperlink command 472
hyphens 149, 366, 367

I
ICA files (IntelliCAD aliases) 513
icad print style tables 384
icad.dwt template 25, 40
icad.fnt font 281
icad.lin file 192
icad.pat library file 127
icadload.dfs files 522
ICM files (IntelliCAD menu files) 491, 495, 496
icons

audio notes 516
coordinate system 157
display options for tool icons 501
displaying embedded files as 459
large tools 501, 503

ID Coordinates command or tool (idpoint) 159
idpoint command 159
i-drop feature 474
image command 452, 456, 457
imageattach command 449
imageclip command 455
imageframe command 454
imagequality command 454
images

attaching 449
changing paths 457
clipping 455
deleting 458
modifying 452
unloading and loading 456

Images tool (Block toolbar) 210
implied boundaries

extending entities to 254
trimming or clipping entities with 256

importing
files 462
profiles 488

imprinting solids 439
improving performance

hatch pattern memory requirements 131
memory-intensive display elements 151
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included angles in arcs 93, 94, 113
indents in paragraphs 279
index colors

current entity color 45
selecting 58
selecting for layers 186

Infinite Line command or tool (infline) 101
infinite lines

defined 551
drawing 101
filleting entities 276

infline command 101
Inquiry toolbar tools

coordinates 159
distances 227
drawing status 229
listing entity info 228
time variables 231

Insert Block dialog box 214, 339–340
Insert External file Blocks tool (Block toolbar) 210, 214
Insert Object dialog box 459, 461
Insert tool (Block toolbar) 210, 214
inserting

blocks 338
drawings from a Web site 474
hatch patterns 127
hyperlinks 472
menu items 492
menu sub-items 493
objects 459, 461
raster images 449
text 278
tolerances 329

inserting dimensions
aligned 304
angular 307
baseline 305
continued 306
diameter 308
horizontal or vertical 303
in paper space 312
leaders on 311
obliqued 313
ordinate 309
radius 309

inserting drawings into other drawings. See Xref Manag-
er command or tool (xrm)

insertion command 79
Insertion Point Snap command (insertion) 79
insertion points

attachment points 279, 285
base points for drawings 229
for blocks 212, 213, 336, 339–340
for external references 214, 350
for text 278, 279, 282, 285
in attribute definitions 342, 343, 344
in extracted attribute file fields 346
snapping to 79

insertobj command 459, 461
installing IntelliCAD 24
int command modifier 34, 81
IntelliCAD Explorer

Blocks list 209–216
Coordinate Systems element 169, 202–206
copying elements to other drawings 174
deleting elements 175
Dimension Styles 216–218
Layers element 177
overview 172–174
purge tool 177
single-click editing 198
Text Styles element (text styles) 198–202
tools 83, 174
Views element 206–209

IntelliCAD Explorer command or tool (explayers) 172
intermediate experience level

changing 3, 32, 495
defines menus 32
explained 3

Internet
e-mailing drawings 471
hyperlinks for 472
opening drawings from 474
publishing drawings to 474

intersection command 80
intersection of 3-dimensional entities

defined 551
intersecting solids 424
snapping to 80, 81

Intersection Snap command (intersection) 80, 81
intervals on entities, marking off 220
invisible data. See attributes
invisible edges

of raster images 454
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on 3-dimensional faces 402, 403
on 3-dimensional polyface meshes 405

invisible layers 177, 179, 182
isometric drawings

defined 551
enabling snap and grid settings 68

isometric planes
defined 551
illustrated 71
setting current plane 68

J
Join command or tool (join) 260
joining

combining solids 423
entities 260, 266, 271
two views 148

justification
attribute text 343
dimension line text 324
text settings 286

K
keyboard shortcuts

adding or deleting 509
customizing 508

L
Last Entity In Drawing selection method 234
latitude lines

dishes 417
domes 418
spheres 416

Layer On/Off tool (IntelliCAD Explorer) 180
layers

blocks with entities from different layers 336
BYLAYER property 45–49
changing for text entities 285
colors and linetypes 45–47, 185–190
colors, linetypes, lineweights, and print styles 178
copying to other drawings 174–175
creating and naming 180, 182
current layer settings 44, 182, 229
defined 551
deleting in IntelliCAD Explorer 175
displaying layer information 228
freezing and thawing 179, 183, 184

hidden and visible 177, 178, 182, 185
in entity properties 240
Layer toolbar in IntelliCAD Explorer 179
Layers dialog box 186, 187, 188
Layers element in IntelliCAD Explorer 175, 177
locking and unlocking 178, 179, 184
overview 6–7, 177–217
print settings 185
printing and nonprinting 177, 182, 185
renaming 181
selecting entities by layer 235
status bar information 29
transparent overlays 6

layout command 366
Layout tabs

displaying 365, 480
print options 373
reordering 367

layout viewports
changing size 371
creating 368
creating dimensions in 312
defined 551
invisible borders on 369
locking 371
modifying 371
scale factor 370
selecting 371
turning on and off 370
UCS per viewport 371

layouts
command or tool (layout) 364
copying 366
creating from templates 366
defined 551
deleting 367
displaying information for entities 228
lineweights 377
maximum number 365
model space and paper space defined 363
print area and origin 374
print options 373
printing 393
renaming 367
reordering 367
saving as templates 366
scale factor 374
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viewing list of 367
Leader command or tool (dimleader) 311
leaders in dimensions

allowing text without leader 320
creating 311
defined 301, 551

leading zeros in dimensions 326
least material condition (LMC) 328
left-aligned text 283
length of lines

in freehand sketches 103
specifying before drawing 90

lengthening or shortening entities. See resizing entities
levels of entities in arrays 426
levels of precision. See accuracy
libraries

of hatch patterns 127
of linetype 190, 192

light sources 441, 442, 445
Lighting command or tool (lighting) 445
limits

See also extents
defined 551
displaying entire drawings 145
displaying limits for drawings 229
drawing limits for printing 375
setting 54, 56

limits tolerance. See tolerances
lin files (linetype libraries) 192
Line command or tool (line) 90
Linear command or tool (dimlinear) 303
linear dimensions

aligned 304
baseline 305
continued 306
creating 302
formatting dimension unit display 326
illustrated 300
rounding in 325

linear drawing units 50–51
lines

adding to arcs 90
colors in dimensions 321
converting complex entity sides to 108, 111, 113, 

120
dimensioning angles between lines 308
drawing lines 90

extending to boundaries 253
filled or outlined on complex entities 108, 111, 113
formats in dimensions 321
freehand sketches as 104
hiding in 3D entities 442–443
in hatching 127, 162
in polylines 111
infinite lines 101
joining 260, 266
measuring and marking off intervals 220
moving with grips 249
of text See text entities
profile tolerance symbols 327
width 109

linetype scale
changing global 47
setting current 46

linetypes
changing in entity properties 240
compatibility with AutoCAD files 3
copying to other drawings 174
creating new linetypes 193
current settings 46, 229
default linetypes 180
defined 551
deleting in IntelliCAD Explorer 175
displaying information about entities 228
drawing scale factor and 53
global scale settings 47
layer settings 177, 187
library files 192
linetype scale settings 47
loading additional linetypes 192
overriding for entities 187, 191
overview 190–191
print styles 385
status bar information 29

Linetypes element (IntelliCAD Explorer) 192, 193
lineweights

current settings 48
defined 551
displaying 154
layer settings 188
overriding for entities 188
print settings 377
print styles 385
scale factor 154
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set default 154
linking

See also ActiveX; embedding
defined 551
drawings into other applications 465
editing linked objects 461
external reference files 348–358
objects into drawings 460–461
raster images 449

LISP programs
calculating coordinates in rectangular meshes 404
defined 552
IntelliCAD compatibility 4
running programs 521–523

List Entity Info command or tool (list) 228
List Processing Language. See LISP Programs
listening to audio notes 517
listing

blocks and external references 210
external references 351
fonts and text styles 198, 216, 282
hatch patterns 128, 129
layers 178
linetypes 190
named views 206
print style tables 387
user coordinate systems 203

LMC (least material condition) 328
Load Application Files dialog box 521
load command 518, 522
Load LISP or SDS Application command (appload) 521, 

523
loading

additional linetypes 192
alias files 514
code pages 296
color books 66
default drawing environment settings 486
keyboard shortcut files 511
LISP programs 521
menu files 481, 496
profiles 486
raster images 456

location tolerance symbols 327
locations in drawings

absolute and relative coordinates 160, 164
coordinate systems 156

display order 250
displaying entity coordinates 228
finding point coordinates 159
moving and rotating entities 249–251
obtaining precise point locations 227

Lock/Unlock command tool (IntelliCAD Explorer) 184
locking layers 178, 179, 184, 552
locking layout viewports 371
log file

setting the default file 479
luminance 59

M
M or N direction

defined 552
in rectangular meshes 404
in surface meshes 406, 407, 409

macros 525, 552
See also scripts

magnification of drawings
See also scale factors
magnifying views 5
methods 142
zooming and panning in 3-dimensional drawings 

398
magnifying glass cursor 142
major axes 552
Make Oblique command or tool (dimedit) 313
Make Snapshot command or tool (msnapshot) 448
manual drafting compared to IntelliCAD 5
MAPI protocol 471
margins on drawings. See extents; limits
marker blips. See blips
marker blocks 220
marking off interval on entities 220
master drawings from component drawings 348
material condition symbols 328
materials 445
Materials command or tool (materials) 445
maximum material condition (MMC) 328
MDI (multiple-document interface) 3, 149, 552
Measure command or tool (measure) 220, 221
measurement lines. See dimensions and dimension styles
measuring and marking entities 220
memory requirements

for IntelliCAD 24
hatch pattern requirements 131
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memory-intensive display elements 151
menu files

customizing menus 491–498
IntelliCAD compatibility with AutoCAD files 3
loading 496
saving 495

Menu Item command 493
Menu Sub-Item command 493
menus

adding commands 493
automatically loading 481
changing experience levels 3, 32, 476, 495
creating new menus 493
customizing 491
deleting commands from 494
menu bar illustrated 27
renaming commands 494
search path for files 478
starting commands with 32

Mesh command or tool (mesh) 404
mesh surfaces. See surface meshes
Messaging Application Program Interface (MAPI) 471
middle-aligned text 283
midpoint of two points 34
Midpoint Snap command (midpoint) 76
midpoints of entities 74, 76
minor axes 552
Mirror command or tool (mirror) 246
mirror3D command 428
mirroring entities 246, 552
mistakes, correcting 36
MMC (maximum material condition) 328
MNS files (AutoCAD menu files) 491, 496, 504
MNU files (AutoCAD menu files) 491, 496, 504
model space

See also paper space
defined 552
displaying information for entities 228
overview 8, 362
print options 373
snap from paper space 364
status bar information 29
switching to 364, 365
switching to paper space 364
viewport scale factor 370

Model tab
cannot delete 367

displaying 365, 480
displaying information for entities 228
model space and paper space defined 362
print options 373
printing from 360, 393
viewports illustrated 362

Modify toolbar 27
modifying. See editing
monochrome print style tables 384
mouse shortcuts 35
mouse wheel direction 481
Move command or tool (move) 248
moving

around in drawings 138
external reference files 354
profiles 488
prompt boxes 30
raster image files 456
toolbars and command bar 25

moving entities
dimension text 314
move command 248–249
solid faces 433
to other drawings 149
to other layers before layer deletion 176
vertices in polylines 268
with grips 239

msnapshot command 448
mtext command 279, 294
MText dialog box 279
mtexted command 293
mtp command modifier 34
multiple commands

modifying commands 34
nesting several commands 33
repeating commands 33
using while commands are active 32

multiple copies
of entities 243
of external references 350
of layouts 366

multiple drawings 3, 149
multiple views

See views and viewports
multiple-document interface (MDI) 3, 149, 552
mview command 370
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N
N direction. See M or N direction
N symbol in extracted attribute file fields 346
named print style tables

changing a drawing’s table type 387
comparing with color-dependent tables 380
converting to 388
copying, renaming, deleting 387
creating 384
default settings 488
defined 379
modifying 385
setting current print style 49

named text styles 281
See also text styles

named views 206, 552
See also views and viewports

Nearest Snap command (nearest) 76
negative coordinate locations 156
nested

blocks 336, 552
commands 33
external reference files 350

nested blocks
See also blocks

New command (newwiz) 40
new drawings 40
new features 14
New Item tool 83, 169, 174
newwiz command 40
node command 80
nonassociative hatches 552
none command 82

See also Clear Entity Snaps command or tool
non-ISO linetypes 385
numbers, rounding 325–327
numeric fields in extracted attribute file fields 346

O
Object command (insertobj) 459, 461
object linking and embedding. See Active X
oblique angle

in dimension lines 313
in text styles 199, 201, 281, 285

offset copies of entities. See parallel entities
offsetting

baseline dimensions 305

solid faces 435
text on dimension lines 324

OLE. See Active X
On/Off tool (IntelliCAD Explorer) 180, 183
online Help 14, 37
onweb command 474
oops command 337
Open command or tool (open) 41
Open Drawing dialog box 42
opening

color books 62, 65
damaged files 42
drawings from a Web site 474
drawings using Recover 476
drawings with prompt for code page 296
existing drawings 41
external references 352
files in other formats 462
files sent through e-mail 471
IntelliCAD 25
polylines 264
profile files 488
templates for printed layouts 366

operating system code page 295
Options command (config) 477, 479, 481, 483, 489, 490
Options dialog box 478
options, setting or changing 476
Ordinate command or tool (dimordinate) 310
ordinate dimensions

creating 310
defined 553
illustrated 300

organizing information
color books 62, 65
for printing 359
on layers 6, 177
with blocks 336

orientation
of page 373
of text 198
of view 146, 147
printing upside down 373
tolerance symbols 327–333

origin points
adding dimensions by selecting origins 302, 303
compared to viewpoints in 3-dimensional drawings 

396–399
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defined 553
displaying distances in ordinate dimensions 310
of coordinate systems 168, 203
of extension lines 302
of print areas 377
of snap and grid 69
specifying locations by 161

ORTHO setting in status bar 72
orthogonal mode

defined 553
displaying current settings 229
overview 7
status bar information 29
turning on 68, 72

orthogonal projection 553
osnap command. See entity snap
outlined elements in IntelliCAD Explorer 173
outlining

donut lines 118
image frames 454
planes 120
polygon lines 111
polyline lines 113
rectangle lines 108
turning off fill display to improve performance 152
wire-frame models 399

output files of extracted attribute data 347
Outside Circle selection method 235, 553
Outside Polygon selection method 235, 553
Outside Window selection method 234, 553
overlaying external references 350
overlays. See layers
overscoring text 285

P
Pan command or tool (pan) 139
panning

See also zooming in or out
defined 553
in 3-dimensional drawings 398
in viewports 364
methods 139
viewing drawings by 5

paper size 373
paper space

See also model space
copying or resizing viewports. See model space

defined 553
dimensions 312
displaying information for entities 228
editing method 368
layout viewports 368
overview 8, 362
print options 373
printing from 361
scale factor 370
snap from 364
status bar information 29
switching to 364

paragraph text
aligning 284
creating 279

parallel
dimensions. See baseline dimensions
drawing method, infinite lines and rays 100

Parallel command or tool (parallel) 245
parallel entities

defined 553
filleting parallel lines 276
parallel copies of entities 244

parallelism tolerance symbols 327
partial coordinates 166
passwords for drawings 87
Paste command or tool

IntelliCAD Explorer 174
pasteclip command 244

Paste command or tool (IntelliCAD Explorer) 83, 174
Paste Special command and dialog box 461
pasting

embedded objects into drawings 459
entities into other drawings 149, 244
layers into other drawings 175
linked objects into drawings 461
settings into other drawings 174
text 280
text in Prompt History window 34

patch meshes 409
paths for files

color books 66
external references 354
raster images 457
search paths 478

patterned
lines. See linetypes
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PCP files 390
PDF files 468
pen assignments 379–389
pen numbers 385
pencil tool 103
percent signs 285
performance issues. See improving performance
perimeters 553

calculating areas 223
perpendicular distances from origin points 309
perpendicular entities

defined 553
infinite lines 101
rays 100
snapping to 74, 77

Perpendicular Snap command (perpendicular) 77
perpendicularity tolerance symbols 327
pface command 405
PGP files (AutoCAD aliases) 513
photo-realistic 441, 443
plan view

coordinate system icons 157
defined 553
displaying 3-dimensional drawings 398

Plan View command or tool (plan) 398
planar entities

converting to 3D 400
defined 553

planar tops for pyramids 414
Plane command or tool (plane) 119
planes

3-dimensional faces 403
converting sides to lines 120
defined 553
drawing 119
isometric planes 71

playing
audio notes 517
scripts 518–521

pline command. See Polyline command or tool (polyline) 
554

plotters
printer configuration files 390
printing drawings 393
selecting 374

plotting. See printing drawings
plus or minus signs 285

pmspace command 364
point command 98
point filters (coordinate filters) 166, 547
Point Selection method 235
Point Snap command (node) 80
Point tool 98
points

See also base points; displacement points; endpoints 
of entities; insertion points; midpoints of entities; 
origin points; start points of entities

changing point entity appearance 98
defined 553, 554
drawing point entities 98
finding point coordinates 159
interval marker point entities 220
parallel copies passing through points 245
point locations in coordinate systems 156
snapping to point entities 80

polar
arrays of entities 247, 426–427, 554
coordinates 159, 162
See also coordinate systems

POLAR setting in status bar 73
polar tracking, turning on 73
Polyface Mesh command or tool (pface) 405
polyface meshes 405
Polygon command (polygon) 110
polygon meshes

edge-defined Coons surface patch meshes 409
extruded surface meshes 406
revolved surface meshes 407
ruled surface meshes 405

Polygon, Center-Side tool 111
Polygon, Center-Vertex tool 110
polygons

See also polygon meshes 554
calculating area and perimeter 223
clipped images 455
converting sides to lines 111
defined 554
drawing 110
editing 264
using as selection windows 236

Polyline command or tool (polyline) 111
polylines

chamfering 273
converting entities to polylines 264
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converting segments to entities 113
curving and decurving 265
defined 554
donuts 117
drawing 111
editing 264
editing vertices 268
extending to boundaries 253
filleting entities 274
freehand sketches as 103
joining 266
measuring and marking off intervals 220
opening and closing 112, 264
polygons 110
rectangles 108
tapering 111, 255
width 111, 267

position tolerance symbols 327
positioning

text on dimension lines 323
positioning dimensions

aligned dimensions 304
angular dimensions 307
baseline dimensions 305
diameter dimensions 308
dimension text 314
horizontal or vertical dimensions 303
leaders and annotations 311
radius dimensions 309
text and arrowhead positioning 319

positioning entities 248
See also insertion points
blocks 338
moving entities 239

positive coordinate locations 156
ppreview command 391
precision. See accuracy
preferences command. See config command
prefixes on dimension text 324
presentations 448
Preset Viewpoints

command or tool (setvpoint) 396
dialog box 397

previewing
block images 210
files before opening 42, 86
print jobs 391

Previous Selection selection method 234
print area 375, 377
print command 393
Print command or tool (print) 393
Print dialog box 376, 378
Print Preview command or tool (ppreview) 391
Print Style Table Editor dialog box 386
print style tables

assigning 383
changing drawing’s type 387
comparing types 380
copying, renaming, deleting 387
creating 384
default settings 488
explained 379
getting started with 381
modifying 385
search paths 478
turning off 389

print styles
changing in entity properties 240
default settings 488
explained 379
layer settings 189
modifying 385
setting current 49

printers
printer configuration files 390
printing drawings 393
selecting 374

printing drawings
default print style settings 488
drawing limits 375
getting started 360
headers and footers 488
layer control 185
layout viewports 368
lineweights 377
paper size and orientation 373
paper space 8
plotter drivers 374
previewing before printing 391
print styles 379–389
printing and nonprinting layers 177, 182, 185
printing drawings 393
rendered drawings 446
saving settings 390
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scale factors 53, 374
selecting printer 374
setting the scale 374
upside down 373

profile tolerance symbols 327
profiles 484–488

copying 487
creating 484
deleting 487
explained 484
exporting 488
importing 488
loading 486
renaming 487

profiles for revolved surface meshes 407–409
programming IntelliCAD 521–525
projected tolerances 328–333
projection lines. See extension lines
prompt boxes

choosing command options 30
defined 554
turning off 30, 481

Prompt History window
defined 554
displaying drawing information 228
navigating with arrow keys 480
tracking history 34, 480

prompts in status bar 342
Properties command or tool (entprop)

changing entity properties 240, 370
changing viewport properties 371
IntelliCAD Explorer 83, 174, 186, 187, 188, 201
setting elevation and thickness 402

properties, selection by 237
publishing drawings to the Internet 474
pull-down menus 492
purge tool 177
Pyramid command or tool (pyramid) 413, 414
pyramids

drawing 413
editing 264

Q
qtext command 152
quadrant points of entities 79, 554
Quadrant Snap command (quadrant) 79
quadrilateral filled planes 119

quality of images 454
quick command 82
Quick Snap command (quick) 82
Quick Text feature 152
quitting IntelliCAD 37

R
radial dimensions 300, 301
radians 554
radii of entities

arc 93
arcs 113
circles 91
cylinders 415
defined 554
dishes 417
domes 418
filleting entities 271, 274
spheres 416
tori 419, 421

Radius command or tool (dimradius) 309
radius dimensions 309, 554
Radius-Tangent-Tangent circle method 91
RAM requirements. See memory requirements
raster images

attaching 449
changing paths 457
clipping 455
deleting 458
modifying 452
unloading and loading 456

Ray command or tool (ray) 100
ray tracing 443

defined 554
rays

defined 554
drawing 100
extending to boundaries 253
filleting 276

read-only files 42
Real-Time Pan command (rtpan) 140
Real-Time Sphere command (rtrot) 141
Real-Time Zoom command (rtzoom) 143
Record Script command or tool (recscript) 519, 520
recording audio notes 515
recording scripts 35, 518
Recover command (recover) 43
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Rectangle command or tool (rectangle) 108
rectangles

converting sides to lines 108
defined 554
drawing 108
editing 264
squares 108

rectangular
arrays of entities 247, 426, 554
boxes 410
clipped images 455
filled planes 119

Redo tool 36
redoing actions 36, 554

See also undoing actions
redrawing screen 138, 554

See also regenerating drawings 138
reducing or enlarging view of drawings 142
reference

geometry 350
grid. See grid settings

Reference Grid tool 67
reflections 443
refreshing screen 138
regardless of feature size (RFS) condition 328
Regen command or tool (regen) 138, 152
regenall command 138
regenerating drawings

See also redrawing screen 555
after editing text styles 200
after enabling Quick Text 152
compared to redrawing 138
defined 555

Region command or tool (region) 420
regions 420

slicing and sectioning 431
relative coordinates

See also absolute coordinates; user coordinate sys-
tems (UCS); World Coordinate System (WCS) 
555

3-dimensional coordinate systems 163
defined 555
point filters 166
polar coordinates 162
spherical and cylindrical coordinates 164

relinking external reference files 354
reloading

external reference drawings 214, 349, 353
raster images 456

removing. See deleting
Rename Command (IntelliCAD Explorer) 181
renaming

attribute definitions 344
blocks 212
commands in menus 491, 494
dimension styles 317
layers 181
layouts 367
linetypes 197
print style tables 387
profiles 487
toolbars 501

Render command or tool (render) 443
rendering 3-dimensional entities 441
reordering

entities 250
Layout tabs 367

repeating commands 33
replacing dimension text with new text 315
Reposition Dimension Text command or tool (dimedit) 

314
resetting timer 230
resizing

layout viewports 371
lineweights during printing 377
toolbars 27
viewports 371

resizing entities
arrowheads 318
changing length 257
extending to boundaries 253
scaling 252
stretching 251–252
trimming or clipping 256

Restore Text Position command or tool (dimedit) 315
restoring

aliases to unchanged condition 512
changed blocks to originals 341
default drawing environment settings 486
deleted entities 242
dimension text to home position 315
menus to unchanged condition 491
named views 208–209
previous print settings 378
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previous user coordinate system 170
previous view of drawing 144, 149

restricting. See constraining drawing
reusing information 5

copying settings into other drawings 174
drawing environment settings 484
IntelliCAD compared to manual drafting 8
layouts 366
previous print settings 378
printer configuration files 389
reusing entire blocks and drawings 10

reversing
mouse wheel direction 481
text 201

Revolved Surface command or tool (revsurf) 408
revolved surface meshes 407, 555
revolving solids 422
RFS (regardless of feature size condition) 328
RGB values 59
right-aligned text 284
right-click menus 27
right-click shortcuts 35
right-hand rule to determine coordinates 163, 555
Rotate command or tool (rotate) 249
Rotate Dimension Text command or tool (dimedit) 314
rotating

3-dimensional entities 425
angles in attribute text 343
angles in elliptical arc drawing methods 97
blocks 212, 213, 338–340
coordinate systems 168
creating 3D arrays 427
dimension text 313–314
dimensions. See aligned dimensions
entities 249, 425, 555
external references 214
grid 69
images 452
paragraph text 279
printed page 373
solid faces 434
text 278, 282, 285
viewpoints in 3-dimensional drawings 397
views 141
visualizing rotation direction 163

rotation points
defined 555

specifying 249
rounding corners on entities. See filleting
rounding numbers in dimension display 325
roundness tolerance symbols 327
rows and columns of entities. See rectangular arrays of 

entities
rtrot command 141
rubber-band lines 555
Ruled Surface command or tool (rulesurf) 406
ruled surface meshes 406, 555
running

entity snaps 74, 555
IntelliCAD 25
VBA programs 525

runout tolerance symbols 327

S
SAT files

importing 462
saturation 59
Save As command or tool (saveas) 86
Save Block dialog box 215
Save Block to Disk

command or tool (wblock) 337
tool (Block toolbar) 210

Save command or tool (save) 37, 85
Save/Restore View command or tool (view) 207
saving

attributes 342
blocks 212
blocks as drawing files 337
blocks as separate drawing files 215
color books 62, 65
default Save As format 476
drawings 37
in other formats 467
layouts as templates 366
named views 207–208
new complex linetypes 194–197
new linetypes 193–197
passwords with drawings 87
print settings 390
profile settings 484
sketches as part of drawings 103
snapshots 448
tracking last save time 230
user coordinate system 157, 168, 169
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viewport configuration 149
Scale command or tool (scale) 252
scale factor

lineweights 154
scale factors

blocks 212, 213, 338
drawing to scale 5–6
drawing units 50
external references 214
floating viewports 370
hatching 127
in dimensions 326
linetype scale 47
magnifying view by precise scale factor 144
printing lineweights 377
printing to scale 374
scaling entities 252
understanding drawing scale factors 53
viewports 370

scaling. See resizing entities; scale factors
scientific drawing units 51
screen display

customizing 480
magnifying 5
redrawing and regenerating 138
turning off memory-intensive display elements 151

screenshots (snapshots) 448
Script Recorder 35
scripts defined 555
scroll bars 138

displaying 481
SDF files (Space Delineated Format) 346
SDS programs 4, 36, 555
search paths for files 354, 478
sectioning solids 431
security for drawings 87
segmented dimension lines. See continued dimensions
segments

converting polyline segments into curves 265
defined 555
editing in polylines 111
measuring and marking off intervals on entities 220

Select All Entities selection method 234
Select Color command 186
Select File to Attach dialog box 214
Select Font dialog box 281
Select Layer by Entity command or tool (setlayer) 182

Select Toolbars dialog box 27–28
selecting entities

adding or removing entities from sets 238
by properties 237
highlighting 153, 234
matching specific properties 235
selection methods 234
to copy or duplicate 243
to delete 242
with audio notes 516

selection
sets 234, 555
windows 234

semicolon 518
separating solids 439
setdim command 216

arrows and arrowheads 318, 319, 323
baseline dimension offset 305
blocks and external references 172
creating dimension styles 316
deleting dimension styles 317
dimension line colors 321
formatting dimension text 323
renaming dimension styles 317
rounding off numbers 325
text positioning 320, 323

settings
arrows and arrowheads 318
blips display 153
blocks and external references 210, 211, 213, 215
colors 185
coordinate systems 172, 202
default drawing environment 486
default print style table options 488
dimension styles 316
distances and angles display 158
drawing environment 484
elevation and thickness 399–403
entity snap 74
fills 151
grip display options 239
highlighting 234
layers 44, 174–189
linetypes 174
lineweights 154, 188
mesh surfaces 405
Quick Text display 152
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setting layers by selecting entities 182
shaded surfaces 442
text styles 172, 198, 281
user coordinate systems 168
views 172, 206, 207

settings command
dimension styles 325
drawing limits 56
drawing units 51
elevation and thickness 400–402
entity snap target box 74
freehand sketches 104
grid settings 67, 69
highlighting 234
isometric snap and grid 71
linetype scale 47
linetypes 46
lineweights 48
orthogonal mode 72, 73
point entity display 98
print styles 49
shaded surfaces 442
snap angles 69
snap spacing 69
text height 54

Settings pane in IntelliCAD Explorer 172
setucs command 169, 170
setvpoint command 396
Shade command or tool (shade) 442
shaded image 442
shading surfaces of 3-dimensional entities 442, 555
shadows 443, 445
shape command 518
shelling solids 440
shortcuts

adding access keys to commands 494
customizing keyboard shortcuts 508
displaying shortcut menus 27
entity snaps menu 75
using the mouse 35

shortening or lengthening entities. See resizing entities
SHP files (fonts) 199
SHX files (fonts) 199
sides of entities

editing polygons 111
editing polylines 113
editing rectangles 108

maximum number for polygons 110
specifying to draw polygons 111

simple entities 89
See also types of entities (lines; rays; arcs; and so on)

simulating
3-dimensional drawings 71
paper output on screen. See paper space

size
of files. See file size
of grips 239
of printed drawings 54, 373
of text. See text height

size of entities
displaying size information 228
point entities 98
resizing. See resizing entities

sketch command. See freehand command 103
sketching freehand entities 103
slanted

dimensions. See aligned dimensions
text. See obliquing angle

SLD files (snapshots) 448
slicing solids 431
slide

files 448
shows 448

small tool icons 501, 503–504
snap

angle 555
grids 555
model space from paper space 364
resolution 556
settings. See entity snap
tool 69

SNAP setting in status bar 69
snapshots

defined 556
saving 448

solid
boxes 410
composites 423
cones 412
cylinders 415
dishes 417
domes 418
extruding solids 421
filled planes 119
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fills 151
pyramids 413
regions 420
revolving solids 422
spheres 416
tetrahedrons 413
tori 419
wedges 411

Solutions Development System (SDS) 4, 36, 522, 555
sound clips 514
Space Delimited Format files 346
spacers

in menus 491
in toolbars 500

spacing
for entity snap 69
in reference grid 67

special characters 285
speed of processing. See improving performance
Spelling command or tool (spell) 289
spelling of text 289
Sphere command or tool (sphere) 416
spheres, drawing 416
spherical coordinates 164, 556

See also coordinates
Spline command or tool (spline) 114
splines

closing entities 116
drawing 114
fit tolerance 115

splitting entities 259
spotlights 443
squares 109
stacking entities in arrays 426
standard

text style 198, 281
Standard toolbar 27
start arrows 317
start points of entities

line entities 90
methods of drawing arcs 93, 112

starting
direction of arcs 93
IntelliCAD 25
new drawings with templates 25, 40
points for moving entities. See base points
script recording 518

starting commands
from command bar 33
from menus 32
from toolbars 32

status bar
assistance with IntelliCAD functions 13
displaying cursor position 158
illustrated 27, 29
prompts for commands 491
viewing model space and paper space 364

status command 229
status of drawings, displaying 43, 229
STB files

assigning 383
changing a drawing’s table type 387
compared with CTB files 380
converting to 388
creating 384
default settings 488
defined 379
modifying 385

Stop Recording command or tool (stopscript) 519
straightening curves in polylines 265
straightness tolerance symbols 327
Stretch command or tool (stretch) 251
stretching

entities 239, 251
text 284

style command (IntelliCAD Explorer) 200
styles

dimension styles 316
print styles 379
text styles 281

stylesmanager command
copying print style tables 387
deleting print style tables 387
modifying print style tables 385
new print style tables 384
renaming print style tables 387

Sub-items in menus 491
subtended angles 307
Subtract From Set selection method 234
subtracting areas of combined entities 225–227
subtracting solids 423
suffixes on dimension text 324
surface

material properties 443
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of revolution 556
profile tolerance symbols 327
shading 442

surface meshes
density 406, 407, 408, 409
edge-defined Coons surface patch meshes 409
extruded mesh surfaces 406
polyface meshes 405
rectangular meshes 404
revolved surface meshes 407
ruled surface meshes 405

surface models
See also wire-frame models
defined 399
removing lines and applying shading 442–443

SVG files
defined 556
exporting 467

switching between model space and paper space 364
symbols

datum reference letters 329
material condition symbols 328, 329
special characters in text 285
symmetry tolerance 327
tolerance 327, 329

SYSCODEPAGE 295
system requirements for IntelliCAD 24
system variables 556

T
tables, mapping print settings 379
tabs in paragraphs 279
tabsurf command 407
tabulated surfaces 556
Tangent Arc tool 95
tangent command 78
tangent entities 556

drawing arcs tangent to an arc or line 95
drawing circles tangent to entities 92
drawing donuts tangent to entities 118
snapping to 74, 78

tangent points on splines 114
Tangent Snap command (tangent) 78
tapered polylines 112, 269

after joining 266
changing width 267
results of extending 255

tapering solid faces 435
target box for entity snaps 74
tbconfig command 501
templates

basing new drawings on 40
default icad.dwt template 25
defined 556
for extracted attribute files 346–347
for printed layouts 366
importing 462
opening new drawings with 25
saving from layouts 366
setting default template 479

temporary files search path 478
terrain models 404
tetrahedrons 413
text annotations 311
Text command or tool (dtext)

adding text entities 278
setting text style 282
specifying alignment 283

text editor 293
text entities

See also text height; text in attributes; text on dimen-
sion lines

adding text to drawings 278
alignment 283
alternate text editor 293
attachment points 282, 285
backward or upside-down text 281
changing properties 286
character sets 295
code page 295
color 285
compressing or expanding 284
control codes and special characters 285
editing text 285
fitting between two points 284
insertion points 79, 278, 282
layer settings 285
obliquing 281
paragraph text 279
Quick Text feature 152
rotation angle 278
short lines of text 278
spelling 289
text styles 281
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turning off display to improve performance 153
width 281

text files
script files 518
templates for extracted attribute files 346

text height
calculating for different scale factors 53
changing height 201
drawing scale factor and 53
in dimension styles 324
printed drawings and 53
short lines of text 278
specifying 54, 282, 285
text styles 281

text in attributes 343, 344
text on dimension lines

colors 324
formatting and positioning 319–321, 323
illustrated 300
moving text 314
prefixes or suffixes 324
replacing with new text 315
restoring to home position 315
rotating 314
specifying text styles in dimension styles 324

text size. See text height
text styles

applying 282
attribute text 343
changing styles 285
compatibility with AutoCAD files 3
copying to other drawings 174
creating new styles 199, 281
current text style 202
deleting in IntelliCAD Explorer 175
editing attribute definitions 344
editing styles 199
listing available styles 282
overview 198
vertical, upside-down, or backward text 199

Text Styles dialog box 281
Text Styles element in IntelliCAD Explorer 198
text-based data. See attributes
thawing layers 179, 183, 184, 556
Thickness command or tool (thickness) 399
thickness in 3-dimensional entities 556

See also elevation in 3-dimensional entities

changing in entity properties 240
default thickness 399

three-dimensional drawings. See 3-dimensional drawings
three-dimensional entities. See 3-dimensional entities
three-point

arc method 93
through points 245, 556
thumbnails of blocks 210
thumbnails of drawings 41
tick marks on dimension lines 317
tiers of dimensions. See baseline dimensions
Tile Horizontally command 146
Tile Vertically command 146
tiling windows 146
tilting. See obliquing angle
time stamps on printouts 488
Time Variables command or tool (time) 231
timers

for AutoSave 476
tracking drawing sessions 230

Tip of the Day 25
title blocks

adding in paper space 362
as available in each view 8

toggling features on or off. See turning features on or off
Tolerance command or tool (tolerance) 329
tolerances

adding geometric tolerances to drawings 327
composite tolerances 328
datum reference letters 329–330
defined 556
in Geometric Tolerances dialog box 329
limits tolerance 556
material condition symbols 328–333
projected tolerances 328
symbols, defined 327
tolerance commands 556
variance tolerance 556

toolbars and tools
compared to manual drafting 6
creating new toolbars 499
customizing tools and toolbars 25, 499
defined 557
displaying and hiding toolbars 27
docking or floating toolbars 27
entity snaps tools 75
experience levels for toolbars 476, 502
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flyouts 32, 501
illustrated 27
IntelliCAD Explorer tools 83, 174
large tool icons 501, 503
Layer toolbar 179
naming new toolbars 501
size and color of tools 27
spacing in toolbars 500
starting commands from 32
toolbars command (tbconfig) 501
Toolbars tab (Custom dialog box) 498
triangles on tools 501

ToolTips
adding to tools 499
assistance with IntelliCAD tools 13
turning on or off 27, 501

top-aligned text 283
tori 419, 421, 557
total runout tolerance symbols 327
tracking

command history 34, 480
last files used 42
number of entities 209

trailing zeros in dimensions 326
transferring drawings to other people 355
transparent

commands 557
images 452
overlays. See layers

triangles on tools 501
triangular filled planes 119
Trim command or tool (trim) 256
trimming

external references 356
printed drawings 375

trimming entities
chamfering 272
filleting 274

troubleshooting
drawing disappears from paper space 364
lineweight display 154
profile settings not saved 485
setting layout viewport borders as invisible 369
text display 295
wipeout display 121

true colors
current entity color 45

selecting 59
selecting for layers 186

turning features on or off
automatically loading menus 481
AutoSave 476
blips 153
continuous inertial motion 481
entity snaps 82
extension line options 322
grips 239
highlighting 153, 234
image frames 454
orthogonal setting 72
polar tracking setting 73
print style tables 389
prompt boxes 30, 481
reference grid 67
snap settings 69
solid fill display 151
text display 152
Tip of the Day 25
ToolTips 501
wipeout frames 122
xref clipping boundaries 358

two-dimensional
drawings. See 2-dimensional drawings 159
entities. See 2-dimensional entities 159

two-point circle method 91
typing commands

aliases 511
entity snap commands 74
in command bar 33
to load custom programs 523

U
UCS. See user coordinate systems (UCS) 168
undelete command (undelete) 242, 337
underscore characters 149, 366, 367
underscoring text 285
undoing actions 36

See also redoing actions
Unicode characters 295
uniform width for polylines 267
units. See drawing units
unloading

custom programs 522
external references 352
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print style tables 389
raster images 456

unlocking layers 184, 557
updating

all instances of blocks 336, 340
attribute values 345
block definitions 340
drawings inserted as blocks 214
external references 215, 348, 353
file paths for external references 354
file paths for raster images 457

upside-down printing 373
upside-down text 201, 281, 286
user coordinate systems (UCS)

See also coordinates, World Coordinate System 
(WCS)

command (IntelliCAD Explorer) 169, 204
command or tool (setucs) 168
current UCS 205
defined 157, 557
defining per layout viewport 371
defining systems 168, 204
dialog box 168
icon 26
listing 202
plan views of drawings 398
preset user coordinate systems 169

user levels. See experience levels

V
validated attribute values 343
values

editing attribute values 345
extracting attribute values 346
variable attribute values 342

variables
dimension variables 316
system variables 556

variance tolerance
See also tolerances

variations in geometry. See tolerances
vba command 525
VBA macros command (vbarun) 525
VBA programs 4, 557
vbarun command 525
vectors 557
vertical

drawing method (infinite lines) 101
drawing method (rays) 100
grid spacing 67
orientation for text 281
text orientation 201

vertical dimensions
creating 303–304
defined 557
illustrated 300

vertices
chamfering 273
defined 557
drawing polygons 110
editing polyline vertices 268
filleting 275–276

View command (IntelliCAD Explorer) 207
View Snapshot

command or tool (vsnapshot) 449
dialog box 449
snapshots 449

viewing
See also views and viewports; windows 557
3-dimensional drawings 396
command bar 28
drawing thumbnails 41
dynamic view controls 397
external references 351
hiding lines in 3-dimensional entities 442
layout viewports 370
list of layouts 367
locked layers 184
Model and Layout tabs 480
panning drawings 139
plan view 398
preset viewpoints 396
print jobs before printing 391
print style tables 385
Prompt History window 34
redrawing screen 138
regenerating drawings 138
rotating the view 141
scroll bars 481
shading on entities 442
text 295
thawed layers 183, 184
ToolTips 27
turning layers on 183
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viewpoints in 3-dimensional drawings 396
zooming 142

viewpoints in 3-dimensional drawings 557
views and viewports

See also model space; paper space 557
arranging windows 146
changing properties 208, 371
copying views to other drawings 83, 174
creating layout viewports 368
deleting views in IntelliCAD Explorer 175
displaying entire drawings 145
height and width of views 206
invisible borders on layout viewports 369
joining two views 148
layout viewports overview 368
listing named views 206–207
moving around in viewports 138
multiple views 146
orientation of viewports 147
restoring named views 208
restoring previous view of drawing 144
saving view configuration 149, 207
scale factor 370
switching between model and paper space 364
turning on and off 370
viewport configuration defined 558
viewports defined 362, 557
views defined 557
zooming and panning 368

Views list in IntelliCAD Explorer 206
visibility of layers 177, 179, 182
visible

attributes 342
grid. See grid settings

Visual Basic Editor command (vba) 525
Visual Basic for Applications 4
Visual Basic for Applications (VBA) 4, 525, 557
visualizing coordinate systems 163

W
warnings when opening drawings 476
WAV files 514
wblock command 337
WCS. See Word Coordinate System (WCS)
Web sites

accessing IntelliCAD 474
hyperlinks for 472

opening files from 474
publishing drawings for 474

Wedge command or tool (wedge) 411
wedges 411, 558
what’s new 14
width

after creating regions 420
after exploding 270
after joining 266
changing the polyline width 267
lineweight settings 48
of donuts 117
of fields in extracted attribute files 346
of lines 109
of polylines 111, 269
printing lineweights 377

width of text
in text styles 199, 201, 281
specifying 285

Window Circle selection method 235
Window Polygon selection method 235, 236
Window-Inside selection method 234, 235
Windows

metafiles. See WMF files
windows

See also views and viewports 557
arranging 146
cascading 146
displaying entire drawings 145
joining two views 148
listing and saving named views 206
main IntelliCAD window 27
model space and paper space defined 362
moving around in 138
multiple views 146
opening new windows 146
saving arrangements 149
selection windows 234
tiling 146
unique numbers 146

Windows Clipboard
See Clipboard
embedding objects into drawings 458
embedding objects into other applications 464, 472
linking drawings into other applications 466

Wipeout command or tool (wipeout) 121
wipeouts 121–122
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wire-frame models
See also surface models
defined 399, 558
removing lines and applying shading 442

witness lines. See extension lines
WMF files

defined 558
exporting IntelliCAD files as 467
snapshots 448

World Coordinate System (WCS)
defined 558
overview 157
plan views of drawings 398
selecting 170
working with coordinate systems 202

World tool (IntelliCAD Explorer) 83, 174
Write, Then Resume option (freehand command) 103
writing sketches into drawings 103

X
x-axis

color 483
in coordinate systems 156

xclip command
deleting 358
polyline clipping boundaries 357
rectangular clipping boundaries 357
turning xref clipping on and off 358

Xlines 101
See also infinite lines

x-ordinate dimensions 309
Xref Manager command or tool (xrm) 348, 349

See also blocks
attaching files to drawings 214
attaching or detaching external references 350
binding external references 355
changing file paths 354
clipping 356
defined 209, 550
inserting drawings as 214
nesting 350
overlaying 350
overview 348
reloading or updating 353
reusing entire blocks and drawings 10

xrm command
See also Xref Manager command or tool (xrm)

attaching external references 350
binding external path names 355
clipping boundaries 356
detaching external references 353
moving or changing the path name 354
opening external references 352
reloading or uploading external references 353
search path for files 478
searching for external references 354
unloading external references 352
viewing external references 351

Y
y-axis

color 483
in coordinate systems 156

y-ordinate dimensions 309

Z
z-axis

in coordinate systems 156
z-coordinates in elevation 399, 402
zero angle settings 52
Zoom All tool 145
Zoom Center tool 144
Zoom command (zoom) 142, 370
Zoom Extents tool 145
Zoom In command or tool (zoom) 142, 144
Zoom Left tool 144
Zoom Out tool 142
Zoom Previous tool 144
zooming in or out

changing mouse wheel zoom direction 481
changing viewport scale factor 370
defined 558
in 3-dimensional drawings 398
in print preview window 392
in viewports 368
overview 142
viewing drawings 5

zooming methods 142
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